LDF: GLAST LAT Data Format \n (LDF) \n parser package

  • Main Page
  • Classes
  • Files
  • Related Pages

GLAST LAT Data Format \n (LDF) \n parser package

v06-02-00

Introduction

This package contains a set of C++ classes for navigating LAT Data Format (LDF) event data. It also includes code necessary for exposing these C++ classes to Python (the sip files).

The LDF data format is defined in:

  • The Tower Electronics Module (TEM) Programming ICD(LAT-TD-00605), chapter 4
  • The ACD Electronics Module (AEM) Programming ICD (LAT-TD-00639), chapter 3
  • The Global Trigger (GLT) Electronics Module (GEM) Programming ICD (LAT-TD-01545), chapter 4
  • The Event Builder Module (EBM) Programming ICD (LAT-TD-01546).
  • The LAT Communications Board (LCB) Programming ICD (LAT-TD-00860), chapter 3.
  • LAT Inter-module Communications Reference Manual (LAT-TD-00606), chapter 3.

Also Online System Science Data Format (LDF) may be of assistance.

Building LDF libraries and example code

If you're interested in building only the libraries and test code for either of the supported platforms, you don't need LATTE, Python or sip as described below. Just the compilation tools listed are sufficient.

Windows XP

Required software:
  • LATTE (LDF is included in the LATTE dist)
  • Microsoft Visual Studio .NET (2002 or later)
  • Python 2.3 (or later)
  • sip 4 (or later, included with PyQT)

Building with Visual Studio .NET 7.1 is supported (.sln files). The 7.0 project files (.vcproj) are also included but are no longer supported, so may be out of date.

Library: Open VS and load the LDF project. Build.
Example code: Open VS and load test/LDFdump. Build.

SLAC Linux (ex: libra3.slac.stanford.edu)

Required software:
  • LATTE (LDF is included in the LATTE dist)
  • g++, GNU make, etc
  • Python 2.3 (or later)
  • sip 4 (or later, included with PyQT)
  • automake (>=1.6), autoconf, libtool

You'll be building in a build directory, e.g. LDF-BUILD. If at any point you don't like it's contents, delete it and start over. This doesn't affect the source tree in LDF.

> cvs checkout Online/LDF
> mkdir Online/LDF-BUILD  # substitute BUILD with whatever you like
> cd Online/LDF

Execute the following shell script. This needs to be done only on a fresh cvs check-out or if the configure.in file changed or any change in the m4 macros in config/m4.

> ./autogen
> cd ../LDF-BUILD

Run the configure procedure. If you're building in AFS space give it the option --disable-libtool-lock. If python is not installed in the default location, add the option --with-python-include=<python path> in the configure line. You can influence where the products are installed with the --prefix option. Do configure --help for more details.

> ../LDF/configure
All the checks this procedure makes should pass. This procedure will use automake to read the Makefile.am files and generates the Makefile.in files, and autoconf to generate the configure script. The configure script will then generate the Makefiles and some other files that need configuration.

> make
will create the shared library files libLDFc.so, which C++ programs use and LDF.so, which can be imported from python. It will also build the test executables are in test/.

You can build the html documentation using

> make docs
Typically there is no need to do this since the documentation will be kept up to date at the GLAST LAT I&T/Online web site.

Use

> make install
to install the package in the directory given with the --prefix option to configure. If it was omitted, this command will install into /usr/local.

Using LDF example code:

Executable

On Windows, the executable is located in either test/Debug or test/Release, and is named LDFdump.exe. On Linux, the executable is test/LDFdump. Both have the similar syntax:
LDFdump.exe <ldf filename>
This executable can only dump datagram encapsulated files (such as .ldf or .arch files)

FITS files can be run through RunControl/fits2Arch.py to generate an .ldf or .arch file that can be dumped using test/LDFdump.

Python

On either Windows or Linux, cd to test and execute the following from the command line:
> python -i LDFdump.py
At the python prompt the following functions are available:
>>> testRaw(<file>)      # dump a .ldf or .arch file
>>> testFITS(<file>)     # dump a FITS format file
>>> testEBF(<file>)      # dump a file containing "pure" EBF events,
                         # without datagram encapsulation
>>> testHex(<file>)      # dump a hex dump from a text file
                         # (Cut and paste the event dump generated
                         # by evtCli or od -t x4.)
>>> test(<buffer>)       # dump a binary buffer.  Several are defined in
                         # LDFdump.py:  temBuf(), aemBuf(), evtBuf(), etc.
>>> testRaw_Dist(server) # Dump events from a multicast server

As well, the following runs testRaw(<file>) from the command line:

> python LDFdump.py <file>

Writing your own

For an example of the C++ API, take a look at LDFdump.cpp in the test directory. Another example might go as follows:

  • Read an event into an unsigned char* buffer.
  • Instantiate an EBFeventBuffer(buffer)
  • Iterate:
    test()
{
  MyLATcomponentIterator lci;

  while (1)
  {
    unsigned char* buffer = readEvent();
    if (!buffer)   break;
    LATevent*      event  = EBFeventBuffer(buffer).event();
    lci.iterate(event);
  }
}

For an example of the Python API, take a look at LDFdumper.py.

Releases

See Release notes for changes, new features and bug fixes.
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class List

  • Related Pages
  • Alphabetical List
  • Class List
  • Class Hierarchy
  • Class Members

LDF Class List

Here are the classes, structs, unions and interfaces with brief descriptions:
ACDmap | Class for mapping an AEM's contribution from electronics space to detector space
ACDpha | Class for accessing fields in the ACD PHA data word
ACDtileSide | Class for mapping an AEM's contribution from electronics space to detector space.Helper class for accessing the items in the ACDmap look-up table
AEMcontribution | Class for decoding a AEM's contribution to a EBFevent
AEMcontributionIterator | Class for iterating over contributions to an AEMcontribution
AEMheader | Class for accessing fields in the AEM header words
ASCcno | Class for accessing counters in the ASC Cno contribution
ASCcontribution | Class for decoding a ASC (ACD Scalar Contribtion) LDF datagram
ASCcontributionIterator | Class for iterating over the parts of an ASCcontribution
ASCsummary | Class for accessing counters in the ASC error summary contribution
ASCtile | Class for accessing counters in the ASC associated with a single tile or ribbon
ASCtileContribution | Class for accessing fields in the ASC tile statistics contribution
ASCtileContributionIterator | Class for iterating over the individual tiles in an ASCtileContribution
CALcontribution | Class for decoding CALorimeter's contribution to a TEMcontribution
CALcontributionIterator | Class for iterating over contributions to a CALcontribution
CALdiagnostic | Class for accessing fields in the CAL diagnostic data word
CALlog | Class for accessing fields in the CAL log data longword
CALlogEnd | Class for accessing fields in the CAL log-end data word
CALmap | Class for mapping a CAL contribution from electronics space to detector spaec
DIAGcontributionIterator | Class for iterating over parts of a Diagnostic contribution
EBFcontribution | Class for decoding a EBF contribution to an event
EBFcontributionIterator | Class for iterating over contributions to an EBFevent
EBFevent | Class for decoding an EBF event
EBFeventIterator | Class for iterating over a buffer of EBFevent(s)
ERRcontributionIterator | Class for iterating over parts of a Diagnostic contribution
ErrorSummary | Class for accessing fields in the TEM error summary longword
EventSummary | Class for accessing fields in the event summary longword
GCCCerror | Helper classes for accessing fields in the error data.Class for decoding a GCCC error message
GEMcondArrivalTime | This is a helper class for parsing the Condition Arrival Time structure
GEMcontribution | Class for parsing the GEM's event contribution
GEMonePPStime | This is a helper class for parsing the One PPS time structure
GEMtileList | Classes for decoding a GEM's contribution to an EBFevent.This is a helper class for handling ACD tile data
GLTcontribution | Class for decoding a GLT's contribution to an EBFevent
GTCCerror | Class for decoding a GTCC error message
GTRCerror | Class for decoding a GTRC error message
LATcomponentIterator | Class for iterating over components in a LATcontribution
LATcontribution | Base class for describing all contributions to a LATdatagram
LATcontributionIterator | Class for iterating over components in a LATdatagram
LATdataBufferIterator | Application class demonstrating the use of the LDF iterators to call application-supplied methods back
LATdatagram | Class for decoding an LAT datagram
LATdatagramIterator | Class for iterating over a list of LATdatagrams
LATPcellHeader | Class for accessing fields in the LAT protocol cell header longword
LATprimaryId | Class providing structure type enumerations
LATsecondaryId | Class providing structure type enumerations
LATtypeId | Support classes for labeling the various classes involved in decoding event data from the LAT
LDBI_EBFeventIterator | Application class demonstrating the use of the EBF iterators to call application-supplied methods back.EBFeventIterator concrete class to invoke the application's LATcomponentIterator
LDBI_LATcontributionIterator | LATcontributionIterator concrete class to invoke LDBI_EBFeventIterator
LDBI_LATdatagramIterator | LATdatagramIterator concrete class to invoke LDBI_LATcontributionIterator
LDFversion | Class for defining the version number of the package
OSWcontributionIterator | Class for iterating over contributions to an OSW (Online SoftWare) contribution
OSWtimeBase | Class for Python support to handle the two timebase longwords
OSWtimeContribution | Class for decoding the time contribution inserted by the Online SoftWare (OSW) to an EBF event
OSWtimeSpec | Class for Python support since it doesn't have a struct timespec type
TEMcontribution | Class for decoding a TEM's contribution to an EBFevent
TEMcontributionIterator | Class for iterating over contributions to a TEMcontribution
TKRcontribution | Class for decoding Tracker's contribution to a TEMcontribution
TKRcontributionIterator | Class for iterating over contributions to a TKRcontribution
TKRdiagnostic | Class for accessing fields in the TKR diagnostic data word
TKRmap | Class for mapping a TKR contribution from electronics space to detector space
TKRstrip | Class for accessing fields in the TKR strip data 12 bit word
TWRmap | Class for mapping a TEM's contribution from electronics space to detector space
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: ACDmap Class Reference

  • Class Hierarchy
  • Class Members

ACDmap Class Reference

Class for mapping an AEM's contribution from electronics space to detector space. More...

#include <ACDmap.h>

Collaboration diagram for ACDmap:

[legend]
List of all members.

Public Member Functions

ACDmap ()
Constructor that initializes the look-up table.
virtual const ACDtileSide * | lookup (LATtypeId evtId, unsigned cable, unsigned channel) const
Method for looking up an ACDtileSide object given an cable (RC) number and an channel (FE) number.
virtual const char * | freeName (LATtypeId evtId, unsigned cable) const
Method for getting the name of the FREE board attached to a given RC (cable) number.
virtual const char * | tileNameFromGemIndex (unsigned gemIndex) const
Method for getting the name of the tile or ribbon by the order they are shipped from GEM status word.

Detailed Description

Class for mapping an AEM's contribution from electronics space to detector space.

Member Function Documentation

const char * ACDmap::freeName | ( | LATtypeId | evtId,
 |  | unsigned | cable |
 | ) |  |  | const [inline, virtual]

Method for getting the name of the FREE board attached to a given RC (cable) number.

This method converts an RC (cable) number into a cable name as per "LAT-TD-00639-D1 ACD Electronics Module (AEM) - Programming ICD specification" section 3.2.

Parameters:
evtId | An EBF event type-ID value.
cable | An RC (cable) number from 0 to 11.
Returns:
The name of the FREE board as a 3 character string.

const ACDtileSide * ACDmap::lookup | ( | LATtypeId | evtId,
 |  | unsigned | cable,
 |  | unsigned | channel |
 | ) |  |  | const [inline, virtual]

Method for looking up an ACDtileSide object given an cable (RC) number and an channel (FE) number.

This method converts RC (cable) number and FE (channel) number into a ACDtileSide object as defined by "LAT-TD-???? GASU based teststands and the ACD" in Appendix B.

Parameters:
evtId | An EBF event type-ID value.
cable | A cable (RC) number from 0 to 11.
channel | An channel (FE) number from 0 to 17.
Returns:
The ACDtileSide object associated with the given cable, channel pair.

const char * ACDmap::tileNameFromGemIndex ( unsigned gemIndex ) const [inline, virtual]

Method for getting the name of the tile or ribbon by the order they are shipped from GEM status word.

Parameters:
gemIndex Index into the GEM tile vector (from 0-127)
Returns:
The name of the FREE board as a 3 character string.

The documentation for this class was generated from the following file:
  • ACDmap.h
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

ACDmap Member List

This is the complete list of members for ACDmap, including all inherited members.

ACDmap() | ACDmap | [inline]
freeName(LATtypeId evtId, unsigned cable) const | ACDmap | [inline, virtual]
lookup(LATtypeId evtId, unsigned cable, unsigned channel) const | ACDmap | [inline, virtual]
tileNameFromGemIndex(unsigned gemIndex) const | ACDmap | [inline, virtual]
~ACDmap() (defined in ACDmap) | ACDmap | [inline, virtual]

Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: ACDpha Class Reference

ACDpha Class Reference

Class for accessing fields in the ACD PHA data word. More...

#include <ACDpha.h>

List of all members.

Public Member Functions

ACDpha (unsigned value)
Constructor for initializing the ACDpha class with a PHA value.
unsigned | more () const
Method for returning the more bit from a PHA value.
unsigned | ADCrange () const
Method for returning the ADCrange value from a PHA value.
unsigned | ADCvalue () const
Method for returning the raw ADCvalue from a PHA value.
unsigned | parityError () const
Method for returning the parityError value from a PHA value.
unsigned | datum () const
Method for returning the PHA value the class was constructed with.

Static Public Member Functions

static unsigned | more (unsigned value)
Static method for returning the more bit from a PHA value.
static unsigned | ADCrange (unsigned value)
Static method for returning the ADCrange value from a PHA value.
static unsigned | ADCvalue (unsigned value)
Static method for returning the raw ADCvalue from a PHA value.
static unsigned | parityError (unsigned value)
Static method for returning the parityError value from a PHA value.

Detailed Description

Class for accessing fields in the ACD PHA data word.

Author:
Ric Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.2
Date:
February 11, 2003 -- Created
Id
ACDpha.h,v 1.2 2004/04/01 23:36:09 claus Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

ACDpha::ACDpha ( unsigned value ) [inline]

Constructor for initializing the ACDpha class with a PHA value.

Parameters:
value - A PHA value

Member Function Documentation

unsigned ACDpha::ADCrange ( ) const [inline]

Method for returning the ADCrange value from a PHA value.

Returns:
The more ADCrange value

unsigned ACDpha::ADCrange ( unsigned value ) [inline, static]

Static method for returning the ADCrange value from a PHA value.

Parameters:
value - A PHA value
Returns:
The more ADCrange value

unsigned ACDpha::ADCvalue ( ) const [inline]

Method for returning the raw ADCvalue from a PHA value.

Returns:
The raw ADCvalue value

unsigned ACDpha::ADCvalue ( unsigned value ) [inline, static]

Static method for returning the raw ADCvalue from a PHA value.

Parameters:
value - A PHA value
Returns:
The raw ADCvalue value

unsigned ACDpha::datum ( ) const [inline]

Method for returning the PHA value the class was constructed with.

Returns:
The PHA value

unsigned ACDpha::more ( ) const [inline]

Method for returning the more bit from a PHA value.

Returns:
The more bit's value

unsigned ACDpha::more ( unsigned value ) [inline, static]

Static method for returning the more bit from a PHA value.

Parameters:
value - A PHA value
Returns:
The more bit's value

unsigned ACDpha::parityError ( ) const [inline]

Method for returning the parityError value from a PHA value.

Returns:
The parityError value

unsigned ACDpha::parityError ( unsigned value ) [inline, static]

Static method for returning the parityError value from a PHA value.

Parameters:
value - A PHA value
Returns:
The parityError value

The documentation for this class was generated from the following file:
  • ACDpha.h
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

ACDpha Member List

This is the complete list of members for ACDpha, including all inherited members.

ACDpha(unsigned value) | ACDpha | [inline]
ACDpha() (defined in ACDpha) | ACDpha | [inline]
ADCrange(unsigned value) | ACDpha | [inline, static]
ADCrange() const | ACDpha | [inline]
ADCvalue(unsigned value) | ACDpha | [inline, static]
ADCvalue() const | ACDpha | [inline]
datum() const | ACDpha | [inline]
more(unsigned value) | ACDpha | [inline, static]
more() const | ACDpha | [inline]
parityError(unsigned value) | ACDpha | [inline, static]
parityError() const | ACDpha | [inline]
~ACDpha() (defined in ACDpha) | ACDpha | [inline]

Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: ACDtileSide Class Reference

ACDtileSide Class Reference

Class for mapping an AEM's contribution from electronics space to detector space.Helper class for accessing the items in the ACDmap look-up table. More...

#include <ACDmap.h>

List of all members.

Public Member Functions

ACDtileSide (unsigned t, bool s, const char *n)
Constructor for initializing the object.
unsigned | tile () const
Return the tile number.
bool | a () const
Return the side.
const char * | name () const
Return the tile name.

Detailed Description

Class for mapping an AEM's contribution from electronics space to detector space.Helper class for accessing the items in the ACDmap look-up table.

Constructor & Destructor Documentation

ACDtileSide::ACDtileSide | ( | unsigned | t,
 |  | bool | s,
 |  | const char * | n |
 | ) |  |  | [inline]

Constructor for initializing the object.

Parameters:
t | A tile number
s | A side value (A = 0, B = 1)
n | A tile name

The documentation for this class was generated from the following file:
  • ACDmap.h
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

ACDtileSide Member List

This is the complete list of members for ACDtileSide, including all inherited members.

a() const | ACDtileSide | [inline]
ACDtileSide(unsigned t, bool s, const char *n) | ACDtileSide | [inline]
name() const | ACDtileSide | [inline]
tile() const | ACDtileSide | [inline]
~ACDtileSide() (defined in ACDtileSide) | ACDtileSide | [inline]

Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: AEMcontribution Class Reference

AEMcontribution Class Reference

Class for decoding a AEM's contribution to a EBFevent. More...

#include <AEMcontribution.h>

Inheritance diagram for AEMcontribution:

[legend]
Collaboration diagram for AEMcontribution:

[legend]
List of all members.

Public Member Functions

char * data () const
Return a char pointer to the beginning of the AEM data.

Detailed Description

Class for decoding a AEM's contribution to a EBFevent.

Author:
Ric Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.4
Date:
January 26, 2003 -- Created
Id
AEMcontribution.h,v 1.4 2004/04/01 23:36:41 claus Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Member Function Documentation

char * AEMcontribution::data ( ) const [inline]

Return a char pointer to the beginning of the AEM data.

Returns:
A char pointer to the beginning of the AEM data

The documentation for this class was generated from the following file:
  • AEMcontribution.h
Generated on Mon Jul 31 17:48:12 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

AEMcontribution Member List

This is the complete list of members for AEMcontribution, including all inherited members.

AEM enum value (defined in EBFcontribution) | EBFcontribution |
AEMcontribution() (defined in AEMcontribution) | AEMcontribution | [inline]
aemContribution() const | EBFcontribution | [inline]
Broadcast enum value (defined in EBFcontribution) | EBFcontribution |
CRU enum value (defined in EBFcontribution) | EBFcontribution |
data() const | AEMcontribution | [inline]
EBFcontribution() (defined in EBFcontribution) | EBFcontribution | [inline]
EBM enum value (defined in EBFcontribution) | EBFcontribution |
GEM enum value (defined in EBFcontribution) | EBFcontribution |
gemContribution() const | EBFcontribution | [inline]
gltContribution() const | EBFcontribution | [inline]
header() const | EBFcontribution | [inline]
length() const | EBFcontribution | [inline]
next() const | EBFcontribution | [inline]
NumberOfContributions enum value (defined in EBFcontribution) | EBFcontribution |
OSW enum value (defined in EBFcontribution) | EBFcontribution |
oswContribution() const | EBFcontribution | [inline]
packetError() const | EBFcontribution | [inline]
Parity enum value (defined in EBFcontribution) | EBFcontribution |
payload() const | EBFcontribution | [inline]
payloadSize() const | EBFcontribution | [inline]
PDU_0 enum value (defined in EBFcontribution) | EBFcontribution |
PDU_1 enum value (defined in EBFcontribution) | EBFcontribution |
sequence() const | EBFcontribution | [inline]
summary() const | EBFcontribution | [inline]
temContribution() const | EBFcontribution | [inline]
TimedOut enum value (defined in EBFcontribution) | EBFcontribution |
Tower_00 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_01 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_02 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_03 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_04 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_05 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_06 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_07 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_08 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_09 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_10 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_11 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_12 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_13 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_14 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_15 enum value (defined in EBFcontribution) | EBFcontribution |
Truncated enum value (defined in EBFcontribution) | EBFcontribution |
WriteFault enum value (defined in EBFcontribution) | EBFcontribution |
~AEMcontribution() (defined in AEMcontribution) | AEMcontribution | [inline]
~EBFcontribution() (defined in EBFcontribution) | EBFcontribution | [inline]

Generated on Mon Jul 31 17:48:12 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: AEMcontributionIterator Class Reference

AEMcontributionIterator Class Reference

Class for iterating over contributions to an AEMcontribution. More...

#include <AEMcontributionIterator.h>

Collaboration diagram for AEMcontributionIterator:

[legend]
List of all members.

Public Types

ERR_TooManyPhas = 1
enum | { ERR_TooManyPhas = 1 }

Public Member Functions

AEMcontributionIterator (EBFevent *, AEMcontribution *, ACDmap *)
Constructor for iterating over the ACD contribution.
AEMcontributionIterator (EBFevent *, AEMcontribution *)
Constructor for iterating over the ACD contribution.
AEMcontributionIterator (ACDmap *)
Constructor for setting up the electronic space to detector space map.
AEMcontributionIterator ()
Do nothing constructor.
unsigned | iterate ()
Iterate over the ACD contribution.
unsigned | iterate (EBFevent *, AEMcontribution *)
Iterate over the ACD contribution.
unsigned | iterate (EBFevent *, AEMcontribution *, ACDmap *)
Iterate over the ACD contribution.
virtual int | handleError (AEMcontribution *, unsigned code, unsigned p1=0, unsigned p2=0) const
Handle all errors possible in AEMcontributionIterator.
const EBFevent * | event () const
const AEMcontribution * | contribution () const
const ACDmap * | map () const
virtual void | header (unsigned cable, AEMheader hdr)=0
Pure virtual method for calling the application back with an ACD cable header.
virtual void | pha (unsigned cable, unsigned channel, ACDpha pha)=0
Pure virtual method for calling the application back with an ACD PHA object.

Detailed Description

Class for iterating over contributions to an AEMcontribution.

Author:
Jim Panetta -- GLAST LAT I&T/Online (panetta@slac.stanford.edu)
Revision
1.8
Date:
January 27, 2004 -- Created
Id
AEMcontributionIterator.h,v 1.8 2005/03/15 18:59:37 panetta Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

AEMcontributionIterator::AEMcontributionIterator | ( | EBFevent * | event,
 |  | AEMcontribution * | contribution,
 |  | ACDmap * | map |
 | ) |  |  | [inline]

Constructor for iterating over the ACD contribution.

This constructor caches the event, contribution and map provided by the caller.

Parameters:
event | A pointer to the EBFevent containing the contribution
contribution | A pointer to the contribution to iterate over
map | A pointer to the electronic space to detector space map

AEMcontributionIterator::AEMcontributionIterator | ( | EBFevent * | event,
 |  | AEMcontribution * | contribution |
 | ) |  |  | [inline]

Constructor for iterating over the ACD contribution.

This constructor caches the event and contribution provided by the caller.

Parameters:
event | A pointer to the EBFevent containing the contribution
contribution | A pointer to the contribution to iterate over

Member Function Documentation

const AEMcontribution* AEMcontributionIterator::contribution ( ) const [inline]

Return a pointer to the start of this contribution

const EBFevent* AEMcontributionIterator::event ( ) const [inline]

Return a pointer to the EBFevent containing this contribution

int AEMcontributionIterator::handleError | ( | AEMcontribution * | contribution,
 |  | unsigned | code,
 |  | unsigned | p1 = 0,
 |  | unsigned | p2 = 0 |
 | ) |  |  | const [virtual]

Handle all errors possible in AEMcontributionIterator.

This method is used to handle errors occurring during the iteration over an AEMcontribution. By default it does nothing, however it is virtual and is able to be overridden by the user.

Parameters:
contribution | The contribution in error
code | The error code
p1 | a parameter associated with the error code
p2 | a parameter associated with the error code

virtual void AEMcontributionIterator::header | ( | unsigned | cable,
 |  | AEMheader | hdr |
 | ) |  |  | [pure virtual]

Pure virtual method for calling the application back with an ACD cable header.

Parameters:
cable | - The physical cable header came from
hdr | - The header object

unsigned AEMcontributionIterator::iterate | ( | EBFevent * | event,
 |  | AEMcontribution * | contribution,
 |  | ACDmap * | map |
 | ) |  |  | [inline]

Iterate over the ACD contribution.

This method calls the header() virtual function for each cable contribution encountered and the pha() virtual function with every hit it finds.

Parameters:
event | A pointer to the EBFevent containing the contribution
contribution | A pointer to the contribution to iterate over
map | A pointer to the electronic space to detector space map
Returns:
The number of cable contributions seen.

unsigned AEMcontributionIterator::iterate | ( | EBFevent * | event,
 |  | AEMcontribution * | contribution |
 | ) |  |  | [inline]

Iterate over the ACD contribution.

This method calls the header() virtual function for each cable contribution encountered and the pha() virtual function with every hit it finds. This method uses the event and contribution provided by the caller and the map established by the ctor.

Parameters:
event | A pointer to the EBFevent containing the contribution
contribution | A pointer to the contribution to iterate over
Returns:
The number of cable contributions seen.

unsigned AEMcontributionIterator::iterate ( ) [inline]

Iterate over the ACD contribution.

This method calls the header() virtual function for each cable contribution encountered and the pha() virtual function with every hit it finds. This method uses the event, contribution and map established by the ctor.

Returns:
The number of cable contributions seen.

const ACDmap* AEMcontributionIterator::map ( ) const [inline]

Return a pointer to the ACD map

virtual void AEMcontributionIterator::pha | ( | unsigned | cable,
 |  | unsigned | channel,
 |  | ACDpha | pha |
 | ) |  |  | [pure virtual]

Pure virtual method for calling the application back with an ACD PHA object.

Parameters:
cable | - The physical cable PHA value came from
channel | - The physical channel the PHA value came from
pha | - The PHA object

The documentation for this class was generated from the following files:
  • AEMcontributionIterator.h
  • AEMcontributionIterator.cpp
Generated on Mon Jul 31 17:48:12 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

AEMcontributionIterator Member List

This is the complete list of members for AEMcontributionIterator, including all inherited members.

AEMcontributionIterator(EBFevent *, AEMcontribution *, ACDmap *) | AEMcontributionIterator | [inline]
AEMcontributionIterator(EBFevent *, AEMcontribution *) | AEMcontributionIterator | [inline]
AEMcontributionIterator(ACDmap *) | AEMcontributionIterator | [inline]
AEMcontributionIterator() | AEMcontributionIterator | [inline]
contribution() const | AEMcontributionIterator | [inline]
ERR_TooManyPhas enum value (defined in AEMcontributionIterator) | AEMcontributionIterator |
event() const | AEMcontributionIterator | [inline]
handleError(AEMcontribution *, unsigned code, unsigned p1=0, unsigned p2=0) const | AEMcontributionIterator | [virtual]
header(unsigned cable, AEMheader hdr)=0 | AEMcontributionIterator | [pure virtual]
iterate() | AEMcontributionIterator | [inline]
iterate(EBFevent *, AEMcontribution *) | AEMcontributionIterator | [inline]
iterate(EBFevent *, AEMcontribution *, ACDmap *) | AEMcontributionIterator | [inline]
map() const | AEMcontributionIterator | [inline]
pha(unsigned cable, unsigned channel, ACDpha pha)=0 | AEMcontributionIterator | [pure virtual]
~AEMcontributionIterator() (defined in AEMcontributionIterator) | AEMcontributionIterator | [inline, virtual]

Generated on Mon Jul 31 17:48:12 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: AEMheader Class Reference

AEMheader Class Reference

Class for accessing fields in the AEM header words. More...

#include <AEMheader.h>

List of all members.

Public Types

NUM_CABLES = 12
NUM_CHANNELS = 18
enum | { NUM_CABLES = 12, NUM_CHANNELS = 18 }

Public Member Functions

AEMheader (unsigned short *header)
Constructor for initializing the class with raw header data.
unsigned | startBit () const
Static method to return the start bit when suppied an AEM header.
unsigned | hitMap () const
Static method to return the hit map when suppied an AEM header.
unsigned | acceptMap () const
Static method to return the accept map when suppied an AEM header.
unsigned | phaVector () const
Static method to return the PHA vector when suppied an AEM header.
unsigned | parityError () const
Static method to return the parity error when suppied an AEM header.
unsigned | endOfCables () const
Static method to return the end of cables indicator when suppied an AEM header.
unsigned | cableNumber () const
Static method to return the cable number when suppied an AEM header.

Static Public Member Functions

static unsigned | startBit (unsigned short *header)
Static method to return the start bit when suppied an AEM header.
static unsigned | hitMap (unsigned short *header)
Static method to return the hit map when suppied an AEM header.
static unsigned | acceptMap (unsigned short *header)
Static method to return the accept map when suppied an AEM header.
static unsigned | phaVector (unsigned short *header)
Static method to return the PHA vector when suppied an AEM header.
static unsigned | parityError (unsigned short *header)
Static method to return the parity error when suppied an AEM header.
static unsigned | endOfCables (unsigned short *header)
Static method to return the end of cables indicator when suppied an AEM header.
static unsigned | cableNumber (unsigned short *header)
Static method to return the cable number when suppied an AEM header.

Detailed Description

Class for accessing fields in the AEM header words.

Format of AEM header is defined in the AEM primer: "The ACD Electronics Module (AEM): Programming ICD specification" LAT-TD-00639 - rev 2.6, section 3.2.1

Author:
Ric Claus, Jim Panetta -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.6
Date:
February 11, 2003 -- Created January 22, 2004 -- Bug in bit ordering of hitMap and acceptMap fixed See LIT Issue 37
Id
AEMheader.h,v 1.6 2006/03/30 19:05:45 perazzo Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

AEMheader::AEMheader ( unsigned short * header ) [inline]

Constructor for initializing the class with raw header data.

Parameters:
header - A pointer to the AEM header data

Member Function Documentation

unsigned AEMheader::acceptMap ( ) const [inline]

Static method to return the accept map when suppied an AEM header.

Returns:
The acceptMap value

unsigned AEMheader::acceptMap ( unsigned short * header ) [inline, static]

Static method to return the accept map when suppied an AEM header.

Parameters:
header - A pointer to the AEM header data
Returns:
The acceptMap value

unsigned AEMheader::cableNumber ( ) const [inline]

Static method to return the cable number when suppied an AEM header.

Returns:
The cableNumber value

unsigned AEMheader::cableNumber ( unsigned short * header ) [inline, static]

Static method to return the cable number when suppied an AEM header.

Parameters:
header - A pointer to the AEM header data
Returns:
The cableNumber value

unsigned AEMheader::endOfCables ( ) const [inline]

Static method to return the end of cables indicator when suppied an AEM header.

Returns:
The EndOfCables value

unsigned AEMheader::endOfCables ( unsigned short * header ) [inline, static]

Static method to return the end of cables indicator when suppied an AEM header.

Parameters:
header - A pointer to the AEM header data
Returns:
The EndOfCables value

unsigned AEMheader::hitMap ( ) const [inline]

Static method to return the hit map when suppied an AEM header.

Returns:
The hitMap value

unsigned AEMheader::hitMap ( unsigned short * header ) [inline, static]

Static method to return the hit map when suppied an AEM header.

Parameters:
header - A header pointer to the AEM header data
Returns:
The hitMap value

unsigned AEMheader::parityError ( ) const [inline]

Static method to return the parity error when suppied an AEM header.

Returns:
The parityError value

unsigned AEMheader::parityError ( unsigned short * header ) [inline, static]

Static method to return the parity error when suppied an AEM header.

Parameters:
header - A pointer to the AEM header data
Returns:
The parityError value

unsigned AEMheader::phaVector ( ) const [inline]

Static method to return the PHA vector when suppied an AEM header.

Returns:
The startBit value

unsigned AEMheader::phaVector ( unsigned short * header ) [inline, static]

Static method to return the PHA vector when suppied an AEM header.

Parameters:
header - A pointer to the AEM header data
Returns:
The startBit value

unsigned AEMheader::startBit ( ) const [inline]

Static method to return the start bit when suppied an AEM header.

Returns:
The startBit value

unsigned AEMheader::startBit ( unsigned short * header ) [inline, static]

Static method to return the start bit when suppied an AEM header.

Parameters:
header - A pointer to the AEM header data
Returns:
The startBit value

The documentation for this class was generated from the following file:
  • AEMheader.h
Generated on Mon Jul 31 17:48:12 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

AEMheader Member List

This is the complete list of members for AEMheader, including all inherited members.

acceptMap(unsigned short *header) | AEMheader | [inline, static]
acceptMap() const | AEMheader | [inline]
AEMheader(unsigned short *header) | AEMheader | [inline]
AEMheader() (defined in AEMheader) | AEMheader | [inline]
cableNumber(unsigned short *header) | AEMheader | [inline, static]
cableNumber() const | AEMheader | [inline]
endOfCables(unsigned short *header) | AEMheader | [inline, static]
endOfCables() const | AEMheader | [inline]
hitMap(unsigned short *header) | AEMheader | [inline, static]
hitMap() const | AEMheader | [inline]
NUM_CABLES enum value (defined in AEMheader) | AEMheader |
NUM_CHANNELS enum value (defined in AEMheader) | AEMheader |
parityError(unsigned short *header) | AEMheader | [inline, static]
parityError() const | AEMheader | [inline]
phaVector(unsigned short *header) | AEMheader | [inline, static]
phaVector() const | AEMheader | [inline]
startBit(unsigned short *header) | AEMheader | [inline, static]
startBit() const | AEMheader | [inline]
~AEMheader() (defined in AEMheader) | AEMheader | [inline]

Generated on Mon Jul 31 17:48:12 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: ASCcno Class Reference

ASCcno Class Reference

Class for accessing counters in the ASC Cno contribution. More...

#include <ASCcno.h>

List of all members.

Public Types

One = 0
TwoL
TwoR
Three
FourL
FourR
N_BoardPair
A = 0
B
None = 0
AOnly
BOnly
Both
N_BoardStatus
enum BoardPair {
One = 0, TwoL, TwoR, Three,
FourL, FourR, N_BoardPair
}
enum | BoardBit { A = 0, B }
enum BoardStatus {
None = 0, AOnly, BOnly, Both,
N_BoardStatus
}

Public Member Functions

ASCcno (unsigned ptr[24])
Constructor for initializing the ASCcno class with a ptr to the data.
unsigned | counts (BoardPair board, BoardStatus status) const
Method for returning the number of counts with particular status flags.
unsigned | counts_fired (BoardPair board) const
Method for returning the number times a particular Board pair fired.
unsigned | counts_fired (BoardPair board, BoardBit AorB) const
Static method for returning the number times a particular Board pair fired.
unsigned * | ptr () const

Static Public Member Functions

static unsigned | counts (unsigned *ptr, BoardPair board, BoardStatus status)
Static method for returning the number of counts with particular status flags.
static unsigned | counts_fired (unsigned *ptr, BoardPair board)
Static method for returning the number times a particular Board pair fired.
static unsigned | counts_fired (unsigned *ptr, BoardPair board, BoardBit AorB)
Static method for returning the number times a particular Board pair fired.

Detailed Description

Class for accessing counters in the ASC Cno contribution.

Author:
Eric Charles -- GLAST LAT I&T/SVAC - (echarles@slac.stanford.edu)
Revision
1.1
Date:
September 21, 2005 -- Created
Id
ASCcno.h,v 1.1 2005/09/28 22:04:13 echarles Exp

Copyright: Copyright 2005 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

ASCcno::ASCcno ( unsigned ptr[24] ) [inline]

Constructor for initializing the ASCcno class with a ptr to the data.

Parameters:
ptr - pointer to the first bin of the ASC CNO data

Member Function Documentation

unsigned ASCcno::counts | ( | BoardPair | board,
 |  | BoardStatus | status |
 | ) |  |  | const [inline]

Method for returning the number of counts with particular status flags.

Parameters:
pair | - which pair of free boards
status | - CNO status of the free board pair
Returns:
Number of counts with status coming in the pair

unsigned ASCcno::counts | ( | unsigned * | ptr,
 |  | BoardPair | board,
 |  | BoardStatus | status |
 | ) |  |  | [inline, static]

Static method for returning the number of counts with particular status flags.

Parameters:
ptr | - pointer to the first bin of the histogram
pair | - which pair of free boards
status | - CNO status of the free board pair
Returns:
Number of counts with status coming in the pair

unsigned ASCcno::counts_fired | ( | BoardPair | board,
 |  | BoardBit | AorB |
 | ) |  |  | const [inline]

Static method for returning the number times a particular Board pair fired.

Parameters:
ptr | - pointer to the first bin of the histogram
board | - which pair of free boards
AorB | - which board in the pair
Returns:
Number of counts with board fired

unsigned ASCcno::counts_fired | ( | unsigned * | ptr,
 |  | BoardPair | board,
 |  | BoardBit | AorB |
 | ) |  |  | [inline, static]

Static method for returning the number times a particular Board pair fired.

Parameters:
ptr | - pointer to the first bin of the histogram
board | - which pair of free boards
AorB | - which board in the pair
Returns:
Number of counts with board fired

unsigned ASCcno::counts_fired ( BoardPair board ) const [inline]

Method for returning the number times a particular Board pair fired.

Parameters:
board - which pair of free boards
Returns:
Number of counts with either board fired

unsigned ASCcno::counts_fired | ( | unsigned * | ptr,
 |  | BoardPair | board |
 | ) |  |  | [inline, static]

Static method for returning the number times a particular Board pair fired.

Parameters:
ptr | - pointer to the first bin of the histogram
board | - which pair of free boards
Returns:
Number of counts with either board fired

The documentation for this class was generated from the following file:
  • ASCcno.h
Generated on Mon Jul 31 17:48:12 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

ASCcno Member List

This is the complete list of members for ASCcno, including all inherited members.

A enum value (defined in ASCcno) | ASCcno |
AOnly enum value (defined in ASCcno) | ASCcno |
ASCcno(unsigned ptr[24]) | ASCcno | [inline]
ASCcno() (defined in ASCcno) | ASCcno | [inline]
B enum value (defined in ASCcno) | ASCcno |
BoardBit enum name (defined in ASCcno) | ASCcno |
BoardPair enum name (defined in ASCcno) | ASCcno |
BoardStatus enum name (defined in ASCcno) | ASCcno |
BOnly enum value (defined in ASCcno) | ASCcno |
Both enum value (defined in ASCcno) | ASCcno |
counts(unsigned *ptr, BoardPair board, BoardStatus status) | ASCcno | [inline, static]
counts(BoardPair board, BoardStatus status) const | ASCcno | [inline]
counts_fired(unsigned *ptr, BoardPair board) | ASCcno | [inline, static]
counts_fired(BoardPair board) const | ASCcno | [inline]
counts_fired(unsigned *ptr, BoardPair board, BoardBit AorB) | ASCcno | [inline, static]
counts_fired(BoardPair board, BoardBit AorB) const | ASCcno | [inline]
FourL enum value (defined in ASCcno) | ASCcno |
FourR enum value (defined in ASCcno) | ASCcno |
N_BoardPair enum value (defined in ASCcno) | ASCcno |
N_BoardStatus enum value (defined in ASCcno) | ASCcno |
None enum value (defined in ASCcno) | ASCcno |
One enum value (defined in ASCcno) | ASCcno |
ptr() const (defined in ASCcno) | ASCcno | [inline]
Three enum value (defined in ASCcno) | ASCcno |
TwoL enum value (defined in ASCcno) | ASCcno |
TwoR enum value (defined in ASCcno) | ASCcno |
~ASCcno() (defined in ASCcno) | ASCcno | [inline]

Generated on Mon Jul 31 17:48:12 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: ASCcontribution Class Reference

ASCcontribution Class Reference

Class for decoding a ASC (ACD Scalar Contribtion) LDF datagram. More...

#include <ASCcontribution.h>

Inheritance diagram for ASCcontribution:

[legend]
Collaboration diagram for ASCcontribution:

[legend]
List of all members.

Public Types

Summary_Words = 16
CNO_Words = 24
Tile_Words = 4096
enum | { Summary_Words = 16, CNO_Words = 24, Tile_Words = 4096 }

Public Member Functions

unsigned char * | string (bool swap=!DFC_BIG_ENDIAN)
Return this ASCcontribution in string form.
unsigned * | summaryPtr () const
unsigned * | cnoPtr () const
unsigned * | tilesPtr () const

Static Public Member Functions

static ASCcontribution * | create (unsigned char *buffer, unsigned size, bool swap=!DFC_BIG_ENDIAN)
Create an ASCcontribtuion from a Python string.

Detailed Description

Class for decoding a ASC (ACD Scalar Contribtion) LDF datagram.

Author:
Eric Charles -- GLAST LAT I&T/SVAC - (echarles@slac.stanford.edu)
Revision
1.1
Date:
September 21, 2005 -- Created
Id
ASCcontribution.h,v 1.1 2005/09/28 22:04:13 echarles Exp

Copyright: Copyright 2005 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Member Function Documentation

unsigned* ASCcontribution::cnoPtr ( ) const [inline]

Returns:
- pointer to the start of the cno summary data

ASCcontribution * ASCcontribution::create | ( | unsigned char * | buffer,
 |  | unsigned | size,
 |  | bool | swap = !DFC_BIG_ENDIAN |
 | ) |  |  | [inline, static]

Create an ASCcontribtuion from a Python string.

This comment is copied from EBFevent header file

This method is here to support the Python interface. A Python string is cast to an ASCcontribution. If this class had anything but a no-op constructor this would not work and we would have to use placement new. The reason this wasn't done right off the bat is that it isn't entirely clear that we know how to do this correctly vis a vis the Python object reference counting. Sometimes a Python crash is observed that complains about an object already being marked for garbage collection. I have not been able to narrow this down to a particular class, but think it might have to do with the placement new used in the LATdatagram class.

Parameters:
buffer | - A buffer containing an ASCcontribution in string form
size | - The size of the buffer
swap | - Optional parameter to force or not force in place byte swapping
Returns:
- A pointer to the buffer cast as an ASCcontribution

unsigned char * ASCcontribution::string ( bool swap = !DFC_BIG_ENDIAN ) [inline]

Return this ASCcontribution in string form.

This comment is copied from EBFevent header file

This method is here to support the Python interface.

Parameters:
swap - Boolean to cause the buffer to be byte swapped in place
Returns:
A pointer to this ASCcontribution cast as an array of unsigned chars

Reimplemented from LATcontribution.

unsigned* ASCcontribution::summaryPtr ( ) const [inline]

Returns:
- pointer to the start of the error summary data

unsigned* ASCcontribution::tilesPtr ( ) const [inline]

Returns:
- pointer to the start of the tiles summary data

The documentation for this class was generated from the following file:
  • ASCcontribution.h
Generated on Mon Jul 31 17:48:12 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

ASCcontribution Member List

This is the complete list of members for ASCcontribution, including all inherited members.

ASCcontribution() (defined in ASCcontribution) | ASCcontribution | [inline]
CNO_Words enum value (defined in ASCcontribution) | ASCcontribution |
cnoPtr() const | ASCcontribution | [inline]
create(unsigned char *buffer, unsigned size, bool swap=!DFC_BIG_ENDIAN) | ASCcontribution | [inline, static]
LATcontribution::create(LATtypeId identity, unsigned size, unsigned char *buffer, bool swap=!DFC_BIG_ENDIAN) | LATcontribution | [inline, static]
ID enum value (defined in LATcontribution) | LATcontribution |
identity() const | LATcontribution | [inline]
LATcontribution() | LATcontribution | [inline]
LATcontribution(LATtypeId identity, unsigned length) | LATcontribution | [inline]
length() const | LATcontribution | [inline]
next() const | LATcontribution | [inline]
operator delete(void *, void *, unsigned short, bool) | LATcontribution | [inline]
operator delete(void *) | LATcontribution | [inline]
operator new(size_t) | LATcontribution | [inline]
operator new(size_t, LATtypeId identity, unsigned length) | LATcontribution | [inline]
operator new(size_t, const LATcontribution &) | LATcontribution | [inline]
operator new(size_t, void *, unsigned short supplemental, bool swap=!DFC_BIG_ENDIAN) | LATcontribution | [inline]
rawData() const | LATcontribution | [inline]
rawDataSize() const | LATcontribution | [inline]
string(bool swap=!DFC_BIG_ENDIAN) | ASCcontribution | [inline]
Summary_Words enum value (defined in ASCcontribution) | ASCcontribution |
summaryPtr() const | ASCcontribution | [inline]
Tile_Words enum value (defined in ASCcontribution) | ASCcontribution |
tilesPtr() const | ASCcontribution | [inline]
~ASCcontribution() (defined in ASCcontribution) | ASCcontribution | [inline]
~LATcontribution() (defined in LATcontribution) | LATcontribution | [inline]

Generated on Mon Jul 31 17:48:12 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: ASCcontributionIterator Class Reference

ASCcontributionIterator Class Reference

Class for iterating over the parts of an ASCcontribution. More...

#include <ASCcontributionIterator.h>

Collaboration diagram for ASCcontributionIterator:

[legend]
List of all members.

Public Member Functions

ASCcontributionIterator (ASCcontribution *, ACDmap *)
Constructor for iterating over the ACD contribution.
ASCcontributionIterator ()
Do nothing constructor.
unsigned | iterate ()
Iterate over the ACD contribution.
unsigned | iterate (ASCcontribution *)
Iterate over the ACD contribution.
unsigned | iterate (ASCcontribution *, ACDmap *)
Iterate over the ACD contribution.
virtual int | handleError (ASCcontribution *, unsigned code, unsigned p1=0, unsigned p2=0) const
Handle all errors possible in ASCcontributionIterator.
ASCcontribution * | contribution () const
const ACDmap * | map () const
virtual void | summary (ASCsummary &summary)=0
Pure virtual method for calling the application back with an ACSsummary object.
virtual void | cno (ASCcno &cno)=0
Pure virtual method for calling the application back with an ACDcno object.
virtual void | tiles (ASCtileContribution &tiles)=0
Pure virtual method for calling the application back with an ACDtileContribution object.
int | status () const

Detailed Description

Class for iterating over the parts of an ASCcontribution.

Author:
Eric Charles -- GLAST LAT I&T/SVAC (echarles@slac.stanford.edu)
Revision
1.1
Date:
September 21, 2005 -- Created
Id
ASCcontributionIterator.h,v 1.1 2005/09/28 22:04:13 echarles Exp

Copyright: Copyright 2005 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

ASCcontributionIterator::ASCcontributionIterator | ( | ASCcontribution * | contribution,
 |  | ACDmap * | map |
 | ) |  |  | [inline]

Constructor for iterating over the ACD contribution.

This constructor caches the event, contribution and map provided by the caller.

Parameters:
contribution | A pointer to the contribution to iterate over
map | A pointer to the electronic space to detector space map

Member Function Documentation

virtual void ASCcontributionIterator::cno ( ASCcno & cno ) [pure virtual]

Pure virtual method for calling the application back with an ACDcno object.

Parameters:
cno - The cno object

ASCcontribution* ASCcontributionIterator::contribution ( ) const [inline]

Return a pointer to the start of this contribution

int ASCcontributionIterator::handleError | ( | ASCcontribution * | contribution,
 |  | unsigned | code,
 |  | unsigned | p1 = 0,
 |  | unsigned | p2 = 0 |
 | ) |  |  | const [virtual]

Handle all errors possible in ASCcontributionIterator.

This method is used to handle errors occurring during the iteration over an ASCcontribution. By default it does nothing, however it is virtual and is able to be overridden by the user.

Parameters:
contribution | The contribution in error
code | The error code
p1 | a parameter associated with the error code
p2 | a parameter associated with the error code

unsigned ASCcontributionIterator::iterate | ( | ASCcontribution * | contribution,
 |  | ACDmap * | map |
 | ) |  |  | [inline]

Iterate over the ACD contribution.

This method calls the summary(), cno() and tiles() virtual functions for the various parts of the datagram being iterated over

Parameters:
contribution | A pointer to the contribution to iterate over
map | A pointer to the electronic space to detector space map
Returns:
The number of cable contributions seen.

unsigned ASCcontributionIterator::iterate ( ASCcontribution * contribution ) [inline]

Iterate over the ACD contribution.

This method calls the summary(), cno() and tiles() virtual functions for the various parts of the datagram being iterated over

Parameters:
contribution A pointer to the contribution to iterate over
Returns:
The number of cable contributions seen.

unsigned ASCcontributionIterator::iterate ( ) [inline]

Iterate over the ACD contribution.

This method calls the summary(), cno() and tiles() virtual functions for the various parts of the datagram being iterated over

Returns:
The number of contributions seen.

const ACDmap* ASCcontributionIterator::map ( ) const [inline]

Return a pointer to the ACD map

int ASCcontributionIterator::status ( ) const [inline]

Return the status of this iterator

virtual void ASCcontributionIterator::summary ( ASCsummary & summary ) [pure virtual]

Pure virtual method for calling the application back with an ACSsummary object.

Parameters:
summary - The summary object

virtual void ASCcontributionIterator::tiles ( ASCtileContribution & tiles ) [pure virtual]

Pure virtual method for calling the application back with an ACDtileContribution object.

Parameters:
tiles - The tile contribution object

The documentation for this class was generated from the following files:
  • ASCcontributionIterator.h
  • ASCcontributionIterator.cpp
Generated on Mon Jul 31 17:48:13 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

ASCcontributionIterator Member List

This is the complete list of members for ASCcontributionIterator, including all inherited members.

ASCcontributionIterator(ASCcontribution *, ACDmap *) | ASCcontributionIterator | [inline]
ASCcontributionIterator() | ASCcontributionIterator | [inline]
cno(ASCcno &cno)=0 | ASCcontributionIterator | [pure virtual]
contribution() const | ASCcontributionIterator | [inline]
handleError(ASCcontribution *, unsigned code, unsigned p1=0, unsigned p2=0) const | ASCcontributionIterator | [virtual]
iterate() | ASCcontributionIterator | [inline]
iterate(ASCcontribution *) | ASCcontributionIterator | [inline]
iterate(ASCcontribution *, ACDmap *) | ASCcontributionIterator | [inline]
map() const | ASCcontributionIterator | [inline]
status() const | ASCcontributionIterator | [inline]
summary(ASCsummary &summary)=0 | ASCcontributionIterator | [pure virtual]
tiles(ASCtileContribution &tiles)=0 | ASCcontributionIterator | [pure virtual]
~ASCcontributionIterator() (defined in ASCcontributionIterator) | ASCcontributionIterator | [inline, virtual]

Generated on Mon Jul 31 17:48:13 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: ASCsummary Class Reference

ASCsummary Class Reference

Class for accessing counters in the ASC error summary contribution. More...

#include <ASCsummary.h>

List of all members.

Public Types

AEM_Ok = 0
AEM_InError = 1
AEM_Missing = 2
N_AEM_Status = 3
GEM_Ok = 0
GEM_InError = 1
GEM_Missing = 2
N_GEM_Status = 3
enum | AemStatus { AEM_Ok = 0, AEM_InError = 1, AEM_Missing = 2, N_AEM_Status = 3 }
enum | GemStatus { GEM_Ok = 0, GEM_InError = 1, GEM_Missing = 2, N_GEM_Status = 3 }

Public Member Functions

ASCsummary (unsigned ptr[9])
Constructor for initializing the ASCsummary class with a ptr to the data.
unsigned | counts (AemStatus aemStatus, GemStatus gemStatus) const
method for returning the number of counts with particular status flags
unsigned | counts (AemStatus aemStatus) const
method for returning the number of counts with particular status flags
unsigned | counts (GemStatus gemStatus) const
method for returning the number of counts with particular status flags
unsigned * | ptr () const
method for returning the ptr to the data

Static Public Member Functions

static unsigned | counts (unsigned *ptr, AemStatus aemStatus, GemStatus gemStatus)
Static method for returning the number of counts with particular status flags.
static unsigned | counts (unsigned *ptr, AemStatus aemStatus)
Static method for returning the number of counts with particular status flags.
static unsigned | counts (unsigned *ptr, GemStatus gemStatus)
Static method for returning the number of counts with particular status flags.

Detailed Description

Class for accessing counters in the ASC error summary contribution.

Author:
Eric Charles -- GLAST LAT I&T/SVAC - (echarles@slac.stanford.edu)
Revision
1.1
Date:
September 21, 2005 -- Created
Id
ASCsummary.h,v 1.1 2005/09/28 22:04:13 echarles Exp

Copyright: Copyright 2005 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

ASCsummary::ASCsummary ( unsigned ptr[9] ) [inline]

Constructor for initializing the ASCsummary class with a ptr to the data.

Parameters:
ptr - pointer to the first bin

Member Function Documentation

unsigned ASCsummary::counts ( GemStatus gemStatus ) const [inline]

method for returning the number of counts with particular status flags

Parameters:
GemStatus - status of the Gem
Returns:
Number of counts with GemStatus

unsigned ASCsummary::counts | ( | unsigned * | ptr,
 |  | GemStatus | gemStatus |
 | ) |  |  | [inline, static]

Static method for returning the number of counts with particular status flags.

Parameters:
ptr | - pointer to the first bin of the histogram
GemStatus | - status of the Gem
Returns:
Number of counts with GemStatus

unsigned ASCsummary::counts ( AemStatus aemStatus ) const [inline]

method for returning the number of counts with particular status flags

Parameters:
AemStatus - status of the Aem
Returns:
Number of counts with AemStatus

unsigned ASCsummary::counts | ( | unsigned * | ptr,
 |  | AemStatus | aemStatus |
 | ) |  |  | [inline, static]

Static method for returning the number of counts with particular status flags.

Parameters:
ptr | - pointer to the first bin of the histogram
AemStatus | - status of the Aem
Returns:
Number of counts with AemStatus

unsigned ASCsummary::counts | ( | AemStatus | aemStatus,
 |  | GemStatus | gemStatus |
 | ) |  |  | const [inline]

method for returning the number of counts with particular status flags

Parameters:
AemStatus | - status of the Aem
GemStatus | - status of the Gem
Returns:
Number of counts with AemStatus and GemStatus

unsigned ASCsummary::counts | ( | unsigned * | ptr,
 |  | AemStatus | aemStatus,
 |  | GemStatus | gemStatus |
 | ) |  |  | [inline, static]

Static method for returning the number of counts with particular status flags.

Parameters:
ptr | - pointer to the first bin of the histogram
AemStatus | - status of the Aem
GemStatus | - status of the Gem
Returns:
Number of counts with AemStatus and GemStatus

unsigned * ASCsummary::ptr ( ) const [inline]

method for returning the ptr to the data

Returns:
the address of the first datum

The documentation for this class was generated from the following file:
  • ASCsummary.h
Generated on Mon Jul 31 17:48:13 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

ASCsummary Member List

This is the complete list of members for ASCsummary, including all inherited members.

AEM_InError enum value (defined in ASCsummary) | ASCsummary |
AEM_Missing enum value (defined in ASCsummary) | ASCsummary |
AEM_Ok enum value (defined in ASCsummary) | ASCsummary |
AemStatus enum name (defined in ASCsummary) | ASCsummary |
ASCsummary(unsigned ptr[9]) | ASCsummary | [inline]
ASCsummary() (defined in ASCsummary) | ASCsummary | [inline]
counts(unsigned *ptr, AemStatus aemStatus, GemStatus gemStatus) | ASCsummary | [inline, static]
counts(AemStatus aemStatus, GemStatus gemStatus) const | ASCsummary | [inline]
counts(unsigned *ptr, AemStatus aemStatus) | ASCsummary | [inline, static]
counts(AemStatus aemStatus) const | ASCsummary | [inline]
counts(unsigned *ptr, GemStatus gemStatus) | ASCsummary | [inline, static]
counts(GemStatus gemStatus) const | ASCsummary | [inline]
GEM_InError enum value (defined in ASCsummary) | ASCsummary |
GEM_Missing enum value (defined in ASCsummary) | ASCsummary |
GEM_Ok enum value (defined in ASCsummary) | ASCsummary |
GemStatus enum name (defined in ASCsummary) | ASCsummary |
N_AEM_Status enum value (defined in ASCsummary) | ASCsummary |
N_GEM_Status enum value (defined in ASCsummary) | ASCsummary |
ptr() const | ASCsummary | [inline]
~ASCsummary() (defined in ASCsummary) | ASCsummary | [inline]

Generated on Mon Jul 31 17:48:13 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: ASCtile Class Reference

ASCtile Class Reference

Class for accessing counters in the ASC associated with a single tile or ribbon. More...

#include <ASCtile.h>

List of all members.

Public Types

SignalA = 0
SignalB = 1
VetoA = 2
VetoB = 3
GemVeto = 4
enum StatusBit {
SignalA = 0, SignalB = 1, VetoA = 2, VetoB = 3,
GemVeto = 4
}

Public Member Functions

ASCtile (unsigned ptr[32])
Constructor for initializing the ASCtile class with a ptr to the data.
unsigned | counts (StatusMask mask) const
method for returning the number of counts with particular status flags
unsigned | counts (StatusBit bit) const
method for returning the number of counts with particular status flags
unsigned * | ptr () const
char * | rawData () const

Static Public Member Functions

static unsigned | counts (unsigned *ptr, StatusMask mask)
Static method for returning the number of counts with particular status flags.
static unsigned | counts (unsigned *ptr, StatusBit bit)
Static method for returning the number of counts with particular status flag.

Classes

class | StatusMask

Detailed Description

Class for accessing counters in the ASC associated with a single tile or ribbon.

Author:
Eric Charles -- GLAST LAT I&T/SVAC - (echarles@slac.stanford.edu)
Revision
1.2
Date:
September 21, 2005 -- Created
Id
ASCtile.h,v 1.2 2005/10/22 12:52:41 claus Exp

Copyright: Copyright 2005 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

ASCtile::ASCtile ( unsigned ptr[32] ) [inline]

Constructor for initializing the ASCtile class with a ptr to the data.

Parameters:
ptr - pointer to the first bin

Member Function Documentation

unsigned ASCtile::counts ( StatusBit bit ) const [inline]

method for returning the number of counts with particular status flags

Parameters:
StatusBit - a particular bit of the status mask
Returns:
Number of counts with StatusBit true

unsigned ASCtile::counts | ( | unsigned * | ptr,
 |  | StatusBit | bit |
 | ) |  |  | [inline, static]

Static method for returning the number of counts with particular status flag.

Parameters:
ptr | - pointer to the first bin of the histogram
StatusBit | - a particular bit of the status mask
Returns:
Number of counts with StatusBit true

unsigned ASCtile::counts ( StatusMask mask ) const [inline]

method for returning the number of counts with particular status flags

Parameters:
StatusMask - status flags
Returns:
Number of counts with AemStatus and GemStatus

unsigned ASCtile::counts | ( | unsigned * | ptr,
 |  | StatusMask | mask |
 | ) |  |  | [inline, static]

Static method for returning the number of counts with particular status flags.

Parameters:
ptr | - pointer to the first bin of the histogram
StatusMask | - status flags
Returns:
Number of counts with AemStatus and GemStatus

The documentation for this class was generated from the following file:
  • ASCtile.h
Generated on Mon Jul 31 17:48:13 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

ASCtile Member List

This is the complete list of members for ASCtile, including all inherited members.

ASCtile(unsigned ptr[32]) | ASCtile | [inline]
ASCtile() (defined in ASCtile) | ASCtile | [inline]
counts(unsigned *ptr, StatusMask mask) | ASCtile | [inline, static]
counts(StatusMask mask) const | ASCtile | [inline]
counts(unsigned *ptr, StatusBit bit) | ASCtile | [inline, static]
counts(StatusBit bit) const | ASCtile | [inline]
GemVeto enum value (defined in ASCtile) | ASCtile |
ptr() const (defined in ASCtile) | ASCtile | [inline]
rawData() const (defined in ASCtile) | ASCtile | [inline]
SignalA enum value (defined in ASCtile) | ASCtile |
SignalB enum value (defined in ASCtile) | ASCtile |
StatusBit enum name (defined in ASCtile) | ASCtile |
VetoA enum value (defined in ASCtile) | ASCtile |
VetoB enum value (defined in ASCtile) | ASCtile |
~ASCtile() (defined in ASCtile) | ASCtile | [inline]

Generated on Mon Jul 31 17:48:13 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: ASCtileContribution Class Reference

ASCtileContribution Class Reference

Class for accessing fields in the ASC tile statistics contribution. More...

#include <ASCtileContribution.h>

List of all members.

Public Types

Tile_Words = 32
enum | { Tile_Words = 32 }

Public Member Functions

ASCtileContribution (unsigned *ptr)
Constructor for initializing the ASCtileContribution class with a ptr to the data.
ASCtileContribution ()
Constructor for initializing the ASCtileContribution.
unsigned * | ptr () const
Return a pointer to the beginning of the ASC tile statistics data.

Detailed Description

Class for accessing fields in the ASC tile statistics contribution.

Author:
Eric Charles -- GLAST LAT I&T/SVAC - (echarles@slac.stanford.edu)
Revision
1.1
Date:
September 21, 2005 -- Created
Id
ASCtileContribution.h,v 1.1 2005/09/28 22:04:13 echarles Exp

Copyright: Copyright 2005 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

ASCtileContribution::ASCtileContribution ( unsigned * ptr ) [inline]

Constructor for initializing the ASCtileContribution class with a ptr to the data.

Parameters:
ptr - pointer to the first bin

Member Function Documentation

unsigned * ASCtileContribution::ptr ( ) const [inline]

Return a pointer to the beginning of the ASC tile statistics data.

Returns:
A pointer to the beginning of the ASC tile statistics data

The documentation for this class was generated from the following file:
  • ASCtileContribution.h
Generated on Mon Jul 31 17:48:13 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

ASCtileContribution Member List

This is the complete list of members for ASCtileContribution, including all inherited members.

ASCtileContribution(unsigned *ptr) | ASCtileContribution | [inline]
ASCtileContribution() | ASCtileContribution | [inline]
ptr() const | ASCtileContribution | [inline]
Tile_Words enum value (defined in ASCtileContribution) | ASCtileContribution |
~ASCtileContribution() (defined in ASCtileContribution) | ASCtileContribution | [inline]

Generated on Mon Jul 31 17:48:13 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: ASCtileContributionIterator Class Reference

ASCtileContributionIterator Class Reference

Class for iterating over the individual tiles in an ASCtileContribution. More...

#include <ASCtileContributionIterator.h>

Collaboration diagram for ASCtileContributionIterator:

[legend]
List of all members.

Public Member Functions

ASCtileContributionIterator (ASCcontribution *, ASCtileContribution *, ACDmap *)
Constructor for iterating over the ACD contribution.
ASCtileContributionIterator ()
Do nothing constructor.
unsigned | iterate ()
Iterate over the ACD contribution.
unsigned | iterate (ASCcontribution *, ASCtileContribution *)
Iterate over the ACD contribution.
unsigned | iterate (ASCcontribution *, ASCtileContribution *, const ACDmap *)
Iterate over the ACD contribution.
virtual int | handleError (ASCtileContribution *, unsigned code, unsigned p1=0, unsigned p2=0) const
Handle all errors possible in ASCtileContributionIterator.
const ASCcontribution * | ascDatagram () const
const ASCtileContribution * | contribution () const
const ACDmap * | map () const
virtual void | tile (unsigned channel, const ASCtile &tile)=0
Pure virtual method for calling the application back with an ASCtile.

Detailed Description

Class for iterating over the individual tiles in an ASCtileContribution.

Author:
Eric Charles -- GLAST LAT I&T/SVAC (echarles@slac.stanford.edu)
Revision
1.1
Date:
September 21, 2005 -- Created
Id
ASCtileContributionIterator.h,v 1.1 2005/09/28 22:04:13 echarles Exp

Copyright: Copyright 2005 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

ASCtileContributionIterator::ASCtileContributionIterator | ( | ASCcontribution * | asc,
 |  | ASCtileContribution * | contribution,
 |  | ACDmap * | map |
 | ) |  |  | [inline]

Constructor for iterating over the ACD contribution.

This constructor caches the event, contribution and map provided by the caller.

Parameters:
asc | A pointer to the ASCcontribution containing the contribution
contribution | A pointer to the contribution to iterate over
map | A pointer to the electronic space to detector space map

Member Function Documentation

const ASCcontribution* ASCtileContributionIterator::ascDatagram ( ) const [inline]

Return a pointer to the ASCcontribution containing this contribution

const ASCtileContribution* ASCtileContributionIterator::contribution ( ) const [inline]

Return a pointer to the start of this contribution

int ASCtileContributionIterator::handleError | ( | ASCtileContribution * | tileContribution,
 |  | unsigned | code,
 |  | unsigned | p1 = 0,
 |  | unsigned | p2 = 0 |
 | ) |  |  | const [virtual]

Handle all errors possible in ASCtileContributionIterator.

This method is used to handle errors occurring during the iteration over an ASCtileContribution. By default it does nothing, however it is virtual and is able to be overridden by the user.

Parameters:
tileContribution | The tileContribution in error
code | The error code
p1 | a parameter associated with the error code
p2 | a parameter associated with the error code

unsigned ASCtileContributionIterator::iterate | ( | ASCcontribution * | asc,
 |  | ASCtileContribution * | contribution,
 |  | const ACDmap * | map |
 | ) |  |  | [inline]

Iterate over the ACD contribution.

This method calls the header() virtual function for each cable contribution encountered and the pha() virtual function with every hit it finds.

Parameters:
event | A pointer to the EBFevent containing the contribution
contribution | A pointer to the contribution to iterate over
map | A pointer to the electronic space to detector space map
Returns:
The number of cable contributions seen.

unsigned ASCtileContributionIterator::iterate | ( | ASCcontribution * | asc,
 |  | ASCtileContribution * | contribution |
 | ) |  |  | [inline]

Iterate over the ACD contribution.

This method calls the header() virtual function for each cable contribution encountered and the pha() virtual function with every hit it finds.

Parameters:
event | A pointer to the EBFevent containing the contribution
contribution | A pointer to the contribution to iterate over
Returns:
The number of cable contributions seen.

unsigned ASCtileContributionIterator::iterate ( ) [inline]

Iterate over the ACD contribution.

This method calls the header() virtual function for each cable contribution encountered and the pha() virtual function with every hit it finds. This method uses the event, contribution and map established by the ctor.

Returns:
The number of cable contributions seen.

const ACDmap* ASCtileContributionIterator::map ( ) const [inline]

Return a pointer to the ACD map

virtual void ASCtileContributionIterator::tile | ( | unsigned | channel,
 |  | const ASCtile & | tile |
 | ) |  |  | [pure virtual]

Pure virtual method for calling the application back with an ASCtile.

Parameters:
channel | - The channel id for the tile contribtution
tile | - the tile object

The documentation for this class was generated from the following files:
  • ASCtileContributionIterator.h
  • ASCtileContributionIterator.cpp
Generated on Mon Jul 31 17:48:13 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

ASCtileContributionIterator Member List

This is the complete list of members for ASCtileContributionIterator, including all inherited members.

ascDatagram() const | ASCtileContributionIterator | [inline]
ASCtileContributionIterator(ASCcontribution *, ASCtileContribution *, ACDmap *) | ASCtileContributionIterator | [inline]
ASCtileContributionIterator() | ASCtileContributionIterator | [inline]
contribution() const | ASCtileContributionIterator | [inline]
handleError(ASCtileContribution *, unsigned code, unsigned p1=0, unsigned p2=0) const | ASCtileContributionIterator | [virtual]
iterate() | ASCtileContributionIterator | [inline]
iterate(ASCcontribution *, ASCtileContribution *) | ASCtileContributionIterator | [inline]
iterate(ASCcontribution *, ASCtileContribution *, const ACDmap *) | ASCtileContributionIterator | [inline]
map() const | ASCtileContributionIterator | [inline]
tile(unsigned channel, const ASCtile &tile)=0 | ASCtileContributionIterator | [pure virtual]
~ASCtileContributionIterator() (defined in ASCtileContributionIterator) | ASCtileContributionIterator | [inline, virtual]

Generated on Mon Jul 31 17:48:13 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: CALcontribution Class Reference

CALcontribution Class Reference

Class for decoding CALorimeter's contribution to a TEMcontribution. More...

#include <CALcontribution.h>

Inheritance diagram for CALcontribution:

[legend]
Collaboration diagram for CALcontribution:

[legend]
List of all members.

Public Member Functions

char * data () const
Return a char pointer to the beginning of the CAL data starting after the log accepts mask.

Detailed Description

Class for decoding CALorimeter's contribution to a TEMcontribution.

Author:
Ric Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.6
Date:
January 26, 2003 -- Created
Id
CALcontribution.h,v 1.6 2004/04/02 01:11:47 claus Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Member Function Documentation

char * CALcontribution::data ( ) const [inline]

Return a char pointer to the beginning of the CAL data starting after the log accepts mask.

Returns:
A char pointer to the beginning of the CAL data starting after the log accepts mask

The documentation for this class was generated from the following file:
  • CALcontribution.h
Generated on Mon Jul 31 17:48:13 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

CALcontribution Member List

This is the complete list of members for CALcontribution, including all inherited members.

AEM enum value (defined in EBFcontribution) | EBFcontribution |
aemContribution() const | EBFcontribution | [inline]
Broadcast enum value (defined in EBFcontribution) | EBFcontribution |
CALcontribution() (defined in CALcontribution) | CALcontribution | [inline]
calContribution() const | TEMcontribution | [inline]
CRU enum value (defined in EBFcontribution) | EBFcontribution |
data() const | CALcontribution | [inline]
EBFcontribution() (defined in EBFcontribution) | EBFcontribution | [inline]
EBM enum value (defined in EBFcontribution) | EBFcontribution |
GEM enum value (defined in EBFcontribution) | EBFcontribution |
gemContribution() const | EBFcontribution | [inline]
gltContribution() const | EBFcontribution | [inline]
header() const | EBFcontribution | [inline]
length() const | EBFcontribution | [inline]
logAccepts() const | TEMcontribution | [inline]
next() const | EBFcontribution | [inline]
NumberOfContributions enum value (defined in EBFcontribution) | EBFcontribution |
numLogAccepts() const | TEMcontribution | [inline]
OSW enum value (defined in EBFcontribution) | EBFcontribution |
oswContribution() const | EBFcontribution | [inline]
packetError() const | EBFcontribution | [inline]
Parity enum value (defined in EBFcontribution) | EBFcontribution |
payload() const | EBFcontribution | [inline]
payloadSize() const | EBFcontribution | [inline]
PDU_0 enum value (defined in EBFcontribution) | EBFcontribution |
PDU_1 enum value (defined in EBFcontribution) | EBFcontribution |
sequence() const | EBFcontribution | [inline]
summary() const | EBFcontribution | [inline]
TEMcontribution() (defined in TEMcontribution) | TEMcontribution | [inline]
temContribution() const | EBFcontribution | [inline]
TimedOut enum value (defined in EBFcontribution) | EBFcontribution |
tkrContribution() const | TEMcontribution | [inline]
Tower_00 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_01 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_02 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_03 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_04 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_05 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_06 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_07 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_08 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_09 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_10 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_11 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_12 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_13 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_14 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_15 enum value (defined in EBFcontribution) | EBFcontribution |
Truncated enum value (defined in EBFcontribution) | EBFcontribution |
WriteFault enum value (defined in EBFcontribution) | EBFcontribution |
~CALcontribution() (defined in CALcontribution) | CALcontribution | [inline]
~EBFcontribution() (defined in EBFcontribution) | EBFcontribution | [inline]
~TEMcontribution() (defined in TEMcontribution) | TEMcontribution | [inline]

Generated on Mon Jul 31 17:48:13 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: CALcontributionIterator Class Reference

CALcontributionIterator Class Reference

Class for iterating over contributions to a CALcontribution. More...

#include <CALcontributionIterator.h>

Collaboration diagram for CALcontributionIterator:

[legend]
List of all members.

Public Member Functions

CALcontributionIterator (EBFevent *, CALcontribution *, CALmap *)
Constructor for iterating over the calorimeter contribution.
CALcontributionIterator (EBFevent *, CALcontribution *)
Constructor for iterating over the calorimeter contribution.
CALcontributionIterator (CALmap *)
Constructor for setting up the electronic space to detector space map.
CALcontributionIterator ()
Do nothing constructor.
unsigned | iterate ()
Iterate over the calorimeter contribution.
unsigned | iterate (EBFevent *, CALcontribution *)
Iterate over the calorimeter contribution.
unsigned | iterate (EBFevent *, CALcontribution *, CALmap *)
Class for iterating over contributions to a CAL contribution.Iterate over the calorimeter contribution.
virtual int | handleError (CALcontribution *, unsigned code, unsigned p1=0, unsigned p2=0) const
Handle all errors possible in CALcontributionIterator.
const EBFevent * | event () const
const CALcontribution * | contribution () const
unsigned | CALend () const
const CALmap * | map () const
virtual void | log (unsigned tower, unsigned layer, CALlog log)=0
Pure virtual method for calling the application back with a CAL log value.

Detailed Description

Class for iterating over contributions to a CALcontribution.

Author:
Jim Panetta -- GLAST LAT I&T/Online - (panetta@slac.stanford.edu)
Revision
1.8
Date:
July 17, 2003 -- Created
Id
CALcontributionIterator.h,v 1.8 2005/03/15 18:59:38 panetta Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

CALcontributionIterator::CALcontributionIterator | ( | EBFevent * | event,
 |  | CALcontribution * | contribution,
 |  | CALmap * | map |
 | ) |  |  | [inline]

Constructor for iterating over the calorimeter contribution.

This constructor caches the event, contribution and map provided by the caller.

Parameters:
event | A pointer to the EBFevent containing the contribution
contribution | A pointer to the contribution to iterate over
map | A pointer to the electronic space to detector space map

CALcontributionIterator::CALcontributionIterator | ( | EBFevent * | event,
 |  | CALcontribution * | contribution |
 | ) |  |  | [inline]

Constructor for iterating over the calorimeter contribution.

This constructor caches the event and contribution provided by the caller.

Parameters:
event | A pointer to the EBFevent containing the contribution
contribution | A pointer to the contribution to iterate over

CALcontributionIterator::CALcontributionIterator ( CALmap * map ) [inline]

Constructor for setting up the electronic space to detector space map.

Parameters:
map A pointer to the electronic space to detector space map

Member Function Documentation

unsigned CALcontributionIterator::CALend ( ) const [inline]

Return the offset to the end of the CAL portion of the contribution

const CALcontribution* CALcontributionIterator::contribution ( ) const [inline]

Return a pointer to the start of this contribution

const EBFevent* CALcontributionIterator::event ( ) const [inline]

Return a pointer to the EBFevent containing this contribution

int CALcontributionIterator::handleError | ( | CALcontribution * | ,
 |  | unsigned | code,
 |  | unsigned | p1 = 0,
 |  | unsigned | p2 = 0 |
 | ) |  |  | const [inline, virtual]

Handle all errors possible in CALcontributionIterator.

This method is used to handle errors occurring during the iteration over an CALcontribution. By default it does nothing, however it is virtual and is able to be overridden by the user.

Parameters:
code | The error code
p1 | a parameter associated with the error code
p2 | a parameter associated with the error code

unsigned CALcontributionIterator::iterate | ( | EBFevent * | event,
 |  | CALcontribution * | contribution,
 |  | CALmap * | map
 | ) |  |

Class for iterating over contributions to a CAL contribution.Iterate over the calorimeter contribution.

This method calls the log() virtual function back with every hit it finds. This method uses the event, contribution and map provided by the caller.

Parameters:
event | A pointer to the EBFevent containing the contribution
contribution | A pointer to the contribution to iterate over
map | A pointer to the electronic space to detector space map
Returns:
The number of logs handled.

unsigned CALcontributionIterator::iterate | ( | EBFevent * | event,
 |  | CALcontribution * | contribution |
 | ) |  |  | [inline]

Iterate over the calorimeter contribution.

This method calls the log() virtual function back with every hit it finds. This method uses the event and contribution provided by the caller and the map established by the ctor.

Parameters:
event | A pointer to the EBFevent containing the contribution
contribution | A pointer to the contribution to iterate over
Returns:
The number of logs handled.

unsigned CALcontributionIterator::iterate ( ) [inline]

Iterate over the calorimeter contribution.

This method calls the log() virtual function back with every hit it finds. This method uses the event, contribution and map established by the ctor.

Returns:
The number of logs handled.

virtual void CALcontributionIterator::log | ( | unsigned | tower,
 |  | unsigned | layer,
 |  | CALlog | log |
 | ) |  |  | [pure virtual]

Pure virtual method for calling the application back with a CAL log value.

Parameters:
tower | - The tower (in detector space) the log value came from
layer | - The layer (in detector space) the log value came from
log | - The log object

const CALmap* CALcontributionIterator::map ( ) const [inline]

Return a pointer to the calorimeter map

The documentation for this class was generated from the following files:
  • CALcontributionIterator.h
  • CALcontributionIterator.cpp
Generated on Mon Jul 31 17:48:13 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

CALcontributionIterator Member List

This is the complete list of members for CALcontributionIterator, including all inherited members.

CALcontributionIterator(EBFevent *, CALcontribution *, CALmap *) | CALcontributionIterator | [inline]
CALcontributionIterator(EBFevent *, CALcontribution *) | CALcontributionIterator | [inline]
CALcontributionIterator(CALmap *) | CALcontributionIterator | [inline]
CALcontributionIterator() | CALcontributionIterator | [inline]
CALend() const | CALcontributionIterator | [inline]
contribution() const | CALcontributionIterator | [inline]
event() const | CALcontributionIterator | [inline]
handleError(CALcontribution *, unsigned code, unsigned p1=0, unsigned p2=0) const | CALcontributionIterator | [inline, virtual]
iterate() | CALcontributionIterator | [inline]
iterate(EBFevent *, CALcontribution *) | CALcontributionIterator | [inline]
iterate(EBFevent *, CALcontribution *, CALmap *) | CALcontributionIterator |
log(unsigned tower, unsigned layer, CALlog log)=0 | CALcontributionIterator | [pure virtual]
map() const | CALcontributionIterator | [inline]
~CALcontributionIterator() (defined in CALcontributionIterator) | CALcontributionIterator | [inline, virtual]

Generated on Mon Jul 31 17:48:13 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: CALdiagnostic Class Reference

CALdiagnostic Class Reference

Class for accessing fields in the CAL diagnostic data word. More...

#include <CALdiagnostic.h>

List of all members.

Public Member Functions

CALdiagnostic (unsigned datum)
CALdiagnostic constructor for parsing CAL diagnostic data.
unsigned | high (unsigned side)
Method for returning the high energy trigger request value.
unsigned | low (unsigned side)
Method for returning the low energy trigger request value.
unsigned | logAccepts (unsigned side)
Method for returning the status of the log accept lines.
unsigned | datum () const
Method for returning the CAL diagnostic value the class was constructed with.

Static Public Member Functions

static unsigned | high (unsigned datum, unsigned side)
Static method for returning the high energy trigger request value.
static unsigned | low (unsigned datum, unsigned side)
Static method for returning the low energy trigger request value.
static unsigned | logAccepts (unsigned datum, unsigned side)
Static method for returning the status of the log accept lines.

Detailed Description

Class for accessing fields in the CAL diagnostic data word.

Author:
Ric Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.3
Date:
January 23, 2003 -- Created
Id
CALdiagnostic.h,v 1.3 2004/04/02 01:14:43 claus Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

CALdiagnostic::CALdiagnostic ( unsigned datum ) [inline]

CALdiagnostic constructor for parsing CAL diagnostic data.

Parameters:
datum The diagnostic data structure

Member Function Documentation

unsigned CALdiagnostic::datum ( ) const [inline]

Method for returning the CAL diagnostic value the class was constructed with.

Returns:
The CAL diagnostic value

unsigned CALdiagnostic::high ( unsigned side ) [inline]

Method for returning the high energy trigger request value.

Parameters:
side The layer end to return data for: 0 for positive, 1 for negative
Returns:
The high energy trigger request value

unsigned CALdiagnostic::high | ( | unsigned | datum,
 |  | unsigned | side |
 | ) |  |  | [inline, static]

Static method for returning the high energy trigger request value.

Parameters:
datum | The diagnostic data structure
side | The layer end to return data for: 0 for positive, 1 for negative
Returns:
The high energy trigger request value

unsigned CALdiagnostic::logAccepts ( unsigned side ) [inline]

Method for returning the status of the log accept lines.

Parameters:
side The layer end to return data for: 0 for positive, 1 for negative
Returns:
The status of the log accept lines

unsigned CALdiagnostic::logAccepts | ( | unsigned | datum,
 |  | unsigned | side |
 | ) |  |  | [inline, static]

Static method for returning the status of the log accept lines.

Parameters:
datum | The diagnostic data structure
side | The layer end to return data for: 0 for positive, 1 for negative
Returns:
The status of the log accept lines

unsigned CALdiagnostic::low ( unsigned side ) [inline]

Method for returning the low energy trigger request value.

Parameters:
side The layer end to return data for: 0 for positive, 1 for negative
Returns:
The low energy trigger request value

unsigned CALdiagnostic::low | ( | unsigned | datum,
 |  | unsigned | side |
 | ) |  |  | [inline, static]

Static method for returning the low energy trigger request value.

Parameters:
datum | The diagnostic data structure
side | The layer end to return data for: 0 for positive, 1 for negative
Returns:
The low energy trigger request value

The documentation for this class was generated from the following file:
  • CALdiagnostic.h
Generated on Mon Jul 31 17:48:13 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

CALdiagnostic Member List

This is the complete list of members for CALdiagnostic, including all inherited members.

CALdiagnostic(unsigned datum) | CALdiagnostic | [inline]
CALdiagnostic() (defined in CALdiagnostic) | CALdiagnostic | [inline]
datum() const | CALdiagnostic | [inline]
high(unsigned datum, unsigned side) | CALdiagnostic | [inline, static]
high(unsigned side) | CALdiagnostic | [inline]
logAccepts(unsigned datum, unsigned side) | CALdiagnostic | [inline, static]
logAccepts(unsigned side) | CALdiagnostic | [inline]
low(unsigned datum, unsigned side) | CALdiagnostic | [inline, static]
low(unsigned side) | CALdiagnostic | [inline]
~CALdiagnostic() (defined in CALdiagnostic) | CALdiagnostic | [inline]

Generated on Mon Jul 31 17:48:13 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: CALlog Class Reference

CALlog Class Reference

Class for accessing fields in the CAL log data longword. More...

#include <CALlog.h>

List of all members.

Public Member Functions

CALlog (unsigned datum)
Constructor for initializing the CALlog class with a log value.
unsigned | column () const
Method for returning the column from a log value.
CALlogEnd | negative () const
Static method for returning the negative log-end from a log value.
CALlogEnd | positive () const
Static method for returning the positive log-end from a log value.
unsigned | datum () const
Method for returning the log value the class was constructed with.

Static Public Member Functions

static unsigned | column (unsigned datum)
Static method for returning the column from a log value.
static CALlogEnd | negative (unsigned datum)
Static method for returning the negative log-end from a log value.
static CALlogEnd | positive (unsigned datum)
Static method for returning the positive log-end from a log value.

Detailed Description

Class for accessing fields in the CAL log data longword.

Author:
Ric Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.3
Date:
January 23, 2003 -- Created
Id
CALlog.h,v 1.3 2004/04/01 23:40:46 claus Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

CALlog::CALlog ( unsigned datum ) [inline]

Constructor for initializing the CALlog class with a log value.

Parameters:
datum - A log value

Member Function Documentation

unsigned CALlog::column ( ) const [inline]

Method for returning the column from a log value.

Returns:
The column value

unsigned CALlog::column ( unsigned datum ) [inline, static]

Static method for returning the column from a log value.

Parameters:
datum - A log value
Returns:
The column value

unsigned CALlog::datum ( ) const [inline]

Method for returning the log value the class was constructed with.

Returns:
The log value

CALlogEnd CALlog::negative ( ) const [inline]

Static method for returning the negative log-end from a log value.

Returns:
The negative log-end structure

CALlogEnd CALlog::negative ( unsigned datum ) [inline, static]

Static method for returning the negative log-end from a log value.

Parameters:
datum - A log value
Returns:
The negative log-end structure

CALlogEnd CALlog::positive ( ) const [inline]

Static method for returning the positive log-end from a log value.

Returns:
The positive log-end structure

CALlogEnd CALlog::positive ( unsigned datum ) [inline, static]

Static method for returning the positive log-end from a log value.

Parameters:
datum - A log value
Returns:
The positive log-end structure

The documentation for this class was generated from the following file:
  • CALlog.h
Generated on Mon Jul 31 17:48:13 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

CALlog Member List

This is the complete list of members for CALlog, including all inherited members.

CALlog(unsigned datum) | CALlog | [inline]
CALlog() (defined in CALlog) | CALlog | [inline]
column(unsigned datum) | CALlog | [inline, static]
column() const | CALlog | [inline]
datum() const | CALlog | [inline]
negative(unsigned datum) | CALlog | [inline, static]
negative() const | CALlog | [inline]
positive(unsigned datum) | CALlog | [inline, static]
positive() const | CALlog | [inline]
~CALlog() (defined in CALlog) | CALlog | [inline]

Generated on Mon Jul 31 17:48:13 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: CALlogEnd Class Reference

CALlogEnd Class Reference

Class for accessing fields in the CAL log-end data word. More...

#include <CALlogEnd.h>

List of all members.

Public Member Functions

CALlogEnd (unsigned datum)
Constructor for initializing the CALlogEnd class with a log-end value.
unsigned | range () const
Method for returning the log-end ADC range value.
unsigned | value () const
Method for returning the log-end ADC value.
unsigned | datum () const
Method for returning the log-end value the class was constructed with.

Static Public Member Functions

static unsigned | range (unsigned datum)
Static method for returning the log-end ADC range value.
static unsigned | value (unsigned datum)
Static method for returning the log-end ADC value.

Detailed Description

Class for accessing fields in the CAL log-end data word.

Author:
Ric Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.2
Date:
January 23, 2003 -- Created
Id
CALlogEnd.h,v 1.2 2004/04/01 23:42:02 claus Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

CALlogEnd::CALlogEnd ( unsigned datum ) [inline]

Constructor for initializing the CALlogEnd class with a log-end value.

Parameters:
datum - A log-end value

Member Function Documentation

unsigned CALlogEnd::datum ( ) const [inline]

Method for returning the log-end value the class was constructed with.

Returns:
The log-end value

unsigned CALlogEnd::range ( ) const [inline]

Method for returning the log-end ADC range value.

Returns:
The log-end range value

unsigned CALlogEnd::range ( unsigned datum ) [inline, static]

Static method for returning the log-end ADC range value.

Parameters:
datum - A log-end value
Returns:
The log-end range value

unsigned CALlogEnd::value ( ) const [inline]

Method for returning the log-end ADC value.

Returns:
The log-end ADC value

unsigned CALlogEnd::value ( unsigned datum ) [inline, static]

Static method for returning the log-end ADC value.

Parameters:
datum - A log-end value
Returns:
The log-end ADC value

The documentation for this class was generated from the following file:
  • CALlogEnd.h
Generated on Mon Jul 31 17:48:13 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

CALlogEnd Member List

This is the complete list of members for CALlogEnd, including all inherited members.

CALlogEnd(unsigned datum) | CALlogEnd | [inline]
CALlogEnd() (defined in CALlogEnd) | CALlogEnd | [inline]
datum() const | CALlogEnd | [inline]
range(unsigned datum) | CALlogEnd | [inline, static]
range() const | CALlogEnd | [inline]
value(unsigned datum) | CALlogEnd | [inline, static]
value() const | CALlogEnd | [inline]
~CALlogEnd() (defined in CALlogEnd) | CALlogEnd | [inline]

Generated on Mon Jul 31 17:48:13 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: CALmap Class Reference

CALmap Class Reference

Class for mapping a CAL contribution from electronics space to detector spaec. More...

#include <CALmap.h>

Inheritance diagram for CALmap:

[legend]
Collaboration diagram for CALmap:

[legend]
List of all members.

Public Member Functions

virtual unsigned layerID (LATtypeId ebfId, unsigned source) const
This method provides an opportunity to remap the layer number.

Detailed Description

Class for mapping a CAL contribution from electronics space to detector spaec.

Author:
R. Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.2
Date:
February 24, 2004 -- Created
Id
CALmap.h,v 1.2 2004/04/14 03:52:11 claus Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Member Function Documentation

unsigned CALmap::layerID | ( | LATtypeId | ebfId,
 |  | unsigned | source |
 | ) |  |  | const [inline, virtual]

This method provides an opportunity to remap the layer number.

This could be done based on a EBF format version number. Layer ID runs from 0 to 7 and indicates which layer was hit in the LAT coordinate system. Remap is necessary if the correspondance between gccc and physical location changes

Parameters:
ebfId | - The EBF format typeId (version number)
source | - The source layer in electronics space
Returns:
The mapped layer number

The documentation for this class was generated from the following file:
  • CALmap.h
Generated on Mon Jul 31 17:48:14 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

CALmap Member List

This is the complete list of members for CALmap, including all inherited members.

CALmap() (defined in CALmap) | CALmap | [inline]
layerID(LATtypeId ebfId, unsigned source) const | CALmap | [inline, virtual]
tower(LATtypeId evtId, unsigned id) const | TWRmap | [inline, virtual]
TWRmap() (defined in TWRmap) | TWRmap | [inline]
~CALmap() (defined in CALmap) | CALmap | [inline, virtual]
~TWRmap() (defined in TWRmap) | TWRmap | [inline, virtual]

Generated on Mon Jul 31 17:48:14 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: DIAGcontributionIterator Class Reference

DIAGcontributionIterator Class Reference

Class for iterating over parts of a Diagnostic contribution. More...

#include <DIAGcontributionIterator.h>

Collaboration diagram for DIAGcontributionIterator:

[legend]
List of all members.

Public Member Functions

DIAGcontributionIterator (EBFevent *event, TEMcontribution *contribution, CALmap *calMap, TKRmap *tkrMap)
DIAGcontributionIterator constructor initializing the class according to the passed in parameters.
DIAGcontributionIterator (EBFevent *event, TEMcontribution *contribution)
DIAGcontributionIterator constructor initializing the class according to the passed in parameters.
virtual int | handleError (TEMcontribution *, unsigned code, unsigned p1=0, unsigned p2=0) const
Handle all errors possible in DIAGcontributionIterator.
DIAGcontributionIterator ()
DIAGcontributionIterator constructor initializing the class to an invalid state.
unsigned | iterateCAL ()
Iterate over CAL diagnostic contributions.
unsigned | iterateCAL (EBFevent *event, TEMcontribution *contribution)
Iterate over CAL diagnostic contributions.
unsigned | iterateCAL (EBFevent *event, TEMcontribution *contribution, CALmap *map)
Iterate over CAL diagnostic contributions.
unsigned | iterateTKR ()
Iterate over TKR diagnostic contributions.
unsigned | iterateTKR (EBFevent *event, TEMcontribution *contribution)
Iterate over TKR diagnostic contributions.
unsigned | iterateTKR (EBFevent *event, TEMcontribution *contribution, TKRmap *map)
Iterate over a TKR diagnostic contribution.
const EBFevent * | event () const
const TEMcontribution * | contribution () const
const CALmap * | calMap () const
const TKRmap * | tkrMap () const
int | status () const
unsigned | size () const
void | offset (unsigned o)
Set the offset into the TEM contribution where the diagnostic data starts.
virtual int | CALdiag (unsigned tower, unsigned layer, CALdiagnostic diag)
Non-pure virtual method for calling the application back with CAL diagnostic data.
virtual int | TKRdiag (unsigned tower, unsigned gtcc, TKRdiagnostic diag)
Non-pure virtual method for calling the application back with TKR diagnostic data.

Detailed Description

Class for iterating over parts of a Diagnostic contribution.

Author:
J. Panetta -- GLAST LAT I&T/Online - (panetta@slac.stanford.edu)
Revision
1.8
Date:
November 25, 2003 -- Created
Id
DIAGcontributionIterator.h,v 1.8 2005/03/18 05:20:36 panetta Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

DIAGcontributionIterator::DIAGcontributionIterator | ( | EBFevent * | event,
 |  | TEMcontribution * | contribution,
 |  | CALmap * | calMap,
 |  | TKRmap * | tkrMap |
 | ) |  |  | [inline]

DIAGcontributionIterator constructor initializing the class according to the passed in parameters.

Parameters:
event | - The event containing the DIAG contribution
contribution | - The TEM contribution containing the DIAG contribution
calMap | - The electronic space to detector space map for CAL
tkrMap | - The electronic space to detector space map for TKR

DIAGcontributionIterator::DIAGcontributionIterator | ( | EBFevent * | event,
 |  | TEMcontribution * | contribution |
 | ) |  |  | [inline]

DIAGcontributionIterator constructor initializing the class according to the passed in parameters.

Parameters:
event | - A pointer to the event containing the DIAG contribution
contribution | - A pointer to the TEM contribution containing the DIAG contribution

Member Function Documentation

int DIAGcontributionIterator::CALdiag | ( | unsigned | tower,
 |  | unsigned | layer,
 |  | CALdiagnostic | diag |
 | ) |  |  | [inline, virtual]

Non-pure virtual method for calling the application back with CAL diagnostic data.

If this method is not overridden by the application, it defaults to a do-nothing method.

Parameters:
tower | - The tower (in detector space) the diagnostic data came from
layer | - The layer (in detector space) the diagnostic data came from
diag | - The CAL diagnostic object
Returns:
A status value. If non-zero, iteration is terminated.

const CALmap * DIAGcontributionIterator::calMap ( ) const [inline]

Return a pointer to the CAL map

const TEMcontribution * DIAGcontributionIterator::contribution ( ) const [inline]

Return a pointer to the start of this contribution

const EBFevent * DIAGcontributionIterator::event ( ) const [inline]

Return a pointer to the EBFevent containing this contribution

int DIAGcontributionIterator::handleError | ( | TEMcontribution * | contribution,
 |  | unsigned | code,
 |  | unsigned | p1 = 0,
 |  | unsigned | p2 = 0 |
 | ) |  |  | const [inline, virtual]

Handle all errors possible in DIAGcontributionIterator.

This method is used to handle errors occurring during the iteration over an DIAGcontribution. By default it does nothing, however it is virtual and is able to be overridden by the user.

Parameters:
contribution | The contribution in error
code | The error code
p1 | a parameter associated with the error code
p2 | a parameter associated with the error code

unsigned DIAGcontributionIterator::iterateCAL | ( | EBFevent * | event,
 |  | TEMcontribution * | contribution,
 |  | CALmap * | map
 | ) |  |

Iterate over CAL diagnostic contributions.

This method calls the CALdiag() virtual function back for every CAL diagnostic word.

Parameters:
event | - A pointer to the EBFevent containing the contribution
contribution | - A pointer to the contribution to iterate over
map | - A pointer to the electronic space to detector space map
Returns:
The number of contributions handled

unsigned DIAGcontributionIterator::iterateCAL | ( | EBFevent * | event,
 |  | TEMcontribution * | contribution |
 | ) |  |  | [inline]

Iterate over CAL diagnostic contributions.

This method iterates over the supplied contribution using the cached map.

Parameters:
event | A pointer to the EBFevent containing the contribution
contribution | A pointer to the contribution to iterate over
Returns:
The number of contributions handled

unsigned DIAGcontributionIterator::iterateCAL ( ) [inline]

Iterate over CAL diagnostic contributions.

This method uses the cached contribution and map to interate over.

Returns:
The number of contributions handled

unsigned DIAGcontributionIterator::iterateTKR | ( | EBFevent * | event,
 |  | TEMcontribution * | contribution,
 |  | TKRmap * | map
 | ) |  |

Iterate over a TKR diagnostic contribution.

This method calls the TKRdiag() virtual function back for every TKR diagnostic word. It also defines the end of the diagnostic part of the TEMcontribution

Parameters:
event | A pointer to the EBFevent containing the contribution
contribution | A pointer to the contribution to iterate over
map | A pointer to the electronic space to detector space map
Returns:
The number of contributions handled

unsigned DIAGcontributionIterator::iterateTKR | ( | EBFevent * | event,
 |  | TEMcontribution * | contribution |
 | ) |  |  | [inline]

Iterate over TKR diagnostic contributions.

This method iterates over the supplied contribution using the cached map.

Parameters:
event | A pointer to the EBFevent containing the contribution
contribution | A pointer to the contribution to iterate over
Returns:
The number of contributions handled

unsigned DIAGcontributionIterator::iterateTKR ( ) [inline]

Iterate over TKR diagnostic contributions.

This method uses the cached contribution and map to interate over.

Returns:
The number of contributions handled

unsigned DIAGcontributionIterator::size ( ) const [inline]

Return the size of the diagnostic contribution

int DIAGcontributionIterator::status ( ) const [inline]

Return the iteration status code

int DIAGcontributionIterator::TKRdiag | ( | unsigned | tower,
 |  | unsigned | gtcc,
 |  | TKRdiagnostic | diag |
 | ) |  |  | [inline, virtual]

Non-pure virtual method for calling the application back with TKR diagnostic data.

If this method is not overridden by the application, it defaults to a do-nothing method.

Parameters:
tower | - The tower (in detector space) the diagnostic data came from
gtcc | - The GTCC (in detector space) the diagnostic data came from
diag | - The TKR diagnostic object
Returns:
A status value. If non-zero, iteration is terminated.

const TKRmap * DIAGcontributionIterator::tkrMap ( ) const [inline]

Return a pointer to the TKR map

The documentation for this class was generated from the following files:
  • DIAGcontributionIterator.h
  • DIAGcontributionIterator.cpp
Generated on Mon Jul 31 17:48:14 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

DIAGcontributionIterator Member List

This is the complete list of members for DIAGcontributionIterator, including all inherited members.

CALdiag(unsigned tower, unsigned layer, CALdiagnostic diag) | DIAGcontributionIterator | [inline, virtual]
calMap() const | DIAGcontributionIterator | [inline]
contribution() const | DIAGcontributionIterator | [inline]
DIAGcontributionIterator(EBFevent *event, TEMcontribution *contribution, CALmap *calMap, TKRmap *tkrMap) | DIAGcontributionIterator | [inline]
DIAGcontributionIterator(EBFevent *event, TEMcontribution *contribution) | DIAGcontributionIterator | [inline]
DIAGcontributionIterator() | DIAGcontributionIterator | [inline]
event() const | DIAGcontributionIterator | [inline]
handleError(TEMcontribution *, unsigned code, unsigned p1=0, unsigned p2=0) const | DIAGcontributionIterator | [inline, virtual]
iterateCAL() | DIAGcontributionIterator | [inline]
iterateCAL(EBFevent *event, TEMcontribution *contribution) | DIAGcontributionIterator | [inline]
iterateCAL(EBFevent *event, TEMcontribution *contribution, CALmap *map) | DIAGcontributionIterator |
iterateTKR() | DIAGcontributionIterator | [inline]
iterateTKR(EBFevent *event, TEMcontribution *contribution) | DIAGcontributionIterator | [inline]
iterateTKR(EBFevent *event, TEMcontribution *contribution, TKRmap *map) | DIAGcontributionIterator |
offset(unsigned o) | DIAGcontributionIterator | [inline]
size() const | DIAGcontributionIterator | [inline]
status() const | DIAGcontributionIterator | [inline]
TKRdiag(unsigned tower, unsigned gtcc, TKRdiagnostic diag) | DIAGcontributionIterator | [inline, virtual]
tkrMap() const | DIAGcontributionIterator | [inline]
~DIAGcontributionIterator() (defined in DIAGcontributionIterator) | DIAGcontributionIterator | [inline, virtual]

Generated on Mon Jul 31 17:48:14 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: EBFcontribution Class Reference

EBFcontribution Class Reference

Class for decoding a EBF contribution to an event. More...

#include <EBFcontribution.h>

Inheritance diagram for EBFcontribution:

[legend]
List of all members.

Public Types

Tower_00 = 0
Tower_01 = 1
Tower_02 = 2
Tower_03 = 3
Tower_04 = 4
Tower_05 = 5
Tower_06 = 6
Tower_07 = 7
Tower_08 = 8
Tower_09 = 9
Tower_10 = 10
Tower_11 = 11
Tower_12 = 12
Tower_13 = 13
Tower_14 = 14
Tower_15 = 15
PDU_0 = 16
PDU_1 = 17
GEM = 18
AEM = 19
EBM = 20
CRU = 30
Broadcast = 31
OSW = 32
Parity = 1
Truncated = 2
WriteFault = 3
TimedOut = 4
NumberOfContributions = 64
enum {
Tower_00 = 0, Tower_01 = 1, Tower_02 = 2, Tower_03 = 3,
Tower_04 = 4, Tower_05 = 5, Tower_06 = 6, Tower_07 = 7,
Tower_08 = 8, Tower_09 = 9, Tower_10 = 10, Tower_11 = 11,
Tower_12 = 12, Tower_13 = 13, Tower_14 = 14, Tower_15 = 15,
PDU_0 = 16, PDU_1 = 17, GEM = 18, AEM = 19,
EBM = 20, CRU = 30, Broadcast = 31, OSW = 32
}
enum | { Parity = 1, Truncated = 2, WriteFault = 3, TimedOut = 4 }
enum | { NumberOfContributions = 64 }

Public Member Functions

unsigned | header () const
Return the LATp header in the contribution.
unsigned | packetError () const
Return the packet error value in the contribution.
unsigned | sequence () const
Return the sequence number in the contribution.
unsigned | length () const
Return the contribution's size in units of bytes.
unsigned | summary () const
Return the event's summary word.
EBFcontribution * | next () const
Return a pointer to the next EBFcontribution.
unsigned | payloadSize () const
Return the size of the payload in the contribution.
char * | payload () const
Return a pointer to the payload in the contribution.
TEMcontribution * | temContribution () const
Return a pointer to this contribution cast as a TEMcontribution.
AEMcontribution * | aemContribution () const
Return a pointer to this contribution cast as a AEMcontribution.
GEMcontribution * | gemContribution () const
Return a pointer to this contribution cast as a GEMcontribution.
GLTcontribution * | gltContribution () const
Return a pointer to this contribution cast as a GLTcontribution.
OSWcontribution * | oswContribution () const
Return a pointer to this contribution cast as a OSWcontribution.

Detailed Description

Class for decoding a EBF contribution to an event.

Author:
R. Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.7
Date:
January 23, 2003 -- Created
Id
EBFcontribution.h,v 1.7 2006/03/30 19:05:45 perazzo Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Member Function Documentation

AEMcontribution * EBFcontribution::aemContribution ( ) const [inline]

Return a pointer to this contribution cast as a AEMcontribution.

Returns:
A pointer to this contribution cast as a AEMcontribution

GEMcontribution * EBFcontribution::gemContribution ( ) const [inline]

Return a pointer to this contribution cast as a GEMcontribution.

Returns:
A pointer to this contribution cast as a GEMcontribution

GLTcontribution * EBFcontribution::gltContribution ( ) const [inline]

Return a pointer to this contribution cast as a GLTcontribution.

Returns:
A pointer to this contribution cast as a GLTcontribution

unsigned EBFcontribution::header ( ) const [inline]

Return the LATp header in the contribution.

Returns:
The LATp header in the contribution

unsigned EBFcontribution::length ( ) const [inline]

Return the contribution's size in units of bytes.

Returns:
The contribution's size in units of bytes.

EBFcontribution * EBFcontribution::next ( ) const [inline]

Return a pointer to the next EBFcontribution.

Returns:
A pointer to the next EBFcontribution

OSWcontribution * EBFcontribution::oswContribution ( ) const [inline]

Return a pointer to this contribution cast as a OSWcontribution.

Returns:
A pointer to this contribution cast as a OSWcontribution

unsigned EBFcontribution::packetError ( ) const [inline]

Return the packet error value in the contribution.

Returns:
The packet error value in the contribution

char * EBFcontribution::payload ( ) const [inline]

Return a pointer to the payload in the contribution.

Returns:
A pointer to the payload in the contribution

unsigned EBFcontribution::payloadSize ( ) const [inline]

Return the size of the payload in the contribution.

Returns:
The size of the payload in the contribution

unsigned EBFcontribution::sequence ( ) const [inline]

Return the sequence number in the contribution.

Returns:
The sequence number in the contribution

unsigned EBFcontribution::summary ( ) const [inline]

Return the event's summary word.

Returns:
The event's summary word.

TEMcontribution * EBFcontribution::temContribution ( ) const [inline]

Return a pointer to this contribution cast as a TEMcontribution.

Returns:
A pointer to this contribution cast as a TEMcontribution

The documentation for this class was generated from the following file:
  • EBFcontribution.h
Generated on Mon Jul 31 17:48:14 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

EBFcontribution Member List

This is the complete list of members for EBFcontribution, including all inherited members.

AEM enum value (defined in EBFcontribution) | EBFcontribution |
aemContribution() const | EBFcontribution | [inline]
Broadcast enum value (defined in EBFcontribution) | EBFcontribution |
CRU enum value (defined in EBFcontribution) | EBFcontribution |
EBFcontribution() (defined in EBFcontribution) | EBFcontribution | [inline]
EBM enum value (defined in EBFcontribution) | EBFcontribution |
GEM enum value (defined in EBFcontribution) | EBFcontribution |
gemContribution() const | EBFcontribution | [inline]
gltContribution() const | EBFcontribution | [inline]
header() const | EBFcontribution | [inline]
length() const | EBFcontribution | [inline]
next() const | EBFcontribution | [inline]
NumberOfContributions enum value (defined in EBFcontribution) | EBFcontribution |
OSW enum value (defined in EBFcontribution) | EBFcontribution |
oswContribution() const | EBFcontribution | [inline]
packetError() const | EBFcontribution | [inline]
Parity enum value (defined in EBFcontribution) | EBFcontribution |
payload() const | EBFcontribution | [inline]
payloadSize() const | EBFcontribution | [inline]
PDU_0 enum value (defined in EBFcontribution) | EBFcontribution |
PDU_1 enum value (defined in EBFcontribution) | EBFcontribution |
sequence() const | EBFcontribution | [inline]
summary() const | EBFcontribution | [inline]
temContribution() const | EBFcontribution | [inline]
TimedOut enum value (defined in EBFcontribution) | EBFcontribution |
Tower_00 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_01 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_02 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_03 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_04 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_05 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_06 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_07 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_08 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_09 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_10 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_11 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_12 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_13 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_14 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_15 enum value (defined in EBFcontribution) | EBFcontribution |
Truncated enum value (defined in EBFcontribution) | EBFcontribution |
WriteFault enum value (defined in EBFcontribution) | EBFcontribution |
~EBFcontribution() (defined in EBFcontribution) | EBFcontribution | [inline]

Generated on Mon Jul 31 17:48:14 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: EBFcontributionIterator Class Reference

EBFcontributionIterator Class Reference

Class for iterating over contributions to an EBFevent. More...

#include <EBFcontributionIterator.h>

Inheritance diagram for EBFcontributionIterator:

[legend]
Collaboration diagram for EBFcontributionIterator:

[legend]
List of all members.

Public Types

ERR_NumContributions = 1
ERR_PastEnd = 2
ERR_ZeroLength = 3
ERR_PacketError = 4
ERR_NoMap = 5
enum {
ERR_NumContributions = 1, ERR_PastEnd = 2, ERR_ZeroLength = 3, ERR_PacketError = 4,
ERR_NoMap = 5
}

Public Member Functions

EBFcontributionIterator (EBFevent *event)
Constructor for iterating over EBFcontributions.
EBFcontributionIterator ()
Default constructor for iterating over EBFcontributions.
unsigned | iterate ()
Iterate over the EBF contributions in an event.
unsigned | iterate (EBFevent *event)
Class for iterating over a EBF event contributionsIterate over the EBF contributions in an event.
const EBFevent * | event () const
int | status () const
virtual int | handleError (EBFevent *event, unsigned code, unsigned p1=0, unsigned p2=0) const
Handle all errors possible in EBFcontributionIterator.
virtual int | GEM (EBFevent *, EBFcontribution *)=0
virtual int | GLT (EBFevent *, EBFcontribution *)=0
virtual int | AEM (EBFevent *, EBFcontribution *)=0
virtual int | TEM (EBFevent *, EBFcontribution *)=0
virtual int | OSW (EBFevent *, EBFcontribution *)=0
virtual int | UDF (EBFevent *, EBFcontribution *)=0

Detailed Description

Class for iterating over contributions to an EBFevent.

Author:
R. Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.8
Date:
January 23, 2003 -- Created
Id
EBFcontributionIterator.h,v 1.8 2005/03/16 03:00:52 panetta Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

EBFcontributionIterator::EBFcontributionIterator ( EBFevent * event ) [inline]

Constructor for iterating over EBFcontributions.

This constructor caches the event provided by the caller.

Parameters:
event A pointer to an EBFevent

Member Function Documentation

virtual int EBFcontributionIterator::AEM | ( | EBFevent * | ,
 |  | EBFcontribution * |  |
 | ) |  |  | [pure virtual]

AEM contribution handler

Implemented in LATcomponentIterator.

const EBFevent * EBFcontributionIterator::event ( ) const [inline]

Return a pointer to the EBFevent containing this contribution

virtual int EBFcontributionIterator::GEM | ( | EBFevent * | ,
 |  | EBFcontribution * |  |
 | ) |  |  | [pure virtual]

GEM contribution handler

Implemented in LATcomponentIterator.

virtual int EBFcontributionIterator::GLT | ( | EBFevent * | ,
 |  | EBFcontribution * |  |
 | ) |  |  | [pure virtual]

GLT contribution handler

Implemented in LATcomponentIterator.

int EBFcontributionIterator::handleError | ( | EBFevent * | event,
 |  | unsigned | code,
 |  | unsigned | p1 = 0,
 |  | unsigned | p2 = 0 |
 | ) |  |  | const [virtual]

Handle all errors possible in EBFcontributionIterator.

This method is used to handle errors occurring during the iteration over an EBFcontribution. By default it does nothing, however it is virtual and is able to be overridden by the user.

Parameters:
event | The event in error
code | The error code
p1 | a parameter associated with the error code
p2 | a parameter associated with the error code

Reimplemented in LATcomponentIterator.

unsigned EBFcontributionIterator::iterate ( EBFevent * event )

Class for iterating over a EBF event contributionsIterate over the EBF contributions in an event.

This method calls back a virtual contribution handlers for each contribution it finds. Which handler is called back is determined by the contribution source ID and the _map method. Contribution handlers take the event and the contribution as arguments.

Parameters:
event A pointer to the EBFevent to be iterated over
Returns:
The number of contributions handled.

Reimplemented in LATcomponentIterator.

unsigned EBFcontributionIterator::iterate ( ) [inline]

Iterate over the EBF contributions in an event.

This method uses the event cached by the ctor.

Returns:
The number of contributions handled.

virtual int EBFcontributionIterator::OSW | ( | EBFevent * | ,
 |  | EBFcontribution * |  |
 | ) |  |  | [pure virtual]

OSW (Online SoftWare) contribution handler

Implemented in LATcomponentIterator.

int EBFcontributionIterator::status ( ) const [inline]

Return the iteration status code

virtual int EBFcontributionIterator::TEM | ( | EBFevent * | ,
 |  | EBFcontribution * |  |
 | ) |  |  | [pure virtual]

TEM contribution handler

Implemented in LATcomponentIterator.

virtual int EBFcontributionIterator::UDF | ( | EBFevent * | ,
 |  | EBFcontribution * |  |
 | ) |  |  | [pure virtual]

Undefined contribution handler

Implemented in LATcomponentIterator.

The documentation for this class was generated from the following files:
  • EBFcontributionIterator.h
  • EBFcontributionIterator.cpp
Generated on Mon Jul 31 17:48:14 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

EBFcontributionIterator Member List

This is the complete list of members for EBFcontributionIterator, including all inherited members.

AEM(EBFevent *, EBFcontribution *)=0 | EBFcontributionIterator | [pure virtual]
EBFcontributionIterator(EBFevent *event) | EBFcontributionIterator | [inline]
EBFcontributionIterator() | EBFcontributionIterator | [inline]
ERR_NoMap enum value (defined in EBFcontributionIterator) | EBFcontributionIterator |
ERR_NumContributions enum value (defined in EBFcontributionIterator) | EBFcontributionIterator |
ERR_PacketError enum value (defined in EBFcontributionIterator) | EBFcontributionIterator |
ERR_PastEnd enum value (defined in EBFcontributionIterator) | EBFcontributionIterator |
ERR_ZeroLength enum value (defined in EBFcontributionIterator) | EBFcontributionIterator |
event() const | EBFcontributionIterator | [inline]
GEM(EBFevent *, EBFcontribution *)=0 | EBFcontributionIterator | [pure virtual]
GLT(EBFevent *, EBFcontribution *)=0 | EBFcontributionIterator | [pure virtual]
handleError(EBFevent *event, unsigned code, unsigned p1=0, unsigned p2=0) const | EBFcontributionIterator | [virtual]
iterate() | EBFcontributionIterator | [inline]
iterate(EBFevent *event) | EBFcontributionIterator |
OSW(EBFevent *, EBFcontribution *)=0 | EBFcontributionIterator | [pure virtual]
status() const | EBFcontributionIterator | [inline]
TEM(EBFevent *, EBFcontribution *)=0 | EBFcontributionIterator | [pure virtual]
UDF(EBFevent *, EBFcontribution *)=0 | EBFcontributionIterator | [pure virtual]
~EBFcontributionIterator() (defined in EBFcontributionIterator) | EBFcontributionIterator | [inline, virtual]

Generated on Mon Jul 31 17:48:14 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: EBFevent Class Reference

EBFevent Class Reference

Class for decoding an EBF event. More...

#include <EBFevent.h>

Inheritance diagram for EBFevent:

[legend]
Collaboration diagram for EBFevent:

[legend]
List of all members.

Public Types

ID_1 = LATidentity_(LATprimaryId::Id_EBF, LATsecondaryId::Id_EBF_1)
ID_2 = LATidentity_(LATprimaryId::Id_EBF, LATsecondaryId::Id_EBF_2)
ID_3 = LATidentity_(LATprimaryId::Id_EBF, LATsecondaryId::Id_EBF_3)
ID = LATidentity_(LATprimaryId::Id_EBF, LATsecondaryId::Id_EBF)
ID_MC = LATidentity_(LATprimaryId::Id_EBF_MC, LATsecondaryId::Id_EBF_MC)
enum {
ID_1 = LATidentity_(LATprimaryId::Id_EBF, LATsecondaryId::Id_EBF_1), ID_2 = LATidentity_(LATprimaryId::Id_EBF, LATsecondaryId::Id_EBF_2), ID_3 = LATidentity_(LATprimaryId::Id_EBF, LATsecondaryId::Id_EBF_3), ID = LATidentity_(LATprimaryId::Id_EBF, LATsecondaryId::Id_EBF),
ID_MC = LATidentity_(LATprimaryId::Id_EBF_MC, LATsecondaryId::Id_EBF_MC)
}

Public Member Functions

unsigned | status () const
Return the event's status word as generated by the hardware.
unsigned | summary () const
Return the event's summary word.
unsigned | payloadSize () const
Return the size of the event's data payload.
EBFcontribution * | payload () const
Return a pointer to the first contribution to the event.
unsigned char * | string (bool swap=!DFC_BIG_ENDIAN)
Return this EBFevent in string form.

Static Public Member Functions

static EBFevent * | create (unsigned char *buffer, unsigned size, bool swap=!DFC_BIG_ENDIAN)
Create an EBFevent from a Python string.

Detailed Description

Class for decoding an EBF event.

EBF stands for Event Builder Format and is the format that is generated by the LAT hardware. Events in this format are the input to the FSW filter algorithm.

Author:
R. Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.9
Date:
January 22, 2003 -- Created
Id
EBFevent.h,v 1.9 2006/03/30 19:05:45 perazzo Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Member Function Documentation

EBFevent * EBFevent::create | ( | unsigned char * | buffer,
 |  | unsigned | size,
 |  | bool | swap = !DFC_BIG_ENDIAN |
 | ) |  |  | [inline, static]

Create an EBFevent from a Python string.

This method is here to support the Python interface. A Python string is casted to an EBFevent. If this class had anything but a no-op constructor this would not work and we would have to use placement new. The reason this wasn't done right off the bat is that it isn't entirely clear that we know how to do this correctly vis a vis the Python object reference counting. Sometimes a Python crash is observed that complains about an object already being marked for garbage collection. I have not beeg able to narrow this down to a particular class, but think it might have to do with the placement new used in the LATdatagram class.

Parameters:
buffer | - A buffer containing an EBFevent in string form
size | - The size of the buffer
swap | - Optional parameter to force or not force in place byte swapping
Returns:
- A pointer to the buffer cast as an EBFevent

EBFcontribution * EBFevent::payload ( ) const [inline]

Return a pointer to the first contribution to the event.

Returns:
A pointer to the first EBFcontribution in the EBFevent

unsigned EBFevent::payloadSize ( ) const [inline]

Return the size of the event's data payload.

Returns:
The size of the event's payload

unsigned EBFevent::status ( ) const [inline]

Return the event's status word as generated by the hardware.

Returns:
The event's status

unsigned char * EBFevent::string ( bool swap = !DFC_BIG_ENDIAN ) [inline]

Return this EBFevent in string form.

This method is here to support the Python interface.

Parameters:
swap - Boolean to cause the buffer to be byte swapped in place
Returns:
A pointer to this EBFevent cast as an array of unsigned chars

Reimplemented from LATcontribution.

unsigned EBFevent::summary ( ) const [inline]

Return the event's summary word.

This word really doesn't belong with the event, but with the first contributor to the event. However, all contributors are expected to generate the same summary word, so we let the first contributor's version speak for the whole event.

Returns:
The event's summary word

The documentation for this class was generated from the following file:
  • EBFevent.h
Generated on Mon Jul 31 17:48:15 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

EBFevent Member List

This is the complete list of members for EBFevent, including all inherited members.

create(unsigned char *buffer, unsigned size, bool swap=!DFC_BIG_ENDIAN) | EBFevent | [inline, static]
LATcontribution::create(LATtypeId identity, unsigned size, unsigned char *buffer, bool swap=!DFC_BIG_ENDIAN) | LATcontribution | [inline, static]
EBFevent() (defined in EBFevent) | EBFevent | [inline]
ID enum value (defined in EBFevent) | EBFevent |
ID_1 enum value (defined in EBFevent) | EBFevent |
ID_2 enum value (defined in EBFevent) | EBFevent |
ID_3 enum value (defined in EBFevent) | EBFevent |
ID_MC enum value (defined in EBFevent) | EBFevent |
identity() const | LATcontribution | [inline]
LATcontribution() | LATcontribution | [inline]
LATcontribution(LATtypeId identity, unsigned length) | LATcontribution | [inline]
length() const | LATcontribution | [inline]
next() const | LATcontribution | [inline]
operator delete(void *, void *, unsigned short, bool) | LATcontribution | [inline]
operator delete(void *) | LATcontribution | [inline]
operator new(size_t) | LATcontribution | [inline]
operator new(size_t, LATtypeId identity, unsigned length) | LATcontribution | [inline]
operator new(size_t, const LATcontribution &) | LATcontribution | [inline]
operator new(size_t, void *, unsigned short supplemental, bool swap=!DFC_BIG_ENDIAN) | LATcontribution | [inline]
payload() const | EBFevent | [inline]
payloadSize() const | EBFevent | [inline]
rawData() const | LATcontribution | [inline]
rawDataSize() const | LATcontribution | [inline]
status() const | EBFevent | [inline]
string(bool swap=!DFC_BIG_ENDIAN) | EBFevent | [inline]
summary() const | EBFevent | [inline]
~EBFevent() (defined in EBFevent) | EBFevent | [inline]
~LATcontribution() (defined in LATcontribution) | LATcontribution | [inline]

Generated on Mon Jul 31 17:48:15 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: EBFeventIterator Class Reference

EBFeventIterator Class Reference

Class for iterating over a buffer of EBFevent(s). More...

#include <EBFeventIterator.h>

Inheritance diagram for EBFeventIterator:

[legend]
Collaboration diagram for EBFeventIterator:

[legend]
List of all members.

Public Types

ERR_NonEBFevent = 1
enum | { ERR_NonEBFevent = 1 }

Public Member Functions

EBFeventIterator (EBFevent *start, EBFevent *end)
Constructor used with an array of EBFevents.
EBFeventIterator (char *buffer, unsigned size, bool swap=!DFC_BIG_ENDIAN)
Constructor used with an array of EBFevents passed in a string buffer.
EBFeventIterator ()
Default constructor used with an array of EBFevents.
unsigned | iterate (EBFevent *start, EBFevent *end)
Class for iterating over a buffer of EBFevent(s).Iterate over the EBFevents in the array from start to end.
unsigned | iterate (char *buffer, unsigned size, bool swap=!DFC_BIG_ENDIAN)
Iterate over the EBFevents in the passed in buffer from start to end.
unsigned | iterate ()
Iterate over the EBFevents in the array from start to end.
virtual int | handleError (EBFevent *evt, unsigned code, unsigned p1=0, unsigned p2=0) const
Handle all errors possible in EBFeventIterator.
virtual int | process (EBFevent *evt)=0
const EBFevent * | start () const
Return a pointer to the first event in the array.
const EBFevent * | end () const
Return a pointer to the first event after the end of the array.
unsigned | status () const
Return the iteration status.

Detailed Description

Class for iterating over a buffer of EBFevent(s).

Author:
R. Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.8
Date:
February 21, 2003 -- Created
Id
EBFeventIterator.h,v 1.8 2006/03/30 19:05:45 perazzo Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

EBFeventIterator::EBFeventIterator | ( | EBFevent * | start,
 |  | EBFevent * | end |
 | ) |  |  | [inline]

Constructor used with an array of EBFevents.

Parameters:
start | - A pointer to the first EBFevent in the array
end | - A pointer to the first EBFevent after the end of the array

EBFeventIterator::EBFeventIterator | ( | char * | buffer,
 |  | unsigned | size,
 |  | bool | swap = !DFC_BIG_ENDIAN |
 | ) |  |  | [inline]

Constructor used with an array of EBFevents passed in a string buffer.

Parameters:
buffer | - A string buffer containing (an) EBFevent(s)
size | - The size of the string buffer in bytes
swap | - An optional parameter to force, or not force, the buffer to be byte swapped in place. By default it is set according to the endianess of the machine running this code with the assumption that buffer is in big endian format.

Member Function Documentation

const EBFevent * EBFeventIterator::end ( ) const [inline]

Return a pointer to the first event after the end of the array.

Returns:
The first EBFevent after the end of the array.

int EBFeventIterator::handleError | ( | EBFevent * | evt,
 |  | unsigned | code,
 |  | unsigned | p1 = 0,
 |  | unsigned | p2 = 0 |
 | ) |  |  | const [virtual]

Handle all errors possible in EBFeventIterator.

This method is used to handle errors occurring during the iteration over an EBFevent. By default it does nothing, however it is virtual and is able to be overridden by the user.

Parameters:
evt | The event in error
code | The error code
p1 | a parameter associated with the error code
p2 | a parameter associated with the error code

Reimplemented in LDBI_EBFeventIterator.

unsigned EBFeventIterator::iterate ( ) [inline]

Iterate over the EBFevents in the array from start to end.

This method is used when a constructor setting up the array parameters has been used.

Returns:
Any status returned by the called back process() method, -1 when an error is detected, or 0 upon successful completion.

unsigned EBFeventIterator::iterate | ( | char * | buffer,
 |  | unsigned | size,
 |  | bool | swap = !DFC_BIG_ENDIAN |
 | ) |  |  | [inline]

Iterate over the EBFevents in the passed in buffer from start to end.

This method is used when a buffer containing EBFevents is provided by the caller.

Parameters:
buffer | - A buffer containing an EBFevent in string form
size | - The size of the buffer
swap | - Optional parameter to force or not force in place byte swapping
Returns:
Any status returned by the called back process() method, -1 when an error is detected, or 0 upon successful completion.

unsigned EBFeventIterator::iterate | ( | EBFevent * | start,
 |  | EBFevent * | end
 | ) |  |

Class for iterating over a buffer of EBFevent(s).Iterate over the EBFevents in the array from start to end.

This method is used when the array parameters are passed on the fly.

Parameters:
start | - A pointer to the first EBFevent in the array
end | - A pointer to the first EBFevent after the end of the array
Returns:
Any status returned by the called back process() method, -1 when an error is detected, or 0 upon successful completion.

virtual int EBFeventIterator::process ( EBFevent * evt ) [pure virtual]

Virtual method for calling the application back with an EBFevent

Implemented in LDBI_EBFeventIterator.

const EBFevent * EBFeventIterator::start ( ) const [inline]

Return a pointer to the first event in the array.

Returns:
The first EBFevent in the array.

unsigned EBFeventIterator::status ( ) const [inline]

Return the iteration status.

Returns:
The iteration status

The documentation for this class was generated from the following files:
  • EBFeventIterator.h
  • EBFeventIterator.cpp
Generated on Mon Jul 31 17:48:15 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

EBFeventIterator Member List

This is the complete list of members for EBFeventIterator, including all inherited members.

EBFeventIterator(EBFevent *start, EBFevent *end) | EBFeventIterator | [inline]
EBFeventIterator(char *buffer, unsigned size, bool swap=!DFC_BIG_ENDIAN) | EBFeventIterator | [inline]
EBFeventIterator() | EBFeventIterator | [inline]
end() const | EBFeventIterator | [inline]
ERR_NonEBFevent enum value (defined in EBFeventIterator) | EBFeventIterator |
handleError(EBFevent *evt, unsigned code, unsigned p1=0, unsigned p2=0) const | EBFeventIterator | [virtual]
iterate(EBFevent *start, EBFevent *end) | EBFeventIterator |
iterate(char *buffer, unsigned size, bool swap=!DFC_BIG_ENDIAN) | EBFeventIterator | [inline]
iterate() | EBFeventIterator | [inline]
process(EBFevent *evt)=0 | EBFeventIterator | [pure virtual]
start() const | EBFeventIterator | [inline]
status() const | EBFeventIterator | [inline]
~EBFeventIterator() (defined in EBFeventIterator) | EBFeventIterator | [inline, virtual]

Generated on Mon Jul 31 17:48:15 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: ERRcontributionIterator Class Reference

ERRcontributionIterator Class Reference

Class for iterating over parts of a Diagnostic contribution. More...

#include <ERRcontributionIterator.h>

Collaboration diagram for ERRcontributionIterator:

[legend]
List of all members.

Public Types

ERR_PastEnd = 1
enum | { ERR_PastEnd = 1 }

Public Member Functions

ERRcontributionIterator (EBFevent *event, TEMcontribution *contribution, TWRmap *map)
ERRcontributionIterator constructor initializing the class according to the passed in parameters.
ERRcontributionIterator (EBFevent *event, TEMcontribution *contribution)
ERRcontributionIterator constructor initializing the class according to the passed in parameters.
ERRcontributionIterator ()
ERRcontributionIterator constructor initializing the class to an invalid state.
unsigned | iterate ()
Iterate over error contributions.
unsigned | iterate (EBFevent *event, TEMcontribution *contribution)
Iterate over error contributions.
unsigned | iterate (EBFevent *event, TEMcontribution *contribution, TWRmap *map)
Iterate over error contributions.
const EBFevent * | event () const
const TEMcontribution * | contribution () const
const TWRmap * | map () const
int | status () const
unsigned | size () const
void | offset (unsigned o)
Set the offset into the TEM contribution where the diagnostic data starts.
const ErrorSummary | theError ()
virtual int | handleError (TEMcontribution *contribution, unsigned code, unsigned p1=0, unsigned p2=0) const
Handle all errors possible in ERRcontributionIterator.
virtual int | gcccError (unsigned tower, unsigned gccc, GCCCerror err)
Dispatch function for GCCC errors.
virtual int | gtccError (unsigned tower, unsigned gtcc, GTCCerror err)
Dispatch function for GTCC errors.
virtual int | phaseError (unsigned tower, unsigned short err)
Dispatch function for cable phase errors.
virtual int | timeoutError (unsigned tower, unsigned short err)
Dispatch function for cable timeout errors.
virtual int | gtrcPhaseError (unsigned tower, unsigned gtcc, unsigned gtrc, GTRCerror err)
Dispatch function for GTCC "GTRC phase error" errors.
virtual int | gtfePhaseError (unsigned tower, unsigned gtcc, unsigned gtrc, unsigned short err1, unsigned short err2, unsigned short err3, unsigned short err4, unsigned short err5)
Dispatch function for GTCC "GTFE phase error" errors.
virtual int | gtccFIFOerror (unsigned tower, unsigned gtcc, unsigned short err)
Dispatch function for GTCC "FIFO full error" errors.
virtual int | gtccTMOerror (unsigned tower, unsigned gtcc)
Dispatch function for GTCC "cable timeout error" errors.
virtual int | gtccHDRParityError (unsigned tower, unsigned gtcc)
Dispatch function for GTCC "header parity error" errors.
virtual int | gtccWCParityError (unsigned tower, unsigned gtcc)
Dispatch function for GTCC "word count parity error" errors.
virtual int | gtrcSummaryError (unsigned tower, unsigned gtcc)
Dispatch function for GTCC "GTRC summary error" errors.
virtual int | gtccDataParityError (unsigned tower, unsigned gtcc)
Dispatch function for GTCC "data parity error" errors.

Detailed Description

Class for iterating over parts of a Diagnostic contribution.

Author:
J. Panetta -- GLAST LAT I&T/Online - (panetta@slac.stanford.edu)
Revision
1.8
Date:
November 25, 2003 -- Created
Id
ERRcontributionIterator.h,v 1.8 2006/02/10 22:13:21 claus Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

ERRcontributionIterator::ERRcontributionIterator | ( | EBFevent * | event,
 |  | TEMcontribution * | contribution,
 |  | TWRmap * | map |
 | ) |  |  | [inline]

ERRcontributionIterator constructor initializing the class according to the passed in parameters.

Parameters:
event | - The event containing the error contribution
contribution | - The TEM contribution containing the error contribution
map | - The electronic space to detector space map for a tower

ERRcontributionIterator::ERRcontributionIterator | ( | EBFevent * | event,
 |  | TEMcontribution * | contribution |
 | ) |  |  | [inline]

ERRcontributionIterator constructor initializing the class according to the passed in parameters.

Parameters:
event | - A pointer to the event containing the error contribution
contribution | - A pointer to the TEM contribution containing the error contribution

Member Function Documentation

const TEMcontribution * ERRcontributionIterator::contribution ( ) const [inline]

Return a pointer to the start of this contribution

const EBFevent * ERRcontributionIterator::event ( ) const [inline]

Return a pointer to the EBFevent containing this contribution

int ERRcontributionIterator::gcccError | ( | unsigned | tower,
 |  | unsigned | gccc,
 |  | GCCCerror | err |
 | ) |  |  | [inline, virtual]

Dispatch function for GCCC errors.

These may be implemented by the user. These are *not* pure virtual because the user doesn't need to always implement them.

Parameters:
tower | The remapped tower number
gccc | The remapped GCCC number (see _GCCC())
err | The error message
Returns:
A status value, which, if non-zero, disables further error callbacks

int ERRcontributionIterator::gtccDataParityError | ( | unsigned | tower,
 |  | unsigned | gtcc |
 | ) |  |  | [inline, virtual]

Dispatch function for GTCC "data parity error" errors.

These may be implemented by the user. These are *not* pure virtual because the user doesn't need to always implement them.

Parameters:
tower | The remapped tower number
gtcc | The remapped GTCC number (see _GTCC())
Returns:
A status value, which, if non-zero, disables further error callbacks

int ERRcontributionIterator::gtccError | ( | unsigned | tower,
 |  | unsigned | gtcc,
 |  | GTCCerror | err |
 | ) |  |  | [inline, virtual]

Dispatch function for GTCC errors.

These may be implemented by the user. These are *not* pure virtual because the user doesn't need to always implement them.

Parameters:
tower | The remapped tower number
gtcc | The remapped GTCC number (see _GTCC())
err | The error message
Returns:
A status value, which, if non-zero, disables further error callbacks

int ERRcontributionIterator::gtccFIFOerror | ( | unsigned | tower,
 |  | unsigned | gtcc,
 |  | unsigned short | err |
 | ) |  |  | [inline, virtual]

Dispatch function for GTCC "FIFO full error" errors.

These may be implemented by the user. These are *not* pure virtual because the user doesn't need to always implement them.

Parameters:
tower | The remapped tower number
gtcc | The remapped GTCC number (see _GTCC())
err | The projected word count
Returns:
A status value, which, if non-zero, disables further error callbacks

int ERRcontributionIterator::gtccHDRParityError | ( | unsigned | tower,
 |  | unsigned | gtcc |
 | ) |  |  | [inline, virtual]

Dispatch function for GTCC "header parity error" errors.

These may be implemented by the user. These are *not* pure virtual because the user doesn't need to always implement them.

Parameters:
tower | The remapped tower number
gtcc | The remapped GTCC number (see _GTCC())
Returns:
A status value, which, if non-zero, disables further error callbacks

int ERRcontributionIterator::gtccTMOerror | ( | unsigned | tower,
 |  | unsigned | gtcc |
 | ) |  |  | [inline, virtual]

Dispatch function for GTCC "cable timeout error" errors.

These may be implemented by the user. These are *not* pure virtual because the user doesn't need to always implement them.

Parameters:
tower | The remapped tower number
gtcc | The remapped GTCC number (see _GTCC())
Returns:
A status value, which, if non-zero, disables further error callbacks

int ERRcontributionIterator::gtccWCParityError | ( | unsigned | tower,
 |  | unsigned | gtcc |
 | ) |  |  | [inline, virtual]

Dispatch function for GTCC "word count parity error" errors.

These may be implemented by the user. These are *not* pure virtual because the user doesn't need to always implement them.

Parameters:
tower | The remapped tower number
gtcc | The remapped GTCC number (see _GTCC())
Returns:
A status value, which, if non-zero, disables further error callbacks

int ERRcontributionIterator::gtfePhaseError | ( | unsigned | tower,
 |  | unsigned | gtcc,
 |  | unsigned | gtrc,
 |  | unsigned short | err1,
 |  | unsigned short | err2,
 |  | unsigned short | err3,
 |  | unsigned short | err4,
 |  | unsigned short | err5 |
 | ) |  |  | [inline, virtual]

Dispatch function for GTCC "GTFE phase error" errors.

These may be implemented by the user. These are *not* pure virtual because the user doesn't need to always implement them.

Five GTFE tag words for FEphase error. Ugly construction because passing a ushort to Python is hard in SIP. The GTFE tags are supplied in the generated order, i.e. not reversed.

Parameters:
tower | The remapped tower number
gtcc | The remapped GTCC number (see _GTCC())
gtrc | The GTRC number
err1 | The first GTFE tag word
err2 | The second GTFE tag word
err3 | The third GTFE tag word
err4 | The fourth GTFE tag word
err5 | The fifth GTFE tag word
Returns:
A status value, which, if non-zero, disables further error callbacks

int ERRcontributionIterator::gtrcPhaseError | ( | unsigned | tower,
 |  | unsigned | gtcc,
 |  | unsigned | gtrc,
 |  | GTRCerror | err |
 | ) |  |  | [inline, virtual]

Dispatch function for GTCC "GTRC phase error" errors.

These may be implemented by the user. These are *not* pure virtual because the user doesn't need to always implement them.

Parameters:
tower | The remapped tower number
gtcc | The remapped GTCC number (see _GCCC())
gtrc | The GTRC number
err | A GTRC tag mismatch structure
Returns:
A status value, which, if non-zero, disables further error callbacks

int ERRcontributionIterator::gtrcSummaryError | ( | unsigned | tower,
 |  | unsigned | gtcc |
 | ) |  |  | [inline, virtual]

Dispatch function for GTCC "GTRC summary error" errors.

These may be implemented by the user. These are *not* pure virtual because the user doesn't need to always implement them.

Parameters:
tower | The remapped tower number
gtcc | The remapped GTCC number (see _GTCC())
Returns:
A status value, which, if non-zero, disables further error callbacks

int ERRcontributionIterator::handleError | ( | TEMcontribution * | contrib,
 |  | unsigned | code,
 |  | unsigned | p1 = 0,
 |  | unsigned | p2 = 0 |
 | ) |  |  | const [inline, virtual]

Handle all errors possible in ERRcontributionIterator.

This method is used to handle errors occurring during the iteration over an ERRcontribution. By default it does nothing, however it is virtual and is able to be overridden by the user.

Parameters:
contrib | The contribution in error
code | The error code
p1 | a parameter associated with the error code
p2 | a parameter associated with the error code

unsigned ERRcontributionIterator::iterate | ( | EBFevent * | event,
 |  | TEMcontribution * | contribution,
 |  | TWRmap * | map
 | ) |  |

Iterate over error contributions.

Parameters:
event | A pointer to the EBFevent containing the contribution
contribution | A pointer to the TEMcontribution to iterate over
map | A pointer to a tower map
Returns:
The number of contributions handled

unsigned ERRcontributionIterator::iterate | ( | EBFevent * | event,
 |  | TEMcontribution * | contribution |
 | ) |  |  | [inline]

Iterate over error contributions.

This method iterates over the supplied contribution using the cached map.

Parameters:
event | A pointer to the EBFevent containing the contribution
contribution | A pointer to the contribution to iterate over
Returns:
The number of contributions handled

unsigned ERRcontributionIterator::iterate ( ) [inline]

Iterate over error contributions.

This method uses the cached contribution to interate over.

Returns:
The number of contributions handled

const TWRmap * ERRcontributionIterator::map ( ) const [inline]

Return a pointer to the tower map

int ERRcontributionIterator::phaseError | ( | unsigned | tower,
 |  | unsigned short | err |
 | ) |  |  | [inline, virtual]

Dispatch function for cable phase errors.

These may be implemented by the user. These are *not* pure virtual because the user doesn't need to always implement them.

Parameters:
tower | The remapped tower number
err | The error message
Returns:
A status value, which, if non-zero, disables further error callbacks

unsigned ERRcontributionIterator::size ( ) const [inline]

Return the size of the diagnostic contribution

int ERRcontributionIterator::status ( ) const [inline]

Return the iteration status code

const ErrorSummary ERRcontributionIterator::theError ( ) [inline]

Return the error summary word from the contribution

int ERRcontributionIterator::timeoutError | ( | unsigned | tower,
 |  | unsigned short | err |
 | ) |  |  | [inline, virtual]

Dispatch function for cable timeout errors.

These may be implemented by the user. These are *not* pure virtual because the user doesn't need to always implement them.

Parameters:
tower | The remapped tower number
err | The error message
Returns:
A status value, which, if non-zero, disables further error callbacks

The documentation for this class was generated from the following files:
  • ERRcontributionIterator.h
  • ERRcontributionIterator.cpp
Generated on Mon Jul 31 17:48:15 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

ERRcontributionIterator Member List

This is the complete list of members for ERRcontributionIterator, including all inherited members.

contribution() const | ERRcontributionIterator | [inline]
ERR_PastEnd enum value (defined in ERRcontributionIterator) | ERRcontributionIterator |
ERRcontributionIterator(EBFevent *event, TEMcontribution *contribution, TWRmap *map) | ERRcontributionIterator | [inline]
ERRcontributionIterator(EBFevent *event, TEMcontribution *contribution) | ERRcontributionIterator | [inline]
ERRcontributionIterator() | ERRcontributionIterator | [inline]
event() const | ERRcontributionIterator | [inline]
gcccError(unsigned tower, unsigned gccc, GCCCerror err) | ERRcontributionIterator | [inline, virtual]
gtccDataParityError(unsigned tower, unsigned gtcc) | ERRcontributionIterator | [inline, virtual]
gtccError(unsigned tower, unsigned gtcc, GTCCerror err) | ERRcontributionIterator | [inline, virtual]
gtccFIFOerror(unsigned tower, unsigned gtcc, unsigned short err) | ERRcontributionIterator | [inline, virtual]
gtccHDRParityError(unsigned tower, unsigned gtcc) | ERRcontributionIterator | [inline, virtual]
gtccTMOerror(unsigned tower, unsigned gtcc) | ERRcontributionIterator | [inline, virtual]
gtccWCParityError(unsigned tower, unsigned gtcc) | ERRcontributionIterator | [inline, virtual]
gtfePhaseError(unsigned tower, unsigned gtcc, unsigned gtrc, unsigned short err1, unsigned short err2, unsigned short err3, unsigned short err4, unsigned short err5) | ERRcontributionIterator | [inline, virtual]
gtrcPhaseError(unsigned tower, unsigned gtcc, unsigned gtrc, GTRCerror err) | ERRcontributionIterator | [inline, virtual]
gtrcSummaryError(unsigned tower, unsigned gtcc) | ERRcontributionIterator | [inline, virtual]
handleError(TEMcontribution *contribution, unsigned code, unsigned p1=0, unsigned p2=0) const | ERRcontributionIterator | [inline, virtual]
iterate() | ERRcontributionIterator | [inline]
iterate(EBFevent *event, TEMcontribution *contribution) | ERRcontributionIterator | [inline]
iterate(EBFevent *event, TEMcontribution *contribution, TWRmap *map) | ERRcontributionIterator |
map() const | ERRcontributionIterator | [inline]
offset(unsigned o) | ERRcontributionIterator | [inline]
phaseError(unsigned tower, unsigned short err) | ERRcontributionIterator | [inline, virtual]
size() const | ERRcontributionIterator | [inline]
status() const | ERRcontributionIterator | [inline]
theError() | ERRcontributionIterator | [inline]
timeoutError(unsigned tower, unsigned short err) | ERRcontributionIterator | [inline, virtual]
~ERRcontributionIterator() (defined in ERRcontributionIterator) | ERRcontributionIterator | [inline, virtual]

Generated on Mon Jul 31 17:48:15 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: ErrorSummary Class Reference

ErrorSummary Class Reference

Class for accessing fields in the TEM error summary longword. More...

#include <errorSummary.h>

List of all members.

Public Member Functions

ErrorSummary (unsigned summary)
Constructor for initializing the ErrorSummary class with a TEM error summary word.
unsigned | tmo () const
Method for returning the cable controller timeout indicator from a TEM error summary word.
unsigned | phs () const
Method for returning the cable controller phasing error indicator from a TEM error summary word.
unsigned | tkr () const
Method for returning the error component for the tracker cable controller from a TEM error summary word.
unsigned | cal () const
Method for returning the error component for the calorimeter cable controller from a TEM error summary word.

Static Public Member Functions

static unsigned | tmo (unsigned summary)
Static method for returning the cable controller timeout indicator from a TEM error summary word.
static unsigned | phs (unsigned summary)
Static method for returning the cable controller phasing error indicator from a TEM error summary word.
static unsigned | tkr (unsigned summary)
Static method for returning the error component for the tracker cable controller from a TEM error summary word.
static unsigned | cal (unsigned summary)
Static method for returning the error component for the calorimeter cable controller from a TEM error summary word.

Detailed Description

Class for accessing fields in the TEM error summary longword.

Author:
Ric Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.4
Date:
January 23, 2003 -- Created
Id
errorSummary.h,v 1.4 2004/04/01 23:45:30 claus Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

ErrorSummary::ErrorSummary ( unsigned summary ) [inline]

Constructor for initializing the ErrorSummary class with a TEM error summary word.

Parameters:
summary - A TEM error summary word

Member Function Documentation

unsigned ErrorSummary::cal ( ) const [inline]

Method for returning the error component for the calorimeter cable controller from a TEM error summary word.

Returns:
The calorimeter error component

unsigned ErrorSummary::cal ( unsigned summary ) [inline, static]

Static method for returning the error component for the calorimeter cable controller from a TEM error summary word.

Parameters:
summary - A TEM error summary word
Returns:
The calorimeter error component

unsigned ErrorSummary::phs ( ) const [inline]

Method for returning the cable controller phasing error indicator from a TEM error summary word.

Returns:
The phasing error indication

unsigned ErrorSummary::phs ( unsigned summary ) [inline, static]

Static method for returning the cable controller phasing error indicator from a TEM error summary word.

Parameters:
summary - A TEM error summary word
Returns:
The phasing error indication

unsigned ErrorSummary::tkr ( ) const [inline]

Method for returning the error component for the tracker cable controller from a TEM error summary word.

Returns:
The tracker error component

unsigned ErrorSummary::tkr ( unsigned summary ) [inline, static]

Static method for returning the error component for the tracker cable controller from a TEM error summary word.

Parameters:
summary - A TEM error summary word
Returns:
The tracker error component

unsigned ErrorSummary::tmo ( ) const [inline]

Method for returning the cable controller timeout indicator from a TEM error summary word.

Returns:
The timeout error indication

unsigned ErrorSummary::tmo ( unsigned summary ) [inline, static]

Static method for returning the cable controller timeout indicator from a TEM error summary word.

Parameters:
summary - A TEM error summary word
Returns:
The timeout error indication

The documentation for this class was generated from the following file:
  • errorSummary.h
Generated on Mon Jul 31 17:48:15 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

ErrorSummary Member List

This is the complete list of members for ErrorSummary, including all inherited members.

cal(unsigned summary) | ErrorSummary | [inline, static]
cal() const | ErrorSummary | [inline]
ErrorSummary(unsigned summary) | ErrorSummary | [inline]
ErrorSummary() (defined in ErrorSummary) | ErrorSummary | [inline]
phs(unsigned summary) | ErrorSummary | [inline, static]
phs() const | ErrorSummary | [inline]
tkr(unsigned summary) | ErrorSummary | [inline, static]
tkr() const | ErrorSummary | [inline]
tmo(unsigned summary) | ErrorSummary | [inline, static]
tmo() const | ErrorSummary | [inline]
~ErrorSummary() (defined in ErrorSummary) | ErrorSummary | [inline]

Generated on Mon Jul 31 17:48:15 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: EventSummary Class Reference

EventSummary Class Reference

Class for accessing fields in the event summary longword. More...

#include <eventSummary.h>

List of all members.

Public Member Functions

EventSummary (unsigned summary)
Constructor for initializing the EventSummary class with a summary word.
unsigned | calStrobe () const
Method for returning the calStrobe state in the summary word.
unsigned | tag () const
Method for returning the tag value in the summary word.
unsigned | TACK () const
Method for returning the TACK state in the summary word.
unsigned | readout4 () const
Method for returning the 4-range readout state in the summary word.
unsigned | zeroSuppress () const
Method for returning the zeroSuppress state in the summary word.
unsigned | marker () const
Method for returning the marker value in the summary word.
unsigned | error () const
Method for returning the error state in the summary word.
unsigned | diagnostic () const
Method for returning the diagnostic state in the summary word.
unsigned | eventNumber () const
Method for returning the eventNumber value in the summary word.
unsigned | trgParityError () const
Method for returning the trigger message parity error state in the summary word.

Static Public Member Functions

static unsigned | calStrobe (unsigned summary)
Static method for returning the calStrobe state in the summary word.
static unsigned | tag (unsigned summary)
Static method for returning the tag value in the summary word.
static unsigned | TACK (unsigned summary)
Static method for returning the TACK state in the summary word.
static unsigned | readout4 (unsigned summary)
Static method for returning the 4-range readout state in the summary word.
static unsigned | zeroSuppress (unsigned summary)
Static method for returning the zeroSuppress state in the summary word.
static unsigned | marker (unsigned summary)
Static method for returning the marker value in the summary word.
static unsigned | error (unsigned summary)
Static method for returning the error state in the summary word.
static unsigned | diagnostic (unsigned summary)
Static method for returning the diagnostic state in the summary word.
static unsigned | eventNumber (unsigned summary)
Static method for returning the eventNumber value in the summary word.
static unsigned | trgParityError (unsigned summary)
Static method for returning the trigger message parity error state in the summary word.

Detailed Description

Class for accessing fields in the event summary longword.

Author:
Ric Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.2
Date:
January 22, 2003 -- Created
Id
eventSummary.h,v 1.2 2004/04/01 23:45:57 claus Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

EventSummary::EventSummary ( unsigned summary ) [inline]

Constructor for initializing the EventSummary class with a summary word.

Parameters:
summary - A summary word

Member Function Documentation

unsigned EventSummary::calStrobe ( ) const [inline]

Method for returning the calStrobe state in the summary word.

Returns:
The calStrobe state

unsigned EventSummary::calStrobe ( unsigned summary ) [inline, static]

Static method for returning the calStrobe state in the summary word.

Parameters:
summary - A summary word
Returns:
The calStrobe state

unsigned EventSummary::diagnostic ( ) const [inline]

Method for returning the diagnostic state in the summary word.

If this error state is true, this event will have an diagnostic contribution decodable with DIAGcontributionIterator.

Returns:
The diagnostic state

unsigned EventSummary::diagnostic ( unsigned summary ) [inline, static]

Static method for returning the diagnostic state in the summary word.

If this error state is true, this event will have an diagnostic contribution decodable with DIAGcontributionIterator.

Parameters:
summary - A summary word
Returns:
The diagnostic state

unsigned EventSummary::error ( ) const [inline]

Method for returning the error state in the summary word.

If this error state is true, this event will have an error contribution decodable with ERRcontributionIterator.

Returns:
The error state

unsigned EventSummary::error ( unsigned summary ) [inline, static]

Static method for returning the error state in the summary word.

If this error state is true, this event will have an error contribution decodable with ERRcontributionIterator.

Parameters:
summary - A summary word
Returns:
The error state

unsigned EventSummary::eventNumber ( ) const [inline]

Method for returning the eventNumber value in the summary word.

Returns:
The eventNumber value

unsigned EventSummary::eventNumber ( unsigned summary ) [inline, static]

Static method for returning the eventNumber value in the summary word.

Parameters:
summary - A summary word
Returns:
The eventNumber value

unsigned EventSummary::marker ( ) const [inline]

Method for returning the marker value in the summary word.

Returns:
The marker value

unsigned EventSummary::marker ( unsigned summary ) [inline, static]

Static method for returning the marker value in the summary word.

Parameters:
summary - A summary word
Returns:
The marker value

unsigned EventSummary::readout4 ( ) const [inline]

Method for returning the 4-range readout state in the summary word.

Returns:
The 4-range readout state

unsigned EventSummary::readout4 ( unsigned summary ) [inline, static]

Static method for returning the 4-range readout state in the summary word.

Parameters:
summary - A summary word
Returns:
The 4-range readout state

unsigned EventSummary::TACK ( ) const [inline]

Method for returning the TACK state in the summary word.

Returns:
The TACK state

unsigned EventSummary::TACK ( unsigned summary ) [inline, static]

Static method for returning the TACK state in the summary word.

Parameters:
summary - A summary word
Returns:
The TACK state

unsigned EventSummary::tag ( ) const [inline]

Method for returning the tag value in the summary word.

Returns:
The tag value

unsigned EventSummary::tag ( unsigned summary ) [inline, static]

Static method for returning the tag value in the summary word.

Parameters:
summary - A summary word
Returns:
The tag value

unsigned EventSummary::trgParityError ( ) const [inline]

Method for returning the trigger message parity error state in the summary word.

Returns:
The trigger message parity error state

unsigned EventSummary::trgParityError ( unsigned summary ) [inline, static]

Static method for returning the trigger message parity error state in the summary word.

Parameters:
summary - A summary word
Returns:
The trigger message parity error state

unsigned EventSummary::zeroSuppress ( ) const [inline]

Method for returning the zeroSuppress state in the summary word.

Returns:
The zeroSuppress state

unsigned EventSummary::zeroSuppress ( unsigned summary ) [inline, static]

Static method for returning the zeroSuppress state in the summary word.

Parameters:
summary - A summary word
Returns:
The zeroSuppress state

The documentation for this class was generated from the following file:
  • eventSummary.h
Generated on Mon Jul 31 17:48:15 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

EventSummary Member List

This is the complete list of members for EventSummary, including all inherited members.

calStrobe(unsigned summary) | EventSummary | [inline, static]
calStrobe() const | EventSummary | [inline]
diagnostic(unsigned summary) | EventSummary | [inline, static]
diagnostic() const | EventSummary | [inline]
error(unsigned summary) | EventSummary | [inline, static]
error() const | EventSummary | [inline]
eventNumber(unsigned summary) | EventSummary | [inline, static]
eventNumber() const | EventSummary | [inline]
EventSummary(unsigned summary) | EventSummary | [inline]
EventSummary() (defined in EventSummary) | EventSummary | [inline]
marker(unsigned summary) | EventSummary | [inline, static]
marker() const | EventSummary | [inline]
readout4(unsigned summary) | EventSummary | [inline, static]
readout4() const | EventSummary | [inline]
TACK(unsigned summary) | EventSummary | [inline, static]
TACK() const | EventSummary | [inline]
tag(unsigned summary) | EventSummary | [inline, static]
tag() const | EventSummary | [inline]
trgParityError(unsigned summary) | EventSummary | [inline, static]
trgParityError() const | EventSummary | [inline]
zeroSuppress(unsigned summary) | EventSummary | [inline, static]
zeroSuppress() const | EventSummary | [inline]
~EventSummary() (defined in EventSummary) | EventSummary | [inline]

Generated on Mon Jul 31 17:48:15 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: GCCCerror Class Reference

GCCCerror Class Reference

Helper classes for accessing fields in the error data.Class for decoding a GCCC error message. More...

#include <GXXXerror.h>

List of all members.

Public Member Functions

GCCCerror (unsigned msg)
unsigned | type () const
unsigned | sweep () const
unsigned | param () const
unsigned | raw () const

Static Public Member Functions

static unsigned | type (unsigned msg)
static unsigned | sweep (unsigned msg)
static unsigned | param (unsigned msg)

Detailed Description

Helper classes for accessing fields in the error data.Class for decoding a GCCC error message.

Constructor & Destructor Documentation

GCCCerror::GCCCerror ( unsigned msg ) [inline]

Constructor for initializing the class with an error message

Member Function Documentation

unsigned GCCCerror::param ( ) const [inline]

Return the error parameter of the GCCC error message

static unsigned GCCCerror::param ( unsigned msg ) [inline, static]

Static method to return the error parameter of a given GCCC error message

unsigned GCCCerror::raw ( ) const [inline]

Return the raw error message the GCCCerror class was initialized with

unsigned GCCCerror::sweep ( ) const [inline]

Return the sweep number of the GCCC error message

static unsigned GCCCerror::sweep ( unsigned msg ) [inline, static]

Static method to return the sweep number of a given GCCC error message

unsigned GCCCerror::type ( ) const [inline]

Return the error type of the GCCC error message

static unsigned GCCCerror::type ( unsigned msg ) [inline, static]

Static method to return the error type of a given GCCC error message

The documentation for this class was generated from the following file:
  • GXXXerror.h
Generated on Mon Jul 31 17:48:15 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

GCCCerror Member List

This is the complete list of members for GCCCerror, including all inherited members.

GCCCerror(unsigned msg) | GCCCerror | [inline]
param(unsigned msg) | GCCCerror | [inline, static]
param() const | GCCCerror | [inline]
raw() const | GCCCerror | [inline]
sweep(unsigned msg) | GCCCerror | [inline, static]
sweep() const | GCCCerror | [inline]
type(unsigned msg) | GCCCerror | [inline, static]
type() const | GCCCerror | [inline]
~GCCCerror() (defined in GCCCerror) | GCCCerror | [inline]

Generated on Mon Jul 31 17:48:15 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: GEMcondArrivalTime Class Reference

GEMcondArrivalTime Class Reference

This is a helper class for parsing the Condition Arrival Time structure. More...

#include <GEMcontribution.h>

List of all members.

Public Member Functions

unsigned short | external () const
Return the condition arrival time in 50 ns ticks of the external trigger bit.
unsigned short | cno () const
Return the condition arrival time in 50 ns ticks of the cno trigger bit.
unsigned short | calLE () const
Return the condition arrival time in 50 ns ticks of the calLE trigger bit.
unsigned short | calHE () const
Return the condition arrival time in 50 ns ticks of the calHE trigger bit.
unsigned short | tkr () const
Return the condition arrival time in 50 ns ticks of the tkr trigger bit.
unsigned short | roi () const
Return the condition arrival time in 50 ns ticks of the roi trigger bit.
unsigned | datum () const
Return the raw condition arrival time value.

Detailed Description

This is a helper class for parsing the Condition Arrival Time structure.

Member Function Documentation

unsigned short GEMcondArrivalTime::calHE ( ) const [inline]

Return the condition arrival time in 50 ns ticks of the calHE trigger bit.

Returns:
The condition arrival time in 50 ns ticks of the calHE trigger bit

unsigned short GEMcondArrivalTime::calLE ( ) const [inline]

Return the condition arrival time in 50 ns ticks of the calLE trigger bit.

Returns:
The condition arrival time in 50 ns ticks of the calLE trigger bit

unsigned short GEMcondArrivalTime::cno ( ) const [inline]

Return the condition arrival time in 50 ns ticks of the cno trigger bit.

Returns:
The condition arrival time in 50 ns ticks of the cno trigger bit

unsigned GEMcondArrivalTime::datum ( ) const [inline]

Return the raw condition arrival time value.

Returns:
The raw condition arrival time unsigned

unsigned short GEMcondArrivalTime::external ( ) const [inline]

Return the condition arrival time in 50 ns ticks of the external trigger bit.

Returns:
The condition arrival time in 50 ns ticks of the external trigger bit

unsigned short GEMcondArrivalTime::roi ( ) const [inline]

Return the condition arrival time in 50 ns ticks of the roi trigger bit.

Returns:
The condition arrival time in 50 ns ticks of the roi trigger bit

unsigned short GEMcondArrivalTime::tkr ( ) const [inline]

Return the condition arrival time in 50 ns ticks of the tkr trigger bit.

Returns:
The condition arrival time in 50 ns ticks of the tkr trigger bit

The documentation for this class was generated from the following file:
  • GEMcontribution.h
Generated on Mon Jul 31 17:48:15 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

GEMcondArrivalTime Member List

This is the complete list of members for GEMcondArrivalTime, including all inherited members.

calHE() const | GEMcondArrivalTime | [inline]
calLE() const | GEMcondArrivalTime | [inline]
cno() const | GEMcondArrivalTime | [inline]
datum() const | GEMcondArrivalTime | [inline]
external() const | GEMcondArrivalTime | [inline]
roi() const | GEMcondArrivalTime | [inline]
tkr() const | GEMcondArrivalTime | [inline]

Generated on Mon Jul 31 17:48:15 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: GEMcontribution Class Reference

GEMcontribution Class Reference

Class for parsing the GEM's event contribution. More...

#include <GEMcontribution.h>

Inheritance diagram for GEMcontribution:

[legend]
Collaboration diagram for GEMcontribution:

[legend]
List of all members.

Public Member Functions

char * | data () const
Return a pointer to the data payload.
unsigned short | tkrVector () const
Return the Tracker vector.
unsigned short | roiVector () const
Return the Region of Interest vector.
unsigned short | calLEvector () const
Return the CAL Low Energy vector.
unsigned short | calHEvector () const
Return the CAL High Energy vector.
unsigned short | cnoVector () const
Return the CNO vector.
unsigned short | conditionSummary () const
Return the condition summary.
unsigned short | missed () const
Return the least 8 significant bits of the missed counter.
unsigned short | deadZone () const
Return the least 8 significant bits of the GEMST.dead_zoned counter.
const GEMtileList * | tileList () const
Return a pointer to the tile list.
unsigned | liveTime () const
Return the sampled live time value.
unsigned | prescaled () const
Return the sampled prescaled count.
unsigned | discarded () const
Return the sampled discarded count.
unsigned | sent () const
Return the sampled send count.
GEMcondArrivalTime | condArrTime () const
Return the condition arrival time data block.
unsigned | triggerTime () const
Return the trigger time.
GEMonePPStime | onePPStime () const
Return the one PPS time data block.
unsigned short | deltaEventTime () const
Return the delta event time.
unsigned short | deltaWindowOpenTime () const
Return the delta window open time.

Classes

union | sent_condArr

Detailed Description

Class for parsing the GEM's event contribution.

Member Function Documentation

unsigned short GEMcontribution::calHEvector ( ) const [inline]

Return the CAL High Energy vector.

Returns:
The CAL High Energy vector word

unsigned short GEMcontribution::calLEvector ( ) const [inline]

Return the CAL Low Energy vector.

Returns:
The CAL Low Energy vector word

unsigned short GEMcontribution::cnoVector ( ) const [inline]

Return the CNO vector.

Returns:
The CNO vector word

GEMcondArrivalTime GEMcontribution::condArrTime ( ) const [inline]

Return the condition arrival time data block.

Returns:
The condition arrival time structure

unsigned short GEMcontribution::conditionSummary ( ) const [inline]

Return the condition summary.

Returns:
The condition summary word

char * GEMcontribution::data ( ) const [inline]

Return a pointer to the data payload.

Returns:
A pointer to the data payload

unsigned short GEMcontribution::deadZone ( ) const [inline]

Return the least 8 significant bits of the GEMST.dead_zoned counter.

Returns:
The GEMST.dead_zoned counter's 8 LSBs

unsigned short GEMcontribution::deltaEventTime ( ) const [inline]

Return the delta event time.

Returns:
The delta event time

unsigned short GEMcontribution::deltaWindowOpenTime ( ) const [inline]

Return the delta window open time.

Returns:
The delta window open time

unsigned GEMcontribution::discarded ( ) const [inline]

Return the sampled discarded count.

Returns:
The discarded count word

unsigned GEMcontribution::liveTime ( ) const [inline]

Return the sampled live time value.

Returns:
The live time word

unsigned short GEMcontribution::missed ( ) const [inline]

Return the least 8 significant bits of the missed counter.

Returns:
The missed counter's 8 LSBs

GEMonePPStime GEMcontribution::onePPStime ( ) const [inline]

Return the one PPS time data block.

Returns:
The one PPS time structure

unsigned GEMcontribution::prescaled ( ) const [inline]

Return the sampled prescaled count.

Returns:
The prescale count word

unsigned short GEMcontribution::roiVector ( ) const [inline]

Return the Region of Interest vector.

Returns:
The ROI vector word

unsigned GEMcontribution::sent ( ) const [inline]

Return the sampled send count.

Returns:
The sent count word
Note: field deprecated in GEMs manufactured after 31 Jan 2005

const GEMtileList * GEMcontribution::tileList ( ) const [inline]

Return a pointer to the tile list.

Returns:
A pointer to the tile list

unsigned short GEMcontribution::tkrVector ( ) const [inline]

Return the Tracker vector.

Returns:
The Tracker vector word

unsigned GEMcontribution::triggerTime ( ) const [inline]

Return the trigger time.

Returns:
The sampled trigger time counter word

The documentation for this class was generated from the following file:
  • GEMcontribution.h
Generated on Mon Jul 31 17:48:16 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

GEMcontribution Member List

This is the complete list of members for GEMcontribution, including all inherited members.

AEM enum value (defined in EBFcontribution) | EBFcontribution |
aemContribution() const | EBFcontribution | [inline]
Broadcast enum value (defined in EBFcontribution) | EBFcontribution |
calHEvector() const | GEMcontribution | [inline]
calLEvector() const | GEMcontribution | [inline]
cnoVector() const | GEMcontribution | [inline]
condArrTime() const | GEMcontribution | [inline]
conditionSummary() const | GEMcontribution | [inline]
CRU enum value (defined in EBFcontribution) | EBFcontribution |
data() const | GEMcontribution | [inline]
deadZone() const | GEMcontribution | [inline]
deltaEventTime() const | GEMcontribution | [inline]
deltaWindowOpenTime() const | GEMcontribution | [inline]
discarded() const | GEMcontribution | [inline]
EBFcontribution() (defined in EBFcontribution) | EBFcontribution | [inline]
EBM enum value (defined in EBFcontribution) | EBFcontribution |
GEM enum value (defined in EBFcontribution) | EBFcontribution |
GEMcontribution() (defined in GEMcontribution) | GEMcontribution | [inline]
gemContribution() const | EBFcontribution | [inline]
gltContribution() const | EBFcontribution | [inline]
header() const | EBFcontribution | [inline]
length() const | EBFcontribution | [inline]
liveTime() const | GEMcontribution | [inline]
missed() const | GEMcontribution | [inline]
next() const | EBFcontribution | [inline]
NumberOfContributions enum value (defined in EBFcontribution) | EBFcontribution |
onePPStime() const | GEMcontribution | [inline]
OSW enum value (defined in EBFcontribution) | EBFcontribution |
oswContribution() const | EBFcontribution | [inline]
packetError() const | EBFcontribution | [inline]
Parity enum value (defined in EBFcontribution) | EBFcontribution |
payload() const | EBFcontribution | [inline]
payloadSize() const | EBFcontribution | [inline]
PDU_0 enum value (defined in EBFcontribution) | EBFcontribution |
PDU_1 enum value (defined in EBFcontribution) | EBFcontribution |
prescaled() const | GEMcontribution | [inline]
roiVector() const | GEMcontribution | [inline]
sent() const | GEMcontribution | [inline]
sequence() const | EBFcontribution | [inline]
summary() const | EBFcontribution | [inline]
temContribution() const | EBFcontribution | [inline]
tileList() const | GEMcontribution | [inline]
TimedOut enum value (defined in EBFcontribution) | EBFcontribution |
tkrVector() const | GEMcontribution | [inline]
Tower_00 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_01 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_02 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_03 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_04 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_05 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_06 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_07 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_08 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_09 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_10 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_11 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_12 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_13 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_14 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_15 enum value (defined in EBFcontribution) | EBFcontribution |
triggerTime() const | GEMcontribution | [inline]
Truncated enum value (defined in EBFcontribution) | EBFcontribution |
WriteFault enum value (defined in EBFcontribution) | EBFcontribution |
~EBFcontribution() (defined in EBFcontribution) | EBFcontribution | [inline]
~GEMcontribution() (defined in GEMcontribution) | GEMcontribution | [inline]

Generated on Mon Jul 31 17:48:16 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: GEMonePPStime Class Reference

GEMonePPStime Class Reference

This is a helper class for parsing the One PPS time structure. More...

#include <GEMcontribution.h>

List of all members.

Public Member Functions

unsigned | timebase () const
Return the 20 MHz timebase sampled at the 1-PPS time.
unsigned | seconds () const
Return the seconds portion of the sampled 1-PPS time.

Detailed Description

This is a helper class for parsing the One PPS time structure.

Member Function Documentation

unsigned GEMonePPStime::seconds ( ) const [inline]

Return the seconds portion of the sampled 1-PPS time.

Returns:
The seconds word of the sampled 1-PPS time

unsigned GEMonePPStime::timebase ( ) const [inline]

Return the 20 MHz timebase sampled at the 1-PPS time.

Returns:
The timebase word of the 1-PPS time

The documentation for this class was generated from the following file:
  • GEMcontribution.h
Generated on Mon Jul 31 17:48:16 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

GEMonePPStime Member List

This is the complete list of members for GEMonePPStime, including all inherited members.

GEMonePPStime() (defined in GEMonePPStime) | GEMonePPStime | [inline]
seconds() const | GEMonePPStime | [inline]
timebase() const | GEMonePPStime | [inline]
~GEMonePPStime() (defined in GEMonePPStime) | GEMonePPStime | [inline]

Generated on Mon Jul 31 17:48:16 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: GEMtileList Class Reference

GEMtileList Class Reference

Classes for decoding a GEM's contribution to an EBFevent.This is a helper class for handling ACD tile data. More...

#include <GEMcontribution.h>

List of all members.

Public Member Functions

unsigned short | XZM () const
Return the XZM group in the tile list.
unsigned short | XZP () const
Return the XZP group in the tile list.
unsigned short | YZM () const
Return the YZM group in the tile list.
unsigned short | YZP () const
Return the YZP group in the tile list.
unsigned | XY () const
Return the XY group in the tile list.
unsigned short | RBN () const
Return the RBN group in the tile list.
unsigned short | NA () const
Return the NA group in the tile list.

Detailed Description

Classes for decoding a GEM's contribution to an EBFevent.This is a helper class for handling ACD tile data.

Member Function Documentation

unsigned short GEMtileList::NA ( ) const [inline]

Return the NA group in the tile list.

Returns:
The NA group word

unsigned short GEMtileList::RBN ( ) const [inline]

Return the RBN group in the tile list.

Returns:
The RBN group word

unsigned GEMtileList::XY ( ) const [inline]

Return the XY group in the tile list.

Returns:
The XY group word

unsigned short GEMtileList::XZM ( ) const [inline]

Return the XZM group in the tile list.

Returns:
The XZM group word

unsigned short GEMtileList::XZP ( ) const [inline]

Return the XZP group in the tile list.

Returns:
The XZP group word

unsigned short GEMtileList::YZM ( ) const [inline]

Return the YZM group in the tile list.

Returns:
The YZM group word

unsigned short GEMtileList::YZP ( ) const [inline]

Return the YZP group in the tile list.

Returns:
The YZP group word

The documentation for this class was generated from the following file:
  • GEMcontribution.h
Generated on Mon Jul 31 17:48:16 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

GEMtileList Member List

This is the complete list of members for GEMtileList, including all inherited members.

GEMtileList() (defined in GEMtileList) | GEMtileList | [inline]
NA() const | GEMtileList | [inline]
RBN() const | GEMtileList | [inline]
XY() const | GEMtileList | [inline]
XZM() const | GEMtileList | [inline]
XZP() const | GEMtileList | [inline]
YZM() const | GEMtileList | [inline]
YZP() const | GEMtileList | [inline]
~GEMtileList() (defined in GEMtileList) | GEMtileList | [inline]

Generated on Mon Jul 31 17:48:16 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: GLTcontribution Class Reference

GLTcontribution Class Reference

Class for decoding a GLT's contribution to an EBFevent. More...

#include <GLTcontribution.h>

Inheritance diagram for GLTcontribution:

[legend]
Collaboration diagram for GLTcontribution:

[legend]
List of all members.

Public Member Functions

char * | data ()
Return a pointer to the contribution's payload.
timespec * | timeStamp () const
Return the timespec structure found in the data.
const OSWtimeBase * | timebase () const
Return the 64 bit timebase value found in the data as two unsigneds.

Detailed Description

Class for decoding a GLT's contribution to an EBFevent.

This class provides access to software generated time stamps.

This class exists to support data taken before the GASU came into existance. Data that falls into this catagory is labeled with the EBFevent::ID_1 typeId. Data taken after this point contains this time stamp information as well, but in the form of an OSWtimeContribution.

Author:
R. Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.1
Date:
January 26, 2003 -- Created
Id
GLTcontribution.h,v 1.1 2004/04/02 01:56:50 claus Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Member Function Documentation

char * GLTcontribution::data ( ) [inline]

Return a pointer to the contribution's payload.

Returns:
A pointer to the contribution's payload

const OSWtimeBase * GLTcontribution::timebase ( ) const [inline]

Return the 64 bit timebase value found in the data as two unsigneds.

The timebase value comes from a PPC register that increments at a rate given by the board's implementation. Ric hasn't been able to find any supporting documentation giving the rate, but one measurement gives 16.6667 MHz.

Returns:
A pointer to the timebase structure

struct timespec * GLTcontribution::timeStamp ( ) const [inline]

Return the timespec structure found in the data.

The timestamp value comes from the VxWorks real-time clock. The clock is periodically updated. The period is settable through software, but defaults to 60 Hz.

Returns:
A pointer to the timespec structure

The documentation for this class was generated from the following file:
  • GLTcontribution.h
Generated on Mon Jul 31 17:48:16 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

GLTcontribution Member List

This is the complete list of members for GLTcontribution, including all inherited members.

AEM enum value (defined in EBFcontribution) | EBFcontribution |
aemContribution() const | EBFcontribution | [inline]
Broadcast enum value (defined in EBFcontribution) | EBFcontribution |
CRU enum value (defined in EBFcontribution) | EBFcontribution |
data() | GLTcontribution | [inline]
EBFcontribution() (defined in EBFcontribution) | EBFcontribution | [inline]
EBM enum value (defined in EBFcontribution) | EBFcontribution |
GEM enum value (defined in EBFcontribution) | EBFcontribution |
gemContribution() const | EBFcontribution | [inline]
GLTcontribution() (defined in GLTcontribution) | GLTcontribution | [inline]
gltContribution() const | EBFcontribution | [inline]
header() const | EBFcontribution | [inline]
length() const | EBFcontribution | [inline]
next() const | EBFcontribution | [inline]
NumberOfContributions enum value (defined in EBFcontribution) | EBFcontribution |
OSW enum value (defined in EBFcontribution) | EBFcontribution |
oswContribution() const | EBFcontribution | [inline]
packetError() const | EBFcontribution | [inline]
Parity enum value (defined in EBFcontribution) | EBFcontribution |
payload() const | EBFcontribution | [inline]
payloadSize() const | EBFcontribution | [inline]
PDU_0 enum value (defined in EBFcontribution) | EBFcontribution |
PDU_1 enum value (defined in EBFcontribution) | EBFcontribution |
sequence() const | EBFcontribution | [inline]
summary() const | EBFcontribution | [inline]
temContribution() const | EBFcontribution | [inline]
timebase() const | GLTcontribution | [inline]
TimedOut enum value (defined in EBFcontribution) | EBFcontribution |
timeStamp() const | GLTcontribution | [inline]
Tower_00 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_01 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_02 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_03 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_04 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_05 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_06 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_07 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_08 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_09 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_10 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_11 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_12 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_13 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_14 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_15 enum value (defined in EBFcontribution) | EBFcontribution |
Truncated enum value (defined in EBFcontribution) | EBFcontribution |
WriteFault enum value (defined in EBFcontribution) | EBFcontribution |
~EBFcontribution() (defined in EBFcontribution) | EBFcontribution | [inline]
~GLTcontribution() (defined in GLTcontribution) | GLTcontribution | [inline]

Generated on Mon Jul 31 17:48:16 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: GTCCerror Class Reference

GTCCerror Class Reference

Class for decoding a GTCC error message. More...

#include <GXXXerror.h>

List of all members.

Public Member Functions

GTCCerror (unsigned msg)
unsigned | GTRC () const
unsigned | RCphase () const
unsigned | FEphase () const
unsigned | FIFOfull () const
unsigned | cableTMO () const
unsigned | hdrParity () const
unsigned | wrdCntParity () const
unsigned | RCsummary () const
unsigned | dataParity () const
unsigned | raw () const

Static Public Member Functions

static unsigned | GTRC (unsigned msg)
static unsigned | RCphase (unsigned msg)
static unsigned | FEphase (unsigned msg)
static unsigned | FIFOfull (unsigned msg)
static unsigned | cableTMO (unsigned msg)
static unsigned | hdrParity (unsigned msg)
static unsigned | wrdCntParity (unsigned msg)
static unsigned | RCsummary (unsigned msg)
static unsigned | dataParity (unsigned msg)

Detailed Description

Class for decoding a GTCC error message.

Constructor & Destructor Documentation

GTCCerror::GTCCerror ( unsigned msg ) [inline]

Constructor for initializing the class with an error message

Member Function Documentation

unsigned GTCCerror::cableTMO ( ) const [inline]

Method for reporting whether the error message indicates there was a cable timeout error

static unsigned GTCCerror::cableTMO ( unsigned msg ) [inline, static]

Static method for reporting whether this error message indicates there was a cable timeout error

unsigned GTCCerror::dataParity ( ) const [inline]

Method for reporting whether the error message indicates there was a data parity error

static unsigned GTCCerror::dataParity ( unsigned msg ) [inline, static]

Static method for reporting whether this error message indicates there was a data parity error

unsigned GTCCerror::FEphase ( ) const [inline]

Method for reporting whether the error message indicates there was a GTFE phasing error

static unsigned GTCCerror::FEphase ( unsigned msg ) [inline, static]

Static method for reporting whether this error message indicates there was a GTFE phasing error

unsigned GTCCerror::FIFOfull ( ) const [inline]

Method for reporting whether the error message indicates there was a FIFO Full error

static unsigned GTCCerror::FIFOfull ( unsigned msg ) [inline, static]

Static method for reporting whether this error message indicates there was a FIFO Full error

unsigned GTCCerror::GTRC ( ) const [inline]

Return the GTRC number that contributed the error message

static unsigned GTCCerror::GTRC ( unsigned msg ) [inline, static]

Static method to return the GTRC number that contributed this error message

unsigned GTCCerror::hdrParity ( ) const [inline]

Method for reporting whether this error message indicates there was a header parity error

static unsigned GTCCerror::hdrParity ( unsigned msg ) [inline, static]

Static method for reporting whether this error message indicates there was a header parity error

unsigned GTCCerror::raw ( ) const [inline]

Return the raw error message the GCCCerror class was initialized with

unsigned GTCCerror::RCphase ( ) const [inline]

Method for reporting whether the error message indicates there was a GTRC phasing error

static unsigned GTCCerror::RCphase ( unsigned msg ) [inline, static]

Static method for reporting whether this error message indicates there was a GTRC phasing error

unsigned GTCCerror::RCsummary ( ) const [inline]

Method for reporting whether the error message indicates there was a GTRC summary error

static unsigned GTCCerror::RCsummary ( unsigned msg ) [inline, static]

Static method for reporting whether this error message indicates there was a GTRC summary error

unsigned GTCCerror::wrdCntParity ( ) const [inline]

Method for reporting whether the error message indicates there was a word count parity error

static unsigned GTCCerror::wrdCntParity ( unsigned msg ) [inline, static]

Static method for reporting whether this error message indicates there was a word count parity error

The documentation for this class was generated from the following file:
  • GXXXerror.h
Generated on Mon Jul 31 17:48:16 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

GTCCerror Member List

This is the complete list of members for GTCCerror, including all inherited members.

cableTMO(unsigned msg) | GTCCerror | [inline, static]
cableTMO() const | GTCCerror | [inline]
dataParity(unsigned msg) | GTCCerror | [inline, static]
dataParity() const | GTCCerror | [inline]
FEphase(unsigned msg) | GTCCerror | [inline, static]
FEphase() const | GTCCerror | [inline]
FIFOfull(unsigned msg) | GTCCerror | [inline, static]
FIFOfull() const | GTCCerror | [inline]
GTCCerror(unsigned msg) | GTCCerror | [inline]
GTRC(unsigned msg) | GTCCerror | [inline, static]
GTRC() const | GTCCerror | [inline]
hdrParity(unsigned msg) | GTCCerror | [inline, static]
hdrParity() const | GTCCerror | [inline]
raw() const | GTCCerror | [inline]
RCphase(unsigned msg) | GTCCerror | [inline, static]
RCphase() const | GTCCerror | [inline]
RCsummary(unsigned msg) | GTCCerror | [inline, static]
RCsummary() const | GTCCerror | [inline]
wrdCntParity(unsigned msg) | GTCCerror | [inline, static]
wrdCntParity() const | GTCCerror | [inline]
~GTCCerror() (defined in GTCCerror) | GTCCerror | [inline]

Generated on Mon Jul 31 17:48:16 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: GTRCerror Class Reference

GTRCerror Class Reference

Class for decoding a GTRC error message. More...

#include <GXXXerror.h>

List of all members.

Public Member Functions

GTRCerror (unsigned tag)
unsigned | currentTag () const
unsigned | layer0Tag () const
unsigned | expectedLayer () const
unsigned | receivedLayer () const
unsigned | raw () const

Static Public Member Functions

static unsigned | currentTag (unsigned tag)
static unsigned | layer0Tag (unsigned tag)
static unsigned | expectedLayer (unsigned tag)
static unsigned | receivedLayer (unsigned tag)

Detailed Description

Class for decoding a GTRC error message.

Constructor & Destructor Documentation

GTRCerror::GTRCerror ( unsigned tag ) [inline]

Constructor for initializing the class with an error message

Member Function Documentation

unsigned GTRCerror::currentTag ( ) const [inline]

Method returning the current tag number

static unsigned GTRCerror::currentTag ( unsigned tag ) [inline, static]

Static method returning the current tag number

unsigned GTRCerror::expectedLayer ( ) const [inline]

Method returning the expected layer number

static unsigned GTRCerror::expectedLayer ( unsigned tag ) [inline, static]

Static method returning the expected layer number

unsigned GTRCerror::layer0Tag ( ) const [inline]

Method returning the layer zero tag number

static unsigned GTRCerror::layer0Tag ( unsigned tag ) [inline, static]

Static method returning the layer zero tag number

unsigned GTRCerror::raw ( ) const [inline]

Return the raw error message the GCCCerror class was initialized with

unsigned GTRCerror::receivedLayer ( ) const [inline]

Method returning the layer number number received by the TEM

static unsigned GTRCerror::receivedLayer ( unsigned tag ) [inline, static]

Static method returning the layer number number received by the TEM

The documentation for this class was generated from the following file:
  • GXXXerror.h
Generated on Mon Jul 31 17:48:16 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

GTRCerror Member List

This is the complete list of members for GTRCerror, including all inherited members.

currentTag(unsigned tag) | GTRCerror | [inline, static]
currentTag() const | GTRCerror | [inline]
expectedLayer(unsigned tag) | GTRCerror | [inline, static]
expectedLayer() const | GTRCerror | [inline]
GTRCerror(unsigned tag) | GTRCerror | [inline]
layer0Tag(unsigned tag) | GTRCerror | [inline, static]
layer0Tag() const | GTRCerror | [inline]
raw() const | GTRCerror | [inline]
receivedLayer(unsigned tag) | GTRCerror | [inline, static]
receivedLayer() const | GTRCerror | [inline]
~GTRCerror() (defined in GTRCerror) | GTRCerror | [inline]

Generated on Mon Jul 31 17:48:16 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: LATcomponentIterator Class Reference

LATcomponentIterator Class Reference

Class for iterating over components in a LATcontribution. More...

#include <LATcomponentIterator.h>

Inheritance diagram for LATcomponentIterator:

[legend]
Collaboration diagram for LATcomponentIterator:

[legend]
List of all members.

Public Member Functions

LATcomponentIterator (EBFevent *)
Constructor initializing the iterator with an EBFevent.
LATcomponentIterator ()
Do nothing constructor.
unsigned | iterate (EBFevent *event)
Class for iterating over a EBF event contributionsIterate over the EBF contributions in an event.
virtual int | handleError (EBFcontribution *contribution, unsigned code, unsigned p1=0, unsigned p2=0) const
Handle all errors possible in LATcomponentIterator.
virtual int | handleError (EBFevent *event, unsigned code, unsigned p1=0, unsigned p2=0) const
Handle all errors possible in LATcomponentIterator.
int | OSW (EBFevent *event, EBFcontribution *contribution)
Method to call back the application with an OSWcontribution.
int | GLT (EBFevent *event, EBFcontribution *contribution)
Method to call back the application with an GLTcontribution.
int | GEM (EBFevent *event, EBFcontribution *contribution)
Method to call back the application with an GEMcontribution.
int | AEM (EBFevent *event, EBFcontribution *contribution)
Method to call back the application with an AEMcontribution.
int | TEM (EBFevent *event, EBFcontribution *contribution)
Method that iterates over TEMcontributions, calling the application back.
int | UDF (EBFevent *event, EBFcontribution *contribution)
Method to call back the application with an EBFcontribution when the contribution is unrecognized.
int | CAL (EBFevent *event, TEMcontribution *contribution)
Method to call back the application with an CALcontribution.
int | TKR (EBFevent *event, TEMcontribution *contribution)
Method to call back the application with an TKRcontribution.
virtual int | UDFcomponent (EBFevent *event, EBFcontribution *contribution)
Default method called when the application doesn't supply a method to handle undefined EBFcontributions.
virtual int | OSWcomponent (EBFevent *event, OSWcontribution *contribution)
Default method called when the application doesn't supply a method to handle OSWcontributions.
virtual int | GLTcomponent (EBFevent *event, GLTcontribution *contribution)
Default method called when the application doesn't supply a method to handle GLTcontributions.
virtual int | GEMcomponent (EBFevent *event, GEMcontribution *contribution)
Default method called when the application doesn't supply a method to handle GEMcontributions.
virtual int | ACDcomponent (EBFevent *event, AEMcontribution *contribution)
Default method called when the application doesn't supply a method to handle AEMcontributions.
virtual int | CALcomponent (EBFevent *event, CALcontribution *contribution)
Default method called when the application doesn't supply a method to handle CALcontributions.
virtual int | TKRcomponent (EBFevent *event, TKRcontribution *contribution)
Default method called when the application doesn't supply a method to handle TKRcontributions.
virtual int | diagnostic (EBFevent *event, TEMcontribution *contribution)
Default method called when the application doesn't supply a method to handle diagnostic contributions.
virtual int | error (EBFevent *event, TEMcontribution *contribution)
Default method called when the application doesn't supply a method to handle error contributions.
virtual int | cleanup (EBFevent *event, TEMcontribution *contribution)
Default method called when the application doesn't supply a "cleanup" method.

Detailed Description

Class for iterating over components in a LATcontribution.

The idea behind this class was to make one iterator that runs over all components of the event, calling all the subiterators necessary to parse the event in the finest detail. The user of this class only had to provide the virtual methods for those leaf iterators in which his application is interested. Those in which he is not intersted are defaulted to no-op methods to make this a concrete class.

Another consideration is that it appears that having the CPU cross the C++/Python boundary is an expensive operation, so in order to minimize the impact of this, as much as possible was done on the C++ side.

The conflict is that each time additional iterators are created the class interface changes, causing backward compatibility problems. For the moment (March 10, 2004), this class is set up to only do the first layers of iteration, leaving iteration down to the leaf items up to the application.

Author:
R. Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.12
Date:
January 30, 2003 -- Created
Id
LATcomponentIterator.h,v 1.12 2005/03/18 05:20:37 panetta Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

LATcomponentIterator::LATcomponentIterator ( EBFevent * event ) [inline]

Constructor initializing the iterator with an EBFevent.

Parameters:
event - The EBFevent to iterate over

Member Function Documentation

int LATcomponentIterator::ACDcomponent | ( | EBFevent * | event,
 |  | AEMcontribution * | contribution |
 | ) |  |  | [inline, virtual]

Default method called when the application doesn't supply a method to handle AEMcontributions.

Parameters:
event | - The EBFevent containing the AEMcontribution
contribution | - The AEMcontribution
Returns:
Zero for success

int LATcomponentIterator::AEM | ( | EBFevent * | event,
 |  | EBFcontribution * | contribution |
 | ) |  |  | [inline, virtual]

Method to call back the application with an AEMcontribution.

With this example class, this method is called by the EBFcontributionIterator. It should not be called from the application that instantiates this class.

Parameters:
event | - The EBFevent containing the contribution
contribution | - The EBFcontribution to handle as an AEMcontribution
Returns:
An application defined status value.

Implements EBFcontributionIterator.

int LATcomponentIterator::CAL | ( | EBFevent * | event,
 |  | TEMcontribution * | contribution |
 | ) |  |  | [inline, virtual]

Method to call back the application with an CALcontribution.

With this example class, this method is called by the TEMcontributionIterator. It should not be called from the application that instantiates this class.

Parameters:
event | - The EBFevent containing the contribution
contribution | - The EBFcontribution to handle as an CALcontribution
Returns:
An application defined status value.

Implements TEMcontributionIterator.

int LATcomponentIterator::CALcomponent | ( | EBFevent * | event,
 |  | CALcontribution * | contribution |
 | ) |  |  | [inline, virtual]

Default method called when the application doesn't supply a method to handle CALcontributions.

Parameters:
event | - The EBFevent containing the CALcontribution
contribution | - The CALcontribution
Returns:
Zero for success

int LATcomponentIterator::cleanup | ( | EBFevent * | event,
 |  | TEMcontribution * | contribution |
 | ) |  |  | [inline, virtual]

Default method called when the application doesn't supply a "cleanup" method.

The "cleanup" method is used to do additional checking on data following the last contribution in the event. In some examples, it is used to verify that the event is padded out to a LATp cell boundary with zeros.

Parameters:
event | - The EBFevent containing the contribution
contribution | - The EBFcontribution to handle as an EBFcontribution
Returns:
Zero for success

Implements TEMcontributionIterator.

int LATcomponentIterator::diagnostic | ( | EBFevent * | event,
 |  | TEMcontribution * | contribution |
 | ) |  |  | [inline, virtual]

Default method called when the application doesn't supply a method to handle diagnostic contributions.

Parameters:
event | - The EBFevent containing the diagnostic contribution
contribution | - The TEMcontribution
Returns:
Zero for success

Implements TEMcontributionIterator.

int LATcomponentIterator::error | ( | EBFevent * | event,
 |  | TEMcontribution * | contribution |
 | ) |  |  | [inline, virtual]

Default method called when the application doesn't supply a method to handle error contributions.

Parameters:
event | - The EBFevent containing the error contribution
contribution | - The TEMcontribution
Returns:
Zero for success

Implements TEMcontributionIterator.

int LATcomponentIterator::GEM | ( | EBFevent * | event,
 |  | EBFcontribution * | contribution |
 | ) |  |  | [inline, virtual]

Method to call back the application with an GEMcontribution.

With this example class, this method is called by the EBFcontributionIterator. It should not be called from the application that instantiates this class.

Parameters:
event | - The EBFevent containing the contribution
contribution | - The EBFcontribution to handle as a GEMcontribution
Returns:
An application defined status value.

Implements EBFcontributionIterator.

int LATcomponentIterator::GEMcomponent | ( | EBFevent * | event,
 |  | GEMcontribution * | contribution |
 | ) |  |  | [inline, virtual]

Default method called when the application doesn't supply a method to handle GEMcontributions.

Parameters:
event | - The EBFevent containing the GEMcontribution
contribution | - The GEMcontribution
Returns:
Zero for success

int LATcomponentIterator::GLT | ( | EBFevent * | event,
 |  | EBFcontribution * | contribution |
 | ) |  |  | [inline, virtual]

Method to call back the application with an GLTcontribution.

With this example class, this method is called by the EBFcontributionIterator. It should not be called from the application that instantiates this class.

Parameters:
event | - The EBFevent containing the contribution
contribution | - The EBFcontribution to handle as a GLTcontribution
Returns:
An application defined status value.

Implements EBFcontributionIterator.

int LATcomponentIterator::GLTcomponent | ( | EBFevent * | event,
 |  | GLTcontribution * | contribution |
 | ) |  |  | [inline, virtual]

Default method called when the application doesn't supply a method to handle GLTcontributions.

Parameters:
event | - The EBFevent containing the GLTcontribution
contribution | - The GLTcontribution
Returns:
Zero for success

int LATcomponentIterator::handleError | ( | EBFevent * | event,
 |  | unsigned | code,
 |  | unsigned | p1 = 0,
 |  | unsigned | p2 = 0 |
 | ) |  |  | const [inline, virtual]

Handle all errors possible in LATcomponentIterator.

This method is used to handle errors occurring during the iteration over an LATcomponent. By default it does nothing, however it is virtual and is able to be overridden by the user.

Parameters:
event | The event in error
code | The error code
p1 | a parameter associated with the error code
p2 | a parameter associated with the error code

Reimplemented from EBFcontributionIterator.

int LATcomponentIterator::handleError | ( | EBFcontribution * | contribution,
 |  | unsigned | code,
 |  | unsigned | p1 = 0,
 |  | unsigned | p2 = 0 |
 | ) |  |  | const [inline, virtual]

Handle all errors possible in LATcomponentIterator.

This method is used to handle errors occurring during the iteration over an LATcomponent. By default it does nothing, however it is virtual and is able to be overridden by the user.

Parameters:
contribution | The contribution in error
code | The error code
p1 | a parameter associated with the error code
p2 | a parameter associated with the error code

unsigned LATcomponentIterator::iterate ( EBFevent * event ) [inline]

Class for iterating over a EBF event contributionsIterate over the EBF contributions in an event.

This method calls back a virtual contribution handlers for each contribution it finds. Which handler is called back is determined by the contribution source ID and the _map method. Contribution handlers take the event and the contribution as arguments.

Parameters:
event A pointer to the EBFevent to be iterated over
Returns:
The number of contributions handled.

Reimplemented from EBFcontributionIterator.

int LATcomponentIterator::OSW | ( | EBFevent * | event,
 |  | EBFcontribution * | contribution |
 | ) |  |  | [inline, virtual]

Method to call back the application with an OSWcontribution.

With this example class, this method is called by the EBFcontributionIterator. It should not be called from the application that instantiates this class.

Parameters:
event | - The EBFevent containing the contribution
contribution | - The EBFcontribution to handle as an OSWcontribution
Returns:
An application defined status value.

Implements EBFcontributionIterator.

int LATcomponentIterator::OSWcomponent | ( | EBFevent * | event,
 |  | OSWcontribution * | contribution |
 | ) |  |  | [inline, virtual]

Default method called when the application doesn't supply a method to handle OSWcontributions.

Parameters:
event | - The EBFevent containing the OSWcontribution
contribution | - The OSWcontribution
Returns:
Zero for success

int LATcomponentIterator::TEM | ( | EBFevent * | event,
 |  | EBFcontribution * | contribution |
 | ) |  |  | [inline, virtual]

Method that iterates over TEMcontributions, calling the application back.

With this example class, this method is called by the EBFcontributionIterator. It should not be called from the application that instantiates this class.

Parameters:
event | - The EBFevent containing the contribution
contribution | - The EBFcontribution to handle as a TEMcontribution
Returns:
A TEMcontributionIterator::iterate() defined status value.

Implements EBFcontributionIterator.

int LATcomponentIterator::TKR | ( | EBFevent * | event,
 |  | TEMcontribution * | contribution |
 | ) |  |  | [inline, virtual]

Method to call back the application with an TKRcontribution.

With this example class, this method is called by the TEMcontributionIterator. It should not be called from the application that instantiates this class.

Parameters:
event | - The EBFevent containing the contribution
contribution | - The EBFcontribution to handle as an TKRcontribution
Returns:
An application defined status value.

Implements TEMcontributionIterator.

int LATcomponentIterator::TKRcomponent | ( | EBFevent * | event,
 |  | TKRcontribution * | contribution |
 | ) |  |  | [inline, virtual]

Default method called when the application doesn't supply a method to handle TKRcontributions.

Parameters:
event | - The EBFevent containing the TKRcontribution
contribution | - The TKRcontribution
Returns:
Zero for success

int LATcomponentIterator::UDF | ( | EBFevent * | event,
 |  | EBFcontribution * | contribution |
 | ) |  |  | [inline, virtual]

Method to call back the application with an EBFcontribution when the contribution is unrecognized.

With this example class, this method is called by the EBFcontributionIterator. It should not be called from the application that instantiates this class.

Parameters:
event | - The EBFevent containing the contribution
contribution | - The undefined EBFcontribution
Returns:
An application defined status value.

Implements EBFcontributionIterator.

int LATcomponentIterator::UDFcomponent | ( | EBFevent * | event,
 |  | EBFcontribution * | contribution |
 | ) |  |  | [inline, virtual]

Default method called when the application doesn't supply a method to handle undefined EBFcontributions.

Parameters:
event | - The EBFevent containing the EBFcontribution
contribution | - The EBFcontribution
Returns:
Zero for success

The documentation for this class was generated from the following file:
  • LATcomponentIterator.h
Generated on Mon Jul 31 17:48:17 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

LATcomponentIterator Member List

This is the complete list of members for LATcomponentIterator, including all inherited members.

ACDcomponent(EBFevent *event, AEMcontribution *contribution) | LATcomponentIterator | [inline, virtual]
AEM(EBFevent *event, EBFcontribution *contribution) | LATcomponentIterator | [inline, virtual]
CAL(EBFevent *event, TEMcontribution *contribution) | LATcomponentIterator | [inline, virtual]
CALcomponent(EBFevent *event, CALcontribution *contribution) | LATcomponentIterator | [inline, virtual]
CALend() const | TEMcontributionIterator | [inline]
CALend(unsigned offset) | TEMcontributionIterator | [inline]
cleanup(EBFevent *event, TEMcontribution *contribution) | LATcomponentIterator | [inline, virtual]
contribution() const | TEMcontributionIterator | [inline]
diagnostic(EBFevent *event, TEMcontribution *contribution) | LATcomponentIterator | [inline, virtual]
diagnosticEnd() const | TEMcontributionIterator | [inline]
diagnosticEnd(unsigned offset) | TEMcontributionIterator | [inline]
EBFcontributionIterator(EBFevent *event) | EBFcontributionIterator | [inline]
EBFcontributionIterator() | EBFcontributionIterator | [inline]
ERR_NoMap enum value (defined in EBFcontributionIterator) | EBFcontributionIterator |
ERR_NumContributions enum value (defined in EBFcontributionIterator) | EBFcontributionIterator |
ERR_PacketError enum value (defined in EBFcontributionIterator) | EBFcontributionIterator |
ERR_PastEnd enum value (defined in EBFcontributionIterator) | EBFcontributionIterator |
ERR_ZeroLength enum value (defined in EBFcontributionIterator) | EBFcontributionIterator |
error(EBFevent *event, TEMcontribution *contribution) | LATcomponentIterator | [inline, virtual]
errorEnd() const | TEMcontributionIterator | [inline]
errorEnd(unsigned offset) | TEMcontributionIterator | [inline]
EBFcontributionIterator::event() const | EBFcontributionIterator | [inline]
TEMcontributionIterator::event() const | TEMcontributionIterator | [inline]
GEM(EBFevent *event, EBFcontribution *contribution) | LATcomponentIterator | [inline, virtual]
GEMcomponent(EBFevent *event, GEMcontribution *contribution) | LATcomponentIterator | [inline, virtual]
GLT(EBFevent *event, EBFcontribution *contribution) | LATcomponentIterator | [inline, virtual]
GLTcomponent(EBFevent *event, GLTcontribution *contribution) | LATcomponentIterator | [inline, virtual]
handleError(EBFcontribution *contribution, unsigned code, unsigned p1=0, unsigned p2=0) const | LATcomponentIterator | [inline, virtual]
handleError(EBFevent *event, unsigned code, unsigned p1=0, unsigned p2=0) const | LATcomponentIterator | [inline, virtual]
TEMcontributionIterator::handleError(TEMcontribution *contribution, unsigned code, unsigned p1=0, unsigned p2=0) const | TEMcontributionIterator | [inline, virtual]
iterate(EBFevent *event) | LATcomponentIterator | [inline]
EBFcontributionIterator::iterate() | EBFcontributionIterator | [inline]
TEMcontributionIterator::iterate() | TEMcontributionIterator | [inline]
TEMcontributionIterator::iterate(EBFevent *, TEMcontribution *) | TEMcontributionIterator |
LATcomponentIterator(EBFevent *) | LATcomponentIterator | [inline]
LATcomponentIterator() | LATcomponentIterator | [inline]
OSW(EBFevent *event, EBFcontribution *contribution) | LATcomponentIterator | [inline, virtual]
OSWcomponent(EBFevent *event, OSWcontribution *contribution) | LATcomponentIterator | [inline, virtual]
EBFcontributionIterator::status() const | EBFcontributionIterator | [inline]
TEMcontributionIterator::status() const | TEMcontributionIterator | [inline]
TEM(EBFevent *event, EBFcontribution *contribution) | LATcomponentIterator | [inline, virtual]
TEMcontributionIterator(EBFevent *, TEMcontribution *) | TEMcontributionIterator | [inline]
TEMcontributionIterator() | TEMcontributionIterator | [inline]
TKR(EBFevent *event, TEMcontribution *contribution) | LATcomponentIterator | [inline, virtual]
TKRcomponent(EBFevent *event, TKRcontribution *contribution) | LATcomponentIterator | [inline, virtual]
TKRend() const | TEMcontributionIterator | [inline]
TKRend(unsigned offset) | TEMcontributionIterator | [inline]
UDF(EBFevent *event, EBFcontribution *contribution) | LATcomponentIterator | [inline, virtual]
UDFcomponent(EBFevent *event, EBFcontribution *contribution) | LATcomponentIterator | [inline, virtual]
~EBFcontributionIterator() (defined in EBFcontributionIterator) | EBFcontributionIterator | [inline, virtual]
~LATcomponentIterator() (defined in LATcomponentIterator) | LATcomponentIterator | [inline, virtual]
~TEMcontributionIterator() (defined in TEMcontributionIterator) | TEMcontributionIterator | [inline, virtual]

Generated on Mon Jul 31 17:48:17 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: LATcontribution Class Reference

LATcontribution Class Reference

Base class for describing all contributions to a LATdatagram. More...

#include <LATcontribution.h>

Inheritance diagram for LATcontribution:

[legend]
Collaboration diagram for LATcontribution:

[legend]
List of all members.

Public Types

ID = LATidentity_(LATprimaryId::Any, LATsecondaryId::Any)
enum | { ID = LATidentity_(LATprimaryId::Any, LATsecondaryId::Any) }

Public Member Functions

LATcontribution ()
Constructor setting up identity and length defaults.
LATcontribution (LATtypeId identity, unsigned length)
Constructor setting up identity and length defaults.
LATtypeId | identity () const
Return the identity of this block.
LATcontribution * | next () const
Return the next contribution in the datagram.
unsigned | length () const
Return the length of this block.
unsigned | rawDataSize () const
Return the size of the rawData in the contribution.
char * | rawData () const
Return a pointer to the rawData in the contribution.
void * | operator new (size_t)
Allocate a default LATcontribution off the memory heap.
void * | operator new (size_t, LATtypeId identity, unsigned length)
Allocate a LATcontribution with space for a payload off the memory heap.
void * | operator new (size_t, const LATcontribution &)
Copy a LATcontribution to a new one.
void * | operator new (size_t, void *, unsigned short supplemental, bool swap=!DFC_BIG_ENDIAN)
This operator new allows one to place a contribution at a given location.
void | operator delete (void *, void *, unsigned short, bool)
Delete operator used to delete a contribution.
void | operator delete (void *)
Delete operator used to delete a contribution.
unsigned char * | string (bool swap=!DFC_BIG_ENDIAN)
Return a pointer to a LATcontribution as a uchar buffer.

Static Public Member Functions

static LATcontribution * | create (LATtypeId identity, unsigned size, unsigned char *buffer, bool swap=!DFC_BIG_ENDIAN)
Create a LATcontribution from a uchar buffer.

Detailed Description

Base class for describing all contributions to a LATdatagram.

Author:
R. Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.9
Date:
March 3, 2003 -- Created
Id
LATcontribution.h,v 1.9 2006/03/30 18:57:55 perazzo Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

LATcontribution::LATcontribution | ( | LATtypeId | identity,
 |  | unsigned | length |
 | ) |  |  | [inline]

Constructor setting up identity and length defaults.

Parameters:
identity | The structure identifier of this LATcontribution
length | Amount of space in bytes to reserve for this LATcontribution Must be less than USHORT_MAX (64K Bytes)

Member Function Documentation

LATcontribution * LATcontribution::create | ( | LATtypeId | identity,
 |  | unsigned | size,
 |  | unsigned char * | buffer,
 |  | bool | swap = !DFC_BIG_ENDIAN |
 | ) |  |  | [inline, static]

Create a LATcontribution from a uchar buffer.

This method primarily exists for the Python interface.

The buffer can optionally be byte swapped by longwords in place. By default, if the endianness of the machine this code is running on is not big endian, then the buffer is byte swapped.

Parameters:
identity | The structure identifier of this LATcontribution
size | Amount of space in bytes to reserve for this LATcontribution Must be less than USHORT_MAX (64K Bytes)
buffer | A pointer to a buffer containing LATcontribution data
swap | Optionally byte swap the buffer in place
Returns:
A pointer to the buffer as a LATcontribution

void LATcontribution::operator delete ( void * location ) [inline]

Delete operator used to delete a contribution.

This method is used to avoid SIP constructor MemberCode.

void LATcontribution::operator delete | ( | void * | ,
 |  | void * | ,
 |  | unsigned | short,
 |  | bool |  |
 | ) |  |  | [inline]

Delete operator used to delete a contribution.

This method is used to avoid SIP constructor MemberCode.

void * LATcontribution::operator new | ( | size_t | size,
 |  | void * | location,
 |  | unsigned short | supplemental,
 |  | bool | swap = !DFC_BIG_ENDIAN |
 | ) |  |  | [inline]

This operator new allows one to place a contribution at a given location.

This method is used to effectively label a piece of memory containing contribution data a LATcontribution. It is similar to casting a pointer to a LAT contribution pointer.

In the process or placing the contribution, the raw data occupying the space can optionally be byte swapped. By default, if the endianness of the machine this code is running on is not big endian, then the buffer is byte swapped.

Parameters:
size | An ignored parameter
location | A pointer to the location where to place the contribution
supplemental | Additional space to include in the contribution
swap | Optionally byte swap the buffer in place
Returns:
A pointer to the buffer as a LATcontribution

void * LATcontribution::operator new | ( | size_t | size,
 |  | const LATcontribution & | contribution |
 | ) |  |  | [inline]

Copy a LATcontribution to a new one.

This method is used to avoid SIP constructor MemberCode.

Parameters:
size | An ignored parameter
contribution | A reference to the contribution to be copied
Returns:
A pointer to the newly allocated contribution

void * LATcontribution::operator new | ( | size_t | size,
 |  | LATtypeId | identity,
 |  | unsigned | length |
 | ) |  |  | [inline]

Allocate a LATcontribution with space for a payload off the memory heap.

This method is used to avoid SIP constructor MemberCode.

Parameters:
size | An ignored parameter
identity | The structure identifier of this LATcontribution
length | Amount of space in bytes to reserve for this LATcontribution Must be less than USHORT_MAX (64K Bytes)
Returns:
A pointer to the newly allocated contribution

void * LATcontribution::operator new ( size_t size ) [inline]

Allocate a default LATcontribution off the memory heap.

This method is used to avoid SIP constructor MemberCode.

Parameters:
size An ignored parameter
Returns:
A pointer to the newly allocated contribution

char * LATcontribution::rawData ( ) const [inline]

Return a pointer to the rawData in the contribution.

Returns:
A pointer to the rawData in the contribution

unsigned LATcontribution::rawDataSize ( ) const [inline]

Return the size of the rawData in the contribution.

Returns:
The size of the rawData in the contribution

unsigned char * LATcontribution::string ( bool swap = !DFC_BIG_ENDIAN ) [inline]

Return a pointer to a LATcontribution as a uchar buffer.

This method primarily exists for the Python interface.

The buffer can optionally be byte swapped by longwords in place. By default, if the endianness of the machine this code is running on is not big endian, then the buffer is byte swapped. Be sure to supply FALSE for the swap argument if the buffer has already been swapped by a previous call.

Parameters:
swap Optionally byte swap the buffer in place
Returns:
A pointer to the LATcontribution as a string buffer

Reimplemented in ASCcontribution, and EBFevent.

The documentation for this class was generated from the following file:
  • LATcontribution.h
Generated on Mon Jul 31 17:48:17 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

LATcontribution Member List

This is the complete list of members for LATcontribution, including all inherited members.

create(LATtypeId identity, unsigned size, unsigned char *buffer, bool swap=!DFC_BIG_ENDIAN) | LATcontribution | [inline, static]
ID enum value (defined in LATcontribution) | LATcontribution |
identity() const | LATcontribution | [inline]
LATcontribution() | LATcontribution | [inline]
LATcontribution(LATtypeId identity, unsigned length) | LATcontribution | [inline]
length() const | LATcontribution | [inline]
next() const | LATcontribution | [inline]
operator delete(void *, void *, unsigned short, bool) | LATcontribution | [inline]
operator delete(void *) | LATcontribution | [inline]
operator new(size_t) | LATcontribution | [inline]
operator new(size_t, LATtypeId identity, unsigned length) | LATcontribution | [inline]
operator new(size_t, const LATcontribution &) | LATcontribution | [inline]
operator new(size_t, void *, unsigned short supplemental, bool swap=!DFC_BIG_ENDIAN) | LATcontribution | [inline]
rawData() const | LATcontribution | [inline]
rawDataSize() const | LATcontribution | [inline]
string(bool swap=!DFC_BIG_ENDIAN) | LATcontribution | [inline]
~LATcontribution() (defined in LATcontribution) | LATcontribution | [inline]

Generated on Mon Jul 31 17:48:17 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: LATcontributionIterator Class Reference

LATcontributionIterator Class Reference

Class for iterating over components in a LATdatagram. More...

#include <LATcontributionIterator.h>

Inheritance diagram for LATcontributionIterator:

[legend]
Collaboration diagram for LATcontributionIterator:

[legend]
List of all members.

Public Types

ERR_UDFcontribution = 1
enum | { ERR_UDFcontribution = 1 }

Public Member Functions

LATcontributionIterator (LATdatagram *)
Constructor for iterating over a LATdatagram.
LATcontributionIterator ()
Default constructor for iterating over a LATdatagram.
unsigned | iterate ()
Iterate over the LATcontributions in a LATdatagram.
unsigned | iterate (LATdatagram *)
Class for iterating over contributions to a LATdatagramIterate over the LATcontributions in a LATdatagram.
virtual int | handleError (LATcontribution *contrib, unsigned code, unsigned p1=0, unsigned p2=0) const
Handle all errors possible in LATcontributionIterator.
virtual int | EBF (EBFevent *start, EBFevent *end)=0
virtual int | ASC (ASCcontribution *start, LATcontribution *end)
Default ASC contribution method.
virtual int | UDF (LATcontribution *start, LATcontribution *end)
Default undefined contribution method.
const LATdatagram * | datagram () const
int | status () const

Detailed Description

Class for iterating over components in a LATdatagram.

Author:
R. Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.7
Date:
March 6, 2003 -- Created
Id
LATcontributionIterator.h,v 1.7 2006/01/10 23:43:45 claus Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

LATcontributionIterator::LATcontributionIterator ( LATdatagram * datagram ) [inline]

Constructor for iterating over a LATdatagram.

This constructor caches the LATdatagram provided by the caller.

Parameters:
datagram A pointer to a LATdatagram

Member Function Documentation

int LATcontributionIterator::ASC | ( | ASCcontribution * | start,
 |  | LATcontribution * | end |
 | ) |  |  | [virtual]

Default ASC contribution method.

ASC contribution handler

const LATdatagram * LATcontributionIterator::datagram ( ) const [inline]

Return a pointer to the LATdatagram containing this contribution

virtual int LATcontributionIterator::EBF | ( | EBFevent * | start,
 |  | EBFevent * | end |
 | ) |  |  | [pure virtual]

EBFevent contribution handler

Implemented in LDBI_LATcontributionIterator.

int LATcontributionIterator::handleError | ( | LATcontribution * | contribution,
 |  | unsigned | code,
 |  | unsigned | p1 = 0,
 |  | unsigned | p2 = 0 |
 | ) |  |  | const [virtual]

Handle all errors possible in LATcontributionIterator.

This method is used to handle errors occurring during the iteration over an LATcontribution. By default it does nothing, however it is virtual and is able to be overridden by the user.

Parameters:
contribution | The contribution in error
code | The error code
p1 | a parameter associated with the error code
p2 | a parameter associated with the error code

unsigned LATcontributionIterator::iterate ( LATdatagram * datagram )

Class for iterating over contributions to a LATdatagramIterate over the LATcontributions in a LATdatagram.

Parameters:
datagram - The LATdatagram to iterate over
Returns:
The number of contributions treated

unsigned LATcontributionIterator::iterate ( ) [inline]

Iterate over the LATcontributions in a LATdatagram.

This method uses the datagram cached by the ctor.

Returns:
The number of contributions handled.

int LATcontributionIterator::status ( ) const [inline]

Return the iteration status code

int LATcontributionIterator::UDF | ( | LATcontribution * | start,
 |  | LATcontribution * | end |
 | ) |  |  | [virtual]

Default undefined contribution method.

Undefined LATcontribution handler

The documentation for this class was generated from the following files:
  • LATcontributionIterator.h
  • LATcontributionIterator.cpp
Generated on Mon Jul 31 17:48:17 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

LATcontributionIterator Member List

This is the complete list of members for LATcontributionIterator, including all inherited members.

ASC(ASCcontribution *start, LATcontribution *end) | LATcontributionIterator | [virtual]
datagram() const | LATcontributionIterator | [inline]
EBF(EBFevent *start, EBFevent *end)=0 | LATcontributionIterator | [pure virtual]
ERR_UDFcontribution enum value (defined in LATcontributionIterator) | LATcontributionIterator |
handleError(LATcontribution *contrib, unsigned code, unsigned p1=0, unsigned p2=0) const | LATcontributionIterator | [virtual]
iterate() | LATcontributionIterator | [inline]
iterate(LATdatagram *) | LATcontributionIterator |
LATcontributionIterator(LATdatagram *) | LATcontributionIterator | [inline]
LATcontributionIterator() | LATcontributionIterator | [inline]
status() const | LATcontributionIterator | [inline]
UDF(LATcontribution *start, LATcontribution *end) | LATcontributionIterator | [virtual]
~LATcontributionIterator() (defined in LATcontributionIterator) | LATcontributionIterator | [inline, virtual]

Generated on Mon Jul 31 17:48:17 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: LATdataBufferIterator Class Reference

LATdataBufferIterator Class Reference

Application class demonstrating the use of the LDF iterators to call application-supplied methods back. More...

#include <LATdataBufferIterator.h>

Collaboration diagram for LATdataBufferIterator:

[legend]
List of all members.

Public Member Functions

LATdataBufferIterator (LATcomponentIterator *, bool swap=!DFC_BIG_ENDIAN)
LATdataBufferIterator constructor.
LATdataBufferIterator (LDBI_LATcontributionIterator *, bool swap=!DFC_BIG_ENDIAN)
LATdataBufferIterator constructor.
LATdataBufferIterator (LDBI_LATdatagramIterator *, bool swap=!DFC_BIG_ENDIAN)
LATdataBufferIterator constructor.
int | iterate ()
Reiterate over a buffer that has already been iterated over by LATdataBufferIterator::iterate(char* buffer, unsigned length).
int | iterate (char *buffer, unsigned length)
Iterate over a given buffer of specified length. Byteswap by longwords in place according to the constructor swap value.
int | iterate (char *buffer, unsigned length, bool swap)
Iterate over a given buffer of specified length. Byteswap by longwords in place if requested.

Detailed Description

Application class demonstrating the use of the LDF iterators to call application-supplied methods back.

Constructor & Destructor Documentation

LATdataBufferIterator::LATdataBufferIterator | ( | LATcomponentIterator * | lci,
 |  | bool | swap = !DFC_BIG_ENDIAN |
 | ) |  |  | [inline]

LATdataBufferIterator constructor.

LATdataBufferIterator is a convenience class to allow simple invocation of iterators to parse data in supplied string buffers. This class provides applications access only to LATcontributions that are EBFevents, but not to unrecognized LATcontributions. A LATcomponentIterator instance is required to provide the virtual method resolution needed to handle subsystem data. A swapping option is provided to allow byte swapping of the buffer prior to iteratation, if needed.

Parameters:
lci | - A pointer to a LATcomponentIterator instance
swap | - Optional parameter indicating whether buffers should be byteswapped prior to being iterated over. The default value is True if the machine this code is running is not big endian and False otherwise.

LATdataBufferIterator::LATdataBufferIterator | ( | LDBI_LATcontributionIterator * | lci,
 |  | bool | swap = !DFC_BIG_ENDIAN |
 | ) |  |  | [inline]

LATdataBufferIterator constructor.

LATdataBufferIterator is a convenience class to allow simple invocation of iterators to parse data in supplied string buffers. This class provides applications access to LATcontributions, both EBFevents and others. A LDBI_LATcontributionIterator instance is required to provide the virtual method resolution needed to handle subsystem data. A swapping option is provided to allow byte swapping of the buffer prior to iteratation, if needed.

Parameters:
lci | - A pointer to a LDBI_LATcontributionIterator instance
swap | - Optional parameter indicating whether buffers should be byteswapped prior to being iterated over. The default value is True if the machine this code is running is not big endian and False otherwise.

LATdataBufferIterator::LATdataBufferIterator | ( | LDBI_LATdatagramIterator * | ldi,
 |  | bool | swap = !DFC_BIG_ENDIAN |
 | ) |  |  | [inline]

LATdataBufferIterator constructor.

LATdataBufferIterator is a convenience class to allow simple invocation of iterators to parse data in supplied string buffers. This class provides applications access to LATcontributions, both EBFevents and others. A LDBI_LATcontributionIterator instance is required to provide the virtual method resolution needed to handle subsystem data. A swapping option is provided to allow byte swapping of the buffer prior to iteratation, if needed.

Parameters:
ldi | - A pointer to a LATdatagramIterator instance
swap | - Optional parameter indicating whether buffers should be byteswapped prior to being iterated over. The default value is True if the machine this code is running is not big endian and False otherwise.

Member Function Documentation

int LATdataBufferIterator::iterate | ( | char * | buffer,
 |  | unsigned | length,
 |  | bool | swap |
 | ) |  |  | [inline]

Iterate over a given buffer of specified length. Byteswap by longwords in place if requested.

This method iterates over the datagrams in a string buffer of specified length, after possibly bytswapping the buffer by longwords in place first. Use this method to override the constructor swap argument. This allows iterating over the same buffer multiple times without swapping it each time.

Parameters:
buffer | A string buffer containing LATdatagrams
length | The length of the supplied string buffer
swap | Forces the supplied buffer to be byteswapped in place, or not
Returns:
The result from iterating over the datagrams in the buffer

int LATdataBufferIterator::iterate | ( | char * | buffer,
 |  | unsigned | length |
 | ) |  |  | [inline]

Iterate over a given buffer of specified length. Byteswap by longwords in place according to the constructor swap value.

This method iterates over the datagrams in a string buffer of specified length, after possibly bytswapping the buffer by longwords in place first.

Parameters:
buffer | A string buffer containing LATdatagrams
length | The length of the supplied string buffer
Returns:
The result from iterating over the datagrams in the buffer

int LATdataBufferIterator::iterate ( ) [inline]

Reiterate over a buffer that has already been iterated over by LATdataBufferIterator::iterate(char* buffer, unsigned length).

Returns:
The result from iterating over the datagrams in the buffer

The documentation for this class was generated from the following file:
  • LATdataBufferIterator.h
Generated on Mon Jul 31 17:48:18 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

LATdataBufferIterator Member List

This is the complete list of members for LATdataBufferIterator, including all inherited members.

iterate() | LATdataBufferIterator | [inline]
iterate(char *buffer, unsigned length) | LATdataBufferIterator | [inline]
iterate(char *buffer, unsigned length, bool swap) | LATdataBufferIterator | [inline]
LATdataBufferIterator(LATcomponentIterator *, bool swap=!DFC_BIG_ENDIAN) | LATdataBufferIterator | [inline]
LATdataBufferIterator(LDBI_LATcontributionIterator *, bool swap=!DFC_BIG_ENDIAN) | LATdataBufferIterator | [inline]
LATdataBufferIterator(LDBI_LATdatagramIterator *, bool swap=!DFC_BIG_ENDIAN) | LATdataBufferIterator | [inline]
~LATdataBufferIterator() (defined in LATdataBufferIterator) | LATdataBufferIterator | [inline]

Generated on Mon Jul 31 17:48:18 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: LATdatagram Class Reference

LATdatagram Class Reference

Class for decoding an LAT datagram. More...

#include <LATdatagram.h>

Collaboration diagram for LATdatagram:

[legend]
List of all members.

Public Types

ID
enum | { ID }

Public Member Functions

LATdatagram ()
Constructor setting up identity and length defaults.
LATdatagram (unsigned length)
Constructor setting up identity and length defaults.
LATtypeId | identity () const
Return the datagram's identity.
unsigned | length () const
Return the datagram's size in units of bytes.
LATdatagram * | next () const
Return the next datagram in the list of LATdatagrams.
unsigned | payloadSize () const
Return the size of the datagram's payload in units of bytes.
LATcontribution * | payload () const
Return a pointer to the start of the datagram's payload.
EBFevent * | event () const
Return a pointer to the datagram's payload cast as an EBFevent.
unsigned char * | alloc (unsigned size)
Method for allocating additional space in a datagram.
void * | operator new (size_t)
Allocate a default LATdatagram off the memory heap.
void * | operator new (size_t, unsigned length)
Allocate a LATdatagram with space for a payload off the memory heap.
void * | operator new (size_t, const LATdatagram &)
Copy a LATdatagram to a new one.
void * | operator new (size_t, void *, unsigned supplemental, bool swap=!DFC_BIG_ENDIAN)
This operator new allows one to place a datagram at a given location.
void | operator delete (void *, void *, unsigned, bool)
Delete operator used to delete a datagram.
void | operator delete (void *)
Delete operator used to delete a datagram.
unsigned char * | string (bool swap=!DFC_BIG_ENDIAN)
Return a pointer to a LATdatagram as a uchar buffer.

Static Public Member Functions

static LATdatagram * | create (unsigned char *buffer, unsigned size, bool swap=!DFC_BIG_ENDIAN)
Create a LATdatagram from a uchar buffer.

Detailed Description

Class for decoding an LAT datagram.

Author:
R. Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.8
Date:
March 3, 2003 -- Created
Id
LATdatagram.h,v 1.8 2006/03/30 19:05:45 perazzo Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

LATdatagram::LATdatagram ( unsigned length ) [inline]

Constructor setting up identity and length defaults.

Parameters:
length Additional length to include in units of bytes

Member Function Documentation

unsigned char * LATdatagram::alloc ( unsigned size ) [inline]

Method for allocating additional space in a datagram.

This method is used to include additional space at the end of a LATdatagram as part of that LATdatagram. It assumes that the memory for that space has been properly allocated.

Returns:
A pointer to the additional space allocated in the datagram

LATdatagram * LATdatagram::create | ( | unsigned char * | buffer,
 |  | unsigned | size,
 |  | bool | swap = !DFC_BIG_ENDIAN |
 | ) |  |  | [inline, static]

Create a LATdatagram from a uchar buffer.

This method primarily exists for the Python interface.

The buffer can optionally be byte swapped by longwords in place. By default, if the endianness of the machine this code is running on is not big endian, then the buffer is byte swapped.

Parameters:
buffer | A pointer to a buffer containing LATdatagram data
size | Additional size to include into the LATdatagram
swap | Optionally byte swap the buffer in place
Returns:
A pointer to the buffer as a LATdatagram

EBFevent * LATdatagram::event ( ) const [inline]

Return a pointer to the datagram's payload cast as an EBFevent.

This is an obsolete method (I think) since one can't make the assumption that a particular LATdatagram payload is an EBFevent.

void LATdatagram::operator delete ( void * location ) [inline]

Delete operator used to delete a datagram.

This method is used to avoid SIP constructor MemberCode.

void LATdatagram::operator delete | ( | void * | ,
 |  | void * | ,
 |  | unsigned | ,
 |  | bool |  |
 | ) |  |  | [inline]

Delete operator used to delete a datagram.

This method is used to avoid SIP constructor MemberCode.

void * LATdatagram::operator new | ( | size_t | size,
 |  | void * | location,
 |  | unsigned | supplemental,
 |  | bool | swap = !DFC_BIG_ENDIAN |
 | ) |  |  | [inline]

This operator new allows one to place a datagram at a given location.

This method is used to effectively label a piece of memory containing datagram data a LATdatagram. It is similar to casting a pointer to a LAT datagram pointer.

In the process or placing the datagram, the raw data occupying the space can optionally be byte swapped. By default, if the endianness of the machine this code is running on is not big endian, then the buffer is byte swapped.

Parameters:
size | An ignored parameter
location | A pointer to the location where to place the datagram
supplemental | Additional space to include in the datagram
swap | Optionally byte swap the buffer in place
Returns:
A pointer to the buffer as a LATdatagram

void * LATdatagram::operator new | ( | size_t | size,
 |  | const LATdatagram & | datagram |
 | ) |  |  | [inline]

Copy a LATdatagram to a new one.

This method is used to avoid SIP constructor MemberCode.

Parameters:
size | An ignored parameter
datagram | A reference to the datagram to be copied
Returns:
A pointer to the newly allocated datagram

void * LATdatagram::operator new | ( | size_t | size,
 |  | unsigned | length |
 | ) |  |  | [inline]

Allocate a LATdatagram with space for a payload off the memory heap.

This method is used to avoid SIP constructor MemberCode.

Parameters:
size | An ignored parameter
length | The additional amount of space to allocate in units of bytes
Returns:
A pointer to the newly allocated datagram

void * LATdatagram::operator new ( size_t size ) [inline]

Allocate a default LATdatagram off the memory heap.

This method is used to avoid SIP constructor MemberCode.

Parameters:
size An ignored parameter
Returns:
A pointer to the newly allocated datagram

LATcontribution * LATdatagram::payload ( ) const [inline]

Return a pointer to the start of the datagram's payload.

The payload is the data portion of the datagram and does not include its mangement members identity and length.

unsigned LATdatagram::payloadSize ( ) const [inline]

Return the size of the datagram's payload in units of bytes.

The payload is the data portion of the datagram and does not include its mangement members identity and length.

unsigned char * LATdatagram::string ( bool swap = !DFC_BIG_ENDIAN ) [inline]

Return a pointer to a LATdatagram as a uchar buffer.

This method primarily exists for the Python interface.

The buffer can optionally be byte swapped by longwords in place. By default, if the endianness of the machine this code is running on is not big endian, then the buffer is byte swapped. Be sure to supply FALSE for the swap argument if the buffer has already been swapped by a previous call.

Parameters:
swap Optionally byte swap the buffer in place
Returns:
A pointer to the LATdatagram as a string buffer

The documentation for this class was generated from the following file:
  • LATdatagram.h
Generated on Mon Jul 31 17:48:18 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

LATdatagram Member List

This is the complete list of members for LATdatagram, including all inherited members.

alloc(unsigned size) | LATdatagram | [inline]
create(unsigned char *buffer, unsigned size, bool swap=!DFC_BIG_ENDIAN) | LATdatagram | [inline, static]
event() const | LATdatagram | [inline]
ID enum value (defined in LATdatagram) | LATdatagram |
identity() const | LATdatagram | [inline]
LATdatagram() | LATdatagram | [inline]
LATdatagram(unsigned length) | LATdatagram | [inline]
length() const | LATdatagram | [inline]
next() const | LATdatagram | [inline]
operator delete(void *, void *, unsigned, bool) | LATdatagram | [inline]
operator delete(void *) | LATdatagram | [inline]
operator new(size_t) | LATdatagram | [inline]
operator new(size_t, unsigned length) | LATdatagram | [inline]
operator new(size_t, const LATdatagram &) | LATdatagram | [inline]
operator new(size_t, void *, unsigned supplemental, bool swap=!DFC_BIG_ENDIAN) | LATdatagram | [inline]
payload() const | LATdatagram | [inline]
payloadSize() const | LATdatagram | [inline]
string(bool swap=!DFC_BIG_ENDIAN) | LATdatagram | [inline]
~LATdatagram() (defined in LATdatagram) | LATdatagram | [inline]

Generated on Mon Jul 31 17:48:18 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: LATdatagramIterator Class Reference

LATdatagramIterator Class Reference

Class for iterating over a list of LATdatagrams. More...

#include <LATdatagramIterator.h>

Inheritance diagram for LATdatagramIterator:

[legend]
Collaboration diagram for LATdatagramIterator:

[legend]
List of all members.

Public Types

ERR_IDmismatch = 1
enum | { ERR_IDmismatch = 1 }

Public Member Functions

LATdatagramIterator (LATdatagram *start, LATdatagram *end)
Constructor for iterating over a list of datagrams.
LATdatagramIterator ()
Default constructor for iterating over a list of datagrams.
unsigned | iterate ()
Iterate over a list of LATdatagrams from start to end.
unsigned | iterate (LATdatagram *start, LATdatagram *end)
Iterate over a list of LATdatagrams from start to end.
LATdatagram * | start () const
LATdatagram * | end () const
int | status () const
virtual int | handleError (LATdatagram *datagram, unsigned code, unsigned p1=0, unsigned p2=0) const
Handle all errors possible in LATdatagramIterator.
virtual int | process (LATdatagram *)=0

Detailed Description

Class for iterating over a list of LATdatagrams.

Author:
R. Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.6
Date:
March 14, 2003 -- Created
Id
LATdatagramIterator.h,v 1.6 2005/03/15 18:59:41 panetta Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

LATdatagramIterator::LATdatagramIterator | ( | LATdatagram * | start,
 |  | LATdatagram * | end |
 | ) |  |  | [inline]

Constructor for iterating over a list of datagrams.

This constructor caches the start and end pointers of the list provided by the caller.

Parameters:
start | A pointer to the start of a LATdatagram list
end | A pointer to the end of a LATdatagram list

Member Function Documentation

LATdatagram * LATdatagramIterator::end ( ) const [inline]

Return the cached pointer to the end of the LATdatagram list

int LATdatagramIterator::handleError | ( | LATdatagram * | datagram,
 |  | unsigned | code,
 |  | unsigned | p1 = 0,
 |  | unsigned | p2 = 0 |
 | ) |  |  | const [virtual]

Handle all errors possible in LATdatagramIterator.

This method is used to handle errors occurring during the iteration over an LATdatagram. By default it does nothing, however it is virtual and is able to be overridden by the user.

Parameters:
datagram | The datagram in error
code | The error code
p1 | a parameter associated with the error code
p2 | a parameter associated with the error code

unsigned LATdatagramIterator::iterate | ( | LATdatagram * | start,
 |  | LATdatagram * | end
 | ) |  |

Iterate over a list of LATdatagrams from start to end.

Parameters:
start | The start of the LATdatagram list
end | The end of the LAT datagram list
Returns:
The number of LATdatagrams handled

unsigned LATdatagramIterator::iterate ( ) [inline]

Iterate over a list of LATdatagrams from start to end.

This method uses the LATdatagram list parameters cached at construction time.

Returns:
The number of LATdatagrams handled

virtual int LATdatagramIterator::process ( LATdatagram * ) [pure virtual]

Virtual method for calling the application back with a LATdatagram

Implemented in LDBI_LATdatagramIterator.

LATdatagram * LATdatagramIterator::start ( ) const [inline]

Return the cached pointer to the start of the LATdatagram list

int LATdatagramIterator::status ( ) const [inline]

Return the completion status from the iteration

The documentation for this class was generated from the following files:
  • LATdatagramIterator.h
  • LATdatagramIterator.cpp
Generated on Mon Jul 31 17:48:18 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

LATdatagramIterator Member List

This is the complete list of members for LATdatagramIterator, including all inherited members.

end() const | LATdatagramIterator | [inline]
ERR_IDmismatch enum value (defined in LATdatagramIterator) | LATdatagramIterator |
handleError(LATdatagram *datagram, unsigned code, unsigned p1=0, unsigned p2=0) const | LATdatagramIterator | [virtual]
iterate() | LATdatagramIterator | [inline]
iterate(LATdatagram *start, LATdatagram *end) | LATdatagramIterator |
LATdatagramIterator(LATdatagram *start, LATdatagram *end) | LATdatagramIterator | [inline]
LATdatagramIterator() | LATdatagramIterator | [inline]
process(LATdatagram *)=0 | LATdatagramIterator | [pure virtual]
start() const | LATdatagramIterator | [inline]
status() const | LATdatagramIterator | [inline]
~LATdatagramIterator() (defined in LATdatagramIterator) | LATdatagramIterator | [inline, virtual]

Generated on Mon Jul 31 17:48:18 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: LATPcellHeader Class Reference

LATPcellHeader Class Reference

Class for accessing fields in the LAT protocol cell header longword. More...

#include <LATp.h>

List of all members.

Public Member Functions

LATPcellHeader (unsigned header)
Constructor to initialize the class with a LATp cell header word.
unsigned | parity ()
Method returning the state of the LATp cell parity.
unsigned | source ()
Method returning the contribution source ID.
unsigned | protocol ()
Method returning the PROTOCOL value.
unsigned | destination ()
Method returning the contribution destination ID.
unsigned | respond ()
Method returning the state of the RESPOND bit.
unsigned | more ()
Method returning the state of the MORE bit.

Static Public Member Functions

static unsigned | parity (unsigned header)
Static method returning the state of the LATp cell parity.
static unsigned | source (unsigned header)
Static method returning the contribution source ID.
static unsigned | protocol (unsigned header)
Static method returning the PROTOCOL value.
static unsigned | destination (unsigned header)
Static method returning the contribution destination ID.
static unsigned | respond (unsigned header)
Static method returning the state of the RESPOND bit.
static unsigned | more (unsigned header)
Static method returning the state of the MORE bit.

Detailed Description

Class for accessing fields in the LAT protocol cell header longword.

Author:
Ric Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.3
Date:
January 22, 2003 -- Created
Id
LATp.h,v 1.3 2004/04/21 00:04:57 claus Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Member Function Documentation

unsigned LATPcellHeader::destination ( ) [inline]

Method returning the contribution destination ID.

Returns:
The state of the contribution destination ID

unsigned LATPcellHeader::destination ( unsigned header ) [inline, static]

Static method returning the contribution destination ID.

Parameters:
header - A LATp cell header word
Returns:
The state of the contribution destination ID

unsigned LATPcellHeader::more ( ) [inline]

Method returning the state of the MORE bit.

N.B. that the MORE bit and the RESPOND bit are the same bit.

Returns:
The state of the MORE bit

unsigned LATPcellHeader::more ( unsigned header ) [inline, static]

Static method returning the state of the MORE bit.

N.B. that the MORE bit and the RESPOND bit are the same bit.

Parameters:
header - A LATp cell header word
Returns:
The state of the MORE bit

unsigned LATPcellHeader::parity ( ) [inline]

Method returning the state of the LATp cell parity.

Returns:
The state of the LATp cell parity

unsigned LATPcellHeader::parity ( unsigned header ) [inline, static]

Static method returning the state of the LATp cell parity.

Parameters:
header - A LATp cell header word
Returns:
The state of the LATp cell parity

unsigned LATPcellHeader::protocol ( ) [inline]

Method returning the PROTOCOL value.

Returns:
The state of the PROTOCOL value

unsigned LATPcellHeader::protocol ( unsigned header ) [inline, static]

Static method returning the PROTOCOL value.

Parameters:
header - A LATp cell header word
Returns:
The state of the PROTOCOL value

unsigned LATPcellHeader::respond ( ) [inline]

Method returning the state of the RESPOND bit.

N.B. that the RESPOND bit and the MORE bit are the same bit.

Returns:
The state of the RESPOND bit

unsigned LATPcellHeader::respond ( unsigned header ) [inline, static]

Static method returning the state of the RESPOND bit.

N.B. that the RESPOND bit and the MORE bit are the same bit.

Parameters:
header - A LATp cell header word
Returns:
The state of the RESPOND bit

unsigned LATPcellHeader::source ( ) [inline]

Method returning the contribution source ID.

Returns:
The state of the contribution source ID

unsigned LATPcellHeader::source ( unsigned header ) [inline, static]

Static method returning the contribution source ID.

Parameters:
header - A LATp cell header word
Returns:
The state of the contribution source ID

The documentation for this class was generated from the following file:
  • LATp.h
Generated on Mon Jul 31 17:48:18 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

LATPcellHeader Member List

This is the complete list of members for LATPcellHeader, including all inherited members.

destination(unsigned header) | LATPcellHeader | [inline, static]
destination() | LATPcellHeader | [inline]
LATPcellHeader(unsigned header) | LATPcellHeader | [inline]
LATPcellHeader() (defined in LATPcellHeader) | LATPcellHeader | [inline]
more(unsigned header) | LATPcellHeader | [inline, static]
more() | LATPcellHeader | [inline]
parity(unsigned header) | LATPcellHeader | [inline, static]
parity() | LATPcellHeader | [inline]
protocol(unsigned header) | LATPcellHeader | [inline, static]
protocol() | LATPcellHeader | [inline]
respond(unsigned header) | LATPcellHeader | [inline, static]
respond() | LATPcellHeader | [inline]
source(unsigned header) | LATPcellHeader | [inline, static]
source() | LATPcellHeader | [inline]
~LATPcellHeader() (defined in LATPcellHeader) | LATPcellHeader | [inline]

Generated on Mon Jul 31 17:48:18 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: LATprimaryId Class Reference

LATprimaryId Class Reference

Class providing structure type enumerations. More...

#include <LATidentity.h>

List of all members.

Public Types

Any = 0
Base_FSW = Pri_Base_FSW
Base_OEF = Pri_Base_OEF
Base_ACD = Pri_Base_ACD
Base_CAL = Pri_Base_CAL
Base_TKR = Pri_Base_TKR
Base_OSW = Pri_Base_OSW
Base_Scratch = Pri_Base_Scratch
RangeSize = 0x00FFF
Id_EBF = Pri_Id_EBF
Id_EBF_MC = Pri_Id_EBF_MC
Id_Datagram = Pri_Id_Datagram
Id_UnrecBuf = Pri_Id_UnrecBuf
Id_BtAncEvt = Pri_Id_BtAncEvt
Id_BtAncHdr = Pri_Id_BtAncHdr
Id_BtAncTlr = Pri_Id_BtAncTlr
Id_ASC = Pri_Id_ASC
Id_CEDhdr = Pri_Id_CEDhdr
Id_Time = Pri_Id_Time
Id_Consumer = Pri_Id_Consumer
enum | { Any = 0 }
enum {
Base_FSW = Pri_Base_FSW, Base_OEF = Pri_Base_OEF, Base_ACD = Pri_Base_ACD, Base_CAL = Pri_Base_CAL,
Base_TKR = Pri_Base_TKR, Base_OSW = Pri_Base_OSW, Base_Scratch = Pri_Base_Scratch
}
enum | { RangeSize = 0x00FFF }
enum | { Id_EBF = Pri_Id_EBF }
enum | { Id_EBF_MC = Pri_Id_EBF_MC }
enum | { Id_Datagram = Pri_Id_Datagram }
enum | { Id_UnrecBuf = Pri_Id_UnrecBuf }
enum | { Id_BtAncEvt = Pri_Id_BtAncEvt }
enum | { Id_BtAncHdr = Pri_Id_BtAncHdr }
enum | { Id_BtAncTlr = Pri_Id_BtAncTlr }
enum | { Id_ASC = Pri_Id_ASC }
enum | { Id_CEDhdr = Pri_Id_CEDhdr }
enum | { Id_Time = Pri_Id_Time }
enum | { Id_Consumer = Pri_Id_Consumer }

Detailed Description

Class providing structure type enumerations.

The idea here is to use the primary ID to label classes used in decoding LAT event data according to the given segment of the name space they occupy. Developers for each of these segments maintain their own portion of the ID space. When a piece of code is presented with data with a given identity, that code will be able to recognize whether it can decode that data. Perhaps at some point we'll be able to dynamically load a corresponding sharable libary to decode the data.

Member Enumeration Documentation

anonymous enum

Default match-anything value

Enumerator:
Base_OEF | Flight SoftWare base value
Base_ACD | Online Event Format base value
Base_CAL | ACD base value
Base_TKR | CAL base value
Base_OSW | TKR base value
Base_Scratch | Online SoftWare base value

anonymous enum

Event Builder Format

anonymous enum

Monte Carlo generated EBF

anonymous enum

Datagram type

anonymous enum

Unrecognized Buffer type

anonymous enum

Beam Test Ancillary Event

anonymous enum

Beam Test Ancillary Header

anonymous enum

Beam Test Ancillary Trailer

anonymous enum

ACD Software counters

anonymous enum

CAL Event Data header

anonymous enum

Time record

The documentation for this class was generated from the following file:
  • LATidentity.h
Generated on Mon Jul 31 17:48:18 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

LATprimaryId Member List

This is the complete list of members for LATprimaryId, including all inherited members.

Any enum value (defined in LATprimaryId) | LATprimaryId
Base_ACD enum value | LATprimaryId
Base_CAL enum value | LATprimaryId
Base_FSW enum value (defined in LATprimaryId) | LATprimaryId
Base_OEF enum value | LATprimaryId
Base_OSW enum value | LATprimaryId
Base_Scratch enum value | LATprimaryId
Base_TKR enum value | LATprimaryId
Id_ASC enum value (defined in LATprimaryId) | LATprimaryId
Id_BtAncEvt enum value (defined in LATprimaryId) | LATprimaryId
Id_BtAncHdr enum value (defined in LATprimaryId) | LATprimaryId
Id_BtAncTlr enum value (defined in LATprimaryId) | LATprimaryId
Id_CEDhdr enum value (defined in LATprimaryId) | LATprimaryId
Id_Consumer enum value (defined in LATprimaryId) | LATprimaryId
Id_Datagram enum value (defined in LATprimaryId) | LATprimaryId
Id_EBF enum value (defined in LATprimaryId) | LATprimaryId
Id_EBF_MC enum value (defined in LATprimaryId) | LATprimaryId
Id_Time enum value (defined in LATprimaryId) | LATprimaryId
Id_UnrecBuf enum value (defined in LATprimaryId) | LATprimaryId
RangeSize enum value (defined in LATprimaryId) | LATprimaryId

Generated on Mon Jul 31 17:48:18 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: LATsecondaryId Class Reference

LATsecondaryId Class Reference

Class providing structure type enumerations. More...

#include <LATidentity.h>

List of all members.

Public Types

Any = 0
Base_FSW = Sec_Base_FSW
Base_OEF = Sec_Base_OEF
Base_ACD = Sec_Base_ACD
Base_CAL = Sec_Base_CAL
Base_TKR = Sec_Base_TKR
Base_OSW = Sec_Base_OSW
Base_Scratch = Sec_Base_Scratch
RangeSize = 0x0FF
Id_EBF_1 = Sec_Id_EBF_1
Id_EBF_2 = Sec_Id_EBF_2
Id_EBF_3 = Sec_Id_EBF_3
Id_EBF = Sec_Id_EBF
Id_EBF_MC = Sec_Id_EBF_MC
Id_Datagram = Sec_Id_Datagram
Id_UnrecBuf = Sec_Id_UnrecBuf
Id_BtAncEvt = Sec_Id_BtAncEvt
Id_BtAncEvt_1 = Sec_Id_BtAncEvt_1
Id_BtAncHdr = Sec_Id_BtAncHdr
Id_BtAncTlr = Sec_Id_BtAncTlr
Id_ASC = Sec_Id_ASC
Id_CEDhdr = Sec_Id_CEDhdr
Id_Time = Sec_Id_Time
Id_Time_1 = Sec_Id_Time_1
Id_Consumer = Sec_Id_Consumer
enum | { Any = 0 }
enum {
Base_FSW = Sec_Base_FSW, Base_OEF = Sec_Base_OEF, Base_ACD = Sec_Base_ACD, Base_CAL = Sec_Base_CAL,
Base_TKR = Sec_Base_TKR, Base_OSW = Sec_Base_OSW, Base_Scratch = Sec_Base_Scratch
}
enum | { RangeSize = 0x0FF }
enum | { Id_EBF_1 = Sec_Id_EBF_1 }
enum | { Id_EBF_2 = Sec_Id_EBF_2 }
enum | { Id_EBF_3 = Sec_Id_EBF_3 }
enum | { Id_EBF = Sec_Id_EBF }
enum | { Id_EBF_MC = Sec_Id_EBF_MC }
enum | { Id_Datagram = Sec_Id_Datagram }
enum | { Id_UnrecBuf = Sec_Id_UnrecBuf }
enum | { Id_BtAncEvt = Sec_Id_BtAncEvt }
enum | { Id_BtAncEvt_1 = Sec_Id_BtAncEvt_1 }
enum | { Id_BtAncHdr = Sec_Id_BtAncHdr }
enum | { Id_BtAncTlr = Sec_Id_BtAncTlr }
enum | { Id_ASC = Sec_Id_ASC }
enum | { Id_CEDhdr = Sec_Id_CEDhdr }
enum | { Id_Time = Sec_Id_Time }
enum | { Id_Time_1 = Sec_Id_Time_1 }
enum | { Id_Consumer = Sec_Id_Consumer }

Detailed Description

Class providing structure type enumerations.

The idea behind the secondary IDs is to label changes to a class with a corresponding Primary ID, in other words, a class version number.

Member Enumeration Documentation

anonymous enum

Default match-anything value

Enumerator:
Base_OEF | Flight SoftWare base value
Base_ACD | Online Event Format base value
Base_CAL | ACD base value
Base_TKR | CAL base value
Base_OSW | TKR base value
Base_Scratch | Online SoftWare base value

anonymous enum

Datagram type

anonymous enum

Unrecognized Buffer type

anonymous enum

Beam Test Ancillary Event

anonymous enum

Beam Test Ancillary Event

anonymous enum

Beam Test Ancillary Header

anonymous enum

Beam Test Ancillary Trailer

anonymous enum

ACD Software counters

anonymous enum

CAL Event Data header

The documentation for this class was generated from the following file:
  • LATidentity.h
Generated on Mon Jul 31 17:48:18 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

LATsecondaryId Member List

This is the complete list of members for LATsecondaryId, including all inherited members.

Any enum value (defined in LATsecondaryId) | LATsecondaryId
Base_ACD enum value | LATsecondaryId
Base_CAL enum value | LATsecondaryId
Base_FSW enum value (defined in LATsecondaryId) | LATsecondaryId
Base_OEF enum value | LATsecondaryId
Base_OSW enum value | LATsecondaryId
Base_Scratch enum value | LATsecondaryId
Base_TKR enum value | LATsecondaryId
Id_ASC enum value (defined in LATsecondaryId) | LATsecondaryId
Id_BtAncEvt enum value (defined in LATsecondaryId) | LATsecondaryId
Id_BtAncEvt_1 enum value (defined in LATsecondaryId) | LATsecondaryId
Id_BtAncHdr enum value (defined in LATsecondaryId) | LATsecondaryId
Id_BtAncTlr enum value (defined in LATsecondaryId) | LATsecondaryId
Id_CEDhdr enum value (defined in LATsecondaryId) | LATsecondaryId
Id_Consumer enum value (defined in LATsecondaryId) | LATsecondaryId
Id_Datagram enum value (defined in LATsecondaryId) | LATsecondaryId
Id_EBF enum value (defined in LATsecondaryId) | LATsecondaryId
Id_EBF_1 enum value (defined in LATsecondaryId) | LATsecondaryId
Id_EBF_2 enum value (defined in LATsecondaryId) | LATsecondaryId
Id_EBF_3 enum value (defined in LATsecondaryId) | LATsecondaryId
Id_EBF_MC enum value (defined in LATsecondaryId) | LATsecondaryId
Id_Time enum value (defined in LATsecondaryId) | LATsecondaryId
Id_Time_1 enum value (defined in LATsecondaryId) | LATsecondaryId
Id_UnrecBuf enum value (defined in LATsecondaryId) | LATsecondaryId
RangeSize enum value (defined in LATsecondaryId) | LATsecondaryId

Generated on Mon Jul 31 17:48:18 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: LATtypeId Class Reference

LATtypeId Class Reference

Support classes for labeling the various classes involved in decoding event data from the LAT. More...

#include <LATtypeId.h>

List of all members.

Public Types

LATtypeIdPrimOff = 0
LATtypeIdPrimMax = 0x000FFFFF
LATtypeIdPrimMsk = LATtypeIdPrimMax
LATtypeIdSecyOff = 20
LATtypeIdSecyMax = 0x00000FFF
LATtypeIdSecyMsk = LATtypeIdSecyMax << LATtypeIdSecyOff
LATtypeIdSecyAny = 0
LATtypeIdAny = 0
LATtypeIdNull = 0
enum | { LATtypeIdPrimOff = 0, LATtypeIdPrimMax = 0x000FFFFF, LATtypeIdPrimMsk = LATtypeIdPrimMax }
enum | { LATtypeIdSecyOff = 20, LATtypeIdSecyMax = 0x00000FFF, LATtypeIdSecyMsk = LATtypeIdSecyMax << LATtypeIdSecyOff }
enum | { LATtypeIdSecyAny = 0 }
enum | { LATtypeIdAny = 0 }
enum | { LATtypeIdNull = 0 }

Public Member Functions

LATtypeIdValue_t | value () const
LATtypeIdPrimary_t | getPrimary () const
LATtypeIdSecondary_t | getSecondary () const
int | setPrimary (LATtypeIdPrimary_t prim)
Set the primary ID in a LATtypeId.
int | setSecondary (LATtypeIdSecondary_t secy)
Set the secondary ID in a LATtypeId.
LATtypeId (const LATtypeId &v2)
LATtypeId (LATtypeIdPrimary_t prim, LATtypeIdSecondary_t secy)
LATtypeId (LATtypeIdValue_t value)
LATtypeId ()
~LATtypeId ()
Destructor.
LATtypeId & | operator= (const LATtypeId &id)
Assignment.
int | operator== (const LATtypeId &id) const
Equality test.
int | operator!= (const LATtypeId &id) const
Inequality test.

Detailed Description

Support classes for labeling the various classes involved in decoding event data from the LAT.

Ideas here are loosely copied from "Software developed for the BaBar Detector at the SLAC B-Factory". A number of the comments were copied verbatim.

Original notes from GDPF:
Concrete base class that contains all the knowledge necessary to decode type ID codes for DataFlow's transmissible objects. This is a fully private class not intended for use outside the odfTypeIdPrimary and odfTypeIdQualified classes, its subclasses.

Author:
Gregory Dubois-Felsmann gpdf Originator

R. Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)

Revision
1.2
Date:
February 9, 2004 -- Created
Id
LATtypeId.h,v 1.2 2004/10/14 04:41:09 claus Exp

Copyright: Copyright (C) 1997 California Institute of Technology

Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

LATtypeId::LATtypeId ( const LATtypeId & v2 ) [inline]

Copy constructor

LATtypeId::LATtypeId | ( | LATtypeIdPrimary_t | prim,
 |  | LATtypeIdSecondary_t | secy |
 | ) |  |  | [inline]

Constructor initializing a LATtypeId from a LATtypeIdPrimary_t and a LATtypeIdSecondary_t

LATtypeId::LATtypeId ( LATtypeIdValue_t value ) [inline]

Constructor initializing a LATtypeId from an LATtypeIdValue_t

LATtypeId::LATtypeId ( ) [inline]

Constructor to set up a NULL LATtypeId

LATtypeId::~LATtypeId ( ) [inline]

Destructor.

This is a transmissible class and may contain no virtual functions.

Member Function Documentation

LATtypeIdPrimary_t LATtypeId::getPrimary ( ) const [inline]

Return the primary ID portion of a LATtypeId

LATtypeIdSecondary_t LATtypeId::getSecondary ( ) const [inline]

Return the secondary ID portion of a LATtypeId

int LATtypeId::setPrimary ( LATtypeIdPrimary_t prim ) [inline]

Set the primary ID in a LATtypeId.

Returns:
Success or failure (if value is out-of-range).

int LATtypeId::setSecondary ( LATtypeIdSecondary_t secy ) [inline]

Set the secondary ID in a LATtypeId.

Returns:
Success or failure (if value is out-of-range).

LATtypeIdValue_t LATtypeId::value ( ) const [inline]

Return a LATtypeId as an LATtypeIdValue_t

The documentation for this class was generated from the following file:
  • LATtypeId.h
Generated on Mon Jul 31 17:48:18 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

LATtypeId Member List

This is the complete list of members for LATtypeId, including all inherited members.

getPrimary() const | LATtypeId | [inline]
getSecondary() const | LATtypeId | [inline]
LATtypeId(const LATtypeId &v2) | LATtypeId | [inline]
LATtypeId(LATtypeIdPrimary_t prim, LATtypeIdSecondary_t secy) | LATtypeId | [inline]
LATtypeId(LATtypeIdValue_t value) | LATtypeId | [inline]
LATtypeId() | LATtypeId | [inline]
LATtypeIdAny enum value (defined in LATtypeId) | LATtypeId |
LATtypeIdNull enum value (defined in LATtypeId) | LATtypeId |
LATtypeIdPrimMax enum value (defined in LATtypeId) | LATtypeId |
LATtypeIdPrimMsk enum value (defined in LATtypeId) | LATtypeId |
LATtypeIdPrimOff enum value (defined in LATtypeId) | LATtypeId |
LATtypeIdSecyAny enum value (defined in LATtypeId) | LATtypeId |
LATtypeIdSecyMax enum value (defined in LATtypeId) | LATtypeId |
LATtypeIdSecyMsk enum value (defined in LATtypeId) | LATtypeId |
LATtypeIdSecyOff enum value (defined in LATtypeId) | LATtypeId |
operator!=(const LATtypeId &id) const | LATtypeId | [inline]
operator=(const LATtypeId &id) | LATtypeId | [inline]
operator==(const LATtypeId &id) const | LATtypeId | [inline]
setPrimary(LATtypeIdPrimary_t prim) | LATtypeId | [inline]
setSecondary(LATtypeIdSecondary_t secy) | LATtypeId | [inline]
value() const | LATtypeId | [inline]
~LATtypeId() | LATtypeId | [inline]

Generated on Mon Jul 31 17:48:18 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: LDBI_EBFeventIterator Class Reference

LDBI_EBFeventIterator Class Reference

Application class demonstrating the use of the EBF iterators to call application-supplied methods back.EBFeventIterator concrete class to invoke the application's LATcomponentIterator. More...

#include <LATdataBufferIterator.h>

Inheritance diagram for LDBI_EBFeventIterator:

[legend]
Collaboration diagram for LDBI_EBFeventIterator:

[legend]
List of all members.

Public Types

ERR_BadStatus = 1000
enum | { ERR_BadStatus = 1000 }

Public Member Functions

LDBI_EBFeventIterator (LATcomponentIterator *)
Constructor setting up the EBFeventIterator iterator with a LATcomponentIterator.
virtual int | handleError (EBFevent *event, unsigned code, unsigned p1=0, unsigned p2=0) const
Handle all errors possible in LDBI_EBFeventIterator.
virtual int | process (EBFevent *)
Method used to invoke the application's LATcomponentIterator.

Detailed Description

Application class demonstrating the use of the EBF iterators to call application-supplied methods back.EBFeventIterator concrete class to invoke the application's LATcomponentIterator.

Constructor & Destructor Documentation

LDBI_EBFeventIterator::LDBI_EBFeventIterator ( LATcomponentIterator * lci ) [inline]

Constructor setting up the EBFeventIterator iterator with a LATcomponentIterator.

Parameters:
lci - The application's LATcomponentIterator to use

Member Function Documentation

int LDBI_EBFeventIterator::handleError | ( | EBFevent * | event,
 |  | unsigned | code,
 |  | unsigned | p1 = 0,
 |  | unsigned | p2 = 0 |
 | ) |  |  | const [inline, virtual]

Handle all errors possible in LDBI_EBFeventIterator.

This method is used to handle errors occurring during the iteration over an LATcomponent. By default it does nothing, however it is virtual and is able to be overridden by the user.

Parameters:
event | The event in error
code | The error code
p1 | a parameter associated with the error code
p2 | a parameter associated with the error code

Reimplemented from EBFeventIterator.

int LDBI_EBFeventIterator::process ( EBFevent * event ) [inline, virtual]

Method used to invoke the application's LATcomponentIterator.

This method is called back by the EBFeventIterator. It shouldn't be called directly.

Parameters:
event - The event to iterate over
Returns:
The return value from EBFcontributionIterator::iterate(), zero if an error occured

Implements EBFeventIterator.

The documentation for this class was generated from the following file:
  • LATdataBufferIterator.h
Generated on Mon Jul 31 17:48:18 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

LDBI_EBFeventIterator Member List

This is the complete list of members for LDBI_EBFeventIterator, including all inherited members.

EBFeventIterator(EBFevent *start, EBFevent *end) | EBFeventIterator | [inline]
EBFeventIterator(char *buffer, unsigned size, bool swap=!DFC_BIG_ENDIAN) | EBFeventIterator | [inline]
EBFeventIterator() | EBFeventIterator | [inline]
end() const | EBFeventIterator | [inline]
ERR_BadStatus enum value (defined in LDBI_EBFeventIterator) | LDBI_EBFeventIterator |
ERR_NonEBFevent enum value (defined in EBFeventIterator) | EBFeventIterator |
handleError(EBFevent *event, unsigned code, unsigned p1=0, unsigned p2=0) const | LDBI_EBFeventIterator | [inline, virtual]
iterate(EBFevent *start, EBFevent *end) | EBFeventIterator |
iterate(char *buffer, unsigned size, bool swap=!DFC_BIG_ENDIAN) | EBFeventIterator | [inline]
iterate() | EBFeventIterator | [inline]
LDBI_EBFeventIterator(LATcomponentIterator *) | LDBI_EBFeventIterator | [inline]
LDBI_EBFeventIterator() (defined in LDBI_EBFeventIterator) | LDBI_EBFeventIterator | [inline]
process(EBFevent *) | LDBI_EBFeventIterator | [inline, virtual]
start() const | EBFeventIterator | [inline]
status() const | EBFeventIterator | [inline]
~EBFeventIterator() (defined in EBFeventIterator) | EBFeventIterator | [inline, virtual]
~LDBI_EBFeventIterator() (defined in LDBI_EBFeventIterator) | LDBI_EBFeventIterator | [inline, virtual]

Generated on Mon Jul 31 17:48:18 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: LDBI_LATcontributionIterator Class Reference

LDBI_LATcontributionIterator Class Reference

LATcontributionIterator concrete class to invoke LDBI_EBFeventIterator. More...

#include <LATdataBufferIterator.h>

Inheritance diagram for LDBI_LATcontributionIterator:

[legend]
Collaboration diagram for LDBI_LATcontributionIterator:

[legend]
List of all members.

Public Member Functions

LDBI_LATcontributionIterator (LATcomponentIterator *)
Constructor setting up the EBFeventIterator iterator with a LATcomponentIterator.
LDBI_LATcontributionIterator (LDBI_EBFeventIterator *)
Constructor setting up the EBFeventIterator iterator with a LDBI_EBFeventIterator.
virtual int EBF (EBFevent *start, EBFevent *end)
Method used to invoke LDBI_EBFeventIterator.

Detailed Description

LATcontributionIterator concrete class to invoke LDBI_EBFeventIterator.

Constructor & Destructor Documentation

LDBI_LATcontributionIterator::LDBI_LATcontributionIterator ( LATcomponentIterator * lci ) [inline]

Constructor setting up the EBFeventIterator iterator with a LATcomponentIterator.

Parameters:
lci - The application's LATcomponentIterator to use

LDBI_LATcontributionIterator::LDBI_LATcontributionIterator ( LDBI_EBFeventIterator * eei ) [inline]

Constructor setting up the EBFeventIterator iterator with a LDBI_EBFeventIterator.

Parameters:
eei - The application's LDBI_EBFeventIterator to use

Member Function Documentation

int LDBI_LATcontributionIterator::EBF | ( | EBFevent * | start,
 |  | EBFevent * | end |
 | ) |  |  | [inline, virtual]

Method used to invoke LDBI_EBFeventIterator.

This method is called back by the LATcontributionIterator. It shouldn't be called directly.

Parameters:
start | - The start of a list of events to iterate over
end | - The end of a list of events to iterate over
Returns:
The status value after EBFeventIterator::iterate()

Implements LATcontributionIterator.

The documentation for this class was generated from the following file:
  • LATdataBufferIterator.h
Generated on Mon Jul 31 17:48:19 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

LDBI_LATcontributionIterator Member List

This is the complete list of members for LDBI_LATcontributionIterator, including all inherited members.

ASC(ASCcontribution *start, LATcontribution *end) | LATcontributionIterator | [virtual]
datagram() const | LATcontributionIterator | [inline]
EBF(EBFevent *start, EBFevent *end) | LDBI_LATcontributionIterator | [inline, virtual]
ERR_UDFcontribution enum value (defined in LATcontributionIterator) | LATcontributionIterator |
handleError(LATcontribution *contrib, unsigned code, unsigned p1=0, unsigned p2=0) const | LATcontributionIterator | [virtual]
iterate() | LATcontributionIterator | [inline]
iterate(LATdatagram *) | LATcontributionIterator |
LATcontributionIterator(LATdatagram *) | LATcontributionIterator | [inline]
LATcontributionIterator() | LATcontributionIterator | [inline]
LDBI_LATcontributionIterator(LATcomponentIterator *) | LDBI_LATcontributionIterator | [inline]
LDBI_LATcontributionIterator(LDBI_EBFeventIterator *) | LDBI_LATcontributionIterator | [inline]
LDBI_LATcontributionIterator() (defined in LDBI_LATcontributionIterator) | LDBI_LATcontributionIterator | [inline]
status() const | LATcontributionIterator | [inline]
UDF(LATcontribution *start, LATcontribution *end) | LATcontributionIterator | [virtual]
~LATcontributionIterator() (defined in LATcontributionIterator) | LATcontributionIterator | [inline, virtual]
~LDBI_LATcontributionIterator() (defined in LDBI_LATcontributionIterator) | LDBI_LATcontributionIterator | [inline, virtual]

Generated on Mon Jul 31 17:48:19 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: LDBI_LATdatagramIterator Class Reference

LDBI_LATdatagramIterator Class Reference

LATdatagramIterator concrete class to invoke LDBI_LATcontributionIterator. More...

#include <LATdataBufferIterator.h>

Inheritance diagram for LDBI_LATdatagramIterator:

[legend]
Collaboration diagram for LDBI_LATdatagramIterator:

[legend]
List of all members.

Public Member Functions

LDBI_LATdatagramIterator (LATcomponentIterator *)
Constructor setting up the LATdatagramIterator iterator with a LATcomponentIterator.
LDBI_LATdatagramIterator (LDBI_LATcontributionIterator *)
Constructor setting up the LATdatagramIterator iterator with a LATcomponentIterator.
LDBI_LATdatagramIterator (LDBI_EBFeventIterator *)
Constructor setting up the LATdatagramIterator iterator with a LATcomponentIterator.
virtual int process (LATdatagram *)
Method used to invoke LDBI_LATcontributionIterator.

Detailed Description

LATdatagramIterator concrete class to invoke LDBI_LATcontributionIterator.

Constructor & Destructor Documentation

LDBI_LATdatagramIterator::LDBI_LATdatagramIterator ( LATcomponentIterator * lci ) [inline]

Constructor setting up the LATdatagramIterator iterator with a LATcomponentIterator.

Parameters:
lci - The application's LATcomponentIterator to use

LDBI_LATdatagramIterator::LDBI_LATdatagramIterator ( LDBI_LATcontributionIterator * lci ) [inline]

Constructor setting up the LATdatagramIterator iterator with a LATcomponentIterator.

Parameters:
lci - The application's LATcomponentIterator to use

LDBI_LATdatagramIterator::LDBI_LATdatagramIterator ( LDBI_EBFeventIterator * eei ) [inline]

Constructor setting up the LATdatagramIterator iterator with a LATcomponentIterator.

Parameters:
eei - The application's LDBI_EBFeventIterator to use

Member Function Documentation

int LDBI_LATdatagramIterator::process ( LATdatagram * datagram ) [inline, virtual]

Method used to invoke LDBI_LATcontributionIterator.

This method is called back by the LATdatagramIterator. It shouldn't be called directly.

Parameters:
datagram - The LATdatagrm to iterate over
Returns:
The return value from LATcontributionIterator::iterate()

Implements LATdatagramIterator.

The documentation for this class was generated from the following file:
  • LATdataBufferIterator.h
Generated on Mon Jul 31 17:48:19 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

LDBI_LATdatagramIterator Member List

This is the complete list of members for LDBI_LATdatagramIterator, including all inherited members.

end() const | LATdatagramIterator | [inline]
ERR_IDmismatch enum value (defined in LATdatagramIterator) | LATdatagramIterator |
handleError(LATdatagram *datagram, unsigned code, unsigned p1=0, unsigned p2=0) const | LATdatagramIterator | [virtual]
iterate() | LATdatagramIterator | [inline]
iterate(LATdatagram *start, LATdatagram *end) | LATdatagramIterator |
LATdatagramIterator(LATdatagram *start, LATdatagram *end) | LATdatagramIterator | [inline]
LATdatagramIterator() | LATdatagramIterator | [inline]
LDBI_LATdatagramIterator(LATcomponentIterator *) | LDBI_LATdatagramIterator | [inline]
LDBI_LATdatagramIterator(LDBI_LATcontributionIterator *) | LDBI_LATdatagramIterator | [inline]
LDBI_LATdatagramIterator(LDBI_EBFeventIterator *) | LDBI_LATdatagramIterator | [inline]
LDBI_LATdatagramIterator() (defined in LDBI_LATdatagramIterator) | LDBI_LATdatagramIterator | [inline]
process(LATdatagram *) | LDBI_LATdatagramIterator | [inline, virtual]
start() const | LATdatagramIterator | [inline]
status() const | LATdatagramIterator | [inline]
~LATdatagramIterator() (defined in LATdatagramIterator) | LATdatagramIterator | [inline, virtual]
~LDBI_LATdatagramIterator() (defined in LDBI_LATdatagramIterator) | LDBI_LATdatagramIterator | [inline, virtual]

Generated on Mon Jul 31 17:48:19 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: LDFversion Class Reference

LDFversion Class Reference

Class for defining the version number of the package. More...

#include <LDFversion.h>

List of all members.

Static Public Member Functions

static unsigned | major ()
static unsigned | minor ()
static unsigned | revision ()

Detailed Description

Class for defining the version number of the package.

Author:
R. Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.48
Date:
February 22, 2003 -- Created
Id
LDFversion.h,v 1.48 2006/07/31 22:26:26 claus Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Member Function Documentation

static unsigned LDFversion::major ( ) [inline, static]

Return the major release value

static unsigned LDFversion::minor ( ) [inline, static]

Return the minor release value

static unsigned LDFversion::revision ( ) [inline, static]

Return the release revision value

The documentation for this class was generated from the following file:
  • LDFversion.h
Generated on Mon Jul 31 17:48:19 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

LDFversion Member List

This is the complete list of members for LDFversion, including all inherited members.

LDFversion() (defined in LDFversion) | LDFversion | [inline]
major() | LDFversion | [inline, static]
minor() | LDFversion | [inline, static]
revision() | LDFversion | [inline, static]
~LDFversion() (defined in LDFversion) | LDFversion | [inline]

Generated on Mon Jul 31 17:48:19 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: OSWcontributionIterator Class Reference

OSWcontributionIterator Class Reference

Class for iterating over contributions to an OSW (Online SoftWare) contribution. More...

#include <OSWcontributionIterator.h>

Collaboration diagram for OSWcontributionIterator:

[legend]
List of all members.

Public Member Functions

OSWcontributionIterator (EBFevent *event, OSWcontribution *contribution)
Constructor for iterating over an Online Software contribution.
OSWcontributionIterator ()
Do nothing constructor.
virtual int | handleError (OSWcontribution *contribution, unsigned code, unsigned p1=0, unsigned p2=0) const
Handle all errors possible in OSWcontributionIterator.
unsigned | iterate ()
Iterate over the contributions in an OSWcontribution.
unsigned | iterate (EBFevent *event, OSWcontribution *contribution)
Iterate over the contributions in an OSWcontribution.
virtual int | OSWtime (const struct timespec *ts, const OSWtimeBase *tb) const
Virtual method for calling the application back with time data.
virtual int | OSW_time (EBFevent *event, OSWtimeContribution *contribution) const
Virtual method for calling the application back with the time contribution.
virtual int | OSW_UDF (EBFevent *event, OSWcontribution *contribution) const
Undefined Online Software contribution handler.
const EBFevent * | event () const
const OSWcontribution * | contribution () const
int | status () const

Detailed Description

Class for iterating over contributions to an OSW (Online SoftWare) contribution.

Author:
R. Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.5
Date:
February 25, 2004 -- Created
Id
OSWcontributionIterator.h,v 1.5 2005/03/31 00:39:31 claus Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

OSWcontributionIterator::OSWcontributionIterator | ( | EBFevent * | event,
 |  | OSWcontribution * | contribution |
 | ) |  |  | [inline]

Constructor for iterating over an Online Software contribution.

This constructor caches the event and contribution provided by the caller.

Parameters:
event | A pointer to the EBFevent containing the contribution
contribution | A pointer to the contribution to iterate over

Member Function Documentation

const OSWcontribution * OSWcontributionIterator::contribution ( ) const [inline]

Return a pointer to the OSWcontribution to be iterated over

const EBFevent * OSWcontributionIterator::event ( ) const [inline]

Return a pointer to the EBFevent containing this contribution

int OSWcontributionIterator::handleError | ( | OSWcontribution * | contribution,
 |  | unsigned | code,
 |  | unsigned | p1 = 0,
 |  | unsigned | p2 = 0 |
 | ) |  |  | const [inline, virtual]

Handle all errors possible in OSWcontributionIterator.

This method is used to handle errors occurring during the iteration over an OSWcontribution. By default it does nothing, however it is virtual and is able to be overridden by the user.

Parameters:
contribution | The contribution in error
code | The error code
p1 | a parameter associated with the error code
p2 | a parameter associated with the error code

unsigned OSWcontributionIterator::iterate | ( | EBFevent * | event,
 |  | OSWcontribution * | contribution
 | ) |  |

Iterate over the contributions in an OSWcontribution.

Parameters:
event | - The EBFevent containing the OSWcontribution
contribution | - The OSWcontribution to be iterated over
Returns:
The number of contributions treated

unsigned OSWcontributionIterator::iterate ( ) [inline]

Iterate over the contributions in an OSWcontribution.

Returns:
The number of contributions treated

int OSWcontributionIterator::OSW_time | ( | EBFevent * | event,
 |  | OSWtimeContribution * | contribution |
 | ) |  |  | const [inline, virtual]

Virtual method for calling the application back with the time contribution.

The default implementation of this method calls the OSWtime pure virtual method. This is done to preserve the historical interface.

Parameters:
event | - A pointer to the EBFevent containing the contribution
contribution | - A pointer to an OSWtimeContribution
Returns:
A status code

int OSWcontributionIterator::OSW_UDF | ( | EBFevent * | event,
 |  | OSWcontribution * | contribution |
 | ) |  |  | const [inline, virtual]

Undefined Online Software contribution handler.

Parameters:
event | - A pointer to the event containing the contribution
contribution | - A pointer to the contribution being iterated over
Returns:
A status code

int OSWcontributionIterator::OSWtime | ( | const struct timespec * | ts,
 |  | const OSWtimeBase * | tb |
 | ) |  |  | const [inline, virtual]

Virtual method for calling the application back with time data.

Parameters:
ts | - A pointer to a timespec structure containing the event timestamp
tb | - A pointer to an OSWtimeBase containing the event timebase value
Returns:
A status code

int OSWcontributionIterator::status ( ) const [inline]

Return the iteration status code

The documentation for this class was generated from the following files:
  • OSWcontributionIterator.h
  • OSWcontributionIterator.cpp
Generated on Mon Jul 31 17:48:20 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

OSWcontributionIterator Member List

This is the complete list of members for OSWcontributionIterator, including all inherited members.

contribution() const | OSWcontributionIterator | [inline]
event() const | OSWcontributionIterator | [inline]
handleError(OSWcontribution *contribution, unsigned code, unsigned p1=0, unsigned p2=0) const | OSWcontributionIterator | [inline, virtual]
iterate() | OSWcontributionIterator | [inline]
iterate(EBFevent *event, OSWcontribution *contribution) | OSWcontributionIterator |
OSW_time(EBFevent *event, OSWtimeContribution *contribution) const | OSWcontributionIterator | [inline, virtual]
OSW_UDF(EBFevent *event, OSWcontribution *contribution) const | OSWcontributionIterator | [inline, virtual]
OSWcontributionIterator(EBFevent *event, OSWcontribution *contribution) | OSWcontributionIterator | [inline]
OSWcontributionIterator() | OSWcontributionIterator | [inline]
OSWtime(const struct timespec *ts, const OSWtimeBase *tb) const | OSWcontributionIterator | [inline, virtual]
status() const | OSWcontributionIterator | [inline]
~OSWcontributionIterator() (defined in OSWcontributionIterator) | OSWcontributionIterator | [inline, virtual]

Generated on Mon Jul 31 17:48:20 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: OSWtimeBase Class Reference

OSWtimeBase Class Reference

Class for Python support to handle the two timebase longwords. More...

#include <OSWtimeBase.h>

List of all members.

Public Member Functions

OSWtimeBase ()
Do nothing OSWtimeBase constructor.
OSWtimeBase (unsigned *tb)
OSWtimeBase constructor set up from a passed in timebase array.
OSWtimeBase (unsigned upper, unsigned lower)
OSWtimeBase constructor set up from passed in uper and lower values.
const unsigned * | timebase () const
Return the timebase array.
unsigned | upper () const
Return the upper portion of the timebase structure.
unsigned | lower () const
Return the lower portion of the timebase structure.

Detailed Description

Class for Python support to handle the two timebase longwords.

This class stores a 64 bit PPC timebase counter value

Author:
R. Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.1
Date:
March 12, 2004 -- Created
Id
OSWtimeBase.h,v 1.1 2004/04/01 23:50:52 claus Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

OSWtimeBase::OSWtimeBase | ( | unsigned | upper,
 |  | unsigned | lower |
 | ) |  |  | [inline]

OSWtimeBase constructor set up from passed in uper and lower values.

Parameters:
upper | value to initialize timebase value with
lower | value to initialize timebase value with

Member Function Documentation

unsigned OSWtimeBase::lower ( ) const [inline]

Return the lower portion of the timebase structure.

Returns:
The lower portion of the timebase structure

const unsigned * OSWtimeBase::timebase ( ) const [inline]

Return the timebase array.

Returns:
A pointer to the timebase array

unsigned OSWtimeBase::upper ( ) const [inline]

Return the upper portion of the timebase structure.

Returns:
The upper portion of the timebase structure

The documentation for this class was generated from the following file:
  • OSWtimeBase.h
Generated on Mon Jul 31 17:48:20 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

OSWtimeBase Member List

This is the complete list of members for OSWtimeBase, including all inherited members.

lower() const | OSWtimeBase | [inline]
OSWtimeBase() | OSWtimeBase | [inline]
OSWtimeBase(unsigned *tb) | OSWtimeBase | [inline]
OSWtimeBase(unsigned upper, unsigned lower) | OSWtimeBase | [inline]
timebase() const | OSWtimeBase | [inline]
upper() const | OSWtimeBase | [inline]
~OSWtimeBase() (defined in OSWtimeBase) | OSWtimeBase | [inline]

Generated on Mon Jul 31 17:48:20 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: OSWtimeContribution Class Reference

OSWtimeContribution Class Reference

Class for decoding the time contribution inserted by the Online SoftWare (OSW) to an EBF event. More...

#include <OSWtimeContribution.h>

Collaboration diagram for OSWtimeContribution:

[legend]
List of all members.

Public Types

ID = LATidentity_(LATprimaryId::Id_Time, LATsecondaryId::Id_Time)
enum | { ID = LATidentity_(LATprimaryId::Id_Time, LATsecondaryId::Id_Time) }

Public Member Functions

OSWtimeContribution ()
Do nothing constructor.
OSWtimeContribution (const OSWcontribution &contribution)
"Copy" constructor taking an OSWcontribution
~OSWtimeContribution ()
Do nothing destructor.
timespec * | timeStamp () const
Return the timespec structure found in the data.
const OSWtimeBase * | timebase () const
Return the 64 bit timebase value found in the data as two unsigneds.
const unsigned | evtSeqMSW () const
Return the event sequence number most significant word.
const unsigned | evtSequence () const
Return the event sequence number.

Detailed Description

Class for decoding the time contribution inserted by the Online SoftWare (OSW) to an EBF event.

This class exists to support data taken after the GASU came into existance. Data that falls into this catagory is labeled with the EBFevent::ID typeId. Data taken before this point contains this time stamp information as well, but in the form of a GLTcontribution.

This contribution will disappear some time in the future when FSW provides their own implementation of assigning absolute time to events. It is likely to be very different than what is presented here.

Author:
R. Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.4
Date:
January 26, 2004 -- Created
Id
OSWtimeContribution.h,v 1.4 2005/04/02 00:11:17 claus Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

OSWtimeContribution::OSWtimeContribution ( const OSWcontribution & contribution ) [inline]

"Copy" constructor taking an OSWcontribution

This constructor exists for the Python interface to get around the inability to recast an OSWcontribution as an OSWtimeContribution. This constructor creates a new object by making a copy of the parent OSWcontribution.

Member Function Documentation

const unsigned OSWtimeContribution::evtSeqMSW ( ) const [inline]

Return the event sequence number most significant word.

The event sequence number most significant word is created by counting the number of times the hardware's event number rolls over.

Returns:
The event sequence number MSW

const unsigned OSWtimeContribution::evtSequence ( ) const [inline]

Return the event sequence number.

The event sequence number is created by concatenating the event sequence number most significant word (32 bits), the hardware event number (15 bits) and the hardware tag (2 bits) value. Only the lower 32 bits of the result are returned as this allows for some 4 billion events in a run, way more then we ever expect to encounter.

Returns:
The event sequence number

const OSWtimeBase * OSWtimeContribution::timebase ( ) const [inline]

Return the 64 bit timebase value found in the data as two unsigneds.

The timebase value comes from a PPC register that increments at a rate given by the board's implementation. Ric hasn't been able to find any supporting documentation giving the rate, but one measurement gives 16.6667 MHz.

Returns:
A pointer to the timebase structure

struct timespec * OSWtimeContribution::timeStamp ( ) const [inline]

Return the timespec structure found in the data.

The timestamp value comes from the VxWorks real-time clock. The clock is periodically updated. The period is settable through software, but defaults to 60 Hz.

Returns:
A pointer to the timespec structure

The documentation for this class was generated from the following file:
  • OSWtimeContribution.h
Generated on Mon Jul 31 17:48:20 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

OSWtimeContribution Member List

This is the complete list of members for OSWtimeContribution, including all inherited members.

evtSeqMSW() const | OSWtimeContribution | [inline]
evtSequence() const | OSWtimeContribution | [inline]
ID enum value (defined in OSWtimeContribution) | OSWtimeContribution |
OSWtimeContribution() | OSWtimeContribution | [inline]
OSWtimeContribution(const OSWcontribution &contribution) | OSWtimeContribution | [inline]
timebase() const | OSWtimeContribution | [inline]
timeStamp() const | OSWtimeContribution | [inline]
~OSWtimeContribution() | OSWtimeContribution | [inline]

Generated on Mon Jul 31 17:48:20 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: OSWtimeSpec Class Reference

OSWtimeSpec Class Reference

Class for Python support since it doesn't have a struct timespec type. More...

#include <OSWtimeSpec.h>

List of all members.

Public Member Functions

OSWtimeSpec ()
Do nothing OSWtimeSpec constructor.
OSWtimeSpec (struct timespec *ts)
OSWtimeSpec constructor set up from a passed in timespec structure.
OSWtimeSpec (time_t sec, long nSec)
OSWtimeSpec constructor set up from passed in seconds and nanoseconds values.
timespec * | timespec () const
Return the timespec structure.
time_t | sec () const
Return the seconds portion of the timespec structure.
long | nsec () const
Return the nanoseconds portion of the timespec structure.

Detailed Description

Class for Python support since it doesn't have a struct timespec type.

Author:
R. Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.1
Date:
March 12, 2004 -- Created
Id
OSWtimeSpec.h,v 1.1 2004/04/01 23:51:35 claus Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

OSWtimeSpec::OSWtimeSpec | ( | time_t | sec,
 |  | long | nsec |
 | ) |  |  | [inline]

OSWtimeSpec constructor set up from passed in seconds and nanoseconds values.

Parameters:
sec | Seconds value to initialize timespec value with
nsec | Nanoseconds value to initialize timespec value with

Member Function Documentation

long OSWtimeSpec::nsec ( ) const [inline]

Return the nanoseconds portion of the timespec structure.

Returns:
The nanoseconds portion of the timespec structure

time_t OSWtimeSpec::sec ( ) const [inline]

Return the seconds portion of the timespec structure.

Returns:
The seconds portion of the timespec structure

struct timespec * OSWtimeSpec::timespec ( ) const [inline]

Return the timespec structure.

Returns:
A pointer to the timespec struct

The documentation for this class was generated from the following file:
  • OSWtimeSpec.h
Generated on Mon Jul 31 17:48:20 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

OSWtimeSpec Member List

This is the complete list of members for OSWtimeSpec, including all inherited members.

nsec() const | OSWtimeSpec | [inline]
OSWtimeSpec() | OSWtimeSpec | [inline]
OSWtimeSpec(struct timespec *ts) | OSWtimeSpec | [inline]
OSWtimeSpec(time_t sec, long nSec) | OSWtimeSpec | [inline]
sec() const | OSWtimeSpec | [inline]
timespec() const | OSWtimeSpec | [inline]
~OSWtimeSpec() (defined in OSWtimeSpec) | OSWtimeSpec | [inline]

Generated on Mon Jul 31 17:48:20 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: TEMcontribution Class Reference

TEMcontribution Class Reference

Class for decoding a TEM's contribution to an EBFevent. More...

#include <TEMcontribution.h>

Inheritance diagram for TEMcontribution:

[legend]
Collaboration diagram for TEMcontribution:

[legend]
List of all members.

Public Member Functions

unsigned | logAccepts () const
Return a pointer to the CAL log accepts data.
unsigned | numLogAccepts () const
Return the number of CAL log accepts.
CALcontribution * | calContribution () const
Return this contribution as type CALcontribution.
TKRcontribution * | tkrContribution () const
Return this contribution as type TKRcontribution.

Detailed Description

Class for decoding a TEM's contribution to an EBFevent.

Author:
Ric Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.4
Date:
January 26, 2003 -- Created
Id
TEMcontribution.h,v 1.4 2004/04/02 03:07:46 claus Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

The documentation for this class was generated from the following file:
  • TEMcontribution.h
Generated on Mon Jul 31 17:48:20 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

TEMcontribution Member List

This is the complete list of members for TEMcontribution, including all inherited members.

AEM enum value (defined in EBFcontribution) | EBFcontribution |
aemContribution() const | EBFcontribution | [inline]
Broadcast enum value (defined in EBFcontribution) | EBFcontribution |
calContribution() const | TEMcontribution | [inline]
CRU enum value (defined in EBFcontribution) | EBFcontribution |
EBFcontribution() (defined in EBFcontribution) | EBFcontribution | [inline]
EBM enum value (defined in EBFcontribution) | EBFcontribution |
GEM enum value (defined in EBFcontribution) | EBFcontribution |
gemContribution() const | EBFcontribution | [inline]
gltContribution() const | EBFcontribution | [inline]
header() const | EBFcontribution | [inline]
length() const | EBFcontribution | [inline]
logAccepts() const | TEMcontribution | [inline]
next() const | EBFcontribution | [inline]
NumberOfContributions enum value (defined in EBFcontribution) | EBFcontribution |
numLogAccepts() const | TEMcontribution | [inline]
OSW enum value (defined in EBFcontribution) | EBFcontribution |
oswContribution() const | EBFcontribution | [inline]
packetError() const | EBFcontribution | [inline]
Parity enum value (defined in EBFcontribution) | EBFcontribution |
payload() const | EBFcontribution | [inline]
payloadSize() const | EBFcontribution | [inline]
PDU_0 enum value (defined in EBFcontribution) | EBFcontribution |
PDU_1 enum value (defined in EBFcontribution) | EBFcontribution |
sequence() const | EBFcontribution | [inline]
summary() const | EBFcontribution | [inline]
temContribution() const | EBFcontribution | [inline]
TEMcontribution() (defined in TEMcontribution) | TEMcontribution | [inline]
TimedOut enum value (defined in EBFcontribution) | EBFcontribution |
tkrContribution() const | TEMcontribution | [inline]
Tower_00 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_01 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_02 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_03 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_04 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_05 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_06 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_07 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_08 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_09 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_10 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_11 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_12 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_13 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_14 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_15 enum value (defined in EBFcontribution) | EBFcontribution |
Truncated enum value (defined in EBFcontribution) | EBFcontribution |
WriteFault enum value (defined in EBFcontribution) | EBFcontribution |
~EBFcontribution() (defined in EBFcontribution) | EBFcontribution | [inline]
~TEMcontribution() (defined in TEMcontribution) | TEMcontribution | [inline]

Generated on Mon Jul 31 17:48:20 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: TEMcontributionIterator Class Reference

TEMcontributionIterator Class Reference

Class for iterating over contributions to a TEMcontribution. More...

#include <TEMcontributionIterator.h>

Inheritance diagram for TEMcontributionIterator:

[legend]
Collaboration diagram for TEMcontributionIterator:

[legend]
List of all members.

Public Member Functions

TEMcontributionIterator (EBFevent *, TEMcontribution *)
Constructor setting up the iterator with an EBFevent and a TEMcontribution.
TEMcontributionIterator ()
unsigned | iterate ()
Iterate over the contributions in a cached TEMcontribution.
unsigned | iterate (EBFevent *, TEMcontribution *)
Class for iterating over contributions to a TEM contributionIterate over the contributions in a TEMcontribution.
virtual int | handleError (TEMcontribution *contribution, unsigned code, unsigned p1=0, unsigned p2=0) const
Handle all errors possible in TEMcontributionIterator.
virtual int | CAL (EBFevent *event, TEMcontribution *contribution)=0
virtual int | TKR (EBFevent *event, TEMcontribution *contribution)=0
virtual int | diagnostic (EBFevent *event, TEMcontribution *contribution)=0
virtual int | error (EBFevent *event, TEMcontribution *contribution)=0
virtual int | cleanup (EBFevent *event, TEMcontribution *contribution)=0
const EBFevent * | event () const
const TEMcontribution * | contribution () const
unsigned | CALend () const
unsigned | TKRend () const
unsigned | diagnosticEnd () const
unsigned | errorEnd () const
int | status () const
void | CALend (unsigned offset)
Set the offset to the end of the calorimeter data from the start of the contribution. Counted in bytes.
void | TKRend (unsigned offset)
Set the offset to the end of the tracker data from the start of the contribution. Counted in bytes.
void | diagnosticEnd (unsigned offset)
Set the offset to the end of the TEM diagnostic data from the start of the contribution. Counted in bytes.
void | errorEnd (unsigned offset)
Set the offset to the end of the TEM error data from the start of the contribution. Counted in bytes.

Detailed Description

Class for iterating over contributions to a TEMcontribution.

Author:
R. Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.10
Date:
January 23, 2003 -- Created
Id
TEMcontributionIterator.h,v 1.10 2005/03/15 18:59:41 panetta Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

TEMcontributionIterator::TEMcontributionIterator | ( | EBFevent * | event,
 |  | TEMcontribution * | contribution |
 | ) |  |  | [inline]

Constructor setting up the iterator with an EBFevent and a TEMcontribution.

Parameters:
event | - A pointer to an EBFevent
contribution | - A pointer to a TEMcontribution in the event

TEMcontributionIterator::TEMcontributionIterator ( ) [inline]

Default constructor

Member Function Documentation

virtual int TEMcontributionIterator::CAL | ( | EBFevent * | event,
 |  | TEMcontribution * | contribution |
 | ) |  |  | [pure virtual]

CAL contribution handler

Implemented in LATcomponentIterator.

unsigned TEMcontributionIterator::CALend ( ) const [inline]

Return the offset in bytes to then of the calorimeter data

virtual int TEMcontributionIterator::cleanup | ( | EBFevent * | event,
 |  | TEMcontribution * | contribution |
 | ) |  |  | [pure virtual]

Clean-up handler

Implemented in LATcomponentIterator.

const TEMcontribution * TEMcontributionIterator::contribution ( ) const [inline]

Return a pointer to the TEMcontribution being iterated over

virtual int TEMcontributionIterator::diagnostic | ( | EBFevent * | event,
 |  | TEMcontribution * | contribution |
 | ) |  |  | [pure virtual]

Diagnostic contribution handler

Implemented in LATcomponentIterator.

unsigned TEMcontributionIterator::diagnosticEnd ( ) const [inline]

Return the offset in bytes to then of the diagnostic data

virtual int TEMcontributionIterator::error | ( | EBFevent * | event,
 |  | TEMcontribution * | contribution |
 | ) |  |  | [pure virtual]

Error contribution handler

Implemented in LATcomponentIterator.

unsigned TEMcontributionIterator::errorEnd ( ) const [inline]

Return the offset in bytes to then of the error data

const EBFevent * TEMcontributionIterator::event ( ) const [inline]

Return a pointer to the EBFevent containing this contribution

int TEMcontributionIterator::handleError | ( | TEMcontribution * | contribution,
 |  | unsigned | code,
 |  | unsigned | p1 = 0,
 |  | unsigned | p2 = 0 |
 | ) |  |  | const [inline, virtual]

Handle all errors possible in TEMcontributionIterator.

This method is used to handle errors occurring during the iteration over an TEMcontribution. By default it does nothing, however it is virtual and is able to be overridden by the user.

Parameters:
contribution | The contribution in error
code | The error code
p1 | a parameter associated with the error code
p2 | a parameter associated with the error code

unsigned TEMcontributionIterator::iterate | ( | EBFevent * | event,
 |  | TEMcontribution * | contribution
 | ) |  |

Class for iterating over contributions to a TEM contributionIterate over the contributions in a TEMcontribution.

Parameters:
event | - The EBFevent containing the TEMcontribution
contribution | - The TEMcontribution to be iterated over
Returns:
The number of contributions treated

unsigned TEMcontributionIterator::iterate ( ) [inline]

Iterate over the contributions in a cached TEMcontribution.

Returns:
The number of contributions treated

int TEMcontributionIterator::status ( ) const [inline]

Return the iteration status code

virtual int TEMcontributionIterator::TKR | ( | EBFevent * | event,
 |  | TEMcontribution * | contribution |
 | ) |  |  | [pure virtual]

TKR contribution handler

Implemented in LATcomponentIterator.

unsigned TEMcontributionIterator::TKRend ( ) const [inline]

Return the offset in bytes to then of the tracker data

The documentation for this class was generated from the following files:
  • TEMcontributionIterator.h
  • TEMcontributionIterator.cpp
Generated on Mon Jul 31 17:48:20 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

TEMcontributionIterator Member List

This is the complete list of members for TEMcontributionIterator, including all inherited members.

CAL(EBFevent *event, TEMcontribution *contribution)=0 | TEMcontributionIterator | [pure virtual]
CALend() const | TEMcontributionIterator | [inline]
CALend(unsigned offset) | TEMcontributionIterator | [inline]
cleanup(EBFevent *event, TEMcontribution *contribution)=0 | TEMcontributionIterator | [pure virtual]
contribution() const | TEMcontributionIterator | [inline]
diagnostic(EBFevent *event, TEMcontribution *contribution)=0 | TEMcontributionIterator | [pure virtual]
diagnosticEnd() const | TEMcontributionIterator | [inline]
diagnosticEnd(unsigned offset) | TEMcontributionIterator | [inline]
error(EBFevent *event, TEMcontribution *contribution)=0 | TEMcontributionIterator | [pure virtual]
errorEnd() const | TEMcontributionIterator | [inline]
errorEnd(unsigned offset) | TEMcontributionIterator | [inline]
event() const | TEMcontributionIterator | [inline]
handleError(TEMcontribution *contribution, unsigned code, unsigned p1=0, unsigned p2=0) const | TEMcontributionIterator | [inline, virtual]
iterate() | TEMcontributionIterator | [inline]
iterate(EBFevent *, TEMcontribution *) | TEMcontributionIterator |
status() const | TEMcontributionIterator | [inline]
TEMcontributionIterator(EBFevent *, TEMcontribution *) | TEMcontributionIterator | [inline]
TEMcontributionIterator() | TEMcontributionIterator | [inline]
TKR(EBFevent *event, TEMcontribution *contribution)=0 | TEMcontributionIterator | [pure virtual]
TKRend() const | TEMcontributionIterator | [inline]
TKRend(unsigned offset) | TEMcontributionIterator | [inline]
~TEMcontributionIterator() (defined in TEMcontributionIterator) | TEMcontributionIterator | [inline, virtual]

Generated on Mon Jul 31 17:48:20 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: TKRcontribution Class Reference

TKRcontribution Class Reference

Class for decoding Tracker's contribution to a TEMcontribution. More...

#include <TKRcontribution.h>

Inheritance diagram for TKRcontribution:

[legend]
Collaboration diagram for TKRcontribution:

[legend]
List of all members.

Public Member Functions

char * | accepts (const EBFevent *event) const
Returns the start of a 72 x 1 bit array containing the Accepts.
unsigned * | acceptsMask (const EBFevent *event, unsigned *array) const
Returns the 8 Accept mask 9 bit words in an array supplied by the caller.
unsigned | numAccepts (const EBFevent *event) const
Returns the number of Accepts found in the contribution.
char * | data (const EBFevent *event) const
Returns the longword index into the contribution buffer where the data starts.

Detailed Description

Class for decoding Tracker's contribution to a TEMcontribution.

Author:
R. Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.8
Date:
January 27, 2003 -- Created
Id
TKRcontribution.h,v 1.8 2004/09/01 01:09:30 claus Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Member Function Documentation

char * TKRcontribution::data ( const EBFevent * event ) const [inline]

Returns the longword index into the contribution buffer where the data starts.

Note that the data begins at bit 24 of the first longword. The upper 8 bits are part of the accepts array.

The documentation for this class was generated from the following file:
  • TKRcontribution.h
Generated on Mon Jul 31 17:48:21 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

TKRcontribution Member List

This is the complete list of members for TKRcontribution, including all inherited members.

accepts(const EBFevent *event) const | TKRcontribution | [inline]
acceptsMask(const EBFevent *event, unsigned *array) const | TKRcontribution | [inline]
AEM enum value (defined in EBFcontribution) | EBFcontribution |
aemContribution() const | EBFcontribution | [inline]
Broadcast enum value (defined in EBFcontribution) | EBFcontribution |
calContribution() const | TEMcontribution | [inline]
CRU enum value (defined in EBFcontribution) | EBFcontribution |
data(const EBFevent *event) const | TKRcontribution | [inline]
EBFcontribution() (defined in EBFcontribution) | EBFcontribution | [inline]
EBM enum value (defined in EBFcontribution) | EBFcontribution |
GEM enum value (defined in EBFcontribution) | EBFcontribution |
gemContribution() const | EBFcontribution | [inline]
gltContribution() const | EBFcontribution | [inline]
header() const | EBFcontribution | [inline]
length() const | EBFcontribution | [inline]
logAccepts() const | TEMcontribution | [inline]
next() const | EBFcontribution | [inline]
numAccepts(const EBFevent *event) const | TKRcontribution | [inline]
NumberOfContributions enum value (defined in EBFcontribution) | EBFcontribution |
numLogAccepts() const | TEMcontribution | [inline]
OSW enum value (defined in EBFcontribution) | EBFcontribution |
oswContribution() const | EBFcontribution | [inline]
packetError() const | EBFcontribution | [inline]
Parity enum value (defined in EBFcontribution) | EBFcontribution |
payload() const | EBFcontribution | [inline]
payloadSize() const | EBFcontribution | [inline]
PDU_0 enum value (defined in EBFcontribution) | EBFcontribution |
PDU_1 enum value (defined in EBFcontribution) | EBFcontribution |
sequence() const | EBFcontribution | [inline]
summary() const | EBFcontribution | [inline]
temContribution() const | EBFcontribution | [inline]
TEMcontribution() (defined in TEMcontribution) | TEMcontribution | [inline]
TimedOut enum value (defined in EBFcontribution) | EBFcontribution |
tkrContribution() const | TEMcontribution | [inline]
TKRcontribution() (defined in TKRcontribution) | TKRcontribution | [inline]
Tower_00 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_01 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_02 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_03 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_04 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_05 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_06 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_07 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_08 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_09 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_10 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_11 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_12 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_13 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_14 enum value (defined in EBFcontribution) | EBFcontribution |
Tower_15 enum value (defined in EBFcontribution) | EBFcontribution |
Truncated enum value (defined in EBFcontribution) | EBFcontribution |
WriteFault enum value (defined in EBFcontribution) | EBFcontribution |
~EBFcontribution() (defined in EBFcontribution) | EBFcontribution | [inline]
~TEMcontribution() (defined in TEMcontribution) | TEMcontribution | [inline]
~TKRcontribution() (defined in TKRcontribution) | TKRcontribution | [inline]

Generated on Mon Jul 31 17:48:21 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: TKRcontributionIterator Class Reference

TKRcontributionIterator Class Reference

Class for iterating over contributions to a TKRcontribution. More...

#include <TKRcontributionIterator.h>

Collaboration diagram for TKRcontributionIterator:

[legend]
List of all members.

Public Types

ERR_WrongOrder = 1
ERR_PastEnd = 2
iterateStrips() was not called before iterateTOTs()
enum | { ERR_WrongOrder = 1, ERR_PastEnd = 2 }

Public Member Functions

TKRcontributionIterator (EBFevent *, TKRcontribution *, TKRmap *)
Constructor for iterating over the tracker contribution.
TKRcontributionIterator (EBFevent *, TKRcontribution *)
Constructor for iterating over the tracker contribution.
TKRcontributionIterator (TKRmap *)
Constructor for setting up the electronic space to detector space map.
TKRcontributionIterator ()
Do nothing constructor.
unsigned | iterateStrips ()
Iterate over tracker strip data.
unsigned | iterateStrips (EBFevent *, TKRcontribution *)
Iterate over tracker strip hits.
unsigned | iterateStrips (EBFevent *, TKRcontribution *, TKRmap *)
Class for iterating over contributions to a TKR contributionIterate over tracker strip hits. This method calls the strip() virtual function back with every strip hit it finds. Strip data _must_ be iterated over before TOTs can be iterated over. This method uses the event and contribution provided by the caller and the map established by the caller.
unsigned | iterateTOTs ()
Iterate over tracker TOT data.
unsigned | iterateTOTs (TKRcontribution *)
Iterate over tracker TOT data.
unsigned | iterateTOTs (TKRcontribution *, TKRmap *)
Iterate over tracker TOT data.
virtual int | handleError (TKRcontribution *, unsigned code, unsigned p1=0, unsigned p2=0) const
Handle all errors possible in TKRcontributionIterator.
const EBFevent * | event () const
const TKRcontribution * | contribution () const
const TKRmap * | map () const
const unsigned | stripCount () const
Return the number of strip hits found by TKRcontributionIterator::iterateStrips().
const unsigned | diagnostic () const
Return the start of the diagnostic data.
const unsigned | error () const
Return the start of the error data.
virtual void | strip (unsigned tower, unsigned layerEnd, unsigned hit)=0
Pure virtual method for calling the application back with a tracker strip hit value.
virtual void | TOT (unsigned tower, unsigned layerEnd, unsigned tot)=0
Pure virtual method for calling the application back with a tracker TOT value.
const void | endTots (unsigned offset)

Detailed Description

Class for iterating over contributions to a TKRcontribution.

Author:
R. Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.15
Date:
January 27, 2003 -- Created
Id
TKRcontributionIterator.h,v 1.15 2006/02/10 22:13:30 claus Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Member Enumeration Documentation

anonymous enum

Enumerator:
ERR_PastEnd iterateStrips() was not called before iterateTOTs()

Constructor & Destructor Documentation

TKRcontributionIterator::TKRcontributionIterator | ( | EBFevent * | event,
 |  | TKRcontribution * | contribution,
 |  | TKRmap * | map |
 | ) |  |  | [inline]

Constructor for iterating over the tracker contribution.

This constructor caches the event, contribution and map provided by the caller.

Parameters:
event | A pointer to the EBFevent containing the contribution
contribution | A pointer to the contribution to iterate over
map | A pointer to the electronic space to detector space map

TKRcontributionIterator::TKRcontributionIterator | ( | EBFevent * | event,
 |  | TKRcontribution * | contribution |
 | ) |  |  | [inline]

Constructor for iterating over the tracker contribution.

This constructor caches the event and contribution provided by the caller.

Parameters:
event | A pointer to the EBFevent containing the contribution
contribution | A pointer to the contribution to iterate over

Member Function Documentation

const TKRcontribution* TKRcontributionIterator::contribution ( ) const [inline]

Return a pointer to the start of this contribution

const unsigned TKRcontributionIterator::diagnostic ( ) const [inline]

Return the start of the diagnostic data.

Returns:
The start of the diagnostic data

const void TKRcontributionIterator::endTots ( unsigned offset ) [inline]

Set the byte offset from the start of the TKRcontribution at which the TOT data ends

const unsigned TKRcontributionIterator::error ( ) const [inline]

Return the start of the error data.

Returns:
The start of the error data

const EBFevent* TKRcontributionIterator::event ( ) const [inline]

Return a pointer to the EBFevent containing this contribution

int TKRcontributionIterator::handleError | ( | TKRcontribution * | contribution,
 |  | unsigned | code,
 |  | unsigned | p1 = 0,
 |  | unsigned | p2 = 0 |
 | ) |  |  | const [virtual]

Handle all errors possible in TKRcontributionIterator.

This method is used to handle errors occurring during the iteration over an TKRcontribution. By default it does nothing, however it is virtual and is able to be overridden by the user.

Parameters:
contribution | The contribution in error
code | The error code
p1 | a parameter associated with the error code
p2 | a parameter associated with the error code

unsigned TKRcontributionIterator::iterateStrips | ( | EBFevent * | event,
 |  | TKRcontribution * | contribution,
 |  | TKRmap * | map
 | ) |  |

Class for iterating over contributions to a TKR contributionIterate over tracker strip hits. This method calls the strip() virtual function back with every strip hit it finds. Strip data _must_ be iterated over before TOTs can be iterated over. This method uses the event and contribution provided by the caller and the map established by the caller.

Parameters:
event | A pointer to the EBFevent containing the contribution
contribution | A pointer to the contribution to iterate over
map | A pointer to the electronic space to detector space map
Returns:
The number of strips handled

unsigned TKRcontributionIterator::iterateStrips | ( | EBFevent * | event,
 |  | TKRcontribution * | contribution |
 | ) |  |  | [inline]

Iterate over tracker strip hits.

This method calls the strip() virtual function back with every strip hit it finds. Strip data _must_ be iterated over before TOTs can be iterated over. This method uses the event and contribution provided by the caller and the map established by the ctor.

Parameters:
event | A pointer to the EBFevent containing the contribution
contribution | A pointer to the contribution to iterate over
Returns:
The number of strips handled

unsigned TKRcontributionIterator::iterateStrips ( ) [inline]

Iterate over tracker strip data.

This method calls the strip() virtual function back with every strip it finds. This method uses the event, contribution and map established by the ctor.

Returns:
The number of strips handled

unsigned TKRcontributionIterator::iterateTOTs | ( | TKRcontribution * | contribution,
 |  | TKRmap * | map
 | ) |  |

Iterate over tracker TOT data.

This method calls the TOT() virtual function back with every TOT datum it finds. Strip data _must_ be iterated over before TOTs can be iterated over in order to find where the TOT data begins. This method uses the contribution and map provided by the caller.

Parameters:
contribution | A pointer to the contribution to iterate over
map | A pointer to the electronic space to detector space map
Returns:
The number of TOTs handled

unsigned TKRcontributionIterator::iterateTOTs ( TKRcontribution * contribution ) [inline]

Iterate over tracker TOT data.

This method calls the TOT() virtual function back with every TOT datum it finds. Strip data _must_ be iterated over before TOTs can be iterated over in order to find where the TOT data begins. This method uses the contribution provided by the caller and the map established by the ctor.

Parameters:
contribution A pointer to the contribution to iterate over
Returns:
The number of TOTs handled

unsigned TKRcontributionIterator::iterateTOTs ( ) [inline]

Iterate over tracker TOT data.

This method calls the TOT() virtual function back with every TOT datum it finds. Strip data _must_ be iterated over before TOTs can be iterated over in order to find where the TOT data begins. This method uses the contribution and map established by the ctor.

Returns:
The number of TOTs handled

const TKRmap* TKRcontributionIterator::map ( ) const [inline]

Return a pointer to the tracker map

virtual void TKRcontributionIterator::strip | ( | unsigned | tower,
 |  | unsigned | layerEnd,
 |  | unsigned | hit |
 | ) |  |  | [pure virtual]

Pure virtual method for calling the application back with a tracker strip hit value.

Parameters:
tower | - The tower (in detector space) the strip hit came from
layerEnd | - The layer-end (in detector space) the strip hit came from
hit | - The strip hit value

const unsigned TKRcontributionIterator::stripCount ( ) const [inline]

Return the number of strip hits found by TKRcontributionIterator::iterateStrips().

Returns:
The number of strip hits found by TKRcontributionIterator::iterateStrips()

virtual void TKRcontributionIterator::TOT | ( | unsigned | tower,
 |  | unsigned | layerEnd,
 |  | unsigned | tot |
 | ) |  |  | [pure virtual]

Pure virtual method for calling the application back with a tracker TOT value.

Parameters:
tower | - The tower (in detector space) the TOT came from
layerEnd | - The layer-end (in detector space) the TOT came from
tot | - The TOT value

The documentation for this class was generated from the following files:
  • TKRcontributionIterator.h
  • TKRcontributionIterator.cpp
Generated on Mon Jul 31 17:48:21 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

TKRcontributionIterator Member List

This is the complete list of members for TKRcontributionIterator, including all inherited members.

contribution() const | TKRcontributionIterator | [inline]
diagnostic() const | TKRcontributionIterator | [inline]
endTots(unsigned offset) | TKRcontributionIterator | [inline]
ERR_PastEnd enum value | TKRcontributionIterator |
ERR_WrongOrder enum value (defined in TKRcontributionIterator) | TKRcontributionIterator |
error() const | TKRcontributionIterator | [inline]
event() const | TKRcontributionIterator | [inline]
handleError(TKRcontribution *, unsigned code, unsigned p1=0, unsigned p2=0) const | TKRcontributionIterator | [virtual]
iterateStrips() | TKRcontributionIterator | [inline]
iterateStrips(EBFevent *, TKRcontribution *) | TKRcontributionIterator | [inline]
iterateStrips(EBFevent *, TKRcontribution *, TKRmap *) | TKRcontributionIterator |
iterateTOTs() | TKRcontributionIterator | [inline]
iterateTOTs(TKRcontribution *) | TKRcontributionIterator | [inline]
iterateTOTs(TKRcontribution *, TKRmap *) | TKRcontributionIterator |
map() const | TKRcontributionIterator | [inline]
strip(unsigned tower, unsigned layerEnd, unsigned hit)=0 | TKRcontributionIterator | [pure virtual]
stripCount() const | TKRcontributionIterator | [inline]
TKRcontributionIterator(EBFevent *, TKRcontribution *, TKRmap *) | TKRcontributionIterator | [inline]
TKRcontributionIterator(EBFevent *, TKRcontribution *) | TKRcontributionIterator | [inline]
TKRcontributionIterator(TKRmap *) | TKRcontributionIterator | [inline]
TKRcontributionIterator() | TKRcontributionIterator | [inline]
TOT(unsigned tower, unsigned layerEnd, unsigned tot)=0 | TKRcontributionIterator | [pure virtual]
~TKRcontributionIterator() (defined in TKRcontributionIterator) | TKRcontributionIterator | [inline, virtual]

Generated on Mon Jul 31 17:48:21 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: TKRdiagnostic Class Reference

TKRdiagnostic Class Reference

Class for accessing fields in the TKR diagnostic data word. More...

#include <TKRdiagnostic.h>

List of all members.

Public Member Functions

TKRdiagnostic (unsigned datum)
Constructor for initializing the TKRdiagnostic class with a value.
unsigned | GTRC (int gtrc)
Method for returning the state of a GTRC's a trigger request.
unsigned | datum ()
Method for returning the TKR diagnostic data word.

Static Public Member Functions

static unsigned | GTRC (unsigned datum, int gtrc)
Static method for returning the state of a GTRC's a trigger request.
static unsigned | datum (unsigned d)
Static method for returning the TKR diagnostic data word.

Detailed Description

Class for accessing fields in the TKR diagnostic data word.

Author:
Jim Panetta -- GLAST LAT I&T/Online - (panetta@slac.stanford.edu)
Revision
1.2
Date:
November 25, 2003 -- Created
Id
TKRdiagnostic.h,v 1.2 2004/04/02 03:11:34 claus Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

TKRdiagnostic::TKRdiagnostic ( unsigned datum ) [inline]

Constructor for initializing the TKRdiagnostic class with a value.

Parameters:
datum - A diagnostic data word

Member Function Documentation

unsigned TKRdiagnostic::datum ( ) [inline]

Method for returning the TKR diagnostic data word.

Returns:
The diagnostic data word

unsigned TKRdiagnostic::datum ( unsigned d ) [inline, static]

Static method for returning the TKR diagnostic data word.

Parameters:
d - A diagnostic data word
Returns:
The diagnostic data word

unsigned TKRdiagnostic::GTRC ( int gtrc ) [inline]

Method for returning the state of a GTRC's a trigger request.

Parameters:
gtrc - The GTRC number for which to return the trigger request state
Returns:
The GTRC's trigger request state

unsigned TKRdiagnostic::GTRC | ( | unsigned | datum,
 |  | int | gtrc |
 | ) |  |  | [inline, static]

Static method for returning the state of a GTRC's a trigger request.

Parameters:
datum | - A diagnostic data word
gtrc | - The GTRC number for which to return the trigger request state
Returns:
The GTRC's trigger request state

The documentation for this class was generated from the following file:
  • TKRdiagnostic.h
Generated on Mon Jul 31 17:48:21 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

TKRdiagnostic Member List

This is the complete list of members for TKRdiagnostic, including all inherited members.

datum(unsigned d) | TKRdiagnostic | [inline, static]
datum() | TKRdiagnostic | [inline]
GTRC(unsigned datum, int gtrc) | TKRdiagnostic | [inline, static]
GTRC(int gtrc) | TKRdiagnostic | [inline]
TKRdiagnostic(unsigned datum) | TKRdiagnostic | [inline]
TKRdiagnostic() (defined in TKRdiagnostic) | TKRdiagnostic | [inline]
~TKRdiagnostic() (defined in TKRdiagnostic) | TKRdiagnostic | [inline]

Generated on Mon Jul 31 17:48:21 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: TKRmap Class Reference

TKRmap Class Reference

Class for mapping a TKR contribution from electronics space to detector space. More...

#include <TKRmap.h>

Inheritance diagram for TKRmap:

[legend]
Collaboration diagram for TKRmap:

[legend]
List of all members.

Public Member Functions

virtual unsigned | layer (LATtypeId ebfId, unsigned cc, unsigned rc) const
Map cable controller and readout control number to layer number.
virtual unsigned | layerEnd (LATtypeId ebfId, unsigned cc, unsigned rc) const
Map cable controller and readout control number to layer-end.

Detailed Description

Class for mapping a TKR contribution from electronics space to detector space.

Author:
R. Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.2
Date:
February 24, 2004 -- Created
Id
TKRmap.h,v 1.2 2004/04/14 03:52:11 claus Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Member Function Documentation

unsigned TKRmap::layer | ( | LATtypeId | ebfId,
 |  | unsigned | cc,
 |  | unsigned | rc |
 | ) |  |  | const [inline, virtual]

Map cable controller and readout control number to layer number.

This method maps electronics space to detector space. This is used by the strip iterator to provide the layer number to the user's strip() virtual function. Layer runs from 0 to 35 and so doesn't indicate which side (which cable) a strip hit was read from.

Parameters:
ebfId | The EBF format typeId (version number)
cc | A cable controller number
rc | A readout controller number
Returns:
The layer number

unsigned TKRmap::layerEnd | ( | LATtypeId | ebfId,
 |  | unsigned | cc,
 |  | unsigned | rc |
 | ) |  |  | const [inline, virtual]

Map cable controller and readout control number to layer-end.

This method provides an opportunity to remap layerEnd number. This could be done based on the protocol version number, for example. LayerEnd runs from 0 to 71 and is used to provide addressing information to the TOT() virtual function. This value contains information indicating which side (which cable) a TOT value was read from. Divide layerEnd by 9 to retrieve the cable number. LayerEnd % 9 gives the GTRC number on the cable that read out the TOT. LayerEnd / 2 is the layer (uniplane) number in the sense of LAT-TD-00376. The lowest bit of layerEnd addresses the low/high end.

Parameters:
ebfId | The EBF format typeId (version number)
cc | A cable controller number
rc | A readout controller number
Returns:
The layer number

The documentation for this class was generated from the following file:
  • TKRmap.h
Generated on Mon Jul 31 17:48:21 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

TKRmap Member List

This is the complete list of members for TKRmap, including all inherited members.

layer(LATtypeId ebfId, unsigned cc, unsigned rc) const | TKRmap | [inline, virtual]
layerEnd(LATtypeId ebfId, unsigned cc, unsigned rc) const | TKRmap | [inline, virtual]
TKRmap() (defined in TKRmap) | TKRmap | [inline]
tower(LATtypeId evtId, unsigned id) const | TWRmap | [inline, virtual]
TWRmap() (defined in TWRmap) | TWRmap | [inline]
~TKRmap() (defined in TKRmap) | TKRmap | [inline, virtual]
~TWRmap() (defined in TWRmap) | TWRmap | [inline, virtual]

Generated on Mon Jul 31 17:48:21 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: TKRstrip Class Reference

TKRstrip Class Reference

Class for accessing fields in the TKR strip data 12 bit word. More...

#include <TKRstrip.h>

List of all members.

Public Member Functions

TKRstrip (unsigned datum)
Constructor for initializing the TKRstrip class with a strip descriptor.
unsigned | done ()
Method for returning the state of the done bit.
unsigned | gtfe ()
Method for returning the GTFE number that produced the hit.
unsigned | strip ()
Method for returning the strip number from 0 to 63 that produced the hit.
unsigned | stripAdx ()
Method for returning the strip number from 0 to 1535 that produced the hit.

Static Public Member Functions

static unsigned | done (unsigned datum)
Static method for returning the state of the done bit.
static unsigned | gtfe (unsigned datum)
Static method for returning the GTFE number that produced the hit.
static unsigned | strip (unsigned datum)
Static method for returning the strip number from 0 to 63 that produced the hit.
static unsigned | stripAdx (unsigned datum)
Static method for returning the strip number from 0 to 1535 that produced the hit.

Detailed Description

Class for accessing fields in the TKR strip data 12 bit word.

Author:
Ric Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.2
Date:
January 27, 2003 -- Created
Id
TKRstrip.h,v 1.2 2004/04/01 23:53:36 claus Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Constructor & Destructor Documentation

TKRstrip::TKRstrip ( unsigned datum ) [inline]

Constructor for initializing the TKRstrip class with a strip descriptor.

Parameters:
datum - A strip descriptor

Member Function Documentation

unsigned TKRstrip::done ( unsigned datum ) [inline, static]

Static method for returning the state of the done bit.

Parameters:
datum - A strip descriptor

unsigned TKRstrip::gtfe ( unsigned datum ) [inline, static]

Static method for returning the GTFE number that produced the hit.

Parameters:
datum - A strip descriptor

unsigned TKRstrip::strip ( unsigned datum ) [inline, static]

Static method for returning the strip number from 0 to 63 that produced the hit.

Parameters:
datum - A strip descriptor

unsigned TKRstrip::stripAdx ( unsigned datum ) [inline, static]

Static method for returning the strip number from 0 to 1535 that produced the hit.

Parameters:
datum - A strip descriptor

The documentation for this class was generated from the following file:
  • TKRstrip.h
Generated on Mon Jul 31 17:48:21 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

TKRstrip Member List

This is the complete list of members for TKRstrip, including all inherited members.

done(unsigned datum) | TKRstrip | [inline, static]
done() | TKRstrip | [inline]
gtfe(unsigned datum) | TKRstrip | [inline, static]
gtfe() | TKRstrip | [inline]
strip(unsigned datum) | TKRstrip | [inline, static]
strip() | TKRstrip | [inline]
stripAdx(unsigned datum) | TKRstrip | [inline, static]
stripAdx() | TKRstrip | [inline]
TKRstrip(unsigned datum) | TKRstrip | [inline]
TKRstrip() (defined in TKRstrip) | TKRstrip | [inline]
~TKRstrip() (defined in TKRstrip) | TKRstrip | [inline]

Generated on Mon Jul 31 17:48:21 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: TWRmap Class Reference

TWRmap Class Reference

Class for mapping a TEM's contribution from electronics space to detector space. More...

#include <TWRmap.h>

Inheritance diagram for TWRmap:

[legend]
List of all members.

Public Member Functions

virtual unsigned tower (LATtypeId evtId, unsigned id) const
Map a contribution source ID to a tower bay number.

Detailed Description

Class for mapping a TEM's contribution from electronics space to detector space.

Author:
R. Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
Revision
1.2
Date:
February 24, 2004 -- Created
Id
TWRmap.h,v 1.2 2004/04/14 03:52:11 claus Exp

Copyright: Copyright 2004 by The Board of Trustees of the Leland Stanford Junior University. All rights reserved.

Member Function Documentation

unsigned TWRmap::tower | ( | LATtypeId | evtId,
 |  | unsigned | id |
 | ) |  |  | const [inline, virtual]

Map a contribution source ID to a tower bay number.

This method maps a contribution source address to a tower address. This could be done based on the protocol version number, for example.

Parameters:
evtId | The EBF format typeId (version number)
id | The contribution source ID
Returns:
The tower bay ID

The documentation for this class was generated from the following file:
  • TWRmap.h
Generated on Mon Jul 31 17:48:21 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Member List

TWRmap Member List

This is the complete list of members for TWRmap, including all inherited members.

tower(LATtypeId evtId, unsigned id) const | TWRmap | [inline, virtual]
TWRmap() (defined in TWRmap) | TWRmap | [inline]
~TWRmap() (defined in TWRmap) | TWRmap | [inline, virtual]

Generated on Mon Jul 31 17:48:21 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Hierarchical Index

LDF Class Hierarchy

Go to the graphical class hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:

  • ACDmap
  • ACDpha
  • ACDtileSide
  • AEMcontributionIterator
  • AEMheader
  • ASCcno
  • ASCcontributionIterator
  • ASCsummary
  • ASCtile
  • ASCtileContribution
  • ASCtileContributionIterator
  • CALcontributionIterator
  • CALdiagnostic
  • CALlog
  • CALlogEnd
  • DIAGcontributionIterator
  • EBFcontribution
    • AEMcontribution
    • GEMcontribution
    • GLTcontribution
    • TEMcontribution
      • CALcontribution
      • TKRcontribution
  • EBFcontributionIterator
    • LATcomponentIterator
  • EBFeventIterator
    • LDBI_EBFeventIterator
  • ERRcontributionIterator
  • ErrorSummary
  • EventSummary
  • GCCCerror
  • GEMcondArrivalTime
  • GEMonePPStime
  • GEMtileList
  • GTCCerror
  • GTRCerror
  • LATcontribution
    • ASCcontribution
    • EBFevent
  • LATcontributionIterator
    • LDBI_LATcontributionIterator
  • LATdataBufferIterator
  • LATdatagram
  • LATdatagramIterator
    • LDBI_LATdatagramIterator
  • LATPcellHeader
  • LATprimaryId
  • LATsecondaryId
  • LATtypeId
  • LDFversion
  • OSWcontributionIterator
  • OSWtimeBase
  • OSWtimeContribution
  • OSWtimeSpec
  • TEMcontributionIterator
    • LATcomponentIterator
  • TKRcontributionIterator
  • TKRdiagnostic
  • TKRstrip
  • TWRmap
    • CALmap
    • TKRmap
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • All
  • Functions
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • a() : ACDtileSide
  • acceptMap() : AEMheader
  • accepts() : TKRcontribution
  • acceptsMask() : TKRcontribution
  • ACDcomponent() : LATcomponentIterator
  • ACDmap() : ACDmap
  • ACDpha() : ACDpha
  • ACDtileSide() : ACDtileSide
  • ADCrange() : ACDpha
  • ADCvalue() : ACDpha
  • AEM() : LATcomponentIterator, EBFcontributionIterator
  • aemContribution() : EBFcontribution
  • AEMcontributionIterator() : AEMcontributionIterator
  • AEMheader() : AEMheader
  • alloc() : LATdatagram
  • ASC() : LATcontributionIterator
  • ASCcno() : ASCcno
  • ASCcontributionIterator() : ASCcontributionIterator
  • ascDatagram() : ASCtileContributionIterator
  • ASCsummary() : ASCsummary
  • ASCtile() : ASCtile
  • ASCtileContribution() : ASCtileContribution
  • ASCtileContributionIterator() : ASCtileContributionIterator
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • All
  • Functions
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • LATcomponentIterator() : LATcomponentIterator
  • LATcontribution() : LATcontribution
  • LATcontributionIterator() : LATcontributionIterator
  • LATdataBufferIterator() : LATdataBufferIterator
  • LATdatagram() : LATdatagram
  • LATdatagramIterator() : LATdatagramIterator
  • LATPcellHeader() : LATPcellHeader
  • LATtypeId() : LATtypeId
  • layer() : TKRmap
  • layer0Tag() : GTRCerror
  • layerEnd() : TKRmap
  • layerID() : CALmap
  • LDBI_EBFeventIterator() : LDBI_EBFeventIterator
  • LDBI_LATcontributionIterator() : LDBI_LATcontributionIterator
  • LDBI_LATdatagramIterator() : LDBI_LATdatagramIterator
  • length() : LATdatagram, LATcontribution, EBFcontribution
  • liveTime() : GEMcontribution
  • log() : CALcontributionIterator
  • logAccepts() : TEMcontribution, CALdiagnostic
  • lookup() : ACDmap
  • low() : CALdiagnostic
  • lower() : OSWtimeBase
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • All
  • Functions
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • major() : LDFversion
  • map() : TKRcontributionIterator, ERRcontributionIterator, CALcontributionIterator, ASCtileContributionIterator, ASCcontributionIterator, AEMcontributionIterator
  • marker() : EventSummary
  • minor() : LDFversion
  • missed() : GEMcontribution
  • more() : LATPcellHeader, ACDpha
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • All
  • Functions
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • NA() : GEMtileList
  • name() : ACDtileSide
  • negative() : CALlog
  • next() : LATdatagram, LATcontribution, EBFcontribution
  • nsec() : OSWtimeSpec
  • numAccepts() : TKRcontribution
  • numLogAccepts() : TEMcontribution
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • All
  • Functions
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • offset() : ERRcontributionIterator, DIAGcontributionIterator
  • onePPStime() : GEMcontribution
  • operator delete() : LATdatagram, LATcontribution
  • operator new() : LATdatagram, LATcontribution
  • operator!=() : LATtypeId
  • operator=() : LATtypeId
  • operator==() : LATtypeId
  • OSW() : LATcomponentIterator, EBFcontributionIterator
  • OSW_time() : OSWcontributionIterator
  • OSW_UDF() : OSWcontributionIterator
  • OSWcomponent() : LATcomponentIterator
  • oswContribution() : EBFcontribution
  • OSWcontributionIterator() : OSWcontributionIterator
  • OSWtime() : OSWcontributionIterator
  • OSWtimeBase() : OSWtimeBase
  • OSWtimeContribution() : OSWtimeContribution
  • OSWtimeSpec() : OSWtimeSpec
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • All
  • Functions
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- z -

  • zeroSuppress() : EventSummary
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • All
  • Functions
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- ~ -

  • ~LATtypeId() : LATtypeId
  • ~OSWtimeContribution() : OSWtimeContribution
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • All
  • Functions
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • Base_ACD : LATsecondaryId, LATprimaryId
  • Base_CAL : LATsecondaryId, LATprimaryId
  • Base_OEF : LATsecondaryId, LATprimaryId
  • Base_OSW : LATsecondaryId, LATprimaryId
  • Base_Scratch : LATsecondaryId, LATprimaryId
  • Base_TKR : LATsecondaryId, LATprimaryId
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • All
  • Functions
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • cableNumber() : AEMheader
  • cableTMO() : GTCCerror
  • cal() : ErrorSummary
  • CAL() : TEMcontributionIterator, LATcomponentIterator
  • CALcomponent() : LATcomponentIterator
  • calContribution() : TEMcontribution
  • CALcontributionIterator() : CALcontributionIterator
  • CALdiag() : DIAGcontributionIterator
  • CALdiagnostic() : CALdiagnostic
  • CALend() : TEMcontributionIterator, CALcontributionIterator
  • calHE() : GEMcondArrivalTime
  • calHEvector() : GEMcontribution
  • calLE() : GEMcondArrivalTime
  • calLEvector() : GEMcontribution
  • CALlog() : CALlog
  • CALlogEnd() : CALlogEnd
  • calMap() : DIAGcontributionIterator
  • calStrobe() : EventSummary
  • cleanup() : TEMcontributionIterator, LATcomponentIterator
  • cno() : GEMcondArrivalTime, ASCcontributionIterator
  • cnoPtr() : ASCcontribution
  • cnoVector() : GEMcontribution
  • column() : CALlog
  • condArrTime() : GEMcontribution
  • conditionSummary() : GEMcontribution
  • contribution() : TKRcontributionIterator, TEMcontributionIterator, OSWcontributionIterator, ERRcontributionIterator, DIAGcontributionIterator, CALcontributionIterator, ASCtileContributionIterator, ASCcontributionIterator, AEMcontributionIterator
  • counts() : ASCtile, ASCsummary, ASCcno
  • counts_fired() : ASCcno
  • create() : LATdatagram, LATcontribution, EBFevent, ASCcontribution
  • currentTag() : GTRCerror
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • All
  • Functions
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • data() : TKRcontribution, GLTcontribution, GEMcontribution, CALcontribution, AEMcontribution
  • datagram() : LATcontributionIterator
  • dataParity() : GTCCerror
  • datum() : TKRdiagnostic, GEMcondArrivalTime, CALlogEnd, CALlog, CALdiagnostic, ACDpha
  • deadZone() : GEMcontribution
  • deltaEventTime() : GEMcontribution
  • deltaWindowOpenTime() : GEMcontribution
  • destination() : LATPcellHeader
  • DIAGcontributionIterator() : DIAGcontributionIterator
  • diagnostic() : TKRcontributionIterator, TEMcontributionIterator, LATcomponentIterator, EventSummary
  • diagnosticEnd() : TEMcontributionIterator
  • discarded() : GEMcontribution
  • done() : TKRstrip
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • All
  • Functions
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • EBF() : LDBI_LATcontributionIterator, LATcontributionIterator
  • EBFcontributionIterator() : EBFcontributionIterator
  • EBFeventIterator() : EBFeventIterator
  • end() : LATdatagramIterator, EBFeventIterator
  • endOfCables() : AEMheader
  • endTots() : TKRcontributionIterator
  • ERR_PastEnd : TKRcontributionIterator
  • ERRcontributionIterator() : ERRcontributionIterator
  • error() : TKRcontributionIterator, TEMcontributionIterator, LATcomponentIterator, EventSummary
  • errorEnd() : TEMcontributionIterator
  • ErrorSummary() : ErrorSummary
  • event() : TKRcontributionIterator, TEMcontributionIterator, OSWcontributionIterator, LATdatagram, ERRcontributionIterator, EBFcontributionIterator, DIAGcontributionIterator, CALcontributionIterator, AEMcontributionIterator
  • eventNumber() : EventSummary
  • EventSummary() : EventSummary
  • evtSeqMSW() : OSWtimeContribution
  • evtSequence() : OSWtimeContribution
  • expectedLayer() : GTRCerror
  • external() : GEMcondArrivalTime
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • All
  • Functions
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • FEphase() : GTCCerror
  • FIFOfull() : GTCCerror
  • freeName() : ACDmap
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • All
  • Functions
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • gcccError() : ERRcontributionIterator
  • GCCCerror() : GCCCerror
  • GEM() : LATcomponentIterator, EBFcontributionIterator
  • GEMcomponent() : LATcomponentIterator
  • gemContribution() : EBFcontribution
  • getPrimary() : LATtypeId
  • getSecondary() : LATtypeId
  • GLT() : LATcomponentIterator, EBFcontributionIterator
  • GLTcomponent() : LATcomponentIterator
  • gltContribution() : EBFcontribution
  • gtccDataParityError() : ERRcontributionIterator
  • gtccError() : ERRcontributionIterator
  • GTCCerror() : GTCCerror
  • gtccFIFOerror() : ERRcontributionIterator
  • gtccHDRParityError() : ERRcontributionIterator
  • gtccTMOerror() : ERRcontributionIterator
  • gtccWCParityError() : ERRcontributionIterator
  • gtfe() : TKRstrip
  • gtfePhaseError() : ERRcontributionIterator
  • GTRC() : TKRdiagnostic, GTCCerror
  • GTRCerror() : GTRCerror
  • gtrcPhaseError() : ERRcontributionIterator
  • gtrcSummaryError() : ERRcontributionIterator
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • All
  • Functions
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • handleError() : TKRcontributionIterator, TEMcontributionIterator, OSWcontributionIterator, LATdatagramIterator, LDBI_EBFeventIterator, LATcontributionIterator, LATcomponentIterator, ERRcontributionIterator, EBFeventIterator, EBFcontributionIterator, DIAGcontributionIterator, CALcontributionIterator, ASCtileContributionIterator, ASCcontributionIterator, AEMcontributionIterator
  • hdrParity() : GTCCerror
  • header() : EBFcontribution, AEMcontributionIterator
  • high() : CALdiagnostic
  • hitMap() : AEMheader
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • All
  • Functions
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • identity() : LATdatagram, LATcontribution
  • iterate() : TEMcontributionIterator, OSWcontributionIterator, LATdatagramIterator, LATdataBufferIterator, LATcontributionIterator, LATcomponentIterator, ERRcontributionIterator, EBFeventIterator, EBFcontributionIterator, CALcontributionIterator, ASCtileContributionIterator, ASCcontributionIterator, AEMcontributionIterator
  • iterateCAL() : DIAGcontributionIterator
  • iterateStrips() : TKRcontributionIterator
  • iterateTKR() : DIAGcontributionIterator
  • iterateTOTs() : TKRcontributionIterator
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • All
  • Functions
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • packetError() : EBFcontribution
  • param() : GCCCerror
  • parity() : LATPcellHeader
  • parityError() : AEMheader, ACDpha
  • payload() : LATdatagram, EBFevent, EBFcontribution
  • payloadSize() : LATdatagram, EBFevent, EBFcontribution
  • pha() : AEMcontributionIterator
  • phaseError() : ERRcontributionIterator
  • phaVector() : AEMheader
  • phs() : ErrorSummary
  • positive() : CALlog
  • prescaled() : GEMcontribution
  • process() : LATdatagramIterator, LDBI_LATdatagramIterator, LDBI_EBFeventIterator, EBFeventIterator
  • protocol() : LATPcellHeader
  • ptr() : ASCtileContribution, ASCsummary
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • All
  • Functions
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • range() : CALlogEnd
  • raw() : GTRCerror, GTCCerror, GCCCerror
  • rawData() : LATcontribution
  • rawDataSize() : LATcontribution
  • RBN() : GEMtileList
  • RCphase() : GTCCerror
  • RCsummary() : GTCCerror
  • readout4() : EventSummary
  • receivedLayer() : GTRCerror
  • respond() : LATPcellHeader
  • revision() : LDFversion
  • roi() : GEMcondArrivalTime
  • roiVector() : GEMcontribution
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • All
  • Functions
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • sec() : OSWtimeSpec
  • seconds() : GEMonePPStime
  • sent() : GEMcontribution
  • sequence() : EBFcontribution
  • setPrimary() : LATtypeId
  • setSecondary() : LATtypeId
  • size() : ERRcontributionIterator, DIAGcontributionIterator
  • source() : LATPcellHeader
  • start() : LATdatagramIterator, EBFeventIterator
  • startBit() : AEMheader
  • status() : TEMcontributionIterator, OSWcontributionIterator, LATdatagramIterator, LATcontributionIterator, ERRcontributionIterator, EBFeventIterator, EBFevent, EBFcontributionIterator, DIAGcontributionIterator, ASCcontributionIterator
  • string() : LATdatagram, LATcontribution, EBFevent, ASCcontribution
  • strip() : TKRstrip, TKRcontributionIterator
  • stripAdx() : TKRstrip
  • stripCount() : TKRcontributionIterator
  • summary() : EBFevent, EBFcontribution, ASCcontributionIterator
  • summaryPtr() : ASCcontribution
  • sweep() : GCCCerror
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • All
  • Functions
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • TACK() : EventSummary
  • tag() : EventSummary
  • TEM() : LATcomponentIterator, EBFcontributionIterator
  • temContribution() : EBFcontribution
  • TEMcontributionIterator() : TEMcontributionIterator
  • theError() : ERRcontributionIterator
  • tile() : ASCtileContributionIterator, ACDtileSide
  • tileList() : GEMcontribution
  • tileNameFromGemIndex() : ACDmap
  • tiles() : ASCcontributionIterator
  • tilesPtr() : ASCcontribution
  • timebase() : OSWtimeContribution, OSWtimeBase, GLTcontribution, GEMonePPStime
  • timeoutError() : ERRcontributionIterator
  • timespec() : OSWtimeSpec
  • timeStamp() : OSWtimeContribution, GLTcontribution
  • tkr() : GEMcondArrivalTime, ErrorSummary
  • TKR() : TEMcontributionIterator, LATcomponentIterator
  • TKRcomponent() : LATcomponentIterator
  • tkrContribution() : TEMcontribution
  • TKRcontributionIterator() : TKRcontributionIterator
  • TKRdiag() : DIAGcontributionIterator
  • TKRdiagnostic() : TKRdiagnostic
  • TKRend() : TEMcontributionIterator
  • tkrMap() : DIAGcontributionIterator
  • TKRstrip() : TKRstrip
  • tkrVector() : GEMcontribution
  • tmo() : ErrorSummary
  • TOT() : TKRcontributionIterator
  • tower() : TWRmap
  • trgParityError() : EventSummary
  • triggerTime() : GEMcontribution
  • type() : GCCCerror
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • All
  • Functions
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • UDF() : LATcontributionIterator, LATcomponentIterator, EBFcontributionIterator
  • UDFcomponent() : LATcomponentIterator
  • upper() : OSWtimeBase
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • All
  • Functions
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • value() : LATtypeId, CALlogEnd
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • All
  • Functions
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • wrdCntParity() : GTCCerror
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • All
  • Functions
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- x -

  • XY() : GEMtileList
  • XZM() : GEMtileList
  • XZP() : GEMtileList
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • All
  • Functions
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- y -

  • YZM() : GEMtileList
  • YZP() : GEMtileList
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members - Enumerator

  • All
  • Functions
  • Enumerator

  • Base_ACD : LATsecondaryId, LATprimaryId
  • Base_CAL : LATsecondaryId, LATprimaryId
  • Base_OEF : LATsecondaryId, LATprimaryId
  • Base_OSW : LATsecondaryId, LATprimaryId
  • Base_Scratch : LATsecondaryId, LATprimaryId
  • Base_TKR : LATsecondaryId, LATprimaryId
  • ERR_PastEnd : TKRcontributionIterator
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members - Functions

  • All
  • Functions
  • Enumerator
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- a -

  • a() : ACDtileSide
  • acceptMap() : AEMheader
  • accepts() : TKRcontribution
  • acceptsMask() : TKRcontribution
  • ACDcomponent() : LATcomponentIterator
  • ACDmap() : ACDmap
  • ACDpha() : ACDpha
  • ACDtileSide() : ACDtileSide
  • ADCrange() : ACDpha
  • ADCvalue() : ACDpha
  • AEM() : LATcomponentIterator, EBFcontributionIterator
  • aemContribution() : EBFcontribution
  • AEMcontributionIterator() : AEMcontributionIterator
  • AEMheader() : AEMheader
  • alloc() : LATdatagram
  • ASC() : LATcontributionIterator
  • ASCcno() : ASCcno
  • ASCcontributionIterator() : ASCcontributionIterator
  • ascDatagram() : ASCtileContributionIterator
  • ASCsummary() : ASCsummary
  • ASCtile() : ASCtile
  • ASCtileContribution() : ASCtileContribution
  • ASCtileContributionIterator() : ASCtileContributionIterator
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members - Functions

  • All
  • Functions
  • Enumerator
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- l -

  • LATcomponentIterator() : LATcomponentIterator
  • LATcontribution() : LATcontribution
  • LATcontributionIterator() : LATcontributionIterator
  • LATdataBufferIterator() : LATdataBufferIterator
  • LATdatagram() : LATdatagram
  • LATdatagramIterator() : LATdatagramIterator
  • LATPcellHeader() : LATPcellHeader
  • LATtypeId() : LATtypeId
  • layer() : TKRmap
  • layer0Tag() : GTRCerror
  • layerEnd() : TKRmap
  • layerID() : CALmap
  • LDBI_EBFeventIterator() : LDBI_EBFeventIterator
  • LDBI_LATcontributionIterator() : LDBI_LATcontributionIterator
  • LDBI_LATdatagramIterator() : LDBI_LATdatagramIterator
  • length() : LATdatagram, LATcontribution, EBFcontribution
  • liveTime() : GEMcontribution
  • log() : CALcontributionIterator
  • logAccepts() : TEMcontribution, CALdiagnostic
  • lookup() : ACDmap
  • low() : CALdiagnostic
  • lower() : OSWtimeBase
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members - Functions

  • All
  • Functions
  • Enumerator
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- m -

  • major() : LDFversion
  • map() : TKRcontributionIterator, ERRcontributionIterator, CALcontributionIterator, ASCtileContributionIterator, ASCcontributionIterator, AEMcontributionIterator
  • marker() : EventSummary
  • minor() : LDFversion
  • missed() : GEMcontribution
  • more() : LATPcellHeader, ACDpha
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members - Functions

  • All
  • Functions
  • Enumerator
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- n -

  • NA() : GEMtileList
  • name() : ACDtileSide
  • negative() : CALlog
  • next() : LATdatagram, LATcontribution, EBFcontribution
  • nsec() : OSWtimeSpec
  • numAccepts() : TKRcontribution
  • numLogAccepts() : TEMcontribution
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members - Functions

  • All
  • Functions
  • Enumerator
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- o -

  • offset() : ERRcontributionIterator, DIAGcontributionIterator
  • onePPStime() : GEMcontribution
  • operator delete() : LATdatagram, LATcontribution
  • operator new() : LATdatagram, LATcontribution
  • operator!=() : LATtypeId
  • operator=() : LATtypeId
  • operator==() : LATtypeId
  • OSW() : LATcomponentIterator, EBFcontributionIterator
  • OSW_time() : OSWcontributionIterator
  • OSW_UDF() : OSWcontributionIterator
  • OSWcomponent() : LATcomponentIterator
  • oswContribution() : EBFcontribution
  • OSWcontributionIterator() : OSWcontributionIterator
  • OSWtime() : OSWcontributionIterator
  • OSWtimeBase() : OSWtimeBase
  • OSWtimeContribution() : OSWtimeContribution
  • OSWtimeSpec() : OSWtimeSpec
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members - Functions

  • All
  • Functions
  • Enumerator
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- z -

  • zeroSuppress() : EventSummary
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members - Functions

  • All
  • Functions
  • Enumerator
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- ~ -

  • ~LATtypeId() : LATtypeId
  • ~OSWtimeContribution() : OSWtimeContribution
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members - Functions

  • All
  • Functions
  • Enumerator
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- c -

  • cableNumber() : AEMheader
  • cableTMO() : GTCCerror
  • cal() : ErrorSummary
  • CAL() : TEMcontributionIterator, LATcomponentIterator
  • CALcomponent() : LATcomponentIterator
  • calContribution() : TEMcontribution
  • CALcontributionIterator() : CALcontributionIterator
  • CALdiag() : DIAGcontributionIterator
  • CALdiagnostic() : CALdiagnostic
  • CALend() : TEMcontributionIterator, CALcontributionIterator
  • calHE() : GEMcondArrivalTime
  • calHEvector() : GEMcontribution
  • calLE() : GEMcondArrivalTime
  • calLEvector() : GEMcontribution
  • CALlog() : CALlog
  • CALlogEnd() : CALlogEnd
  • calMap() : DIAGcontributionIterator
  • calStrobe() : EventSummary
  • cleanup() : TEMcontributionIterator, LATcomponentIterator
  • cno() : GEMcondArrivalTime, ASCcontributionIterator
  • cnoPtr() : ASCcontribution
  • cnoVector() : GEMcontribution
  • column() : CALlog
  • condArrTime() : GEMcontribution
  • conditionSummary() : GEMcontribution
  • contribution() : TKRcontributionIterator, TEMcontributionIterator, OSWcontributionIterator, ERRcontributionIterator, DIAGcontributionIterator, CALcontributionIterator, ASCtileContributionIterator, ASCcontributionIterator, AEMcontributionIterator
  • counts() : ASCtile, ASCsummary, ASCcno
  • counts_fired() : ASCcno
  • create() : LATdatagram, LATcontribution, EBFevent, ASCcontribution
  • currentTag() : GTRCerror
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members - Functions

  • All
  • Functions
  • Enumerator
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- d -

  • data() : TKRcontribution, GLTcontribution, GEMcontribution, CALcontribution, AEMcontribution
  • datagram() : LATcontributionIterator
  • dataParity() : GTCCerror
  • datum() : TKRdiagnostic, GEMcondArrivalTime, CALlogEnd, CALlog, CALdiagnostic, ACDpha
  • deadZone() : GEMcontribution
  • deltaEventTime() : GEMcontribution
  • deltaWindowOpenTime() : GEMcontribution
  • destination() : LATPcellHeader
  • DIAGcontributionIterator() : DIAGcontributionIterator
  • diagnostic() : TKRcontributionIterator, TEMcontributionIterator, LATcomponentIterator, EventSummary
  • diagnosticEnd() : TEMcontributionIterator
  • discarded() : GEMcontribution
  • done() : TKRstrip
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members - Functions

  • All
  • Functions
  • Enumerator
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- e -

  • EBF() : LDBI_LATcontributionIterator, LATcontributionIterator
  • EBFcontributionIterator() : EBFcontributionIterator
  • EBFeventIterator() : EBFeventIterator
  • end() : LATdatagramIterator, EBFeventIterator
  • endOfCables() : AEMheader
  • endTots() : TKRcontributionIterator
  • ERRcontributionIterator() : ERRcontributionIterator
  • error() : TKRcontributionIterator, TEMcontributionIterator, LATcomponentIterator, EventSummary
  • errorEnd() : TEMcontributionIterator
  • ErrorSummary() : ErrorSummary
  • event() : TKRcontributionIterator, TEMcontributionIterator, OSWcontributionIterator, LATdatagram, ERRcontributionIterator, EBFcontributionIterator, DIAGcontributionIterator, CALcontributionIterator, AEMcontributionIterator
  • eventNumber() : EventSummary
  • EventSummary() : EventSummary
  • evtSeqMSW() : OSWtimeContribution
  • evtSequence() : OSWtimeContribution
  • expectedLayer() : GTRCerror
  • external() : GEMcondArrivalTime
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members - Functions

  • All
  • Functions
  • Enumerator
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- f -

  • FEphase() : GTCCerror
  • FIFOfull() : GTCCerror
  • freeName() : ACDmap
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members - Functions

  • All
  • Functions
  • Enumerator
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- g -

  • gcccError() : ERRcontributionIterator
  • GCCCerror() : GCCCerror
  • GEM() : LATcomponentIterator, EBFcontributionIterator
  • GEMcomponent() : LATcomponentIterator
  • gemContribution() : EBFcontribution
  • getPrimary() : LATtypeId
  • getSecondary() : LATtypeId
  • GLT() : LATcomponentIterator, EBFcontributionIterator
  • GLTcomponent() : LATcomponentIterator
  • gltContribution() : EBFcontribution
  • gtccDataParityError() : ERRcontributionIterator
  • gtccError() : ERRcontributionIterator
  • GTCCerror() : GTCCerror
  • gtccFIFOerror() : ERRcontributionIterator
  • gtccHDRParityError() : ERRcontributionIterator
  • gtccTMOerror() : ERRcontributionIterator
  • gtccWCParityError() : ERRcontributionIterator
  • gtfe() : TKRstrip
  • gtfePhaseError() : ERRcontributionIterator
  • GTRC() : TKRdiagnostic, GTCCerror
  • GTRCerror() : GTRCerror
  • gtrcPhaseError() : ERRcontributionIterator
  • gtrcSummaryError() : ERRcontributionIterator
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members - Functions

  • All
  • Functions
  • Enumerator
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- h -

  • handleError() : TKRcontributionIterator, TEMcontributionIterator, OSWcontributionIterator, LATdatagramIterator, LDBI_EBFeventIterator, LATcontributionIterator, LATcomponentIterator, ERRcontributionIterator, EBFeventIterator, EBFcontributionIterator, DIAGcontributionIterator, CALcontributionIterator, ASCtileContributionIterator, ASCcontributionIterator, AEMcontributionIterator
  • hdrParity() : GTCCerror
  • header() : EBFcontribution, AEMcontributionIterator
  • high() : CALdiagnostic
  • hitMap() : AEMheader
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members - Functions

  • All
  • Functions
  • Enumerator
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- i -

  • identity() : LATdatagram, LATcontribution
  • iterate() : TEMcontributionIterator, OSWcontributionIterator, LATdatagramIterator, LATdataBufferIterator, LATcontributionIterator, LATcomponentIterator, ERRcontributionIterator, EBFeventIterator, EBFcontributionIterator, CALcontributionIterator, ASCtileContributionIterator, ASCcontributionIterator, AEMcontributionIterator
  • iterateCAL() : DIAGcontributionIterator
  • iterateStrips() : TKRcontributionIterator
  • iterateTKR() : DIAGcontributionIterator
  • iterateTOTs() : TKRcontributionIterator
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members - Functions

  • All
  • Functions
  • Enumerator
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- p -

  • packetError() : EBFcontribution
  • param() : GCCCerror
  • parity() : LATPcellHeader
  • parityError() : AEMheader, ACDpha
  • payload() : LATdatagram, EBFevent, EBFcontribution
  • payloadSize() : LATdatagram, EBFevent, EBFcontribution
  • pha() : AEMcontributionIterator
  • phaseError() : ERRcontributionIterator
  • phaVector() : AEMheader
  • phs() : ErrorSummary
  • positive() : CALlog
  • prescaled() : GEMcontribution
  • process() : LATdatagramIterator, LDBI_LATdatagramIterator, LDBI_EBFeventIterator, EBFeventIterator
  • protocol() : LATPcellHeader
  • ptr() : ASCtileContribution, ASCsummary
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members - Functions

  • All
  • Functions
  • Enumerator
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- r -

  • range() : CALlogEnd
  • raw() : GTRCerror, GTCCerror, GCCCerror
  • rawData() : LATcontribution
  • rawDataSize() : LATcontribution
  • RBN() : GEMtileList
  • RCphase() : GTCCerror
  • RCsummary() : GTCCerror
  • readout4() : EventSummary
  • receivedLayer() : GTRCerror
  • respond() : LATPcellHeader
  • revision() : LDFversion
  • roi() : GEMcondArrivalTime
  • roiVector() : GEMcontribution
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members - Functions

  • All
  • Functions
  • Enumerator
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- s -

  • sec() : OSWtimeSpec
  • seconds() : GEMonePPStime
  • sent() : GEMcontribution
  • sequence() : EBFcontribution
  • setPrimary() : LATtypeId
  • setSecondary() : LATtypeId
  • size() : ERRcontributionIterator, DIAGcontributionIterator
  • source() : LATPcellHeader
  • start() : LATdatagramIterator, EBFeventIterator
  • startBit() : AEMheader
  • status() : TEMcontributionIterator, OSWcontributionIterator, LATdatagramIterator, LATcontributionIterator, ERRcontributionIterator, EBFeventIterator, EBFevent, EBFcontributionIterator, DIAGcontributionIterator, ASCcontributionIterator
  • string() : LATdatagram, LATcontribution, EBFevent, ASCcontribution
  • strip() : TKRstrip, TKRcontributionIterator
  • stripAdx() : TKRstrip
  • stripCount() : TKRcontributionIterator
  • summary() : EBFevent, EBFcontribution, ASCcontributionIterator
  • summaryPtr() : ASCcontribution
  • sweep() : GCCCerror
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members - Functions

  • All
  • Functions
  • Enumerator
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- t -

  • TACK() : EventSummary
  • tag() : EventSummary
  • TEM() : LATcomponentIterator, EBFcontributionIterator
  • temContribution() : EBFcontribution
  • TEMcontributionIterator() : TEMcontributionIterator
  • theError() : ERRcontributionIterator
  • tile() : ASCtileContributionIterator, ACDtileSide
  • tileList() : GEMcontribution
  • tileNameFromGemIndex() : ACDmap
  • tiles() : ASCcontributionIterator
  • tilesPtr() : ASCcontribution
  • timebase() : OSWtimeContribution, OSWtimeBase, GLTcontribution, GEMonePPStime
  • timeoutError() : ERRcontributionIterator
  • timespec() : OSWtimeSpec
  • timeStamp() : OSWtimeContribution, GLTcontribution
  • tkr() : GEMcondArrivalTime, ErrorSummary
  • TKR() : TEMcontributionIterator, LATcomponentIterator
  • TKRcomponent() : LATcomponentIterator
  • tkrContribution() : TEMcontribution
  • TKRcontributionIterator() : TKRcontributionIterator
  • TKRdiag() : DIAGcontributionIterator
  • TKRdiagnostic() : TKRdiagnostic
  • TKRend() : TEMcontributionIterator
  • tkrMap() : DIAGcontributionIterator
  • TKRstrip() : TKRstrip
  • tkrVector() : GEMcontribution
  • tmo() : ErrorSummary
  • TOT() : TKRcontributionIterator
  • tower() : TWRmap
  • trgParityError() : EventSummary
  • triggerTime() : GEMcontribution
  • type() : GCCCerror
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members - Functions

  • All
  • Functions
  • Enumerator
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- u -

  • UDF() : LATcontributionIterator, LATcomponentIterator, EBFcontributionIterator
  • UDFcomponent() : LATcomponentIterator
  • upper() : OSWtimeBase
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members - Functions

  • All
  • Functions
  • Enumerator
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- v -

  • value() : LATtypeId, CALlogEnd
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members - Functions

  • All
  • Functions
  • Enumerator
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- w -

  • wrdCntParity() : GTCCerror
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members - Functions

  • All
  • Functions
  • Enumerator
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- x -

  • XY() : GEMtileList
  • XZM() : GEMtileList
  • XZP() : GEMtileList
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members - Functions

  • All
  • Functions
  • Enumerator
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- y -

  • YZM() : GEMtileList
  • YZP() : GEMtileList
Generated on Mon Jul 31 17:48:11 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Graphical Class Hierarchy

LDF Graphical Class Hierarchy

Go to the textual class hierarchy

Generated on Mon Jul 31 17:48:25 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: File Index

  • File List
  • File Members

LDF File List

Here is a list of all documented files with brief descriptions:
ACDmap.h [code] |
ACDpha.h [code] |
AEMcontribution.h [code] |
AEMcontributionIterator.h [code] |
AEMheader.h [code] |
ASCcno.h [code] |
ASCcontribution.h [code] |
ASCcontributionIterator.h [code] |
ASCsummary.h [code] |
ASCtile.h [code] |
ASCtileContribution.h [code] |
ASCtileContributionIterator.h [code] |
CALcontribution.h [code] |
CALcontributionIterator.h [code] |
CALdiagnostic.h [code] |
CALlog.h [code] |
CALlogEnd.h [code] |
CALmap.h [code] |
copyright_SLAC.h [code] |
DFC_endianness.h [code] | Provides definitions of the ENDIANNESS of the target machine
DIAGcontributionIterator.h [code] |
EBF_swap.c | Byte swapping routines
EBF_swap.h [code] | DAQE word swapping utilities, Interface
EBFcontribution.h [code] |
EBFcontributionIterator.h [code] |
EBFevent.h [code] |
EBFeventIterator.h [code] |
ERRcontributionIterator.h [code] |
errorSummary.h [code] |
ev_latID.h [code] |
eventSummary.h [code] |
GEMcontribution.h [code] |
GLTcontribution.h [code] |
GXXXerror.h [code] |
LATcomponentIterator.h [code] |
LATcontribution.h [code] |
LATcontributionIterator.h [code] |
LATdataBufferIterator.h [code] |
LATdatagram.h [code] |
LATdatagramIterator.h [code] |
LATidentity.h [code] |
LATp.h [code] |
LATtypeId.h [code] |
LDFversion.h [code] |
libApiExport.h [code] |
OSWcontribution.h [code] |
OSWcontributionIterator.h [code] |
OSWtimeBase.h [code] |
OSWtimeContribution.h [code] |
OSWtimeSpec.h [code] |
stdafx.h [code] |
TEMcontribution.h [code] |
TEMcontributionIterator.h [code] |
timespec.h [code] |
TKRcontribution.h [code] |
TKRcontributionIterator.h [code] |
TKRdiagnostic.h [code] |
TKRmap.h [code] |
TKRstrip.h [code] |
TWRmap.h [code] |
Generated on Mon Jul 31 17:48:25 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: DFC_endianness.h File Reference

  • File List
  • File Members

DFC_endianness.h File Reference

Provides definitions of the ENDIANNESS of the target machine. More...

#include "copyright_SLAC.h"

Include dependency graph for DFC_endianness.h:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | DFC_K_ENDIANNESS_LITTLE -1
Value of DFC_K_ENDIANNESS if the target is a little endian machine.
#define | DFC_K_ENDIANNESS_UNKNOWN 0
Value of DFC_K_ENDIANNESS the endianness of the machine is not defined.
#define | DFC_K_ENDIANNESS_BIG 1
Value of DFC_K_ENDIANNESS if the target is a big endian machine.
#define | DFC_C_ENDIANNESS DFC_K_UNKNOWN
Assumes one of the values, DFC_K_ENDIANNESS_LITTLE, DFC_L_ENDIANNESS_BIG or DFC_K_ENDIAN_UNKNOWN.
#define | DFC_BIG_ENDIAN (DFC_C_ENDIANNESS == DFC_K_ENDIANNESS_BIG)

Detailed Description

Provides definitions of the ENDIANNESS of the target machine.

Author:
JJRussell - russell@slac.stanford.edu
An overall symbol, DFC_C_ENDIANNESS is defined. It may have one of three values, DFC_K_ENDIANNESS_LITTLE, DFC_K_ENDIANNESS_UNKNOWN DFC_K_ENDIANNESS_BIG.

Define Documentation

#define DFC_C_ENDIANNESS DFC_K_UNKNOWN

Assumes one of the values, DFC_K_ENDIANNESS_LITTLE, DFC_L_ENDIANNESS_BIG or DFC_K_ENDIAN_UNKNOWN.

This preprocessor symbol should be used to conditionally compile code that depends on the endianness of the machine. Currently, an error message is issued if no determination can be made.

Warning:
I tried the tack of just defining a symbol like BIG_ENDIAN or LITTLE_ENDIAN based on the target, but got in trouble with the documentation system, always complaining about one or the other of the symbols not being defined. This is ugly, but it works.

#define DFC_K_ENDIANNESS_BIG 1

Value of DFC_K_ENDIANNESS if the target is a big endian machine.

These preprocessor symbols are always defined. One of these values is assigned to DFC_K_ENDIANNESS.

Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: DFC_endianness.h Source File

  • File List
  • File Members

DFC_endianness.h

Go to the documentation of this file.
00001
00002 /*
00003 ** ++
00004 **
00005 **  Abstract:
00006 *+      $Id: DFC_endianness.h,v 1.4 2006/06/16 17:55:07 claus Exp $
00007 **
00008 *-
00009 **  Author:
00010 **      JJRussell - russell@slac.stanford.edu
00011 **
00012 **  $Revision: 1.4 $
00013 **      August 5, 2002 -- Created
00014 **
00015 **  Copyright:
00016 **                                Copyright 2002
00017 **                                      by
00018 **                         The Board of Trustees of the
00019 **                       Leland Stanford Junior University.
00020 **                              All rights reserved.
00021 **
00022 ** --
00023 */
00024
00025 #ifndef DFC_ENDIANNESS_H
00026 #define DFC_ENDIANNESS_H
00027
00028 #include "copyright_SLAC.h"
00029
00030
00031 /* ---------------------------------------------------------------------- */
00043 /* --------------------------------------------------------------------- */
00044
00045
00046
00047 /* --------------------------------------------------------------------- */
00064 /* --------------------------------------------------------------------- */
00065 #define DFC_K_ENDIANNESS_LITTLE    -1
00066 #define DFC_K_ENDIANNESS_UNKNOWN    0
00067 #define DFC_K_ENDIANNESS_BIG        1
00068 /* --------------------------------------------------------------------- */
00069
00070
00071 /* --------------------------------------------------------------------- */
00087 /* --------------------------------------------------------------------- */
00088 #if   defined(__i386)  || defined(__x86_64)
00089 #     define DFC_C_ENDIANNESS DFC_K_ENDIANNESS_LITTLE
00090 #elif defined(__sparc) || defined(__POWERPC__) || defined(__IEEE_BIG_ENDIAN)
00091 #     define DFC_C_ENDIANNESS DFC_K_ENDIANNESS_BIG
00092 #else
00093 #     error Cannot determine the endianness of the machine
00094 #     define DFC_C_ENDIANNESS DFC_K_UNKNOWN
00095 #endif
00096 /* --------------------------------------------------------------------- */
00097
00098
00099 /* RiC added the following 3/7/03 */
00100 #define DFC_BIG_ENDIAN (DFC_C_ENDIANNESS == DFC_K_ENDIANNESS_BIG)
00101 /* End RiC */
00102
00103 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: EBF_swap.c File Reference

  • File List
  • File Members

EBF_swap.c File Reference

Byte swapping routines. More...

#include "copyright_SLAC.h"
#include "EBF_swap.h"
#include "DFC_endianness.h"

Include dependency graph for EBF_swap.c:

Functions

unsigned int | EBF_swap32 (unsigned int w)
Byte swaps a 32 bit word.
unsigned int | EBF_swap16 (unsigned short w)
Byte swaps a 16 bit words.
void | EBF_swap32N (unsigned int *w, int n)
Byte swaps 32 bit words.
void | EBF_swap16N (unsigned short *w, int n)
Byte swaps 16 bit words.
unsigned int | EBF_swap32_lclXlittle (unsigned int w)
Byte swaps a 32 bit word; local representation <=> little.
unsigned int | EBF_swap16_lclXlittle (unsigned short w)
Byte swaps a 16 bit words; local representation <=> little.
unsigned int | EBF_swap32_lclXbig (unsigned int w)
Byte swaps a 32 bit word; local representation <=> big.
unsigned int | EBF_swap16_lclXbig (unsigned short w)
Byte swap a 16 bit words; local representation <=> big.
void | EBF_swap32_lclXlittleN (unsigned int *w, int n)
Byte swaps 32 bit words; local representation <=> little.
void | EBF_swap16_lclXlittleN (unsigned short *w, int n)
Byte swaps 16 bit words; local representation <=> little.
void | EBF_swap32_lclXbigN (unsigned int *w, int n)
Byte swaps 32 bit words; local representation <=> big.
void | EBF_swap16_lclXbigN (unsigned short *w, int n)
Byte swaps 16 bit words; local representation <=> big.

Detailed Description

Byte swapping routines.

Author:
JJRussell - russell@slac.stanford.edu
This is a cheap version of byte swapping routines. They are meant to be used only locally within this package in an attempt to keep it more or less self-contained.

Function Documentation

unsigned int EBF_swap16 ( unsigned short w ) [inline]

Byte swaps a 16 bit words.

Parameters:
w The 16 bit word to swap

unsigned int EBF_swap16_lclXbig ( unsigned short w )

Byte swap a 16 bit words; local representation <=> big.

Parameters:
w The 16 bit words to swap

void EBF_swap16_lclXbigN | ( | unsigned short * | w,
 |  | int | n
 | ) |  |

Byte swaps 16 bit words; local representation <=> big.

Parameters:
w | The array of 16 bit words to swap
n | The number of 16 bit words to swap

unsigned int EBF_swap16_lclXlittle ( unsigned short w )

Byte swaps a 16 bit words; local representation <=> little.

Parameters:
w The 16 bit words to swap

void EBF_swap16_lclXlittleN | ( | unsigned short * | w,
 |  | int | n
 | ) |  |

Byte swaps 16 bit words; local representation <=> little.

Parameters:
w | The array of 16 bit words to swap
n | The number of 16 bit words to swap

void EBF_swap16N | ( | unsigned short * | w,
 |  | int | n |
 | ) |  |  | [inline]

Byte swaps 16 bit words.

Parameters:
w | The array of 16 bit words to swap
n | The number of 16 bit words to swap

unsigned int EBF_swap32 ( unsigned int w ) [inline]

Byte swaps a 32 bit word.

Parameters:
w The 32 bit word to swap

unsigned int EBF_swap32_lclXbig ( unsigned int w )

Byte swaps a 32 bit word; local representation <=> big.

Parameters:
w The 32 bit word to swap

void EBF_swap32_lclXbigN | ( | unsigned int * | w,
 |  | int | n
 | ) |  |

Byte swaps 32 bit words; local representation <=> big.

Parameters:
w | The array of 32 bit words to swap
n | The number of 32 bit words to swap

unsigned int EBF_swap32_lclXlittle ( unsigned int w )

Byte swaps a 32 bit word; local representation <=> little.

Parameters:
w The 32 bit word to swap

void EBF_swap32_lclXlittleN | ( | unsigned int * | w,
 |  | int | n
 | ) |  |

Byte swaps 32 bit words; local representation <=> little.

Parameters:
w | The array of 32 bit words to swap
n | The number of 32 bit words to swap

void EBF_swap32N | ( | unsigned int * | w,
 |  | int | n |
 | ) |  |  | [inline]

Byte swaps 32 bit words.

Parameters:
w | The array of 32 bit words to swap
n | The number of 32 bit words to swap

Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: EBF_swap.h File Reference

  • File List
  • File Members

EBF_swap.h File Reference

DAQE word swapping utilities, Interface. More...

#include "copyright_SLAC.h"

Include dependency graph for EBF_swap.h:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Functions

unsigned int | EBF_swap32 (unsigned int w)
Byte swaps a 32 bit word.
unsigned int | EBF_swap32_lclXbig (unsigned int w)
Byte swaps a 32 bit word; local representation <=> big.
unsigned int | EBF_swap32_lclXlittle (unsigned int w)
Byte swaps a 32 bit word; local representation <=> little.
unsigned int | EBF_swap16 (unsigned short w)
Byte swaps a 16 bit words.
unsigned int | EBF_swap16_lclXbig (unsigned short w)
Byte swap a 16 bit words; local representation <=> big.
unsigned int | EBF_swap16_lclXlittle (unsigned short w)
Byte swaps a 16 bit words; local representation <=> little.
void | EBF_swap32N (unsigned int *w, int n)
Byte swaps 32 bit words.
void | EBF_swap32_lclXbigN (unsigned int *w, int n)
Byte swaps 32 bit words; local representation <=> big.
void | EBF_swap32_lclXlittleN (unsigned int *w, int n)
Byte swaps 32 bit words; local representation <=> little.
void | EBF_swap16N (unsigned short *w, int n)
Byte swaps 16 bit words.
void | EBF_swap16_lclXbigN (unsigned short *w, int n)
Byte swaps 16 bit words; local representation <=> big.
void | EBF_swap16_lclXlittleN (unsigned short *w, int n)
Byte swaps 16 bit words; local representation <=> little.

Detailed Description

DAQE word swapping utilities, Interface.

Author:
JJRussell - russell@slac.stanford.edu
Input routines for reading files from DAQEngine.

Function Documentation

unsigned int EBF_swap16 ( unsigned short w ) [inline]

Byte swaps a 16 bit words.

Parameters:
w The 16 bit word to swap

unsigned short EBF_swap16_lclXbig ( unsigned short w )

Byte swap a 16 bit words; local representation <=> big.

Parameters:
w The 16 bit words to swap

void EBF_swap16_lclXbigN | ( | unsigned short * | w,
 |  | int | n
 | ) |  |

Byte swaps 16 bit words; local representation <=> big.

Parameters:
w | The array of 16 bit words to swap
n | The number of 16 bit words to swap

void EBF_swap16_lclXlittle ( unsigned short w )

Byte swaps a 16 bit words; local representation <=> little.

Parameters:
w The 16 bit words to swap

void EBF_swap16_lclXlittleN | ( | unsigned short * | w,
 |  | int | n
 | ) |  |

Byte swaps 16 bit words; local representation <=> little.

Parameters:
w | The array of 16 bit words to swap
n | The number of 16 bit words to swap

void EBF_swap16N | ( | unsigned short * | w,
 |  | int | n |
 | ) |  |  | [inline]

Byte swaps 16 bit words.

Parameters:
w | The array of 16 bit words to swap
n | The number of 16 bit words to swap

unsigned int EBF_swap32 ( unsigned int w ) [inline]

Byte swaps a 32 bit word.

Parameters:
w The 32 bit word to swap

unsigned int EBF_swap32_lclXbig ( unsigned int w )

Byte swaps a 32 bit word; local representation <=> big.

Parameters:
w The 32 bit word to swap

void EBF_swap32_lclXbigN | ( | unsigned int * | w,
 |  | int | n
 | ) |  |

Byte swaps 32 bit words; local representation <=> big.

Parameters:
w | The array of 32 bit words to swap
n | The number of 32 bit words to swap

unsigned int EBF_swap32_lclXlittle ( unsigned int w )

Byte swaps a 32 bit word; local representation <=> little.

Parameters:
w The 32 bit word to swap

void EBF_swap32_lclXlittleN | ( | unsigned int * | w,
 |  | int | n
 | ) |  |

Byte swaps 32 bit words; local representation <=> little.

Parameters:
w | The array of 32 bit words to swap
n | The number of 32 bit words to swap

void EBF_swap32N | ( | unsigned int * | w,
 |  | int | n |
 | ) |  |  | [inline]

Byte swaps 32 bit words.

Parameters:
w | The array of 32 bit words to swap
n | The number of 32 bit words to swap

Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: EBF_swap.h Source File

  • File List
  • File Members

EBF_swap.h

Go to the documentation of this file.
00001 /*
00002 ** ++
00003 **
00004 **  Abstract:
00005 *+      $Id: EBF_swap.h,v 1.2 2004/04/01 23:43:24 claus Exp $
00006 **
00007 *-
00008 **  Author:
00009 **      JJRussell - russell@slac.stanford.edu
00010 **
00011 **  $Revision: 1.2 $
00012 **      August 5, 2002 -- Created
00013 **
00014 **  Copyright:
00015 **                                Copyright 2002
00016 **                                      by
00017 **                         The Board of Trustees of the
00018 **                       Leland Stanford Junior University.
00019 **                              All rights reserved.
00020 **
00021 ** --
00022 */
00023
00024 #ifndef EBF_SWAP_H
00025 #define EBF_SWAP_H
00026
00027 #include "copyright_SLAC.h"
00028
00029
00030 /* ---------------------------------------------------------------------- */
00038 /* --------------------------------------------------------------------- */
00039
00040
00041
00042 #ifdef __cplusplus
00043 extern "C" {
00044 #endif
00045
00046
00047
00048 /* --------------------------------------------------------------------- */
00049
00050 /* Single word swap routines */
00051 extern unsigned int EBF_swap32            (unsigned int   w);
00052 extern unsigned int EBF_swap32_lclXbig    (unsigned int   w);
00053 extern unsigned int EBF_swap32_lclXlittle (unsigned int   w);
00054
00055 extern unsigned int EBF_swap16            (unsigned short w);
00056 extern unsigned int EBF_swap16_lclXbig    (unsigned short w);
00057 extern unsigned int EBF_swap16_lclXlittle (unsigned short w);
00058
00059 /* Array swap routines */
00060 extern void EBF_swap32N            (unsigned int   *w, int n);
00061 extern void EBF_swap32_lclXbigN    (unsigned int   *w, int n);
00062 extern void EBF_swap32_lclXlittleN (unsigned int   *w, int n);
00063
00064 extern void EBF_swap16N            (unsigned short *w, int n);
00065 extern void EBF_swap16_lclXbigN    (unsigned short *w, int n);
00066 extern void EBF_swap16_lclXlittleN (unsigned short *w, int n);
00067 /* --------------------------------------------------------------------- */
00068
00069
00070
00071 #ifdef __cplusplus
00072 }
00073 #endif
00074
00075
00076 #endif
00077
00078
00079
00080
00081
00082
00083
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Defines
Here is a list of all documented file members with links to the documentation:

  • DFC_C_ENDIANNESS : DFC_endianness.h
  • DFC_K_ENDIANNESS_BIG : DFC_endianness.h
  • DFC_K_ENDIANNESS_LITTLE : DFC_endianness.h
  • DFC_K_ENDIANNESS_UNKNOWN : DFC_endianness.h
  • EBF_swap16() : EBF_swap.c, EBF_swap.h
  • EBF_swap16_lclXbig() : EBF_swap.c, EBF_swap.h
  • EBF_swap16_lclXbigN() : EBF_swap.c, EBF_swap.h
  • EBF_swap16_lclXlittle() : EBF_swap.c, EBF_swap.h
  • EBF_swap16_lclXlittleN() : EBF_swap.c, EBF_swap.h
  • EBF_swap16N() : EBF_swap.c, EBF_swap.h
  • EBF_swap32() : EBF_swap.c, EBF_swap.h
  • EBF_swap32_lclXbig() : EBF_swap.c, EBF_swap.h
  • EBF_swap32_lclXbigN() : EBF_swap.c, EBF_swap.h
  • EBF_swap32_lclXlittle() : EBF_swap.c, EBF_swap.h
  • EBF_swap32_lclXlittleN() : EBF_swap.c, EBF_swap.h
  • EBF_swap32N() : EBF_swap.c, EBF_swap.h
Generated on Mon Jul 31 17:48:25 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Defines

  • DFC_C_ENDIANNESS : DFC_endianness.h
  • DFC_K_ENDIANNESS_BIG : DFC_endianness.h
  • DFC_K_ENDIANNESS_LITTLE : DFC_endianness.h
  • DFC_K_ENDIANNESS_UNKNOWN : DFC_endianness.h
Generated on Mon Jul 31 17:48:25 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Defines

  • EBF_swap16() : EBF_swap.c, EBF_swap.h
  • EBF_swap16_lclXbig() : EBF_swap.c, EBF_swap.h
  • EBF_swap16_lclXbigN() : EBF_swap.c, EBF_swap.h
  • EBF_swap16_lclXlittle() : EBF_swap.c, EBF_swap.h
  • EBF_swap16_lclXlittleN() : EBF_swap.c, EBF_swap.h
  • EBF_swap16N() : EBF_swap.c, EBF_swap.h
  • EBF_swap32() : EBF_swap.c, EBF_swap.h
  • EBF_swap32_lclXbig() : EBF_swap.c, EBF_swap.h
  • EBF_swap32_lclXbigN() : EBF_swap.c, EBF_swap.h
  • EBF_swap32_lclXlittle() : EBF_swap.c, EBF_swap.h
  • EBF_swap32_lclXlittleN() : EBF_swap.c, EBF_swap.h
  • EBF_swap32N() : EBF_swap.c, EBF_swap.h
Generated on Mon Jul 31 17:48:25 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Page Index

LDF Related Pages

Here is a list of all related documentation pages:
  • Release notes
Generated on Mon Jul 31 17:48:25 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Release notes

Release notes

Notes for V6.2.0 of LDF

Mon Jul 31 15:22:22 2006 - R. Claus
  • As per E. Siskind, disabled parsing of TKR error information when phase bit is up in the error summary word.
  • Added warning to LDFdumper.py to reflect the above.
  • Bumped the minor version number in LDFversion.h and configure.in

Notes for V6.1.0 of LDF

Fri Jun 16 10:18:59 2006 - R. Claus
  • Fixed missing _lclXbig on EBF_swap call in LDFdump.cpp
  • Added __POWERPC__ and __x86_64 to DFC_endianness.h
  • Added include of time.h for __POWERPC__ in timespec.h
  • Added Beam Test related typeIds to ev_latID.h, LATidentity.h, and LATidentity.sip
  • Bumped the minor version number in LDFversion.h and configure.in

Notes for V6.0.3 of LDF

Thu Apr 27 18:45:42 2006 - R. Claus
  • Updated version.h. which was forgotten about for the last 3 releases
  • Added release note for V6.0.2 in this file

Notes for V6.0.2 of LDF

2006/3/30 22:28:15 - P. Kunz (entered by R. Claus)
  • Makefile and configure file fixes to deal with installing copyright

Notes for V6.0.1 of LDF

Thu Mar 30 13:11:26 2006 - R. Claus
  • Fixed Visual Studio build files
  • Changed the call to handleError in _map of EBFcontributionIterator to use 0 (zero) instead of NULL, which causes gcc some problems
  • Fixed missing 'Dump' postfix in LDFdumper LATcomponentIteratorDump.error() instantiation of the ERRcontributionIterator
  • Fixed event length format directive to support 32 bit lengths
  • Updated data directory with current dumps
  • Changed setupLDF.bat to put $ONLINE_ROOT/LDF in PYTHONPATH

Notes for V6.0.0 of LDF

Fri Mar 30 11:50:00 2006 - A. Perazzo
  • Removed status field and make length field 32 bits
    • Note that EBFevent typeId version number didn't change
  • Addition of the string 'Dump' to a few classes in LDFdumper.py
  • Removed __init__.py

Notes for V5.7.3 of LDF

Fri Feb 10 09:30:00 2006 - Paul Kunz
  • Update version number and install python file Tue Jan 10 13:45:25 2006 - R. Claus
  • Handle Python 2.4 sign extension problem of unsigned 32 bit integers
  • Added checks to prevent iterating past the end of TKR and ERR contributions

Notes for V5.7.2 of LDF

2006/1/25 14:40:09 - Paul Kunz
  • Make and config file fixes.

Notes for V5.7.1 of LDF

Tue Jan 10 13:45:25 2006 - R. Claus
  • Various clean up

Notes for V5.7.0 of LDF

Wed Sep 28 11:51:48 2005 - E. Charles
  • Added the ACD scalar contribution (ASC) decoding
  • Added include/ASC*.h, src/ASC*.ccp sip/ASC*.sip
  • Updated test/LDFdump.cpp to use the ASC decoding
  • Updated LDFdumper.py to use the ASC decoding
  • Updated LDFdump.py to use the ASC decoding
  • Updated include/ACDmap.h to map from GEM index (0-127) to tile name
  • Bumped the minor version number in LDFversion.h and configure.in.

Notes for V5.6.3 of LDF

Sun Aug 14 14:08:15 2005 - R. Claus
  • Makefiles updated for rpmbuild by P. Kunz

Notes for V5.6.2 of LDF

Fri Apr 15 10:08:52 2005 - R. Claus
  • Added display of CAL ADC values in decimal to LDFdumper.py and LDFdump.cpp.
  • Added deadZone alias for missed in GEM contribution to .h and .sip
  • Added comment for this to LDFdumper.py and LDFdump.cpp for clarity.
  • Bumped the revision number in LDFversion.h and configure.in.

Notes for V5.6.1 of LDF

Fri Apr 01 16:08:11 2005 - R. Claus
  • Fixed typo in the include of eventSummary.h in OSWtimeContribution.h.
  • Bumped the revision number in LDFversion.h and configure.in.

Notes for V5.6.0 of LDF

Tue Mar 29 09:03:58 2005 - R. Claus
  • Modified setup files and *.py to follow 'import LDF.xxx' style.
  • Added evtSeqMSW() and evtSequence() to OSWtimeContribution.h.
  • Added another secondary Id for the new OSWtimeContribution version.
  • Updated sip to expose the additional OSWtimeContribution methods.
  • Updated woefully out of date LATidentity.sip.
  • Added accessor to the time contribution to OSWcontribuion.h.
  • Added "copy" constructor to create an OSWtimeContribution from an OSWcontribution to make the Python interface work.
  • Decided that the OSWtime() callback of the OSWcontributionIterator had the wrong interface, since it was not extendable. Created a new interface called OSW_time(), which if not implemented by the user, just calls the old OSWtime() back. This preserves backward compatibility. New code should use OSW_time(). Note that OSWtime() is not pure virtual anymore.
  • Added print of the extended event number in LDFdumper.py.
  • Updated LDFdump.cpp to match the above interface changes.
  • Added the printing of the trigger condition names to LDFdumper.py.
  • Removed the ReleaseGILs from the sip files.
  • Bumped the minor version number in LDFversion.h and configure.in.

Notes for V5.5.1 of LDF

Tue Mar 15 11:00:00 2005 - J. Panetta
  • Added contribution/event to all handleError calls and prototypes This allows the user to do something with the problem...
  • Added implementation of handleError calls to LDFdump.py, LDFdumper.py and LDFdump.cpp
  • Added check for isatty to LDFdump.py to allow streaming to a file
  • Added test/data/reallyBad.ldf to test for really bad LDF problems.
  • Bumped the revision number in LDFversion.h and configure.in.

Notes for V5.5.0 of LDF

Wed Feb 23 15:30:00 2005 - J. Panetta
  • Fixed bug in calculation of GEMonePPStime::timebase. Off-by-one error in bit shift.
  • Added call for GEMcontribution::missed() to return 8 LSB of missed events register (Feature in new GEM, not documented in LAT-TD-01545 as of 05/02/23.)
  • Added missed() call to GEMcontribution.sip
  • Added example missed() usage to LDFdump.cpp and LDFdumper.py
  • Bumped the revision number in LDFversion.h and configure.in.

Notes for V5.4.1 of LDF

Mon Feb 14 17:45:00 2005 - J. Panetta
  • Uncommented references to "diagnostic", "error" and "cleanup" in LATcomponentIterator.sip to allow subsystems to inherit directly from LDF.pyd in python rather than through LDFdumper.py
  • add datum() member function to GEMcondArrivalTime as per JIRA LDF-15
  • Add example of datum() usage to LDFdumper.py and LDFdump.cpp
  • Bumped the revision number in LDFversion.h and configure.in.

Notes for V5.4.0 of LDF

Mon Dec 13 16:24:41 2004 - R. Claus & J. Panetta
  • Added ACD ASC to ev_latID.h and LATidentity.[h, sip].
  • Added CAL CEDhdr to ev_latID.h and LATidentity.[h, sip].
  • Propogated CEDhdr and ASC to LATidentity.sip
  • Added code in LDFdump.py to pretty-print ASC contributions
  • Fixed labels in CAL diagnostic callback of LDFdumper.py.
  • Modified parse of GEM contribution data as per v2.5 of LAT-TD-01545:
    Overloaded old sent() word with condArrTime() in GEMcontribution.[h, sip]
    Split _deltaEventTime word into two ushorts: _deltaEventTime and _deltaWindOpenTime
    Added accessor deltaWindowOpenTime in GEMcontribution.[h, sip]
    Added GEMcondArrivalTime to GEMcontribution.[h, sip]
    Removed _pad portion of GEM data as it wasn't cell aligned
  • Added new accessors to GEMcontribution to LDFdumper.py and test/LDFdumper.cpp
  • Bumped the revision number in LDFversion.h and configure.in.

Notes for V5.3.0 of LDF

Thu Nov 18 11:00:00 2004 - J. Panetta
  • Added callback to handle errors for each iterator:
    virtual int IT::handleError( code, p1=0, p2=0 )
    Default behavior is to do nothing, continue iteration.
  • Moved all fprintf(stderr) statements into handleError, and commented them out. Users can override behavior by reimplementing handleError.
  • Bumped the minor release number in LDFversion.h and configure.in.

Notes for V5.2.0 of LDF

Tue Oct 25 14:15:16 2004 - R. Claus
  • Added some Python support code to LATcontribution.h and .sip.
  • Added a LATtypeId constructor to create a LATtypeId from primary and secondary values.
  • Added Python __eq__, __ne__, __len__ methods to LATtypeId.
  • Added __len__ method to LATdatagram and LATcontribution.
  • Added missing LATdataBufferIterator classes to the SIP interface.
  • Added missing status methods to the SIP files that were missing them.
  • Added missing 'const's to those methods missing them in TEMcontributionIterator.sip
  • Added LATdatagram class to LDFdumper.py.
  • Added the ability to iterate over, and dump LATdatagrams to LDFdump.py and modified datagram oriented functions to use it.
  • Corrected signatures of LATcontribution.h to make length and opaque unsigned shorts.
  • Fixed SIP code in which sipArgsParsed was compared to one more than the correct number of arguments everywhere. This had the effect of not being able to override defaults provided in method signatures.
  • LATdatagram::identity() was returning an unsigned instead of a LATtypeId.
  • Added EventSequence number printing to LDFdump.cpp.
  • Changed LDFdump.cpp to read and handle one event at a time.
  • Bumped the minor release number in LDFversion.h and configure.in.

Notes for V5.1.2 of LDF

Tue Aug 31 18:14:35 2004 - R. Claus
  • Found more places using the event summary word that should have been using the contribution summary word.
  • Added contribution packet error handling.
  • Changed LDFdump.cpp and .py to not quit upon bad iteration status.
  • Bumped the revision number in LDFversion.h and configure.in.

Notes for V5.1.1 of LDF

Mon Aug 02 20:15:36 2004 - R. Claus
  • Fixed bug caused by my having forgotten to have updated LDFdump.cpp to use the contribution summary word instead of the event one. This affects the test code only and not the core package, but I don't have a way to release just the test code, so...
  • Bumped the revision number in LDFversion.h and configure.in.

Notes for V5.1.0 of LDF

Thu Jul 08 14:32:42 2004 - R. Claus & J. Panetta
  • Fixed bug in which the event summary word used every where was the version found in the first contribution. Each contribution has its own version and it turns out that they can, in fact, be different. In particular, the error bit is not global to the event, but per contribution.
  • Added support for delivering LATcontributions to application code. This allows applications to handle the ACD software counter contributions, etc.
  • Added some functionality to LATdatagramIterator. It's now usable from within LATTE.
  • Bumped the revision number in LDFversion.h and configure.in.

Notes for V5.0.3 of LDF

Tue Tue Jun 01 18:59:21 2004 - R. Claus & J. Panetta
  • Fixed bug in EBFcontributionIterator.cpp causing version EBFevent::ID_3 data not to be recognized.
  • Bumped the revision number in LDFversion.h and configure.in.

Notes for V5.0.2 of LDF

Tue May 04 16:09:41 2004 - R. Claus & J. Panetta
  • Revised original ACDmap table for handling correctly wired GASUs. Apparently the original incarnation was wrong.
  • Bumped the revision number in LDFversion.h.

Notes for V5.0.1 of LDF

Fri Apr 23 16:11:05 2004 - R. Claus & J. Panetta
  • Added another ACDmap table for handling the first, miswired, GASUs.
  • Added some test data and dumps for comparison in LDF/test/data.
  • Bumped the revision number in LDFversion.h.

Notes for V5.0.0 of LDF

Wed Apr 14 13:29:41 2004 - R. Claus
  • Missed an unused argument in AEMcontributionIterator.cpp. Commented it out.
  • Fixed casing in LATcomponentIterator.h include in LATdataBufferIterator.
  • Fixed the makefile build scheme for Linux. It may work on Solaris, too. It now builds a C++ library separately from the SIP/Python library. See Building LDF libraries and example code for the installation procedure for both kinds of platforms.
  • Added more() method to LATPcellHeader class
  • Modified EBFcontributionIterator to use the more bit to determine when to stop iterating.
  • Added reporting of zero length contributions to EBFcontributionIterator.
  • Reworked ACDmap API at Mike's request, a non-backwardly compatible change.
  • Bumped major release number in LDFversion.h.

Notes for V4.1.0 of LDF

Mon Apr 12 20:19:29 2004 - R. Claus

  • Fixed GCC 3.2 complaint about ContribHandler table in EBFcontributionIterator.
  • Added new EBF identity in LATidentity to support new ContribHandler table in EBFcontributionIterator with GEM and AEM source IDs at 16, 17, resp.
  • Changed AEMcontributionIterator to treat only ID_EBF_1 data differently.
  • Fixed private data member initialization order in DIAGcontributionIterator and ERRcontributionIterator constructors.
  • Fixed missing .value() call on identity usage in various prints in LDFdump.cpp, LATcontributionIterator and EBFeventIterator.
  • Removed stale 'inline' from EBFeventIterator::iterate().
  • Updated obj/Makefile.am to handle new V4 files.
  • Fixed bug in which the map was potentially undefined in AEMcontributionIterator.
  • Commented out unused argument in LATcontributionIterator to quite GCC 3.2. Ditto ACDmap, CALmap, TKRmap, TWRmap, LATcomponentIterator, OSWcontributionIterator, DIAGcontributionIterator, ERRcontributionIterator.
  • Removed stale superfluous 'AEMheader::' from AEMheader.
  • Bumped minor version number in LDFversion.h.

To do:

  • Fix autogen/automake to build LDF on Linux.

Notes for V4.0.1 of LDF

Wed Apr 07 20:11:23 2004 - R. Claus

  • Fixed bug with default constructors setting map pointers to zero for AEM, CAL, TKR, DIAG and ERR -contributionIterators.
  • Bumped revision number in LDFversion.h.

Notes for V4.0.0 of LDF

Tue Feb 10 18:25:16 PST 2004 - R. Claus

  • Changed EBFeventIterator to iterate over a list of EBFevents rather than over a buffer assumed to contain a list of EBFevents. Also, a list of EBFevents is now actually supported rather than being limited to just one.
  • Added LATcontributionIterator to iterate over datagram contributions. Currently the only kind of datagram contribution supported is a list of EBFevents. More kinds are likely to follow, e.g. configuration data.
  • The EBFcontribution with source ID 16 is now a true GEM contribution as defined in "LAT-TD-01545: The GLT Electronics Module". The contribution containing time stamp information the Online Event Server inserts into the event with this ID has been moved into an Online SoftWare contribution (OSWcontribution) with ID 32.
  • Provided GEMcontribution class for accessing GEM data.
  • Provided GLTcontribution class to allow accessing time information in pre-version 0x102F0010 EBF data. This contribution used to be the GEMcontribution.
  • Provided OSWtimeContribution to access time information in EBF version 0x102F0010 data.
  • Introduced class LATtypeId for handling type-IDs. This class, together with those in LATidentity.h and the type-IDs stored in the data, are used to distinguish between different versions of the formats of various blocks of data.
  • Provided backward compatibility so that EBF can still parse version 0x101F0010 EBFevents in addition to the current version 0x102F0010 types.
  • Provided mapping classes ACDmap, CALmap and TKRmap, for mapping from electronics space to detector space and provided standard maps for the nominal LAT situation.
  • Added additional iterators and constructors to allow overriding of the default map. This can be done by deriving from the supplied map classes and supplying implementations for the defaulted virtual methods. The previously existing iterators use the default, standard maps.
  • Updated the AEMcontributionIterator to match the information in the latest version of "LAT-TD-00639-D1 ACD Electronics Module (AEM) - Programming ICD specification" which says that all cables don't have to be present in the AEM event contribution and adds a cable number to the cable contribution headers. These changes are backwardly compatible.
  • Updated the EBFdump examples to be in line with the above changes.
  • Added LATdataBufferIterator class to help users out by stringing together a bunch of iterators to the level where the user is interested again (LATcomponentIterator).
  • Upgraded to SIP 4. This fixed a long outstanding problem with using this package from a LATTE RunControl script. It also caused some minor Python usage changes that required changes to EBFdumper.py.
  • Fixed problem in ERRcontributionIterator in which the 5 GTFE tags for the GTFE phasing error were being reported in reverse order.
  • Added doxygen comments.
  • Changed the name of the package from EBF to LDF (LAT Data Format).
  • Added support for Monte Carlo generated EBF data separately identified from that produced by LATTE at JJ's request.
  • Updated VS.NET 7.1 (2003) project files
  • Updated VS.NET 7.0 project files
  • Added muon-5.arch to cvs in the test directory

Still to be done:

  • Update VS files for Debug releases
  • Update Unix make files
  • Doxygenize the Python files
  • Poor person's verification and validation: Save dumps of various kinds of events in text files for comparison against parsing results from new releases

Notes for V3.3.0 tag of EBF

Wed Mar 17 14:14:00 PST 2004 - J Panetta

In preparation for V4 release, jhp-040206 is being tagged as V3.3.0 for the ACD group.

Notes for jhp-040206 tag of EBF

Fri Feb 6 17:33:00 PST 2004 - J Panetta

Added AEMcontributionIterator to iterate over the AEM contribution of the event without user coding.

Provided pure virtual function callbacks:

  • AEMcontributionIterator::header(int cable, AEMheader hdr)
  • AEMcontributionIterator::pha(int cable, int channel, ACDpha p)

for the user to implement.

Notes for V3.2.2 of EBF

Thu Jan 22 15:19:00 PST 2004 - J Panetta

Modified bits in aemBuf() to match defining comment (hitMap == acceptMap)

Fixed parsing of AEM header and ordering of AEM pha values as per AEM primer, section 3.2.1 Ver 2.6. Closing LATTE Issue #37

Updated comments on location of AEM data definition

Notes for V3.2.0 of EBF

Mon Dec 15 14:05:43 PST 2003 - J Panetta

Added Linux support for EBF. See README for build instructions

Notes for V3.1.7 of EBF

Mon Dec 1 15:26:15 PST 2003 - J Panetta

Added DIAGcontributionIterator and ERRcontributionIterator to iterate over the diagnostic component of the TEM contribution and the error component respectively. Added a TKRdiagnostic object to reference into the bitfield defined in the TEM primer.

TKRdiagnostic provides the function hooks:

  • GTRC(int) : return the GTRC diagnostic bit
  • datum() : return the diagnostic word

DIAGcontributionIterator provides the following function hooks:

  • iterateCAL() : iterate over CAL diagnostic data
  • iterateTKR() : iterate over TKR diag data
  • offset(unsigned) : set offset to start of diag data
  • size() : return size of diag data (should be 12*sizeof(unsigned))

and callbacks:

  • CALdiag(unsigned tower, unsigned layer, CALdiagnostic diag)
  • TKRdiag(unsigned tower, unsigned gtcc, TKRdiagnostic diag)

The callbacks can be implemented by the user if the data is needed. By default, they are implemented as null functions.

ERRcontributionIterator provides the following function hooks:

  • iterate() : iterate over error data
  • offset(unsigned) : set offset to start of error data
  • size() : return size of error data (computed by iterator)

and callbacks:

  • gcccError (unsigned tower, unsigned gccc, GCCCerror err)
  • gtccError (unsigned tower, unsigned gtcc, GTCCerror err)
  • phaseError (unsigned tower, unsigned short err)
  • timeoutError (unsigned tower, unsigned short err)
  • gtrcPhaseError (unsigned tower, unsigned gtcc, unsigned gtrc, GTRCerror err)
  • gtfePhaseError (unsigned tower, unsigned gtcc, unsigned gtr unsigned short err1, unsigned short err2, unsigned short err3, unsigned short err4, unsigned short err5) {}
  • gtccFIFOerror (unsigned tower, unsigned gtcc, unsigned short err)
  • gtccTMOerror (unsigned tower, unsigned gtcc)
  • gtccHDRParityError (unsigned tower, unsigned gtcc)
  • gtccWCParityError (unsigned tower, unsigned gtcc)
  • gtrcSummaryError (unsigned tower, unsigned gtcc)
  • gtccDataParityError (unsigned tower, unsigned gtcc)

As above, these callbacks may be implemented by the user if the data is needed. By default, they are implemented as null functions.

Example code for the use of these iterators is contained in the files test/EBFdump.cpp (C++) and in EBFdumper.py (python).

Notes for V3.1.6 of EBF

Thu Oct 23 2003 - J Panetta

Changed compiler flag _WIN32_STATIC to _WIN32_EBF_STATIC at request of offline. [libApiExport.h]

Notes for V3.1.5 of the EBF package

Tue Oct 15 15:16:20 2003 - J Panetta

Added support for statically linked EBF under Windows (Offline request). Add the compiler flag _WIN32_STATIC to activate. [libApiExport.h]

Fixed a counting error in the calculation of the end-of-contribution. [TEMcontributionIterator.h]

Minor mods to setupEBF.sh and setupEBF.bat.

Forgot to add the sln file for EBF/test. [EBFdump.sln]

Notes for V3.1.4 of the EBF package

Sun Aug 31 18:17:40 2003 - R. Claus

Added support for two extra longwords added to the end of the GEM contribution. These contain the results from reading the PPC timebase register at the point that the event is first recognised by Online software in the SBC. This register counts at 16 MHz (60 ns ticks) on the MVME2306 SBCs currently supported by Online. Beware that the counting rate is implementation dependent when using PPC SBCs other than the MVME2306. See EBF/EBFdumper.py and EBF/test/EBFdump.cpp for examples on how to access this data.

Note for posterity: we observe that the minimum event spacing is about 200 uS, presumibly occuring when several events are stacked up in the various buffers (TEM and LAT COMM card) thus causing the readout software to work at the maximum rate.

Notes for V3.1.3 of the EBF package

Tue Aug 26 13:17:33 2003 - R. Claus

Changed the TKRcontributionIterator::strip() virtual function interface to provide layerEnd instead of layer. Affected files are TKRcontributionIterator.h, EBFdumper.py, EBFdump.cpp. Fixed various syntax problems to prevent some compilers from issuing warnings.

Notes for V3.1.2 of the EBF package

Wed Aug 20 10:19:00 2003 - J. Panetta

Fixed two problems in EBFdump.cpp. -#) replaced getch() with getchar(). -#) Fixed a variable out of scope problem that gcc caught and VC++ didn't.

Notes for V3.1.0 of the EBF package.

Thu Aug 06 18:07:20 2003 - J. Panetta

Added CALcontributionIterator to EBF library to remove iteration over the CAL data from the user's hands. Provided pure virtual function log(unsigned tower, unsigned layer, CALlog theLog) for the user to implement. Modified CALlog.h to return a CALlogEnd object in place of an unsigned.

Added offsets to the end of {CAL,TKR,diag,err} data to TEMcontributionIterator. A portion of this functionality was in TKRcontributionIterator, but the diag and err data are part of the TEM contribution.

Implemented the parsing of diagnostics and errors in EBFdump.cpp. This was done a little differently from the python version, taking advantage of #defines to transparently swap bytes when needed.

Added a cleanup() method to TEMcontributionIterator. This method looks in the area between the last useful TEM data and the end of the contribution and checks whether it is both: a) less than one cell away; b) all zeroes. This checks for an error in the TEM hardware where multiples of the last TOT are written to the event stream.

Moved the dump() methods of My{TKR,CAL}contribution in the example files (EBFdump.cpp, EBFdumper.py) to the Iterators. This reverses a dependency of the contribution on the iterator.

Until a SIP error is dealt with, the cleanup(), diagnostic() and error() methods of the LATcomponentIterator class are required to be implemented in user python code. These methods are allowed to be dummies.

This release is consistent with existing data files.

Notes for v3.0.0 of the EBF package.

Wed Jul 09 22:43:02 2003 - R. Claus

Changed the tracker iterator callback method signatures from the "electronics space" notation of v2.0.x to "detector space" notation. This is almost the same as it was for v01-00-00 except "layerEnd" is now correctly calculated. LayerEnd = layer * 2 + (1 bit indicating whether the value was read from the low or the high end of the MCM). LayerEnd is provided to the TOT virtual method where the side the TOT was read from is interesting. Layer is provided to the strip virtual method where the side the hit was read from is not interesting.

Provided geometry remapping private methods in TKRcontributionIterator.h to handle the nonstandard geometry of the first TKR Minitower. The code must be recompiled to handle different geometries. Since the data from the first minitower has already been taken and thus tagged with a particular format version number, and monte carlo data files have been generated with this same format version number, the code can't distinguish which files have which geometries. It's not clear what to do about this.

In anticipation that FSW will only one copy of the summary word, contribution signatures were changed to access the summary word through the EBFevent interface. All contributions should have been able to find the event header anyway. The contribution summary words can still be accessed through the contribution classes, but this may change in the future.

The known problem of v2.0.1 turned out to indeed be a TEM hardware error that has subsequently been fixed in the firmware.

This release is consistent with existing data files.

for v2.0.1 of the EBF package.

Thu May 08 19:54:38 2003 - R. Claus

Found that there was an alignment problem when decoding the Tracker TOTs and fixed it. One set of the error pathologies that didn't decode correctly in v2.0.0 now do. The remaining known pathology that doesn't decode correctly looks to be due to a TEM hardware error. A replicated TOT and subsequent padding appears where an error contribution is expected.

Known problems:

  • One error pathology doesn't decode correctly.

Notes for v2.0.0 of the EBF package.

Thu May 08 12:19:47 2003 - R. Claus

Changed the tracker iterator callback method signatures so that users don't have to decode layer-end into CC and RC numbers. If in the future the definition of the accepts mask changes, the change can be hidden in the EBF code so that user code does not have to change. I haven't yet updated all my Python test code to cope with these changes.

Also added the ability to dump text files using EBFdump.py. The text files contain hex dumps of an event buffer.

Known problems:

  • Some of the error pathologies aren't decoded correctly.
  • Not all files were updated to use the new TKR iterator signatures (e.g. eventFormat.py). I don't expect this to affect anybody but me.

Notes for v1.0.0 of the EBF package.

Wed Mar 19 19:11:37 2003 - R. Claus

This package contains a set of C++ classes for navigating the second version of Event Builder Format (EBF) event data. It also includes code necessary for exposing these C++ classes to Python (the sip files).

The major difference between the current version (v01-00-00) of the EBF package and the previous release (v00-00-00) is that the EBF data as described by Mike Huffer's LAT Inter-module Communications document (LAT-TD-00606) is now augmented with an type/identity value and encapsulated in a "LATdatagram". The datagram has it's own type/identity value, but is of interest because it is extendable. This means that besides an EBF contribution, there may be other contributions to an "event". None are currently defined.

The type/identity value (LATidentity.h) is used to give each transmissible object a "type". Associated with the type is an identifier that is typically used as a version number of the type. A piece of software can then recognize whether it is equiped to deal with the data with which it is presented. It could either decide to bail out if it isn't or dynamically load a library that can.

The EBF format itself has changed from the previous release somewhat in that a couple of extra fields have been added to EBFcontribution and the units of the length field are now in LATp cells rather than bytes. The EBFcontribution::length() method still returns units of bytes, i.e., the change is backwardly compatible.

A program called cvtData-NoneTo1 is provided in the EBF/test directory to convert the data format v00-00-00 handles to the data format that v01-00-00 handles.

What is still needed:

  • More comments
  • Resolution of some class interface issues
  • Resolution of the GC problem encountered in Python applications using EBF
  • Resolution of how to pass buffers, rather than strings, around
  • Remove or formalize dependancy on FSW's EBF_swap.*, etc.
  • Provide an ACD data iterator
  • Provide a diagnostic data iterator
  • Provide an error data iterator
  • Clean up LATidentity usage
  • Clean up the build process
    • Separate the core C++ into EBF.dll that is underneath the sip generated C++ that lives in libEBFc.pyd
    • Provide a makefile (or whatever) for building EBFdump.exe, cvtData*.exe

C++ usage:

Create a class derived from LATcomponentIterator, filling in those virtual functions appropriate to your application. Those you don't need can be omitted, since they are defaulted.

See EBFdump.cpp in the test directory. Read from the bottom up.

Python usage:

See eventFormat.py in the test directory.

Notes for v0.0.0 of the EBF package.

Thu Feb 20 14:59:55 2003 - R. Claus

This package contains a set of C++ classes for navigating Event Builder Format (EBF) event data. It also includes code necessary for exposing these C++ classes to Python (the sip files).

What is still needed:

  • More comments
  • Examples
  • Some way to deal with a package version number
  • Some way to deal with a data format version number
  • Remove or formalize dependancy on JJ's EBF_swap.*, etc.
  • Provide access to diagnostic data
  • Provide access to error data
  • Provide an ACD data iterator
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: ACDmap.h Source File

  • File List
  • File Members

ACDmap.h

00001
00024 #ifndef ACDmap_H
00025 #define ACDmap_H
00026
00027 #include "copyright_SLAC.h"
00028
00029 #include "libApiExport.h"
00030
00031 #include "AEMheader.h"
00032 #include "LATtypeId.h"
00033 #include "EBFevent.h"
00034
00035
00039 class DLL_EXPORT_API ACDtileSide
00040 {
00041 public:
00042   ACDtileSide(unsigned t, bool s, const char* n);
00043   ~ACDtileSide() {}
00044
00045   unsigned    tile() const;
00046   bool        a()    const;
00047   const char* name() const;
00048
00049 private:
00050   unsigned    _tile;
00051   bool        _a;
00052   const char* _name;
00053 };
00054
00055
00062 inline ACDtileSide::ACDtileSide(unsigned t, bool s, const char* n) :
00063   _tile(t), _a(s), _name(n)
00064 {
00065 }
00066
00070 inline unsigned ACDtileSide::tile() const
00071 {
00072   return _tile;
00073 }
00074
00078 inline bool ACDtileSide::a() const
00079 {
00080   return _a == 0;
00081 }
00082
00086 inline const char* ACDtileSide::name() const
00087 {
00088   return _name;
00089 }
00090
00098 inline ACDtileSide* _initTbl()
00099 {
00100   static ACDtileSide a[AEMheader::NUM_CABLES][AEMheader::NUM_CHANNELS] =
00101           {{ACDtileSide(0x25, 0, "120"),  ACDtileSide(0x2B, 0, "NA4"), // 0
00102             ACDtileSide(0x65, 0, "502"),  ACDtileSide(0x2c, 0, "NA5"),
00103             ACDtileSide(0x26, 0, "121"),  ACDtileSide(0x21, 0, "111"),
00104             ACDtileSide(0x1c, 0, "101"),  ACDtileSide(0x27, 0, "122"),
00105             ACDtileSide(0x22, 0, "112"),  ACDtileSide(0x1D, 0, "102"),
00106             ACDtileSide(0x1E, 0, "103"),  ACDtileSide(0x23, 0, "113"),
00107             ACDtileSide(0x28, 0, "123"),  ACDtileSide(0x66, 0, "503"),
00108             ACDtileSide(0x1F, 0, "104"),  ACDtileSide(0x24, 0, "114"),
00109             ACDtileSide(0x29, 0, "124"),  ACDtileSide(0x2A, 0, "130")},
00110            {ACDtileSide(0x2A, 1, "130"),  ACDtileSide(0x25, 1, "120"), // 1
00111             ACDtileSide(0x20, 1, "110"),  ACDtileSide(0x1B, 1, "100"),
00112             ACDtileSide(0x63, 1, "500"),  ACDtileSide(0x26, 1, "121"),
00113             ACDtileSide(0x21, 1, "111"),  ACDtileSide(0x1C, 1, "101"),
00114             ACDtileSide(0x1D, 1, "102"),  ACDtileSide(0x22, 1, "112"),
00115             ACDtileSide(0x27, 1, "122"),  ACDtileSide(0x1E, 1, "103"),
00116             ACDtileSide(0x23, 1, "113"),  ACDtileSide(0x28, 1, "123"),
00117             ACDtileSide(0x2C, 1, "NA5"),  ACDtileSide(0x64, 1, "501"),
00118             ACDtileSide(0x2B, 1, "NA4"),  ACDtileSide(0x29, 1, "124")},
00119            {ACDtileSide(0x20, 0, "110"),  ACDtileSide(0x1B, 0, "100"), // 2
00120             ACDtileSide(0x37, 0, "220"),  ACDtileSide(0x32, 0, "210"),
00121             ACDtileSide(0x67, 0, "600"),  ACDtileSide(0x2D, 0, "200"),
00122             ACDtileSide(0x00, 0, "000"),  ACDtileSide(0x05, 0, "010"),
00123             ACDtileSide(0x0A, 0, "020"),  ACDtileSide(0x38, 0, "221"),
00124             ACDtileSide(0x33, 0, "211"),  ACDtileSide(0x2E, 0, "201"),
00125             ACDtileSide(0x01, 0, "001"),  ACDtileSide(0x06, 0, "011"),
00126             ACDtileSide(0x0B, 0, "021"),  ACDtileSide(0x0C, 0, "022"),
00127             ACDtileSide(0x3D, 0, "NA6"),  ACDtileSide(0x02, 0, "002")},
00128            {ACDtileSide(0x02, 1, "002"),  ACDtileSide(0x68, 1, "601"), // 3
00129             ACDtileSide(0x0C, 1, "022"),  ACDtileSide(0x0B, 1, "021"),
00130             ACDtileSide(0x06, 1, "011"),  ACDtileSide(0x01, 1, "001"),
00131             ACDtileSide(0x2E, 1, "201"),  ACDtileSide(0x33, 1, "211"),
00132             ACDtileSide(0x38, 1, "221"),  ACDtileSide(0x0A, 1, "020"),
00133             ACDtileSide(0x05, 1, "010"),  ACDtileSide(0x00, 1, "000"),
00134             ACDtileSide(0x2D, 1, "200"),  ACDtileSide(0x3D, 1, "NA6"),
00135             ACDtileSide(0x32, 1, "210"),  ACDtileSide(0x37, 1, "220"),
00136             ACDtileSide(0x1A, 1, "NA3"),  ACDtileSide(0x3C, 1, "230")},
00137            {ACDtileSide(0x39, 0, "222"),  ACDtileSide(0x69, 0, "602"), // 4
00138             ACDtileSide(0x34, 0, "212"),  ACDtileSide(0x2F, 0, "202"),
00139             ACDtileSide(0x07, 0, "012"),  ACDtileSide(0x08, 0, "013"),
00140             ACDtileSide(0x03, 0, "003"),  ACDtileSide(0x30, 0, "203"),
00141             ACDtileSide(0x35, 0, "213"),  ACDtileSide(0x3A, 0, "223"),
00142             ACDtileSide(0x09, 0, "014"),  ACDtileSide(0x04, 0, "004"),
00143             ACDtileSide(0x31, 0, "204"),  ACDtileSide(0x3E, 0, "NA7"),
00144             ACDtileSide(0x36, 0, "214"),  ACDtileSide(0x3B, 0, "224"),
00145             ACDtileSide(0x6B, 0, "NA10"), ACDtileSide(0x3C, 0, "230")},
00146            {ACDtileSide(0x44, 1, "310"),  ACDtileSide(0x3F, 1, "300"), // 5
00147             ACDtileSide(0x3B, 1, "224"),  ACDtileSide(0x36, 1, "214"),
00148             ACDtileSide(0x6A, 1, "603"),  ACDtileSide(0x31, 1, "204"),
00149             ACDtileSide(0x04, 1, "004"),  ACDtileSide(0x09, 1, "014"),
00150             ACDtileSide(0x3A, 1, "223"),  ACDtileSide(0x35, 1, "213"),
00151             ACDtileSide(0x30, 1, "203"),  ACDtileSide(0x03, 1, "003"),
00152             ACDtileSide(0x08, 1, "013"),  ACDtileSide(0x07, 1, "012"),
00153             ACDtileSide(0x2F, 1, "202"),  ACDtileSide(0x34, 1, "212"),
00154             ACDtileSide(0x3E, 1, "NA7"),  ACDtileSide(0x39, 1, "222")},
00155            {ACDtileSide(0x4D, 0, "324"),  ACDtileSide(0x50, 0, "NA9"), // 6
00156             ACDtileSide(0x64, 0, "501"),  ACDtileSide(0x4F, 0, "NA8"),
00157             ACDtileSide(0x4C, 0, "323"),  ACDtileSide(0x47, 0, "313"),
00158             ACDtileSide(0x42, 0, "303"),  ACDtileSide(0x4B, 0, "322"),
00159             ACDtileSide(0x46, 0, "312"),  ACDtileSide(0x41, 0, "302"),
00160             ACDtileSide(0x40, 0, "301"),  ACDtileSide(0x45, 0, "311"),
00161             ACDtileSide(0x4A, 0, "321"),  ACDtileSide(0x63, 0, "500"),
00162             ACDtileSide(0x3F, 0, "300"),  ACDtileSide(0x44, 0, "310"),
00163             ACDtileSide(0x49, 0, "320"),  ACDtileSide(0x4E, 0, "330")},
00164            {ACDtileSide(0x4E, 1, "330"),  ACDtileSide(0x4D, 1, "324"), // 7
00165             ACDtileSide(0x48, 1, "314"),  ACDtileSide(0x43, 1, "304"),
00166             ACDtileSide(0x66, 1, "503"),  ACDtileSide(0x4C, 1, "323"),
00167             ACDtileSide(0x47, 1, "313"),  ACDtileSide(0x42, 1, "303"),
00168             ACDtileSide(0x41, 1, "302"),  ACDtileSide(0x46, 1, "312"),
00169             ACDtileSide(0x4B, 1, "322"),  ACDtileSide(0x40, 1, "301"),
00170             ACDtileSide(0x45, 1, "311"),  ACDtileSide(0x4A, 1, "321"),
00171             ACDtileSide(0x4F, 1, "NA8"),  ACDtileSide(0x65, 1, "502"),
00172             ACDtileSide(0x50, 1, "NA9"),  ACDtileSide(0x49, 1, "320")},
00173            {ACDtileSide(0x48, 0, "314"),  ACDtileSide(0x43, 0, "304"), // 8
00174             ACDtileSide(0x61, 0, "NA0"),  ACDtileSide(0x5F, 0, "424"),
00175             ACDtileSide(0x6A, 0, "603"),  ACDtileSide(0x5A, 0, "414"),
00176             ACDtileSide(0x55, 0, "404"),  ACDtileSide(0x18, 0, "044"),
00177             ACDtileSide(0x13, 0, "034"),  ACDtileSide(0x0E, 0, "024"),
00178             ACDtileSide(0x5E, 0, "423"),  ACDtileSide(0x59, 0, "413"),
00179             ACDtileSide(0x54, 0, "403"),  ACDtileSide(0x17, 0, "043"),
00180             ACDtileSide(0x12, 0, "033"),  ACDtileSide(0x0D, 0, "023"),
00181             ACDtileSide(0x62, 0, "NA1"),  ACDtileSide(0x16, 0, "042")},
00182            {ACDtileSide(0x16, 1, "042"),  ACDtileSide(0x69, 1, "602"), // 9
00183             ACDtileSide(0x0D, 1, "023"),  ACDtileSide(0x12, 1, "033"),
00184             ACDtileSide(0x17, 1, "043"),  ACDtileSide(0x54, 1, "403"),
00185             ACDtileSide(0x59, 1, "413"),  ACDtileSide(0x5E, 1, "423"),
00186             ACDtileSide(0x0E, 1, "024"),  ACDtileSide(0x13, 1, "034"),
00187             ACDtileSide(0x18, 1, "044"),  ACDtileSide(0x55, 1, "404"),
00188             ACDtileSide(0x5A, 1, "414"),  ACDtileSide(0x6B, 1, "NA10"),
00189             ACDtileSide(0x5F, 1, "424"),  ACDtileSide(0x61, 1, "NA0"),
00190             ACDtileSide(0x62, 1, "NA1"),  ACDtileSide(0x60, 1, "430")},
00191            {ACDtileSide(0x5D, 0, "422"),  ACDtileSide(0x68, 0, "601"), // 10
00192             ACDtileSide(0x58, 0, "412"),  ACDtileSide(0x53, 0, "402"),
00193             ACDtileSide(0x11, 0, "032"),  ACDtileSide(0x10, 0, "031"),
00194             ACDtileSide(0x15, 0, "041"),  ACDtileSide(0x52, 0, "401"),
00195             ACDtileSide(0x57, 0, "411"),  ACDtileSide(0x5C, 0, "421"),
00196             ACDtileSide(0x0F, 0, "030"),  ACDtileSide(0x14, 0, "040"),
00197             ACDtileSide(0x51, 0, "400"),  ACDtileSide(0x19, 0, "NA2"),
00198             ACDtileSide(0x56, 0, "410"),  ACDtileSide(0x5B, 0, "420"),
00199             ACDtileSide(0x1A, 0, "NA3"),  ACDtileSide(0x60, 0, "430")},
00200            {ACDtileSide(0x24, 1, "114"),  ACDtileSide(0x1F, 1, "104"), // 11
00201             ACDtileSide(0x5B, 1, "420"),  ACDtileSide(0x56, 1, "410"),
00202             ACDtileSide(0x67, 1, "600"),  ACDtileSide(0x51, 1, "400"),
00203             ACDtileSide(0x14, 1, "040"),  ACDtileSide(0x0F, 1, "030"),
00204             ACDtileSide(0x5C, 1, "421"),  ACDtileSide(0x57, 1, "411"),
00205             ACDtileSide(0x52, 1, "401"),  ACDtileSide(0x15, 1, "041"),
00206             ACDtileSide(0x10, 1, "031"),  ACDtileSide(0x11, 1, "032"),
00207             ACDtileSide(0x53, 1, "402"),  ACDtileSide(0x58, 1, "412"),
00208             ACDtileSide(0x19, 1, "NA2"),  ACDtileSide(0x5D, 1, "422")}};
00209
00210   return &a[0][0];
00211 }
00212
00213
00224 inline ACDtileSide* _initTbl2()
00225 {
00226   static ACDtileSide a[AEMheader::NUM_CABLES][AEMheader::NUM_CHANNELS] =
00227           {{ACDtileSide(0x25, 0, "120"),  ACDtileSide(0x69, 0, "502"), // 0
00228             ACDtileSide(0x61, 0, "NA0"),  ACDtileSide(0x62, 0, "NA1"),
00229             ACDtileSide(0x26, 0, "121"),  ACDtileSide(0x21, 0, "111"),
00230             ACDtileSide(0x1c, 0, "101"),  ACDtileSide(0x27, 0, "122"),
00231             ACDtileSide(0x22, 0, "112"),  ACDtileSide(0x1D, 0, "102"),
00232             ACDtileSide(0x1E, 0, "103"),  ACDtileSide(0x23, 0, "113"),
00233             ACDtileSide(0x28, 0, "123"),  ACDtileSide(0x19, 0, "NA2"),
00234             ACDtileSide(0x1F, 0, "104"),  ACDtileSide(0x24, 0, "114"),
00235             ACDtileSide(0x29, 0, "124"),  ACDtileSide(0x2A, 0, "130")},
00236            {ACDtileSide(0x2A, 1, "130"),  ACDtileSide(0x25, 1, "120"), // 1
00237             ACDtileSide(0x20, 1, "110"),  ACDtileSide(0x1B, 1, "100"),
00238             ACDtileSide(0x67, 1, "500"),  ACDtileSide(0x26, 1, "121"),
00239             ACDtileSide(0x21, 1, "111"),  ACDtileSide(0x1C, 1, "101"),
00240             ACDtileSide(0x1D, 1, "102"),  ACDtileSide(0x22, 1, "112"),
00241             ACDtileSide(0x27, 1, "122"),  ACDtileSide(0x1E, 1, "103"),
00242             ACDtileSide(0x23, 1, "113"),  ACDtileSide(0x28, 1, "123"),
00243             ACDtileSide(0x61, 1, "NA0"),  ACDtileSide(0x68, 1, "501"),
00244             ACDtileSide(0x6B, 1, "NA10"), ACDtileSide(0x29, 1, "124")},
00245            {ACDtileSide(0x20, 0, "110"),  ACDtileSide(0x1B, 0, "100"), // 2
00246             ACDtileSide(0x37, 0, "220"),  ACDtileSide(0x32, 0, "210"),
00247             ACDtileSide(0x63, 0, "600"),  ACDtileSide(0x2D, 0, "200"),
00248             ACDtileSide(0x00, 0, "000"),  ACDtileSide(0x05, 0, "010"),
00249             ACDtileSide(0x0A, 0, "020"),  ACDtileSide(0x38, 0, "221"),
00250             ACDtileSide(0x33, 0, "211"),  ACDtileSide(0x2E, 0, "201"),
00251             ACDtileSide(0x01, 0, "001"),  ACDtileSide(0x6A, 0, "503"),
00252             ACDtileSide(0x0B, 0, "021"),  ACDtileSide(0x0C, 0, "022"),
00253             ACDtileSide(0x1A, 0, "NA3"),  ACDtileSide(0x02, 0, "002")},
00254            {ACDtileSide(0x02, 1, "002"),  ACDtileSide(0x64, 1, "601"), // 3
00255             ACDtileSide(0x0C, 1, "022"),  ACDtileSide(0x0B, 1, "021"),
00256             ACDtileSide(0x06, 1, "011"),  ACDtileSide(0x01, 1, "001"),
00257             ACDtileSide(0x2E, 1, "201"),  ACDtileSide(0x33, 1, "211"),
00258             ACDtileSide(0x38, 1, "221"),  ACDtileSide(0x0A, 1, "020"),
00259             ACDtileSide(0x05, 1, "010"),  ACDtileSide(0x00, 1, "000"),
00260             ACDtileSide(0x2D, 1, "200"),  ACDtileSide(0x2B, 0, "NA4"),
00261             ACDtileSide(0x32, 1, "210"),  ACDtileSide(0x37, 1, "220"),
00262             ACDtileSide(0x2C, 0, "NA5"),  ACDtileSide(0x3C, 1, "230")},
00263            {ACDtileSide(0x39, 0, "222"),  ACDtileSide(0x65, 0, "602"), // 4
00264             ACDtileSide(0x34, 0, "212"),  ACDtileSide(0x2F, 0, "202"),
00265             ACDtileSide(0x07, 0, "012"),  ACDtileSide(0x08, 0, "013"),
00266             ACDtileSide(0x03, 0, "003"),  ACDtileSide(0x30, 0, "203"),
00267             ACDtileSide(0x35, 0, "213"),  ACDtileSide(0x3A, 0, "223"),
00268             ACDtileSide(0x09, 0, "014"),  ACDtileSide(0x04, 0, "004"),
00269             ACDtileSide(0x31, 0, "204"),  ACDtileSide(0x06, 0, "011"),
00270             ACDtileSide(0x36, 0, "214"),  ACDtileSide(0x3B, 0, "224"),
00271             ACDtileSide(0x3D, 0, "NA6"),  ACDtileSide(0x3C, 0, "230")},
00272            {ACDtileSide(0x44, 1, "310"),  ACDtileSide(0x3F, 1, "300"), // 5
00273             ACDtileSide(0x3B, 1, "224"),  ACDtileSide(0x36, 1, "214"),
00274             ACDtileSide(0x66, 1, "603"),  ACDtileSide(0x31, 1, "204"),
00275             ACDtileSide(0x04, 1, "004"),  ACDtileSide(0x09, 1, "014"),
00276             ACDtileSide(0x3A, 1, "223"),  ACDtileSide(0x35, 1, "213"),
00277             ACDtileSide(0x30, 1, "203"),  ACDtileSide(0x03, 1, "003"),
00278             ACDtileSide(0x08, 1, "013"),  ACDtileSide(0x07, 1, "012"),
00279             ACDtileSide(0x2F, 1, "202"),  ACDtileSide(0x34, 1, "212"),
00280             ACDtileSide(0x3E, 0, "NA7"),  ACDtileSide(0x39, 1, "222")},
00281            {ACDtileSide(0x4D, 0, "324"),  ACDtileSide(0x4F, 0, "NA8"), // 6
00282             ACDtileSide(0x68, 0, "501"),  ACDtileSide(0x50, 0, "NA9"),
00283             ACDtileSide(0x4C, 0, "323"),  ACDtileSide(0x47, 0, "313"),
00284             ACDtileSide(0x42, 0, "303"),  ACDtileSide(0x4B, 0, "322"),
00285             ACDtileSide(0x46, 0, "312"),  ACDtileSide(0x41, 0, "302"),
00286             ACDtileSide(0x40, 0, "301"),  ACDtileSide(0x45, 0, "311"),
00287             ACDtileSide(0x4A, 0, "321"),  ACDtileSide(0x67, 0, "500"),
00288             ACDtileSide(0x3F, 0, "300"),  ACDtileSide(0x44, 0, "310"),
00289             ACDtileSide(0x49, 0, "320"),  ACDtileSide(0x4E, 0, "330")},
00290            {ACDtileSide(0x4E, 1, "330"),  ACDtileSide(0x4D, 1, "324"), // 7
00291             ACDtileSide(0x48, 1, "314"),  ACDtileSide(0x43, 1, "304"),
00292             ACDtileSide(0x6A, 1, "503"),  ACDtileSide(0x4C, 1, "323"),
00293             ACDtileSide(0x47, 1, "313"),  ACDtileSide(0x42, 1, "303"),
00294             ACDtileSide(0x41, 1, "302"),  ACDtileSide(0x46, 1, "312"),
00295             ACDtileSide(0x4B, 1, "322"),  ACDtileSide(0x40, 1, "301"),
00296             ACDtileSide(0x45, 1, "311"),  ACDtileSide(0x4A, 1, "321"),
00297             ACDtileSide(0x50, 1, "NA9"),  ACDtileSide(0x69, 1, "502"),
00298             ACDtileSide(0x4F, 1, "NA8"),  ACDtileSide(0x49, 1, "320")},
00299            {ACDtileSide(0x48, 0, "314"),  ACDtileSide(0x43, 0, "304"), // 8
00300             ACDtileSide(0x3E, 1, "NA7"),  ACDtileSide(0x5F, 0, "424"),
00301             ACDtileSide(0x66, 0, "603"),  ACDtileSide(0x5A, 0, "414"),
00302             ACDtileSide(0x55, 0, "404"),  ACDtileSide(0x18, 0, "044"),
00303             ACDtileSide(0x13, 0, "034"),  ACDtileSide(0x0E, 0, "024"),
00304             ACDtileSide(0x5E, 0, "423"),  ACDtileSide(0x59, 0, "413"),
00305             ACDtileSide(0x54, 0, "403"),  ACDtileSide(0x17, 0, "043"),
00306             ACDtileSide(0x12, 0, "033"),  ACDtileSide(0x0D, 0, "023"),
00307             ACDtileSide(0x3D, 1, "NA6"),  ACDtileSide(0x16, 0, "042")},
00308            {ACDtileSide(0x16, 1, "042"),  ACDtileSide(0x65, 1, "602"), // 9
00309             ACDtileSide(0x0D, 1, "023"),  ACDtileSide(0x12, 1, "033"),
00310             ACDtileSide(0x17, 1, "043"),  ACDtileSide(0x54, 1, "403"),
00311             ACDtileSide(0x59, 1, "413"),  ACDtileSide(0x5E, 1, "423"),
00312             ACDtileSide(0x0E, 1, "024"),  ACDtileSide(0x13, 1, "034"),
00313             ACDtileSide(0x18, 1, "044"),  ACDtileSide(0x55, 1, "404"),
00314             ACDtileSide(0x5A, 1, "414"),  ACDtileSide(0x1A, 1, "NA3"),
00315             ACDtileSide(0x5F, 1, "424"),  ACDtileSide(0x2B, 1, "NA4"),
00316             ACDtileSide(0x2C, 1, "NA5"),  ACDtileSide(0x60, 1, "430")},
00317            {ACDtileSide(0x5D, 0, "422"),  ACDtileSide(0x64, 0, "601"), // 10
00318             ACDtileSide(0x58, 0, "412"),  ACDtileSide(0x53, 0, "402"),
00319             ACDtileSide(0x11, 0, "032"),  ACDtileSide(0x10, 0, "031"),
00320             ACDtileSide(0x15, 0, "041"),  ACDtileSide(0x52, 0, "401"),
00321             ACDtileSide(0x57, 0, "411"),  ACDtileSide(0x5C, 0, "421"),
00322             ACDtileSide(0x0F, 0, "030"),  ACDtileSide(0x14, 0, "040"),
00323             ACDtileSide(0x51, 0, "400"),  ACDtileSide(0x19, 1, "NA2"),
00324             ACDtileSide(0x56, 0, "410"),  ACDtileSide(0x5B, 0, "420"),
00325             ACDtileSide(0x62, 1, "NA1"),  ACDtileSide(0x60, 0, "430")},
00326            {ACDtileSide(0x24, 1, "114"),  ACDtileSide(0x1F, 1, "104"), // 11
00327             ACDtileSide(0x5B, 1, "420"),  ACDtileSide(0x56, 1, "410"),
00328             ACDtileSide(0x63, 1, "600"),  ACDtileSide(0x51, 1, "400"),
00329             ACDtileSide(0x14, 1, "040"),  ACDtileSide(0x0F, 1, "030"),
00330             ACDtileSide(0x5C, 1, "421"),  ACDtileSide(0x57, 1, "411"),
00331             ACDtileSide(0x52, 1, "401"),  ACDtileSide(0x15, 1, "041"),
00332             ACDtileSide(0x10, 1, "031"),  ACDtileSide(0x11, 1, "032"),
00333             ACDtileSide(0x53, 1, "402"),  ACDtileSide(0x58, 1, "412"),
00334             ACDtileSide(0x6B, 0, "NA10"), ACDtileSide(0x5D, 1, "422")}};
00335
00336   return &a[0][0];
00337 }
00338
00348 inline char** _initGemTbl()
00349 {
00350   static char* a[128] = {"200","201","202","203","204",   // X - minus side 0-15
00351                          "210","211","212","213","214",
00352                          "220","221","222","223","224",
00353                          "230",
00354                          "400","401","402","403","404", // X - plus side  16-31
00355                          "410","411","412","413","414",
00356                          "420","421","422","423","424",
00357                          "430",
00358                          "100","101","102","103","104", // Y - minus side 32-47
00359                          "110","111","112","113","114",
00360                          "120","121","122","123","124",
00361                          "130",
00362                          "300","301","302","303","304", // Y - plus side 48-63
00363                          "310","311","312","313","314",
00364                          "320","321","322","323","324",
00365                          "330",
00366                          "000","001","002","003","004", // Top 64-88
00367                          "010","011","012","013","014",
00368                          "020","021","022","023","024",
00369                          "030","031","032","033","034",
00370                          "040","041","042","043","044",
00371                          "MBZ","MBZ","MBZ","MBZ","MBZ", // 89-95 Must Be Zero
00372                          "MBZ","MBZ",
00373                          "500","501","502","503",       // Ribbons 96-103
00374                          "600","601","602","603",
00375                          "MBZ","MBZ","MBZ","MBZ",       // 104 - 111 Must Be Zero
00376                          "MBZ","MBZ","MBZ","MBZ",
00377                          "NA0","NA1","NA2","NA3","NA4","NA5", // Not Assigned 112-122
00378                          "NA6","NM7","NA8","NA9","NAA",
00379                          "MBZ","MBZ","MBZ","MBZ","MBZ"};       // 123-127 Must Be Zero
00380
00381   return &a[0];
00382 }
00383
00384
00389 class DLL_EXPORT_API ACDmap
00390 {
00391 public:
00392   ACDmap();
00393   virtual ~ACDmap() {}
00394
00395   virtual const ACDtileSide* lookup(LATtypeId evtId,
00396                                     unsigned  cable,
00397                                     unsigned  channel) const;
00398   virtual const char*        freeName(LATtypeId evtId,
00399                                       unsigned  cable) const;
00400
00401   virtual const char*        tileNameFromGemIndex(unsigned gemIndex) const;
00402
00403 private:
00404   ACDtileSide* _lookup;
00405   ACDtileSide* _lookup2;
00406
00407   char** _tileNameFromGemIndex;
00408
00409 };
00410
00414 inline ACDmap::ACDmap() :
00415   _lookup(_initTbl()),
00416   _lookup2(_initTbl2()),
00417   _tileNameFromGemIndex(_initGemTbl())
00418 {
00419 }
00420
00434 inline const ACDtileSide* ACDmap::lookup(LATtypeId evtId,
00435                                          unsigned  cable,
00436                                          unsigned  channel) const
00437 {
00438   ACDtileSide* ts;
00439
00440   if (evtId.value() == EBFevent::ID_3)  // Use the bastardized table
00441     ts = &_lookup2[cable*AEMheader::NUM_CHANNELS + channel];
00442   else                                  // All others use the normal table
00443     ts = &_lookup[cable*AEMheader::NUM_CHANNELS + channel];
00444
00445   return ts;
00446 }
00447
00448
00449
00461 inline const char* ACDmap::freeName(LATtypeId /* evtId */,
00462                                     unsigned  cable) const
00463 {
00464   static const char* name[AEMheader::NUM_CABLES] =
00465     {"1LA", "1RB", "2LA", "2LB", "2RA", "2RB",
00466      "3LA", "3RB", "4LA", "4LB", "4RA", "4RB"
00467     };
00468
00469   return name[cable];
00470 }
00471
00472
00473
00481 inline const char* ACDmap::tileNameFromGemIndex(unsigned gemIndex) const
00482 {
00483   return _tileNameFromGemIndex[gemIndex];
00484 }
00485
00486 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: ACDpha.h Source File

  • File List
  • File Members

ACDpha.h

00001
00023 #ifndef ACDpha_H
00024 #define ACDpha_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030
00031 class DLL_EXPORT_API ACDpha
00032 {
00033 public:
00034   ACDpha(unsigned value);
00035   ACDpha()  {}
00036   ~ACDpha() {}
00037
00038   static
00039   unsigned more(unsigned value);
00040   unsigned more() const;
00041
00042   static
00043   unsigned ADCrange(unsigned value);
00044   unsigned ADCrange() const;
00045
00046   static
00047   unsigned ADCvalue(unsigned value);
00048   unsigned ADCvalue() const;
00049
00050   static
00051   unsigned parityError(unsigned value);
00052   unsigned parityError() const;
00053
00054   unsigned datum() const;
00055
00056 private:
00057   unsigned _value;
00058 };
00059
00060
00065 inline ACDpha::ACDpha(unsigned value) :
00066   _value(value)
00067 {
00068 }
00069
00075 inline unsigned ACDpha::more(unsigned value)
00076 {
00077   return ( value >> 14) & 0x0001;
00078 }
00079
00084 inline unsigned ACDpha::more() const
00085 {
00086   return (_value >> 14) & 0x0001;
00087 }
00088
00094 inline unsigned ACDpha::ADCrange(unsigned value)
00095 {
00096   return ( value >> 13) & 0x0001;
00097 }
00098
00103 inline unsigned ACDpha::ADCrange() const
00104 {
00105   return (_value >> 13) & 0x0001;
00106 }
00107
00113 inline unsigned ACDpha::ADCvalue(unsigned value)
00114 {
00115   return ( value >>  1) & 0x0fff;
00116 }
00117
00122 inline unsigned ACDpha::ADCvalue() const
00123 {
00124   return (_value >>  1) & 0x0fff;
00125 }
00126
00132 inline unsigned ACDpha::parityError(unsigned value)
00133 {
00134   return   value        & 0x0001;
00135 }
00136
00141 inline unsigned ACDpha::parityError() const
00142 {
00143   return  _value        & 0x0001;
00144 }
00145
00150 inline unsigned ACDpha::datum() const
00151 {
00152   return  _value;
00153 }
00154
00155 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: AEMcontribution.h Source File

  • File List
  • File Members

AEMcontribution.h

00001
00023 #ifndef AEMcontribution_H
00024 #define AEMcontribution_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030 #include "EBFcontribution.h"
00031
00032
00033 class DLL_EXPORT_API AEMcontribution : public EBFcontribution
00034 {
00035 public:
00036   AEMcontribution()  {}
00037   ~AEMcontribution() {}
00038
00039   char* data() const;
00040 };
00041
00042
00047 inline char* AEMcontribution::data() const
00048 {
00049   return payload();
00050 }
00051
00052 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: AEMcontributionIterator.h Source File

  • File List
  • File Members

AEMcontributionIterator.h

00001
00023 #ifndef AEMcontributionIterator_H
00024 #define AEMcontributionIterator_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030 #include "LATp.h"
00031 #include "EBFevent.h"
00032 #include "ACDpha.h"
00033 #include "AEMcontribution.h"
00034 #include "AEMheader.h"
00035 #include "eventSummary.h"
00036 #include "ACDmap.h"
00037
00038
00039 class DLL_EXPORT_API AEMcontributionIterator
00040 {
00041 public:
00042   AEMcontributionIterator(EBFevent*, AEMcontribution*, ACDmap*);
00043   AEMcontributionIterator(EBFevent*, AEMcontribution*);
00044   AEMcontributionIterator(ACDmap*);
00045   AEMcontributionIterator();
00046   virtual ~AEMcontributionIterator() {}
00047
00048   enum
00049   {
00050     ERR_TooManyPhas = 1
00051   };
00052
00053   unsigned iterate();
00054   unsigned iterate(EBFevent*, AEMcontribution*);
00055   unsigned iterate(EBFevent*, AEMcontribution*, ACDmap*);
00056
00057   virtual int handleError(AEMcontribution*, unsigned code, unsigned p1=0, unsigned p2=0) const;
00058
00060   const EBFevent*        event()        const  { return _event;        }
00062   const AEMcontribution* contribution() const  { return _contribution; }
00064   const ACDmap*          map()          const  { return _map;          }
00065
00066   // Pure Virtual methods
00073   virtual void header(unsigned cable, AEMheader hdr) = 0;
00081   virtual void pha(unsigned cable, unsigned channel, ACDpha pha) = 0;
00082
00083 private:
00095   unsigned _iterate  (EBFevent*        event,
00096                       AEMcontribution* contribution,
00097                       ACDmap*          map);
00098
00110   unsigned _iterate_1(EBFevent*        event,
00111                       AEMcontribution* contribution,
00112                       ACDmap*          map);
00113
00114 private:
00115   EBFevent*        _event;
00116   AEMcontribution* _contribution;
00117   ACDmap*          _map;
00118   ACDmap           _ACDmap;             // Default map to use
00119 };
00120
00121
00125 inline AEMcontributionIterator::AEMcontributionIterator() :
00126   _event(0),
00127   _contribution(0),
00128   _map(&_ACDmap)
00129 {
00130 }
00131
00135 inline AEMcontributionIterator::AEMcontributionIterator(ACDmap* map) :
00136   _event(0),
00137   _contribution(0),
00138   _map(map)
00139 {
00140 }
00141
00150 inline AEMcontributionIterator::AEMcontributionIterator(EBFevent*        event,
00151                                                         AEMcontribution* contribution) :
00152   _event(event),
00153   _contribution(contribution),
00154   _map(&_ACDmap)
00155 {
00156 }
00157
00168 inline AEMcontributionIterator::AEMcontributionIterator(EBFevent*        event,
00169                                                         AEMcontribution* contribution,
00170                                                         ACDmap*          map) :
00171   _event(event),
00172   _contribution(contribution),
00173   _map(map)
00174 {
00175 }
00176
00186 inline unsigned
00187 AEMcontributionIterator::iterate()
00188 {
00189   return iterate(_event, _contribution, _map);
00190 }
00191
00204 inline unsigned
00205 AEMcontributionIterator::iterate(EBFevent*        event,
00206                                  AEMcontribution* contribution)
00207 {
00208   return iterate(event, contribution, _map);
00209 }
00210
00222 inline unsigned
00223 AEMcontributionIterator::iterate(EBFevent*        event,
00224                                  AEMcontribution* contribution,
00225                                  ACDmap*          map)
00226 {
00227   switch (event->identity().value())
00228   {
00229     case EBFevent::ID_1:  return _iterate_1(event, contribution, map);  break;
00230     default:              return _iterate  (event, contribution, map);  break;
00231   }
00232   return 0;
00233 }
00234
00235 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: AEMheader.h Source File

  • File List
  • File Members

AEMheader.h

00001
00029 #ifndef AEMheader_H
00030 #define AEMheader_H
00031
00032 #include "copyright_SLAC.h"
00033
00034 #include "libApiExport.h"
00035
00036 #include "DFC_endianness.h"
00037
00038
00039 class DLL_EXPORT_API AEMheader
00040 {
00041 public:
00042   AEMheader(unsigned short* header);
00043   AEMheader()  {}
00044   ~AEMheader() {}
00045
00046   enum {NUM_CABLES = 12, NUM_CHANNELS = 18};
00047
00048   static
00049   unsigned startBit(unsigned short* header);
00050   unsigned startBit() const;
00051   static
00052   unsigned hitMap(unsigned short* header);
00053   unsigned hitMap() const;
00054   static
00055   unsigned acceptMap(unsigned short* header);
00056   unsigned acceptMap() const;
00057   static
00058   unsigned phaVector(unsigned short* header);
00059   unsigned phaVector() const;
00060   static
00061   unsigned parityError(unsigned short* header);
00062   unsigned parityError() const;
00063   static
00064   unsigned endOfCables(unsigned short* header);
00065   unsigned endOfCables() const;
00066   static
00067   unsigned cableNumber(unsigned short* header);
00068   unsigned cableNumber() const;
00069
00070 private:
00071 #if DFC_BIG_ENDIAN
00072 #  define HEADER(i) (header[i])
00073 #else
00074 #  define HEADER(i) (_Header(header, i))
00075
00076   // The following crud is for getting around the fact that the shorts
00077   // appear swapped on a little endian machine.  The pointer arithmetic and
00078   // casting is to get around VS.NET compiler warnings.
00079   static unsigned _Header(unsigned short* header, unsigned index)
00080   {
00081     static const unsigned i[] = {1, 0, 3, 2};
00082     unsigned        alignment = (unsigned)((header - (unsigned short*)(0)) & 1);
00083     return header[i[alignment + index] - alignment];
00084   }
00085 #endif
00086   unsigned short _header[3];
00087 };
00088
00089
00094 inline AEMheader::AEMheader(unsigned short* header)
00095 {
00096   _header[0] = HEADER(0);
00097   _header[1] = HEADER(1);
00098   _header[2] = HEADER(2);
00099 }
00100
00106 inline unsigned AEMheader::startBit(unsigned short* header)
00107 {
00108   return  ( HEADER(0) >> 15) & 0x0001;
00109 }
00110
00115 inline unsigned AEMheader::startBit() const
00116 {
00117   return  (_header[0] >> 15) & 0x0001;
00118 }
00119
00125 inline unsigned AEMheader::hitMap(unsigned short* header)
00126 {
00127   return ((( HEADER(0)      ) & 0x7fff) << 3) | (( HEADER(1) >> 13) & 0x0007);
00128 }
00129
00134 inline unsigned AEMheader::hitMap() const
00135 {
00136   return (((_header[0]      ) & 0x7fff) << 3) | ((_header[1] >> 13) & 0x0007);
00137 }
00138
00144 inline unsigned AEMheader::acceptMap(unsigned short* header)
00145 {
00146   return ((( HEADER(1)      ) & 0x1fff) << 5) | (( HEADER(2) >> 11) & 0x001f);
00147 }
00148
00153 inline unsigned AEMheader::acceptMap() const
00154 {
00155   return (((_header[1]      ) & 0x1fff) << 5) | ((_header[2] >> 11) & 0x001f);
00156 }
00157
00163 inline unsigned AEMheader::phaVector(unsigned short* header)
00164 {
00165   return  ( HEADER(2) >> 10) & 0x0001;
00166 }
00167
00172 inline unsigned AEMheader::phaVector() const
00173 {
00174   return  (_header[2] >> 10) & 0x0001;
00175 }
00176
00182 inline unsigned AEMheader::parityError(unsigned short* header)
00183 {
00184   return  ( HEADER(2) >>  9) & 0x0001;
00185 }
00186
00191 inline unsigned AEMheader::parityError() const
00192 {
00193   return  (_header[2] >>  9) & 0x0001;
00194 }
00195
00201 inline unsigned AEMheader::endOfCables(unsigned short* header)
00202 {
00203   return  ( HEADER(2) >>  8) & 0x0001;
00204 }
00205
00210 inline unsigned AEMheader::endOfCables() const
00211 {
00212   return  (_header[2] >>  8) & 0x0001;
00213 }
00214
00220 inline unsigned AEMheader::cableNumber(unsigned short* header)
00221 {
00222   return  ( HEADER(2) >>  4) & 0x000f;
00223 }
00224
00229 inline unsigned AEMheader::cableNumber() const
00230 {
00231   return  (_header[2] >>  4) & 0x000f;
00232 }
00233
00234 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: ASCcno.h Source File

  • File List
  • File Members

ASCcno.h

00001
00023 #ifndef ASCcno_H
00024 #define ASCcno_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030
00031 class DLL_EXPORT_API ASCcno
00032 {
00033 public:
00034
00035   enum BoardPair { One = 0, TwoL, TwoR, Three, FourL, FourR, N_BoardPair } ;
00036   enum BoardBit { A = 0, B };
00037   enum BoardStatus { None = 0, AOnly, BOnly, Both, N_BoardStatus };
00038
00039   ASCcno(unsigned ptr[24]);
00040   ASCcno()  :_ptr(0){};
00041   ~ASCcno() {};
00042
00043   static
00044   unsigned counts(unsigned* ptr, BoardPair board, BoardStatus status);
00045   unsigned counts(BoardPair board, BoardStatus status) const;
00046
00047   static
00048   unsigned counts_fired(unsigned* ptr, BoardPair board );
00049   unsigned counts_fired(BoardPair board) const;
00050
00051   static
00052   unsigned counts_fired(unsigned* ptr, BoardPair board, BoardBit AorB);
00053   unsigned counts_fired(BoardPair board, BoardBit AorB) const;
00054
00055   unsigned* ptr() const { return _ptr; }
00056
00057 private:
00058   unsigned* _ptr;
00059 };
00060
00061
00066 inline ASCcno::ASCcno(unsigned ptr[24]) :
00067   _ptr(ptr)
00068 {
00069 }
00070
00078 inline unsigned ASCcno::counts(unsigned* ptr, BoardPair board, BoardStatus status)
00079 {
00080   if ( ptr == 0 ) return 0;
00081   return ptr[N_BoardStatus*board + status];
00082 }
00083
00090 inline unsigned ASCcno::counts(BoardPair board, BoardStatus status) const
00091 {
00092   if ( _ptr == 0 ) return 0;
00093   return _ptr[N_BoardStatus*board + status];
00094 }
00095
00102 inline unsigned ASCcno::counts_fired(unsigned* ptr,BoardPair board )
00103 {
00104   unsigned returnValue(0);
00105   returnValue += counts(ptr,board,AOnly);
00106   returnValue += counts(ptr,board,BOnly);
00107   returnValue += counts(ptr,board,Both);
00108   return returnValue;
00109 }
00110
00116 inline unsigned ASCcno::counts_fired(BoardPair board ) const
00117 {
00118   unsigned returnValue(0);
00119   returnValue += counts(board,AOnly);
00120   returnValue += counts(board,BOnly);
00121   returnValue += counts(board,Both);
00122   return returnValue;
00123 }
00124
00132 inline unsigned ASCcno::counts_fired(unsigned* ptr,BoardPair board, BoardBit AorB )
00133 {
00134   unsigned returnValue(0);
00135   returnValue += AorB == A ? counts(ptr,board,AOnly) : counts(ptr,board,BOnly);
00136   returnValue += counts(ptr,board,Both);
00137   return returnValue;
00138 }
00139
00147 inline unsigned ASCcno::counts_fired(BoardPair board, BoardBit AorB ) const
00148 {
00149   unsigned returnValue(0);
00150   returnValue += AorB == A ? counts(board,AOnly) : counts(board,BOnly);
00151   returnValue += counts(board,Both);
00152   return returnValue;
00153 }
00154
00155 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: ASCcontribution.h Source File

  • File List
  • File Members

ASCcontribution.h

00001
00023 #ifndef ASCcontribution_H
00024 #define ASCcontribution_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030 #include "LATcontribution.h"
00031
00032 class DLL_EXPORT_API ASCcontribution : public LATcontribution
00033 {
00034 public:
00035
00036   ASCcontribution() {}
00037   ~ASCcontribution() {}
00038
00039   enum {
00040     Summary_Words = 16,   // 16 32 bit words
00041     CNO_Words = 24,       // 24 32 bit words
00042     Tile_Words = 4096,    // 4*32*32 32 bit words -> 4*32*32 = 4096
00043   };
00044
00045   static ASCcontribution*  create(unsigned char* buffer, unsigned size, bool swap = !DFC_BIG_ENDIAN);
00046   unsigned char*    string(bool swap = !DFC_BIG_ENDIAN);
00047
00049   unsigned* summaryPtr() const {
00050     return (unsigned*)rawData();
00051   }
00053   unsigned* cnoPtr() const {
00054     return (unsigned*)rawData() + Summary_Words;
00055   }
00057   unsigned* tilesPtr() const {
00058     return (unsigned*)rawData() + Summary_Words + CNO_Words;
00059   }
00060
00061 };
00062
00083 inline ASCcontribution* ASCcontribution::create(unsigned char* buffer, unsigned size, bool swap)
00084 {
00085   if (swap)
00086   {
00087     EBF_swap32_lclXbigN((unsigned*)buffer, size / sizeof (unsigned));
00088   }
00089   return (ASCcontribution*)buffer;
00090 }
00091
00102 inline unsigned char* ASCcontribution::string(bool swap)
00103 {
00104   if (swap)
00105   {
00106     EBF_swap32_lclXbigN((unsigned*)this, length() / sizeof (unsigned));
00107   }
00108   return (unsigned char*)this;
00109 }
00110
00111 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: ASCcontributionIterator.h Source File

  • File List
  • File Members

ASCcontributionIterator.h

00001
00023 #ifndef ASCcontributionIterator_H
00024 #define ASCcontributionIterator_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030 #include "ASCcontribution.h"
00031
00032 #include "ASCsummary.h"
00033 #include "ASCcno.h"
00034 #include "ASCtileContribution.h"
00035 #include "ACDmap.h"
00036
00037 class DLL_EXPORT_API ASCcontributionIterator
00038 {
00039 public:
00040
00041   ASCcontributionIterator(ASCcontribution*, ACDmap*);
00042   ASCcontributionIterator();
00043   virtual ~ASCcontributionIterator() {}
00044
00045   unsigned iterate();
00046   unsigned iterate(ASCcontribution*);
00047   unsigned iterate(ASCcontribution*, ACDmap*);
00048
00049   virtual int handleError(ASCcontribution*, unsigned code, unsigned p1=0, unsigned p2=0) const;
00050
00052   ASCcontribution* contribution() const  { return _contribution; }
00053
00055   const ACDmap*          map()          const  { return _map;          }
00056
00057   // Pure Virtual methods
00062   virtual void summary(ASCsummary& summary) = 0;
00063
00068   virtual void cno(ASCcno& cno) = 0;
00069
00074   virtual void tiles(ASCtileContribution& tiles) = 0;
00075
00077   int status() const;
00078
00079 private:
00090   unsigned _iterate  (ASCcontribution* contribution,
00091                       ACDmap*          map);
00092
00093 private:
00094   ASCcontribution* _contribution;
00095   ACDmap*          _map;
00096
00097   int _status;
00098 };
00099
00100
00104 inline ASCcontributionIterator::ASCcontributionIterator() :
00105   _contribution(0),
00106   _map(0),
00107   _status(0)
00108 {
00109   static ACDmap aMap;
00110   _map = &aMap;
00111 }
00112
00122 inline ASCcontributionIterator::ASCcontributionIterator(ASCcontribution* contribution,
00123                                                         ACDmap*          map) :
00124   _contribution(contribution),
00125   _map(map),
00126   _status(0)
00127 {
00128   if ( map == 0 ) {
00129     static ACDmap aMap;
00130     _map = &aMap;
00131   }
00132 }
00133
00142 inline unsigned
00143 ASCcontributionIterator::iterate()
00144 {
00145   return iterate(_contribution, _map);
00146 }
00147
00148
00158 inline unsigned
00159 ASCcontributionIterator::iterate(ASCcontribution* contribution)
00160 {
00161   return _iterate  (contribution, _map);
00162 }
00163
00164
00165
00176 inline unsigned
00177 ASCcontributionIterator::iterate(ASCcontribution* contribution,
00178                                  ACDmap*          map)
00179 {
00180   return _iterate  (contribution, map);
00181 }
00182
00183
00185 inline int ASCcontributionIterator::status() const
00186 {
00187   return _status;
00188 }
00189
00190 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: ASCsummary.h Source File

  • File List
  • File Members

ASCsummary.h

00001
00022 #ifndef ASCsummary_H
00023 #define ASCsummary_H
00024
00025 #include "copyright_SLAC.h"
00026
00027 #include "libApiExport.h"
00028
00029
00030 class DLL_EXPORT_API ASCsummary
00031 {
00032 public:
00033
00034   enum AemStatus { AEM_Ok=0, AEM_InError=1, AEM_Missing=2, N_AEM_Status=3 };
00035   enum GemStatus { GEM_Ok=0, GEM_InError=1, GEM_Missing=2, N_GEM_Status=3 };
00036
00037   ASCsummary(unsigned ptr[9]);
00038   ASCsummary():_ptr(0){};
00039   ~ASCsummary() {};
00040
00041   static
00042   unsigned counts(unsigned* ptr, AemStatus aemStatus, GemStatus gemStatus);
00043   unsigned counts(AemStatus aemStatus, GemStatus gemStatus) const;
00044
00045   static
00046   unsigned counts(unsigned* ptr, AemStatus aemStatus);
00047   unsigned counts(AemStatus aemStatus) const;
00048
00049   static
00050   unsigned counts(unsigned* ptr, GemStatus gemStatus);
00051   unsigned counts(GemStatus gemStatus) const;
00052
00053   unsigned* ptr() const;
00054
00055 private:
00056   unsigned* _ptr;
00057 };
00058
00059
00064 inline ASCsummary::ASCsummary(unsigned ptr[9]) :
00065   _ptr(ptr)
00066 {
00067 }
00068
00076 inline unsigned ASCsummary::counts(unsigned* ptr, AemStatus aemStatus, GemStatus gemStatus)
00077 {
00078   if ( ptr == 0 ) return 0;
00079   return ptr[N_GEM_Status*aemStatus + gemStatus];
00080 }
00081
00088 inline unsigned ASCsummary::counts(AemStatus aemStatus, GemStatus gemStatus) const
00089 {
00090   if ( _ptr == 0 ) return 0;
00091   return _ptr[N_GEM_Status*aemStatus + gemStatus];
00092 }
00093
00100 inline unsigned ASCsummary::counts(unsigned* ptr, AemStatus aemStatus)
00101 {
00102   unsigned returnValue(0);
00103   returnValue += counts(ptr,aemStatus,GEM_Ok);
00104   returnValue += counts(ptr,aemStatus,GEM_InError);
00105   returnValue += counts(ptr,aemStatus,GEM_Missing);
00106   return returnValue;
00107 }
00108
00114 inline unsigned ASCsummary::counts(AemStatus aemStatus) const
00115 {
00116   unsigned returnValue(0);
00117   returnValue += counts(aemStatus,GEM_Ok);
00118   returnValue += counts(aemStatus,GEM_InError);
00119   returnValue += counts(aemStatus,GEM_Missing);
00120   return returnValue;
00121 }
00122
00129 inline unsigned ASCsummary::counts(unsigned* ptr, GemStatus gemStatus)
00130 {
00131   unsigned returnValue(0);
00132   returnValue += counts(ptr,AEM_Ok,gemStatus);
00133   returnValue += counts(ptr,AEM_InError,gemStatus);
00134   returnValue += counts(ptr,AEM_Missing,gemStatus);
00135   return returnValue;
00136 }
00137
00143 inline unsigned ASCsummary::counts(GemStatus gemStatus) const
00144 {
00145   unsigned returnValue(0);
00146   returnValue += counts(AEM_Ok,gemStatus);
00147   returnValue += counts(AEM_InError,gemStatus);
00148   returnValue += counts(AEM_Missing,gemStatus);
00149   return returnValue;
00150 }
00151
00156 inline unsigned* ASCsummary::ptr() const {
00157   return _ptr;
00158 }
00159
00160 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: ASCtile.h Source File

  • File List
  • File Members

ASCtile.h

00001
00023 #ifndef ASCtile_H
00024 #define ASCtile_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030
00031 class DLL_EXPORT_API ASCtile
00032 {
00033 public:
00034
00035   enum StatusBit { SignalA=0, SignalB=1, VetoA=2, VetoB=3, GemVeto=4 } ;
00036
00037   class StatusMask {
00038   public:
00039     inline StatusMask():_mask(0){};
00040     StatusMask(bool sigA, bool sigB, bool vetoA, bool vetoB, bool gemVeto);
00041     inline ~StatusMask(){};
00042     unsigned mask();
00043     bool checkBit(StatusBit bit) const;
00044     void setBit(StatusBit bit);
00045   private:
00046     unsigned _mask;
00047   };
00048
00049   ASCtile(unsigned ptr[32]);
00050   ASCtile():_ptr(0){};
00051   ~ASCtile() {};
00052
00053   static
00054   unsigned counts(unsigned* ptr, StatusMask mask);
00055   unsigned counts(StatusMask mask) const;
00056
00057   static
00058   unsigned counts(unsigned* ptr, StatusBit bit);
00059   unsigned counts(StatusBit bit) const;
00060
00061   unsigned* ptr() const { return _ptr; }
00062   char* rawData() const { return (char*)_ptr; }
00063
00064 private:
00065   unsigned* _ptr;
00066 };
00067
00068
00073 inline ASCtile::ASCtile(unsigned ptr[32]) :
00074   _ptr(ptr)
00075 {
00076 }
00077
00086 inline ASCtile::StatusMask::StatusMask(bool sigA, bool sigB, bool vetoA, bool vetoB, bool gemVeto)
00087   :_mask(0){
00088   if ( sigA ) setBit(SignalA);
00089   if ( sigB ) setBit(SignalB);
00090   if ( vetoA ) setBit(VetoA);
00091   if ( vetoB ) setBit(VetoB);
00092   if ( gemVeto ) setBit (GemVeto);
00093 }
00094
00099 inline unsigned ASCtile::StatusMask::mask() {
00100   return _mask;
00101 }
00102
00108 inline bool ASCtile::StatusMask::checkBit(StatusBit bit) const {
00109   return (_mask & (1 << bit)) == 1;
00110 }
00111
00116 inline void ASCtile::StatusMask::setBit(StatusBit bit) {
00117   _mask |= ( 1 << bit );
00118 }
00119
00126 inline unsigned ASCtile::counts(unsigned* ptr, StatusMask mask)
00127 {
00128   if ( ptr == 0 ) return 0;
00129   return ptr[mask.mask()];
00130 }
00131
00137 inline unsigned ASCtile::counts(StatusMask mask) const
00138 {
00139   if ( _ptr == 0 ) return 0;
00140   return _ptr[mask.mask()];
00141 }
00142
00149 inline unsigned ASCtile::counts(unsigned* ptr, StatusBit bit)
00150 {
00151   unsigned returnValue(0);
00152   unsigned testMask = 1 << bit;
00153   for ( unsigned i(0); i < 32; i++ ) {
00154     if ( ! (i & testMask) ) continue;
00155     returnValue += ptr[i];
00156   }
00157   return returnValue;
00158 }
00159
00165 inline unsigned ASCtile::counts(StatusBit bit) const
00166 {
00167   unsigned returnValue(0);
00168   unsigned testMask = 1 << bit;
00169   for ( unsigned i(0); i < 32; i++ ) {
00170     if ( ! (i & testMask) ) continue;
00171     returnValue += _ptr[i];
00172   }
00173   return returnValue;
00174 }
00175
00176 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: ASCtileContribution.h Source File

  • File List
  • File Members

ASCtileContribution.h

00001
00023 #ifndef ASCtileContribution_H
00024 #define ASCtileContribution_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030 class DLL_EXPORT_API ASCtileContribution
00031 {
00032 public:
00033
00034   enum {
00035     Tile_Words = 32 // 32 32 bits words per tile
00036   };
00037
00038   ASCtileContribution(unsigned* ptr);
00039   ASCtileContribution();
00040   ~ASCtileContribution() {};
00041
00042   unsigned* ptr() const;
00043
00044 private:
00045   unsigned* _ptr;
00046 };
00047
00051 inline ASCtileContribution::ASCtileContribution() :
00052   _ptr(0)
00053 {
00054 }
00055
00060 inline ASCtileContribution::ASCtileContribution(unsigned* ptr) :
00061   _ptr(ptr)
00062 {
00063 }
00064
00069 inline unsigned* ASCtileContribution::ptr() const
00070 {
00071   return _ptr;
00072 }
00073
00074 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: ASCtileContributionIterator.h Source File

  • File List
  • File Members

ASCtileContributionIterator.h

00001
00023 #ifndef ASCtileContributionIterator_H
00024 #define ASCtileContributionIterator_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030 #include "ASCcontribution.h"
00031 #include "ASCtileContribution.h"
00032 #include "ASCtile.h"
00033 #include "ACDmap.h"
00034
00035 class DLL_EXPORT_API ASCtileContributionIterator
00036 {
00037 public:
00038
00039   ASCtileContributionIterator(ASCcontribution*,ASCtileContribution*,ACDmap*);
00040   ASCtileContributionIterator();
00041   virtual ~ASCtileContributionIterator() {}
00042
00043   unsigned iterate();
00044   unsigned iterate(ASCcontribution*, ASCtileContribution*);
00045   unsigned iterate(ASCcontribution*, ASCtileContribution*, const ACDmap*);
00046
00047   virtual int handleError(ASCtileContribution*, unsigned code, unsigned p1=0, unsigned p2=0) const;
00048
00050   const ASCcontribution*        ascDatagram()        const  { return _asc;        }
00052   const ASCtileContribution* contribution() const  { return _contribution; }
00054   const ACDmap*          map()          const  { return _map;          }
00055
00056   // Pure Virtual methods
00062   virtual void tile(unsigned channel, const ASCtile& tile) = 0;
00063
00064 private:
00076   unsigned _iterate  (ASCcontribution* asc,
00077                       ASCtileContribution* contribution,
00078                       const ACDmap*          map);
00079
00080 private:
00081   ASCcontribution*        _asc;
00082   ASCtileContribution*    _contribution;
00083   ACDmap*                 _map;
00084
00085 };
00086
00087
00091 inline ASCtileContributionIterator::ASCtileContributionIterator() :
00092   _asc(0),
00093   _contribution(0),
00094   _map(0)
00095 {
00096   // make sure we have a map
00097   static ACDmap aMap;
00098   _map = &aMap;
00099 }
00100
00111 inline ASCtileContributionIterator::ASCtileContributionIterator(ASCcontribution*     asc,
00112                                                                 ASCtileContribution* contribution,
00113                                                                 ACDmap*          map) :
00114   _asc(asc),
00115   _contribution(contribution),
00116   _map(map)
00117 {
00118   if ( _map == 0 ) {
00119     // make sure we have a map
00120     static ACDmap aMap;
00121     _map = &aMap;
00122   }
00123 }
00124
00134 inline unsigned
00135 ASCtileContributionIterator::iterate()
00136 {
00137   return iterate(_asc, _contribution, _map);
00138 }
00139
00150 inline unsigned
00151 ASCtileContributionIterator::iterate(ASCcontribution*     asc,
00152                                      ASCtileContribution* contribution)
00153 {
00154   return _iterate  (asc, contribution, _map);
00155 }
00156
00168 inline unsigned
00169 ASCtileContributionIterator::iterate(ASCcontribution*     asc,
00170                                      ASCtileContribution* contribution,
00171                                      const ACDmap*          map)
00172 {
00173   return _iterate  (asc, contribution, map);
00174 }
00175
00176 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: CALcontribution.h Source File

  • File List
  • File Members

CALcontribution.h

00001
00023 #ifndef CALcontribution_H
00024 #define CALcontribution_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030 #include "TEMcontribution.h"
00031
00032
00033 class DLL_EXPORT_API CALcontribution : public TEMcontribution
00034 {
00035 public:
00036   CALcontribution()    {}
00037   ~CALcontribution()   {}
00038
00039   char*    data() const;
00040 };
00041
00042
00049 inline char* CALcontribution::data() const
00050 {
00051   return &payload()[4];                 /* 1 longword after logAccepts mask */
00052 }
00053
00054 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: CALcontributionIterator.h Source File

  • File List
  • File Members

CALcontributionIterator.h

00001
00023 #ifndef CALcontributionIterator_H
00024 #define CALcontributionIterator_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030 #include "CALlog.h"
00031 #include "CALmap.h"
00032
00033 #include "EBFevent.h"
00034 #include "CALcontribution.h"
00035
00036 class DLL_EXPORT_API CALcontributionIterator
00037 {
00038 public:
00039   CALcontributionIterator(EBFevent*, CALcontribution*, CALmap*);
00040   CALcontributionIterator(EBFevent*, CALcontribution*);
00041   CALcontributionIterator(CALmap*);
00042   CALcontributionIterator();
00043   virtual ~CALcontributionIterator() {}
00044
00045   unsigned iterate();
00046   unsigned iterate(EBFevent*, CALcontribution*);
00047   unsigned iterate(EBFevent*, CALcontribution*, CALmap*);
00048   virtual int handleError(CALcontribution*, unsigned code, unsigned p1=0, unsigned p2=0) const;
00049
00051   const EBFevent*        event()        const  { return _event;        }
00053   const CALcontribution* contribution() const  { return _contribution; }
00055   unsigned               CALend()       const  { return _calEnd;       }
00057   const CALmap*          map()          const  { return _map;          }
00058
00059   // Pure Virtual methods
00067   virtual void log(unsigned tower, unsigned layer, CALlog log) = 0;
00068
00069 private:
00070   EBFevent*        _event;
00071   CALcontribution* _contribution;
00072   unsigned         _calEnd;             // end of CAL data
00073   CALmap*          _map;
00074   CALmap           _CALmap;             // Default map to use
00075 };
00076
00077
00081 inline CALcontributionIterator::CALcontributionIterator() :
00082   _event(0),
00083   _contribution(0),
00084   _calEnd(3*sizeof(unsigned)),
00085   _map(&_CALmap)
00086 {
00087 }
00088
00093 inline CALcontributionIterator::CALcontributionIterator(CALmap* map) :
00094   _event(0),
00095   _contribution(0),
00096   _calEnd(3*sizeof(unsigned)),
00097   _map(map)
00098 {
00099 }
00100
00109 inline CALcontributionIterator::CALcontributionIterator(EBFevent*        event,
00110                                                         CALcontribution* contribution) :
00111   _event(event),
00112   _contribution(contribution),
00113   _calEnd(3*sizeof(unsigned)),
00114   _map(&_CALmap)
00115 {
00116 }
00117
00128 inline CALcontributionIterator::CALcontributionIterator(EBFevent*        event,
00129                                                         CALcontribution* contribution,
00130                                                         CALmap*          map) :
00131   _event(event),
00132   _contribution(contribution),
00133   _calEnd(3*sizeof(unsigned)),
00134   _map(map)
00135 {
00136 }
00137
00147 inline unsigned
00148 CALcontributionIterator::iterate()
00149 {
00150   return iterate(_event, _contribution, _map);
00151 }
00152
00165 inline unsigned
00166 CALcontributionIterator::iterate(EBFevent*        event,
00167                                  CALcontribution* contribution)
00168 {
00169   return iterate(event, contribution, _map);
00170 }
00171
00183 inline int
00184 CALcontributionIterator::handleError(CALcontribution*, unsigned code, unsigned p1, unsigned p2) const
00185 {
00186   return 0;
00187 }
00188
00189 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: CALdiagnostic.h Source File

  • File List
  • File Members

CALdiagnostic.h

00001
00023 #ifndef CALdiagnostic_H
00024 #define CALdiagnostic_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030
00031 class DLL_EXPORT_API CALdiagnostic
00032 {
00033 public:
00034   CALdiagnostic(unsigned datum);
00035   CALdiagnostic()  {}                   // Not useful...
00036   ~CALdiagnostic() {}
00037
00038   static
00039   unsigned high(unsigned datum, unsigned side);
00040   unsigned high(unsigned side);
00041
00042   static
00043   unsigned low(unsigned datum, unsigned side);
00044   unsigned low(unsigned side);
00045
00046   static
00047   unsigned logAccepts(unsigned datum, unsigned side);
00048   unsigned logAccepts(unsigned side);
00049
00050   unsigned datum() const;
00051
00052 private:
00053   unsigned _datum;
00054 };
00055
00056
00061 inline CALdiagnostic::CALdiagnostic(unsigned datum) :
00062   _datum(datum)
00063 {
00064 }
00065
00072 inline unsigned CALdiagnostic::high(unsigned datum, unsigned side)
00073 {
00074   return ( datum >> (13 + ((side & 1) << 4))) & 0x001;
00075 }
00076
00082 inline unsigned CALdiagnostic::high(unsigned side)
00083 {
00084   return (_datum >> (13 + ((side & 1) << 4))) & 0x001;
00085 }
00086
00093 inline unsigned CALdiagnostic::low(unsigned datum, unsigned side)
00094 {
00095   return ( datum >> (12 + ((side & 1) << 4))) & 0x001;
00096 }
00097
00103 inline unsigned CALdiagnostic::low(unsigned side)
00104 {
00105   return (_datum >> (12 + ((side & 1) << 4))) & 0x001;
00106 }
00107
00114 inline unsigned CALdiagnostic::logAccepts(unsigned datum, unsigned side)
00115 {
00116   return ( datum >> ((side & 1) << 4)) & 0xfff;
00117 }
00118
00124 inline unsigned CALdiagnostic::logAccepts(unsigned side)
00125 {
00126   return (_datum >> ((side & 1) << 4)) & 0xfff;
00127 }
00128
00134 inline unsigned CALdiagnostic::datum() const
00135 {
00136   return  _datum;
00137 }
00138
00139 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: CALlog.h Source File

  • File List
  • File Members

CALlog.h

00001
00023 #ifndef CALlog_H
00024 #define CALlog_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "CALlogEnd.h"
00029 #include "libApiExport.h"
00030
00031
00032 class DLL_EXPORT_API CALlog
00033 {
00034 public:
00035   CALlog(unsigned datum);
00036   CALlog()  {}
00037   ~CALlog() {}
00038
00039   static
00040   unsigned column(unsigned datum);
00041   unsigned column() const;
00042
00043   static
00044   CALlogEnd negative(unsigned datum);
00045   CALlogEnd negative() const;
00046
00047   static
00048   CALlogEnd positive(unsigned datum);
00049   CALlogEnd positive() const;
00050
00051   unsigned datum() const;
00052
00053 private:
00054   unsigned _datum;
00055 };
00056
00057
00062 inline CALlog::CALlog(unsigned datum) :
00063   _datum(datum)
00064 {
00065 }
00066
00072 inline unsigned CALlog::column(unsigned datum)
00073 {
00074   return ( datum >> 28) & 0x000f;
00075 }
00076
00081 inline unsigned CALlog::column() const
00082 {
00083   return (_datum >> 28) & 0x000f;
00084 }
00085
00091 inline CALlogEnd CALlog::negative(unsigned datum)
00092 {
00093   return CALlogEnd(( datum >> 14) & 0x3fff);
00094 }
00095
00100 inline CALlogEnd CALlog::negative() const
00101 {
00102   return CALlogEnd((_datum >> 14) & 0x3fff);
00103 }
00104
00110 inline CALlogEnd CALlog::positive(unsigned datum)
00111 {
00112   return CALlogEnd( datum & 0x3fff);
00113 }
00114
00119 inline CALlogEnd CALlog::positive() const
00120 {
00121   return CALlogEnd(_datum & 0x3fff);
00122 }
00123
00128 inline unsigned CALlog::datum() const
00129 {
00130   return  _datum;
00131 }
00132
00133 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: CALlogEnd.h Source File

  • File List
  • File Members

CALlogEnd.h

00001
00023 #ifndef CALlogEnd_H
00024 #define CALlogEnd_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030
00031 class DLL_EXPORT_API CALlogEnd
00032 {
00033 public:
00034   CALlogEnd(unsigned datum);
00035   CALlogEnd()  {}
00036   ~CALlogEnd() {}
00037
00038   static
00039   unsigned range(unsigned datum);
00040   unsigned range() const;
00041
00042   static
00043   unsigned value(unsigned datum);
00044   unsigned value() const;
00045
00046   unsigned datum() const;
00047
00048 private:
00049   unsigned _datum;
00050 };
00051
00056 inline CALlogEnd::CALlogEnd(unsigned datum) :
00057   _datum(datum)
00058 {
00059 }
00060
00066 inline unsigned CALlogEnd::range(unsigned datum)
00067 {
00068   return ( datum >> 12) & 0x003;
00069 }
00070
00075 inline unsigned CALlogEnd::range() const
00076 {
00077   return (_datum >> 12) & 0x003;
00078 }
00079
00085 inline unsigned CALlogEnd::value(unsigned datum)
00086 {
00087   return   datum        & 0xfff;
00088 }
00089
00094 inline unsigned CALlogEnd::value() const
00095 {
00096   return  _datum        & 0xfff;
00097 }
00098
00103 inline unsigned CALlogEnd::datum() const
00104 {
00105   return  _datum;
00106 }
00107
00108 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: CALmap.h Source File

  • File List
  • File Members

CALmap.h

00001
00024 #ifndef CALmap_H
00025 #define CALmap_H
00026
00027 #include "copyright_SLAC.h"
00028
00029 #include "libApiExport.h"
00030
00031 #include "TWRmap.h"
00032 #include "LATtypeId.h"
00033
00034
00035 class DLL_EXPORT_API CALmap : public TWRmap
00036 {
00037 public:
00038   CALmap()          {}
00039   virtual ~CALmap() {}
00040
00041   virtual unsigned layerID(LATtypeId ebfId, unsigned source) const;
00042 };
00043
00044
00058 inline unsigned CALmap::layerID(LATtypeId /* ebfId */,
00059                                 unsigned  source) const
00060 {
00061   // Physical layer mapping
00062   //                         GCCC    0  0  2  2  3  3  1  1
00063 #if 0              // Don't remember what this was for - upside down TEM maybe?
00064   static const unsigned layerID[] = {1, 3, 5, 7, 0, 2, 4, 6};
00065 #else
00066   static const unsigned layerID[] = {0, 2, 4, 6, 1, 3, 5, 7};
00067 #endif
00068   return (layerID[source]);
00069 }
00070
00071 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Alphabetical List

LDF Class Index

A | C | D | E | G | L | O | T

A
C
ERRcontributionIterator LATcontribution OSWcontributionIterator
ACDmap CALcontribution ErrorSummary LATcontributionIterator OSWtimeBase
ACDpha CALcontributionIterator EventSummary LATdataBufferIterator OSWtimeContribution
ACDtileSide CALdiagnostic
G
LATdatagram OSWtimeSpec
AEMcontribution CALlog GCCCerror LATdatagramIterator
T
AEMcontributionIterator CALlogEnd GEMcondArrivalTime LATPcellHeader TEMcontribution
AEMheader CALmap GEMcontribution LATprimaryId TEMcontributionIterator
ASCcno
D
GEMonePPStime LATsecondaryId TKRcontribution
ASCcontribution DIAGcontributionIterator GEMtileList LATtypeId TKRcontributionIterator
ASCcontributionIterator
E
GLTcontribution LDBI_EBFeventIterator TKRdiagnostic
ASCsummary EBFcontribution GTCCerror LDBI_LATcontributionIterator TKRmap
ASCtile EBFcontributionIterator GTRCerror LDBI_LATdatagramIterator TKRstrip
ASCtileContribution EBFevent
L
LDFversion TWRmap
ASCtileContributionIterator EBFeventIterator LATcomponentIterator
O

A | C | D | E | G | L | O | T

Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: copyright_SLAC.h Source File

  • File List
  • File Members

copyright_SLAC.h

00001 #ifndef COPYRIGHT_SLAC_H
00002 #define COPYRIGHT_SLAC_H
00003 /*
00004 **
00005 **                                Copyright 2004
00006 **                                      by
00007 **                         The Board of Trustees of the
00008 **                       Leland Stanford Junior University.
00009 **                              All rights reserved.
00010 **
00011 **         Work supported by the U.S. Department of Energy under contract
00012 **       DE-AC03-76SF00515.
00013 **
00014 **                               Disclaimer Notice
00015 **
00016 **        The items furnished herewith were developed under the sponsorship
00017 **   of the U.S. Government.  Neither the U.S., nor the U.S. D.O.E., nor the
00018 **   Leland Stanford Junior University, nor their employees, makes any war-
00019 **   ranty, express or implied, or assumes any liability or responsibility
00020 **   for accuracy, completeness or usefulness of any information, apparatus,
00021 **   product or process disclosed, or represents that its use will not in-
00022 **   fringe privately-owned rights.  Mention of any product, its manufactur-
00023 **   er, or suppliers shall not, nor is it intended to, imply approval, dis-
00024 **   approval, or fitness for any particular use.  The U.S. and the Univer-
00025 **   sity at all times retain the right to use and disseminate the furnished
00026 **   items for any purpose whatsoever.                       Notice 91 02 01
00027 **
00028 */
00029 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: DIAGcontributionIterator.h Source File

  • File List
  • File Members

DIAGcontributionIterator.h

00001
00023 #ifndef DIAGcontributionIterator_H
00024 #define DIAGcontributionIterator_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030 #include "EBFevent.h"
00031 #include "TEMcontribution.h"
00032 #include "CALdiagnostic.h"
00033 #include "TKRdiagnostic.h"
00034 #include "CALmap.h"
00035 #include "TKRmap.h"
00036
00037
00038 class DLL_EXPORT_API DIAGcontributionIterator
00039 {
00040 public:
00049   DIAGcontributionIterator(EBFevent*        event,
00050                            TEMcontribution* contribution,
00051                            CALmap*          calMap,
00052                            TKRmap*          tkrMap);
00053
00061   DIAGcontributionIterator(EBFevent*        event,
00062                            TEMcontribution* contribution);
00063
00064   virtual int     handleError(TEMcontribution*, unsigned code, unsigned p1=0, unsigned p2=0) const;
00065
00070   DIAGcontributionIterator();
00071   virtual ~DIAGcontributionIterator() {}
00072
00080   unsigned iterateCAL();
00081
00091   unsigned iterateCAL(EBFevent*        event,
00092                       TEMcontribution* contribution);
00093
00106   unsigned iterateCAL(EBFevent*        event,
00107                       TEMcontribution* contribution,
00108                       CALmap*          map);
00116   unsigned iterateTKR();
00117
00127   unsigned iterateTKR(EBFevent*        event,
00128                       TEMcontribution* contribution);
00129
00142   unsigned iterateTKR(EBFevent*        event,
00143                       TEMcontribution* contribution,
00144                       TKRmap*          map);
00145
00147   const EBFevent*        event()        const;
00149   const TEMcontribution* contribution() const;
00151   const CALmap*          calMap()       const;
00153   const TKRmap*          tkrMap()       const;
00155   int                    status()       const;
00156
00158   unsigned size() const;
00160   void     offset(unsigned o);
00161
00162   //  The following methods should be protected, but SIP won't allow it.
00163   //protected:
00164   //These are *not* pure virtual because the user *doesn't* need to always implement them
00177   virtual int CALdiag(unsigned tower, unsigned layer, CALdiagnostic diag);
00178
00191   virtual int TKRdiag(unsigned tower, unsigned gtcc,  TKRdiagnostic diag);
00192
00193 private:
00207   unsigned _GTCC (unsigned cc) const;
00208
00209 private:
00210   EBFevent*        _event;
00211   TEMcontribution* _contribution;
00212   unsigned         _offset;
00213   int              _status;
00214   CALmap*          _calMap;
00215   TKRmap*          _tkrMap;
00216   CALmap           _CALmap;             // Default CAL map to use
00217   TKRmap           _TKRmap;             // Default TKR map to use
00218 };
00219
00220
00221 inline DIAGcontributionIterator::DIAGcontributionIterator() :
00222   _event(0),
00223   _contribution(0),
00224   _offset(0),
00225   _status(0),
00226   _calMap(&_CALmap),
00227   _tkrMap(&_TKRmap)
00228 {
00229 }
00230
00231 inline
00232 DIAGcontributionIterator::DIAGcontributionIterator(EBFevent*        event,
00233                                                    TEMcontribution* contribution) :
00234   _event(event),
00235   _contribution(contribution),
00236   _offset(0),
00237   _status(0),
00238   _calMap(&_CALmap),
00239   _tkrMap(&_TKRmap)
00240
00241 {
00242 }
00243
00244 inline
00245 DIAGcontributionIterator::DIAGcontributionIterator(EBFevent*        event,
00246                                                    TEMcontribution* contribution,
00247                                                    CALmap*          calMap,
00248                                                    TKRmap*          tkrMap) :
00249   _event(event),
00250   _contribution(contribution),
00251   _offset(0),
00252   _status(0),
00253   _calMap(calMap),
00254   _tkrMap(tkrMap)
00255
00256 {
00257 }
00258
00259 inline const EBFevent* DIAGcontributionIterator::event() const
00260 {
00261   return _event;
00262 }
00263
00264 inline const TEMcontribution* DIAGcontributionIterator::contribution() const
00265 {
00266   return _contribution;
00267 }
00268
00269 inline const CALmap* DIAGcontributionIterator::calMap() const
00270 {
00271   return _calMap;
00272 }
00273
00274 inline const TKRmap* DIAGcontributionIterator::tkrMap() const
00275 {
00276   return _tkrMap;
00277 }
00278
00279 inline int DIAGcontributionIterator::status() const
00280 {
00281   return _status;
00282 }
00283
00284 inline unsigned DIAGcontributionIterator::size() const
00285 {
00286   // diagnostic contribution is 12 longwords
00287   return 12 * sizeof(unsigned);
00288 }
00289
00290 inline void DIAGcontributionIterator::offset(unsigned o)
00291 {
00292   _offset = o;
00293 }
00294
00295 inline unsigned DIAGcontributionIterator::_GTCC(unsigned cc) const
00296 {
00297   // - 8 16 bit contributions for GTCC
00298   //     Order: 6 3 7 2 5 0 4 1
00299   const unsigned gtcc[] = {6, 3, 7, 2, 5, 0, 4, 1};
00300
00301   return (gtcc[cc]);
00302 }
00303
00304 inline unsigned DIAGcontributionIterator::iterateCAL()
00305 {
00306   return iterateCAL(_event, _contribution, _calMap);
00307 }
00308
00309 inline unsigned DIAGcontributionIterator::iterateCAL(EBFevent*        event,
00310                                                      TEMcontribution* contribution)
00311 {
00312   return iterateCAL(event, contribution, _calMap);
00313 }
00314
00315 inline unsigned DIAGcontributionIterator::iterateTKR()
00316 {
00317   return iterateTKR(_event, _contribution, _tkrMap);
00318 }
00319
00320 inline unsigned DIAGcontributionIterator::iterateTKR(EBFevent*        event,
00321                                                      TEMcontribution* contribution)
00322 {
00323   return iterateTKR(event, contribution, _tkrMap);
00324 }
00325
00326 inline int DIAGcontributionIterator::CALdiag(unsigned      /* tower */,
00327                                              unsigned      /* layer */,
00328                                              CALdiagnostic /* diag */)
00329 {
00330   return 0;
00331 }
00332
00333 inline int DIAGcontributionIterator::TKRdiag(unsigned      /* tower */,
00334                                              unsigned      /* gtcc */,
00335                                              TKRdiagnostic /* diag */)
00336 {
00337   return 0;
00338 }
00339
00352 inline int
00353 DIAGcontributionIterator::handleError(TEMcontribution* contribution, unsigned code, unsigned p1, unsigned p2) const
00354 {
00355   return 0;
00356 }
00357
00358 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: EBFcontribution.h Source File

  • File List
  • File Members

EBFcontribution.h

00001
00023 #ifndef EBFcontribution_H
00024 #define EBFcontribution_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030 #include "DFC_endianness.h"
00031
00032 #include "LATtypeId.h"
00033
00034
00035 class DLL_EXPORT_API TEMcontribution;
00036 class DLL_EXPORT_API AEMcontribution;
00037 class DLL_EXPORT_API GEMcontribution;
00038 class DLL_EXPORT_API GLTcontribution;
00039 class DLL_EXPORT_API OSWcontribution;
00040
00041
00042 class DLL_EXPORT_API EBFcontribution
00043 {
00044 public:
00045   EBFcontribution()  {}
00046   ~EBFcontribution() {}
00047
00048   // The Tower IDs are detector IDs as described in LAT-TD-00035
00049   enum
00050   {
00051     Tower_00 =  0,    Tower_01 =  1,    Tower_02 =  2,    Tower_03 =  3,
00052     Tower_04 =  4,    Tower_05 =  5,    Tower_06 =  6,    Tower_07 =  7,
00053     Tower_08 =  8,    Tower_09 =  9,    Tower_10 = 10,    Tower_11 = 11,
00054     Tower_12 = 12,    Tower_13 = 13,    Tower_14 = 14,    Tower_15 = 15,
00055     PDU_0    = 16,    PDU_1    = 17,    GEM      = 18,    AEM      = 19,
00056     EBM      = 20,
00057                                         CRU      = 30,    Broadcast = 31,
00058     OSW      = 32
00059   };
00060   enum { Parity = 1, Truncated = 2, WriteFault = 3, TimedOut = 4 };
00061   enum { NumberOfContributions = 64 };
00062
00063   unsigned         header()          const;
00064   unsigned         packetError()     const;
00065   unsigned         sequence()        const;
00066   unsigned         length()          const;
00067   unsigned         summary()         const;
00068   EBFcontribution* next()            const;
00069   unsigned         payloadSize()     const;
00070   char*            payload()         const;
00071   TEMcontribution* temContribution() const;
00072   AEMcontribution* aemContribution() const;
00073   GEMcontribution* gemContribution() const;
00074   GLTcontribution* gltContribution() const;
00075   OSWcontribution* oswContribution() const;
00076
00077 private:
00078 #if DFC_BIG_ENDIAN
00079   unsigned short _header;               /* LATp header */
00080   unsigned short _esl;                  /* Error, Sequence, Length */
00081 #else
00082   unsigned short _esl;                  /* Error, Sequence, Length */
00083   unsigned short _header;               /* LATp header */
00084 #endif
00085   unsigned       _summary;              /* Contribution summary */
00086 };
00087
00088
00093 inline unsigned EBFcontribution::header() const
00094 {
00095   return _header;
00096 }
00097
00102 inline unsigned EBFcontribution::packetError() const
00103 {
00104   return  (_esl >> 13) & 0x0007;
00105 }
00106
00111 inline unsigned EBFcontribution::sequence() const
00112 {
00113   return  (_esl >>  8) & 0x001f;
00114 }
00115
00120 inline unsigned EBFcontribution::length() const
00121 {
00122   return ((_esl      ) & 0x00ff) << 4;  /* Convert cell count to bytes */
00123 }
00124
00129 inline unsigned EBFcontribution::summary() const
00130 {
00131   return _summary;
00132 }
00133
00138 inline EBFcontribution* EBFcontribution::next() const
00139 {
00140   return (EBFcontribution*)((char*)this + length());
00141 }
00142
00147 inline unsigned EBFcontribution::payloadSize() const
00148 {
00149   return length() - sizeof(*this);
00150 }
00151
00156 inline char* EBFcontribution::payload() const
00157 {
00158   return (char*)&this[1];
00159 }
00160
00165 inline TEMcontribution* EBFcontribution::temContribution() const
00166 {
00167   return (TEMcontribution*)this;
00168 }
00169
00174 inline AEMcontribution* EBFcontribution::aemContribution() const
00175 {
00176   return (AEMcontribution*)this;
00177 }
00178
00183 inline GEMcontribution* EBFcontribution::gemContribution() const
00184 {
00185   return (GEMcontribution*)this;
00186 }
00187
00192 inline GLTcontribution* EBFcontribution::gltContribution() const
00193 {
00194   return (GLTcontribution*)this;
00195 }
00196
00201 inline OSWcontribution* EBFcontribution::oswContribution() const
00202 {
00203   return (OSWcontribution*)this;
00204 }
00205
00206 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: EBFcontributionIterator.h Source File

  • File List
  • File Members

EBFcontributionIterator.h

00001
00023 #ifndef EBFcontributionIterator_H
00024 #define EBFcontributionIterator_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030 #include "LATp.h"
00031 #include "EBFcontribution.h"
00032 #include "LATtypeId.h"
00033
00034 #include "EBFevent.h"
00035
00036
00037 class DLL_EXPORT_API EBFcontributionIterator
00038 {
00039 public:
00040   EBFcontributionIterator(EBFevent* event);
00041   EBFcontributionIterator();
00042   virtual ~EBFcontributionIterator() {}
00043
00044   enum
00045   {
00046     ERR_NumContributions = 1,
00047     ERR_PastEnd          = 2,
00048     ERR_ZeroLength       = 3,
00049     ERR_PacketError      = 4,
00050     ERR_NoMap            = 5
00051   };
00052
00053   unsigned        iterate();
00054   unsigned        iterate(EBFevent* event);
00055   const EBFevent* event()  const;
00056   int             status() const;
00057
00058   virtual int     handleError(EBFevent* event, unsigned code, unsigned p1=0, unsigned p2=0) const;
00059
00060   //  The following methods should be protected, but SIP won't allow it.
00061   //protected:
00063   virtual int GEM(EBFevent*, EBFcontribution*) = 0;
00065   virtual int GLT(EBFevent*, EBFcontribution*) = 0;
00067   virtual int AEM(EBFevent*, EBFcontribution*) = 0;
00069   virtual int TEM(EBFevent*, EBFcontribution*) = 0;
00071   virtual int OSW(EBFevent*, EBFcontribution*) = 0;
00073   virtual int UDF(EBFevent*, EBFcontribution*) = 0;
00074
00075 private:
00076   typedef int (EBFcontributionIterator::*ContribHandler)(EBFevent*,
00077                                                          EBFcontribution*);
00078   const EBFcontributionIterator::ContribHandler* _map(LATtypeId ebfId) const;
00079
00080 private:
00081   EBFevent* _event;
00082   int       _status;
00083 };
00084
00085
00093 inline EBFcontributionIterator::EBFcontributionIterator(EBFevent* event) :
00094   _event(event),
00095   _status(0)
00096 {
00097 }
00098
00102 inline EBFcontributionIterator::EBFcontributionIterator() :
00103   _event(0),
00104   _status(0)
00105 {
00106 }
00107
00109 inline const EBFevent* EBFcontributionIterator::event() const
00110 {
00111   return _event;
00112 }
00113
00115 inline int EBFcontributionIterator::status() const
00116 {
00117   return _status;
00118 }
00119
00127 inline unsigned EBFcontributionIterator::iterate()
00128 {
00129   return iterate(_event);
00130 }
00131
00132 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: EBFevent.h Source File

  • File List
  • File Members

EBFevent.h

00001
00027 #ifndef EBFevent_H
00028 #define EBFevent_H
00029
00030 #include "copyright_SLAC.h"
00031
00032 #include "libApiExport.h"
00033
00034 #include "DFC_endianness.h"
00035 #include "EBF_swap.h"
00036
00037 #include "LATcontribution.h"
00038 #include "LATidentity.h"
00039
00040 class DLL_EXPORT_API EBFcontribution;
00041
00042 // This is a transmissible class and may contain no virtual methods.
00043 // Adding virtual methods add a hidden virtual function table pointer to the
00044 // class, preventing it from being memory mapable.  So, virtual methods have
00045 // been removed to keep this class concrete.
00046
00047 class DLL_EXPORT_API EBFevent : public LATcontribution
00048 {
00049 public:
00050   EBFevent()  {}
00051   ~EBFevent() {}
00052
00053   enum
00054   {
00055     ID_1  = LATidentity_(LATprimaryId::Id_EBF,    LATsecondaryId::Id_EBF_1),
00056     ID_2  = LATidentity_(LATprimaryId::Id_EBF,    LATsecondaryId::Id_EBF_2),
00057     ID_3  = LATidentity_(LATprimaryId::Id_EBF,    LATsecondaryId::Id_EBF_3),
00058     ID    = LATidentity_(LATprimaryId::Id_EBF,    LATsecondaryId::Id_EBF),
00059     ID_MC = LATidentity_(LATprimaryId::Id_EBF_MC, LATsecondaryId::Id_EBF_MC)
00060   };
00061
00062   unsigned          status()      const;
00063   unsigned          summary()     const;
00064   unsigned          payloadSize() const;
00065   EBFcontribution*  payload()     const;
00066
00067   static EBFevent*  create(unsigned char* buffer, unsigned size, bool swap = !DFC_BIG_ENDIAN);
00068   unsigned char*    string(bool swap = !DFC_BIG_ENDIAN);
00069 };
00070
00071
00076 inline unsigned EBFevent::status() const
00077 {
00078   return 0;
00079 }
00080
00081
00092 inline unsigned EBFevent::summary() const
00093 {
00094   return ((unsigned*)payload())[1];
00095 }
00096
00097
00102 inline unsigned EBFevent::payloadSize() const
00103 {
00104   return length() - sizeof(*this);
00105 }
00106
00107
00112 inline EBFcontribution* EBFevent::payload() const
00113 {
00114   return (EBFcontribution*)(&this[1]);
00115 }
00116
00117
00136 inline EBFevent* EBFevent::create(unsigned char* buffer, unsigned size, bool swap)
00137 {
00138   if (swap)
00139   {
00140     EBF_swap32_lclXbigN((unsigned*)buffer, size / sizeof (unsigned));
00141   }
00142   return (EBFevent*)buffer;
00143 }
00144
00145
00154 inline unsigned char* EBFevent::string(bool swap)
00155 {
00156   if (swap)
00157   {
00158     EBF_swap32_lclXbigN((unsigned*)this, length() / sizeof (unsigned));
00159   }
00160   return (unsigned char*)this;
00161 }
00162
00163 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: EBFeventIterator.h Source File

  • File List
  • File Members

EBFeventIterator.h

00001
00023 #ifndef EBFeventIterator_H
00024 #define EBFeventIterator_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030 #include "DFC_endianness.h"
00031 #include "EBF_swap.h"
00032
00033 #include "EBFevent.h"
00034
00035
00036 class DLL_EXPORT_API EBFeventIterator
00037 {
00038 public:
00039   EBFeventIterator(EBFevent* start, EBFevent* end);
00040   EBFeventIterator(char* buffer, unsigned size, bool swap = !DFC_BIG_ENDIAN);
00041   EBFeventIterator();
00042   virtual ~EBFeventIterator() {}
00043
00044   enum
00045   {
00046     ERR_NonEBFevent     = 1
00047   };
00048
00049   unsigned iterate(EBFevent* start, EBFevent* end);
00050   unsigned iterate(char* buffer, unsigned size, bool swap = !DFC_BIG_ENDIAN);
00051   unsigned iterate();
00052
00053   virtual int handleError(EBFevent* evt, unsigned code, unsigned p1=0, unsigned p2=0) const;
00054
00056   virtual int process(EBFevent* evt) = 0;
00057
00058   const EBFevent* start()  const;
00059   const EBFevent* end()    const;
00060   unsigned        status() const;
00061
00062 private:
00063   EBFevent* _start;
00064   EBFevent* _end;
00065   unsigned  _status;
00066 };
00067
00068
00074 inline EBFeventIterator::EBFeventIterator(EBFevent* start,
00075                                           EBFevent* end) :
00076   _start(start),
00077   _end(end),
00078   _status(0)
00079 {
00080 }
00081
00091 inline EBFeventIterator::EBFeventIterator(char*    buffer,
00092                                           unsigned size,
00093                                           bool     swap)
00094 {
00095   // Swap the buffer in place
00096   if (swap)
00097   {
00098     EBF_swap32_lclXbigN((unsigned*)buffer, size / sizeof(unsigned));
00099   }
00100   _start  = (EBFevent*)buffer;
00101   _end    = (EBFevent*)(&buffer[size]);
00102   _status = 0;
00103 }
00104
00108 inline EBFeventIterator::EBFeventIterator() :
00109   _start(0),
00110   _end(0),
00111   _status(0)
00112 {
00113 }
00114
00119 inline const EBFevent* EBFeventIterator::start() const
00120 {
00121   return _start;
00122 }
00123
00128 inline const EBFevent* EBFeventIterator::end() const
00129 {
00130   return _end;
00131 }
00132
00133
00138 inline unsigned EBFeventIterator::status() const
00139 {
00140   return _status;
00141 }
00142
00143
00153 inline unsigned EBFeventIterator::iterate()
00154 {
00155   return iterate(_start, _end);
00156 }
00157
00158
00171 inline unsigned EBFeventIterator::iterate(char*    buffer,
00172                                           unsigned size,
00173                                           bool     swap)
00174 {
00175   // Swap the buffer in place
00176   if (swap)
00177   {
00178     EBF_swap32_lclXbigN((unsigned*)buffer, size / sizeof(unsigned));
00179   }
00180
00181   EBFevent* start = (EBFevent*)  buffer;
00182   EBFevent* end   = (EBFevent*)(&buffer[size]);
00183
00184   return iterate(start, end);
00185 }
00186
00187 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: ERRcontributionIterator.h Source File

  • File List
  • File Members

ERRcontributionIterator.h

00001
00023 #ifndef ERRcontributionIterator_H
00024 #define ERRcontributionIterator_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030 #include "errorSummary.h"
00031 #include "GXXXerror.h"
00032 #include "TWRmap.h"
00033 #include "EBFevent.h"
00034 #include "TEMcontribution.h"
00035
00040 #if DFC_BIG_ENDIAN>0
00041 #define GET_IDX(x)   (x)
00042 #else
00043 #define GET_IDX(x)   (x ^ 1)            // (2 * ((x)/2) + ( 1 - ((x) % 2)))
00044 #endif
00045
00046 class DLL_EXPORT_API ERRcontributionIterator
00047 {
00048 public:
00058   ERRcontributionIterator(EBFevent*        event,
00059                           TEMcontribution* contribution,
00060                           TWRmap*          map);
00061
00069   ERRcontributionIterator(EBFevent*        event,
00070                           TEMcontribution* contribution);
00071
00076   ERRcontributionIterator();
00077   virtual ~ERRcontributionIterator() {}
00078
00079   enum
00080   {
00081     ERR_PastEnd = 1         //*! Unexpectedly pointing past end of contribution
00082   };
00083
00091   unsigned iterate();
00092
00102   unsigned iterate(EBFevent*        event,
00103                    TEMcontribution* contribution);
00104
00112   unsigned iterate(EBFevent*        event,
00113                    TEMcontribution* contribution,
00114                    TWRmap*          map);
00115
00117   const EBFevent*        event()        const;
00119   const TEMcontribution* contribution() const;
00121   const TWRmap*          map()          const;
00123   int                    status()       const;
00124
00126   unsigned               size()         const;
00128   void                   offset(unsigned o);
00130   const ErrorSummary     theError();
00131
00132   virtual int handleError(TEMcontribution* contribution, unsigned code, unsigned p1=0, unsigned p2=0) const;
00133
00134   // Dispatch functions for the various types of TEM error.  These may be
00135   // implemented by the user.  These are *not* pure virtual because the user
00136   // *doesn't* need to always implement them
00149   virtual int gcccError(unsigned  tower,
00150                         unsigned  gccc,
00151                         GCCCerror err);
00152
00165   virtual int gtccError(unsigned  tower,
00166                         unsigned  gtcc,
00167                         GTCCerror err);
00168
00180   virtual int phaseError(unsigned       tower,
00181                          unsigned short err);
00182
00194   virtual int timeoutError(unsigned       tower,
00195                            unsigned short err);
00196
00197   // TKR errors
00198
00212   virtual int gtrcPhaseError(unsigned  tower,
00213                              unsigned  gtcc,
00214                              unsigned  gtrc,
00215                              GTRCerror err);
00216
00238   virtual int gtfePhaseError(unsigned       tower,
00239                              unsigned       gtcc,
00240                              unsigned       gtrc,
00241                              unsigned short err1,
00242                              unsigned short err2,
00243                              unsigned short err3,
00244                              unsigned short err4,
00245                              unsigned short err5);
00246
00259   virtual int gtccFIFOerror(unsigned       tower,
00260                             unsigned       gtcc,
00261                             unsigned short err);
00262
00274   virtual int gtccTMOerror(unsigned tower,
00275                            unsigned gtcc);
00276
00288   virtual int gtccHDRParityError(unsigned tower,
00289                                  unsigned gtcc);
00290
00302   virtual int gtccWCParityError(unsigned tower,
00303                                 unsigned gtcc);
00304
00316   virtual int gtrcSummaryError(unsigned tower,
00317                                unsigned gtcc);
00318
00330   virtual int gtccDataParityError(unsigned tower,
00331                                   unsigned gtcc);
00332
00333 private:
00335   unsigned _parseGTCC(int& stat, unsigned tower, unsigned gtcc, GTCCerror err,
00336                       unsigned index, unsigned short* param);
00337
00347   unsigned _GCCC(unsigned word) const;
00348
00358   unsigned _GTCC(unsigned word) const;
00359
00360 private:
00361   EBFevent*        _event;
00362   TEMcontribution* _contribution;
00363   unsigned         _offset;
00364   unsigned         _size;
00365   int              _status;
00366   TWRmap*          _map;
00367   TWRmap           _TWRmap;
00368 };
00369
00370
00371 inline ERRcontributionIterator::ERRcontributionIterator() :
00372   _event(0),
00373   _contribution(0),
00374   _offset(0),
00375   _status(0),
00376   _map(&_TWRmap)
00377 {
00378 }
00379
00380 inline ERRcontributionIterator::ERRcontributionIterator(EBFevent*        event,
00381                                                         TEMcontribution* contribution) :
00382   _event(event),
00383   _contribution(contribution),
00384   _offset(0),
00385   _status(0),
00386   _map(&_TWRmap)
00387 {
00388 }
00389
00390 inline ERRcontributionIterator::ERRcontributionIterator(EBFevent*        event,
00391                                                         TEMcontribution* contribution,
00392                                                         TWRmap*          map) :
00393   _event(event),
00394   _contribution(contribution),
00395   _offset(0),
00396   _status(0),
00397   _map(map)
00398 {
00399 }
00400
00401 inline const EBFevent* ERRcontributionIterator::event() const
00402 {
00403   return _event;
00404 }
00405
00406 inline const TEMcontribution* ERRcontributionIterator::contribution() const
00407 {
00408   return _contribution;
00409 }
00410
00411 inline const TWRmap* ERRcontributionIterator::map() const
00412 {
00413   return _map;
00414 }
00415
00416 inline int ERRcontributionIterator::status() const
00417 {
00418   return _status;
00419 }
00420
00421 inline unsigned ERRcontributionIterator::size() const
00422 {
00423   return _size;
00424 }
00425
00426 inline void ERRcontributionIterator::offset(unsigned o)
00427 {
00428   _offset = o;
00429 }
00430
00431 inline unsigned ERRcontributionIterator::_GCCC(unsigned word) const
00432 {
00433   const unsigned gccc[] = {0,2,3,1};
00434
00435   return (gccc[word]);
00436 }
00437
00438 inline unsigned ERRcontributionIterator::_GTCC(unsigned word) const
00439 {
00440   const unsigned gtcc[] = {3, 6, 2, 7, 0, 5, 1, 4};
00441
00442   return (gtcc[word]);
00443 }
00444
00445 inline const ErrorSummary ERRcontributionIterator::theError()
00446 {
00447   /* Because of byte ordering, must use the GET_IDX referencer */
00448   return ErrorSummary(((unsigned short*)((char*)_contribution + _offset))[GET_IDX(0)]);
00449 }
00450
00451 inline unsigned ERRcontributionIterator::iterate()
00452 {
00453   return iterate(_event, _contribution, _map);
00454 }
00455
00456 inline unsigned ERRcontributionIterator::iterate(EBFevent*        event,
00457                                                  TEMcontribution* contribution)
00458 {
00459   return iterate(event, contribution, _map);
00460 }
00461
00462 inline int ERRcontributionIterator::gcccError(unsigned  /* tower */,
00463                                               unsigned  /* gccc */,
00464                                               GCCCerror /* err */)
00465 {
00466   return 0;
00467 }
00468
00469 inline int ERRcontributionIterator::gtccError(unsigned  /* tower */,
00470                                               unsigned  /* gtcc */,
00471                                               GTCCerror /* err */)
00472 {
00473   return 0;
00474 }
00475
00476 inline int ERRcontributionIterator::phaseError(unsigned       /* tower */,
00477                                                unsigned short /* err */)
00478 {
00479   return 0;
00480 }
00481
00482 inline int ERRcontributionIterator::timeoutError(unsigned       /* tower */,
00483                                                  unsigned short /* err */)
00484 {
00485   return 0;
00486 }
00487
00488 inline int ERRcontributionIterator::gtrcPhaseError(unsigned  /* tower */,
00489                                                    unsigned  /* gtcc */,
00490                                                    unsigned  /* gtrc */,
00491                                                    GTRCerror /* err */)
00492 {
00493   return 0;
00494 }
00495
00496 inline int ERRcontributionIterator::gtfePhaseError(unsigned       /* tower */,
00497                                                    unsigned       /* gtcc */,
00498                                                    unsigned       /* gtrc */,
00499                                                    unsigned short /* err1 */,
00500                                                    unsigned short /* err2 */,
00501                                                    unsigned short /* err3 */,
00502                                                    unsigned short /* err4 */,
00503                                                    unsigned short /* err5 */)
00504 {
00505   return 0;
00506 }
00507
00508 inline int ERRcontributionIterator::gtccFIFOerror(unsigned       /* tower */,
00509                                                   unsigned       /* gtcc */,
00510                                                   unsigned short /* err */)
00511 {
00512   return 0;
00513 }
00514
00515 inline int ERRcontributionIterator::gtccTMOerror(unsigned /* tower */,
00516                                                  unsigned /* gtcc */)
00517 {
00518   return 0;
00519 }
00520
00521 inline int ERRcontributionIterator::gtccHDRParityError(unsigned /* tower */,
00522                                                        unsigned /* gtcc */)
00523 {
00524   return 0;
00525 }
00526
00527 inline int ERRcontributionIterator::gtccWCParityError(unsigned /* tower */,
00528                                                       unsigned /* gtcc */)
00529 {
00530   return 0;
00531 }
00532
00533 inline int ERRcontributionIterator::gtrcSummaryError(unsigned /* tower */,
00534                                                      unsigned /* gtcc */)
00535 {
00536   return 0;
00537 }
00538
00539 inline int ERRcontributionIterator::gtccDataParityError(unsigned /* tower */,
00540                                                         unsigned /* gtcc */)
00541 {
00542   return 0;
00543 }
00544
00557 inline int
00558 ERRcontributionIterator::handleError(TEMcontribution* contrib, unsigned code, unsigned p1, unsigned p2) const
00559 {
00560   return code;
00561 }
00562
00563 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: errorSummary.h Source File

  • File List
  • File Members

errorSummary.h

00001
00023 #ifndef ErrorSummary_H
00024 #define ErrorSummary_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030
00031 class DLL_EXPORT_API ErrorSummary
00032 {
00033 public:
00034   ErrorSummary(unsigned summary);
00035   ErrorSummary()  {}
00036   ~ErrorSummary() {}
00037
00038   static unsigned tmo(unsigned summary);
00039          unsigned tmo() const;
00040
00041   static unsigned phs(unsigned summary);
00042          unsigned phs() const;
00043
00044   static unsigned tkr(unsigned summary);
00045          unsigned tkr() const;
00046
00047   static unsigned cal(unsigned summary);
00048          unsigned cal() const;
00049
00050 private:
00051   unsigned _summary;
00052 };
00053
00054
00059 inline ErrorSummary::ErrorSummary(unsigned summary) :
00060   _summary(summary)
00061 {
00062 }
00063
00070 inline unsigned ErrorSummary::tmo(unsigned summary)
00071 {
00072   return ( summary >> 13) & 0x0001;
00073 }
00074
00080 inline unsigned ErrorSummary::tmo() const
00081 {
00082   return (_summary >> 13) & 0x0001;
00083 }
00084
00091 inline unsigned ErrorSummary::phs(unsigned summary)
00092 {
00093   return ( summary >> 12) & 0x0001;
00094 }
00095
00101 inline unsigned ErrorSummary::phs() const
00102 {
00103   return (_summary >> 12) & 0x0001;
00104 }
00105
00112 inline unsigned ErrorSummary::tkr(unsigned summary)
00113 {
00114   return ( summary >>  4) & 0x00ff;
00115 }
00116
00122 inline unsigned ErrorSummary::tkr() const
00123 {
00124   return (_summary >>  4) & 0x00ff;
00125 }
00126
00133 inline unsigned ErrorSummary::cal(unsigned summary)
00134 {
00135   return   summary        & 0x000f;
00136 }
00137
00143 inline unsigned ErrorSummary::cal() const
00144 {
00145   return  _summary        & 0x000f;
00146 }
00147
00148 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: ev_latID.h Source File

  • File List
  • File Members

ev_latID.h

00001 /*
00002 ** ++
00003 **
00004 **  Abstract:
00005 *+      $Id: ev_latID.h,v 1.10 2006/07/21 23:59:14 claus Exp $
00006 **
00007 **      Enums containing he identity values for labeling the various
00008 **  contributions involved in event data for the LAT.
00009 **
00010 **  Converted to straight C code from the C++ Online code LDF/LATidentity.h
00011 *-
00012 **  Author:
00013 **      Jim Panetta
00014 **
00015 **  $Revision: 1.10 $
00016 **      May 27, 2004 -- Created
00017 **
00018 **  Copyright:
00019 **                                Copyright 2004
00020 **                                      by
00021 **                         The Board of Trustees of the
00022 **                       Leland Stanford Junior University.
00023 **                              All rights reserved.
00024 **
00025 ** --
00026 */
00027
00028 #ifndef EV_LATID_H
00029 #define EV_LATID_H
00030
00031 /*****************************************************************/
00032 /* Primary ID:  labels classes used in decoding LAT evt data     */
00033
00034 /* define bases and ranges for IDs allocated by sections */
00035 enum { Pri_Base_FSW     = 0xF0000,
00036        Pri_Base_OEF     = 0xF1000,
00037        Pri_Base_ACD     = 0xF2000,
00038        Pri_Base_CAL     = 0xF3000,
00039        Pri_Base_TKR     = 0xF4000,
00040        Pri_Base_OSW     = 0xF5000,
00041        Pri_Base_Scratch = 0xFF000 };
00042
00043 /* This has to be maintained very carefully so that archival data can */
00044 /* always be interpreted correctly. */
00045
00046 /* ID definitions in FSW space: */
00047 enum { Pri_Id_EBF      = Pri_Base_FSW + 0x010 };
00048 enum { Pri_Id_EBF_MC   = Pri_Base_FSW + 0x020 };
00050 /* ID definitions in Online Event Format (OEF) space: */
00051 enum { Pri_Id_Datagram = Pri_Base_OEF + 0x010 };
00052 enum { Pri_Id_UnrecBuf = Pri_Base_OEF + 0x020 };
00053 enum { Pri_Id_BtAncEvt = Pri_Base_OEF + 0x030 };
00054 enum { Pri_Id_BtAncHdr = Pri_Base_OEF + 0x040 };
00055 enum { Pri_Id_BtAncTlr = Pri_Base_OEF + 0x050 };
00057 /* ID definitions in ACD space: */
00058 enum { Pri_Id_ASC      = Pri_Base_ACD + 0x010 };
00060 /* ID definitions in Calorimeter (CAL) space: */
00061 enum { Pri_Id_CEDhdr   = Pri_Base_CAL + 0x000 };
00063 /* ID definitions in Online Event Server (OSW) space: */
00064 enum { Pri_Id_Time     = Pri_Base_OSW + 0x010 };
00065 enum { Pri_Id_Consumer = Pri_Base_OSW + 0x020 };
00068 /*****************************************************************/
00069 /* Secondary ID: label changes to a class with a corresponding   */
00070 /* Primary ID, in other words, a class version number.           */
00071
00072 /* define bases and ranges for IDs allocated by sections */
00073 enum { Sec_Base_FSW     = 0x100,
00074        Sec_Base_OEF     = 0x200,
00075        Sec_Base_ACD     = 0x300,
00076        Sec_Base_CAL     = 0x400,
00077        Sec_Base_TKR     = 0x500,
00078        Sec_Base_OSW     = 0x600,
00079        Sec_Base_Scratch = 0xF00 };
00080
00081 /* This has to be maintained very carefully so that archival data can */
00082 /* always be interpreted correctly.  If the meaning of "FSW_Foo", for */
00083 /* instance, were to change, the new meaning would have to be given a */
00084 /* new secondary Id number. */
00085
00086 /* ID definitions in FSW space: */
00087 enum { Sec_Id_EBF_1    = Sec_Base_FSW + 0x01 }; /* GLT, no GEM */
00088 enum { Sec_Id_EBF_2    = Sec_Base_FSW + 0x02 }; /* GEM, AEM @ 17, 18 */
00089 enum { Sec_Id_EBF_3    = Sec_Base_FSW + 0x03 }; /* 1st GASU ACD map */
00090 enum { Sec_Id_EBF      = Sec_Base_FSW + 0x04 }; /* Current version */
00091
00092 enum { Sec_Id_EBF_MC   = Sec_Base_FSW + 0x01 };
00093
00094 /* ID definitions in Online Event Format (OEF) space: */
00095 enum { Sec_Id_Datagram = Sec_Base_OEF + 0x01 };
00096 enum { Sec_Id_UnrecBuf = Sec_Base_OEF + 0x01 };
00097 enum { Sec_Id_BtAncEvt = 0x12c               };
00098 enum { Sec_Id_BtAncEvt_1 = 0x12d             };
00099 enum { Sec_Id_BtAncHdr = 0x0c8               };
00100 enum { Sec_Id_BtAncTlr = 0x064               };
00102 /* ID definitions in ACD space: */
00103 enum { Sec_Id_ASC      = 0x100        + 0x01 };
00105 /* ID definitions in Calorimeter (CAL) space: */
00106 enum { Sec_Id_CEDhdr   = Sec_Base_CAL + 0x00 };
00108 /* ID definitions in Online Event Server (OSW) space: */
00109 enum { Sec_Id_Time     = Sec_Base_OSW + 0x01 };
00110 enum { Sec_Id_Time_1   = Sec_Base_OSW + 0x02 };
00112 enum { Sec_Id_Consumer = Sec_Base_OSW + 0x02 };
00114 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: eventSummary.h Source File

  • File List
  • File Members

eventSummary.h

00001
00023 #ifndef EventSummary_H
00024 #define EventSummary_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030
00031 class DLL_EXPORT_API EventSummary
00032 {
00033 public:
00034   EventSummary(unsigned summary);
00035   EventSummary()  {}
00036   ~EventSummary() {}
00037
00038   static
00039   unsigned calStrobe(unsigned summary);
00040   unsigned calStrobe() const;
00041
00042   static
00043   unsigned tag(unsigned summary);
00044   unsigned tag() const;
00045
00046   static
00047   unsigned TACK(unsigned summary);
00048   unsigned TACK() const;
00049
00050   static
00051   unsigned readout4(unsigned summary);
00052   unsigned readout4() const;
00053
00054   static
00055   unsigned zeroSuppress(unsigned summary);
00056   unsigned zeroSuppress() const;
00057
00058   static
00059   unsigned marker(unsigned summary);
00060   unsigned marker() const;
00061
00062   static
00063   unsigned error(unsigned summary);
00064   unsigned error() const;
00065
00066   static
00067   unsigned diagnostic(unsigned summary);
00068   unsigned diagnostic() const;
00069
00070   static
00071   unsigned eventNumber(unsigned summary);
00072   unsigned eventNumber() const;
00073
00074   static
00075   unsigned trgParityError(unsigned summary);
00076   unsigned trgParityError() const;
00077
00078 private:
00079   unsigned _summary;
00080 };
00081
00082
00088 inline EventSummary::EventSummary(unsigned summary) :
00089   _summary(summary)
00090 {
00091 }
00092
00098 inline unsigned EventSummary::calStrobe(unsigned summary)
00099 {
00100   return ( summary >> 30) & 0x0001;
00101 }
00102
00107 inline unsigned EventSummary::calStrobe() const
00108 {
00109   return (_summary >> 30) & 0x0001;
00110 }
00111
00117 inline unsigned EventSummary::tag(unsigned summary)
00118 {
00119   return ( summary >> 28) & 0x0003;
00120 }
00121
00126 inline unsigned EventSummary::tag() const
00127 {
00128   return (_summary >> 28) & 0x0003;
00129 }
00130
00136 inline unsigned EventSummary::TACK(unsigned summary)
00137 {
00138   return ( summary >> 27) & 0x0001;
00139 }
00140
00145 inline unsigned EventSummary::TACK() const
00146 {
00147   return (_summary >> 27) & 0x0001;
00148 }
00149
00155 inline unsigned EventSummary::readout4(unsigned summary)
00156 {
00157   return ( summary >> 26) & 0x0001;
00158 }
00159
00164 inline unsigned EventSummary::readout4() const
00165 {
00166   return (_summary >> 26) & 0x0001;
00167 }
00168
00174 inline unsigned EventSummary::zeroSuppress(unsigned summary)
00175 {
00176   return ( summary >> 25) & 0x0001;
00177 }
00178
00183 inline unsigned EventSummary::zeroSuppress() const
00184 {
00185   return (_summary >> 25) & 0x0001;
00186 }
00187
00193 inline unsigned EventSummary::marker(unsigned summary)
00194 {
00195   return ( summary >> 22) & 0x0007;
00196 }
00197
00202 inline unsigned EventSummary::marker() const
00203 {
00204   return (_summary >> 22) & 0x0007;
00205 }
00206
00216 inline unsigned EventSummary::error(unsigned summary)
00217 {
00218   return ( summary >> 21) & 0x0001;
00219 }
00220
00229 inline unsigned EventSummary::error() const
00230 {
00231   return (_summary >> 21) & 0x0001;
00232 }
00233
00243 inline unsigned EventSummary::diagnostic(unsigned summary)
00244 {
00245   return ( summary >> 20) & 0x0001;
00246 }
00247
00256 inline unsigned EventSummary::diagnostic() const
00257 {
00258   return (_summary >> 20) & 0x0001;
00259 }
00260
00266 inline unsigned EventSummary::eventNumber(unsigned summary)
00267 {
00268   return ( summary >>  1) & 0x7fff;
00269 }
00270
00275 inline unsigned EventSummary::eventNumber() const
00276 {
00277   return (_summary >>  1) & 0x7fff;
00278 }
00279
00286 inline unsigned EventSummary::trgParityError(unsigned summary)
00287 {
00288   return ( summary      ) & 0x0001;
00289 }
00290
00296 inline unsigned EventSummary::trgParityError() const
00297 {
00298   return (_summary      ) & 0x0001;
00299 }
00300
00301
00302 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: GEMcontribution.h Source File

  • File List
  • File Members

GEMcontribution.h

00001
00023 #ifndef GEMcontribution_H
00024 #define GEMcontribution_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030 #include "DFC_endianness.h"
00031 #include "EBFcontribution.h"
00032
00033
00037 class DLL_EXPORT_API GEMtileList
00038 {
00039 public:
00040   GEMtileList()  {}
00041   ~GEMtileList() {}
00042
00043   unsigned short XZM()  const;
00044   unsigned short XZP()  const;
00045   unsigned short YZM()  const;
00046   unsigned short YZP()  const;
00047   unsigned       XY()   const;
00048   unsigned short RBN()  const;
00049   unsigned short NA()   const;
00050
00051 private:
00052 #if DFC_BIG_ENDIAN
00053   unsigned short _xzp;
00054   unsigned short _xzm;
00055   unsigned short _yzp;
00056   unsigned short _yzm;
00057 #else   /* DFC_BIG_ENDIAN */
00058   unsigned short _xzm;
00059   unsigned short _xzp;
00060   unsigned short _yzm;
00061   unsigned short _yzp;
00062 #endif  /* DFC_BIG_ENDIAN */
00063   unsigned       _xy;
00064 #if DFC_BIG_ENDIAN
00065   unsigned short _na;
00066   unsigned short _rbn;
00067 #else   /* DFC_BIG_ENDIAN */
00068   unsigned short _rbn;
00069   unsigned short _na;
00070 #endif  /* DFC_BIG_ENDIAN */
00071 };
00072
00073
00077 class DLL_EXPORT_API GEMonePPStime
00078 {
00079 public:
00080   GEMonePPStime()  {}
00081   ~GEMonePPStime() {}
00082
00083   unsigned timebase()  const;
00084   unsigned seconds()   const;
00085
00086 private:
00087   unsigned _onePPStime;
00088 };
00089
00093 class DLL_EXPORT_API GEMcondArrivalTime
00094 {
00095 public:
00096   //constructor and destructor removed as class is inside union
00097   //GEMcondArrivalTime()  {}
00098   //~GEMcondArrivalTime() {}
00099
00100   unsigned short external()  const;
00101   unsigned short cno()       const;
00102   unsigned short calLE()     const;
00103   unsigned short calHE()     const;
00104   unsigned short tkr()       const;
00105   unsigned short roi()       const;
00106   unsigned       datum()     const;
00107
00108 private:
00109   unsigned _condArr;
00110 };
00111
00112
00116 class DLL_EXPORT_API GEMcontribution : public EBFcontribution
00117 {
00118 public:
00119   GEMcontribution()    {}
00120   ~GEMcontribution()   {}
00121
00122   char* data() const;
00123
00124   unsigned short     tkrVector()         const;
00125   unsigned short     roiVector()         const;
00126   unsigned short     calLEvector()       const;
00127   unsigned short     calHEvector()       const;
00128   unsigned short     cnoVector()         const;
00129   unsigned short     conditionSummary()  const;
00130   unsigned short     missed()            const;
00131   unsigned short     deadZone()          const;
00132   const GEMtileList* tileList()          const;
00133   unsigned           liveTime()          const;
00134   unsigned           prescaled()         const;
00135   unsigned           discarded()         const;
00136   unsigned           sent()              const;
00137   GEMcondArrivalTime condArrTime()       const;
00138   unsigned           triggerTime()       const;
00139   GEMonePPStime      onePPStime()        const;
00140   unsigned short     deltaEventTime()    const;
00141   unsigned short     deltaWindowOpenTime() const;
00142
00143   // GEM doc v2.5 redefined sent() field as condition_arrival_times
00144   // We keep both accessors to this field for backward compatibility,
00145   // but overload the memory location with a union.
00146   union sent_condArr {
00147     unsigned sent;
00148     GEMcondArrivalTime condArr;
00149   };
00150
00151 private:                                   // inherit 8 bytes of header
00152 #if DFC_BIG_ENDIAN
00153   unsigned short _ROIvector;
00154   unsigned short _TKRvector;
00155   unsigned short _CAL_HEvector;
00156   unsigned short _CAL_LEvector;
00157   unsigned short _conditionSummary;
00158   unsigned short _CNOvector;
00159 #else   /* DFC_BIG_ENDIAN */
00160   unsigned short _TKRvector;
00161   unsigned short _ROIvector;
00162   unsigned short _CAL_LEvector;
00163   unsigned short _CAL_HEvector;
00164   unsigned short _CNOvector;
00165   unsigned short _conditionSummary;         // 12 -> 20 bytes so far
00166 #endif  /* DFC_BIG_ENDIAN */
00167   GEMtileList    _tileList;                 // 16 -> 36 bsf
00168   unsigned       _liveTime;                 // 4  -> 40 bsf
00169   unsigned       _prescaled;                // 4  -> 44 bsf
00170   unsigned       _discarded;                // 4  -> 48 bsf
00171   sent_condArr   _sent_condArr;             // 4  -> 52 bsf
00172   unsigned       _triggerTime;              // 4  -> 56 bsf
00173   GEMonePPStime  _onePPStime;               // 4  -> 60 bsf
00174 #if DFC_BIG_ENDIAN
00175   unsigned short _deltaWindOpenTime;
00176   unsigned short _deltaEventTime;
00177 #else   /* DFC_BIG_ENDIAN */
00178   unsigned short _deltaEventTime;
00179   unsigned short _deltaWindOpenTime;
00180 #endif  /* DFC_BIG_ENDIAN */                // 4  -> 64 bsf  *** 16 byte boundary required ***
00181
00182 };
00183
00184
00189 inline char* GEMcontribution::data() const
00190 {
00191   return payload();
00192 }
00193
00198 inline unsigned short  GEMcontribution::tkrVector()      const
00199 {
00200   return _TKRvector;
00201 }
00202
00207 inline unsigned short  GEMcontribution::roiVector()      const
00208 {
00209   return _ROIvector;
00210 }
00211
00216 inline unsigned short  GEMcontribution::calLEvector()    const
00217 {
00218   return _CAL_LEvector;
00219 }
00220
00225 inline unsigned short  GEMcontribution::calHEvector()    const
00226 {
00227   return _CAL_HEvector;
00228 }
00229
00234 inline unsigned short  GEMcontribution::cnoVector()      const
00235 {
00236   return _CNOvector;
00237 }
00238
00243 inline unsigned short  GEMcontribution::conditionSummary() const
00244 {
00245   return _conditionSummary & (( 1 << 8 ) - 1 );
00246 }
00247
00252 inline unsigned short  GEMcontribution::missed() const
00253 {
00254   return (_conditionSummary >> 8) & (( 1 << 8 ) - 1 );
00255 }
00256
00261 inline unsigned short  GEMcontribution::deadZone() const
00262 {
00263   return (missed());
00264 }
00265
00270 inline const GEMtileList*    GEMcontribution::tileList()       const
00271 {
00272   return &_tileList;
00273 }
00274
00279 inline unsigned        GEMcontribution::liveTime()       const
00280 {
00281   return _liveTime;
00282 }
00283
00288 inline unsigned        GEMcontribution::prescaled()      const
00289 {
00290   return _prescaled;
00291 }
00292
00297 inline unsigned        GEMcontribution::discarded()           const
00298 {
00299   return _discarded;
00300 }
00301
00308 inline unsigned        GEMcontribution::sent()           const
00309 {
00310   return _sent_condArr.sent;
00311 }
00312
00317 inline GEMcondArrivalTime GEMcontribution::condArrTime() const
00318 {
00319   return _sent_condArr.condArr;
00320 }
00321
00326 inline unsigned        GEMcontribution::triggerTime()    const
00327 {
00328   return _triggerTime;
00329 }
00330
00335 inline GEMonePPStime   GEMcontribution::onePPStime()     const
00336 {
00337   return _onePPStime;
00338 }
00339
00344 inline unsigned short   GEMcontribution::deltaEventTime()    const
00345 {
00346   return _deltaEventTime;
00347 }
00348
00353 inline unsigned short   GEMcontribution::deltaWindowOpenTime()  const
00354 {
00355   return _deltaWindOpenTime;
00356 }
00357
00362 inline unsigned short  GEMtileList::XZM() const
00363 {
00364   return _xzm;
00365 }
00366
00371 inline unsigned short  GEMtileList::XZP() const
00372 {
00373   return _xzp;
00374 }
00375
00380 inline unsigned short  GEMtileList::YZM() const
00381 {
00382   return _yzm;
00383 }
00384
00389 inline unsigned short  GEMtileList::YZP() const
00390 {
00391   return _yzp;
00392 }
00393
00398 inline unsigned        GEMtileList::XY()  const
00399 {
00400   return _xy;
00401 }
00402
00407 inline unsigned short  GEMtileList::RBN() const
00408 {
00409   return _rbn;
00410 }
00411
00416 inline unsigned short  GEMtileList::NA()  const
00417 {
00418   return _na;
00419 }
00420
00425 inline unsigned GEMonePPStime::seconds()  const
00426 {
00427   return (_onePPStime >> 25) & ((1 <<  8) - 1);
00428 }
00429
00434 inline unsigned GEMonePPStime::timebase() const
00435 {
00436   return (_onePPStime      ) & ((1 << 25) - 1);
00437 }
00438
00443 inline unsigned short  GEMcondArrivalTime::external() const
00444 {
00445   return (_condArr >> 25) & ((1 << 5) -1);
00446 }
00447
00452 inline unsigned short  GEMcondArrivalTime::cno()      const
00453 {
00454   return (_condArr >> 20) & ((1 << 5) -1);
00455 }
00456
00461 inline unsigned short  GEMcondArrivalTime::calHE()    const
00462 {
00463   return (_condArr >> 15) & ((1 << 5) -1);
00464 }
00465
00470 inline unsigned short  GEMcondArrivalTime::calLE()    const
00471 {
00472   return (_condArr >> 10) & ((1 << 5) -1);
00473 }
00474
00479 inline unsigned short  GEMcondArrivalTime::tkr()      const
00480 {
00481   return (_condArr >>  5) & ((1 << 5) -1);
00482 }
00483
00488 inline unsigned short  GEMcondArrivalTime::roi()      const
00489 {
00490   return (_condArr      ) & ((1 << 5) -1);
00491 }
00492
00497 inline unsigned GEMcondArrivalTime::datum()   const
00498 {
00499   return _condArr;
00500 }
00501 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: GLTcontribution.h Source File

  • File List
  • File Members

GLTcontribution.h

00001
00030 #ifndef GLTcontribution_H
00031 #define GLTcontribution_H
00032
00033 #include "copyright_SLAC.h"
00034
00035 #include "libApiExport.h"
00036
00037 #include "EBFcontribution.h"
00038 #include "timespec.h"
00039 #include "OSWtimeBase.h"
00040
00041
00042 class DLL_EXPORT_API GLTcontribution : public EBFcontribution
00043 {
00044 public:
00045   GLTcontribution()    {}
00046   ~GLTcontribution()   {}
00047
00048   char* data();
00049
00050   const struct timespec* timeStamp() const;
00051   const OSWtimeBase*     timebase()  const;
00052
00053 private:
00054   struct timespec _timeStamp;
00055   OSWtimeBase     _timebase;
00056   unsigned        _pad[2];            // Pad to integer number of 16 byte cells
00057 };
00058
00059
00064 inline char* GLTcontribution::data()
00065 {
00066   return payload();
00067 }
00068
00078 inline const struct timespec* GLTcontribution::timeStamp() const
00079 {
00080   return &_timeStamp;
00081 }
00082
00093 inline const OSWtimeBase* GLTcontribution::timebase() const
00094 {
00095   return &_timebase;
00096 }
00097
00098 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! A template class */
template<class T> class Templ { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};
If the MAX_DOT_GRAPH_HEIGHT tag in the configuration file is set to 240 this will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled black box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.
The arrows have the following meaning:
  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.
Generated on Mon Jul 31 17:48:25 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: GXXXerror.h Source File

  • File List
  • File Members

GXXXerror.h

00001
00023 #ifndef GXXXerror_H
00024 #define GXXXerror_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030
00034 class DLL_EXPORT_API GCCCerror
00035 {
00036 public:
00038   GCCCerror(unsigned msg) : _msg(msg) {}
00039   ~GCCCerror()                        {}
00040
00042   static unsigned type(unsigned msg)           { return ( msg      ) & 0x000f; }
00044          unsigned type()          const        { return (_msg      ) & 0x000f; }
00046   static unsigned sweep(unsigned msg)          { return ( msg >>  6) & 0x0003; }
00048          unsigned sweep()         const        { return (_msg >>  6) & 0x0003; }
00050   static unsigned param(unsigned msg)          { return ( msg >>  8) & 0x00ff; }
00052          unsigned param()         const        { return (_msg >>  8) & 0x00ff; }
00054          unsigned raw()           const        { return _msg; }
00055 private:
00056   unsigned _msg;
00057 };
00058
00059
00063 class DLL_EXPORT_API GTCCerror
00064 {
00065 public:
00067   GTCCerror(unsigned msg) : _msg(msg) {}
00068   ~GTCCerror()                        {}
00069
00071   static unsigned GTRC(unsigned msg)           { return ( msg      ) & 0x00ff; }
00073          unsigned GTRC()          const        { return (_msg      ) & 0x00ff; }
00075   static unsigned RCphase(unsigned msg)        { return ( msg >>  8) & 0x0001; }
00077          unsigned RCphase()       const        { return (_msg >>  8) & 0x0001; }
00079   static unsigned FEphase(unsigned msg)        { return ( msg >>  9) & 0x0001; }
00081          unsigned FEphase()       const        { return (_msg >>  9) & 0x0001; }
00083   static unsigned FIFOfull(unsigned msg)       { return ( msg >> 10) & 0x0001; }
00085          unsigned FIFOfull()      const        { return (_msg >> 10) & 0x0001; }
00087   static unsigned cableTMO(unsigned msg)       { return ( msg >> 11) & 0x0001; }
00089          unsigned cableTMO()      const        { return (_msg >> 11) & 0x0001; }
00091   static unsigned hdrParity(unsigned msg)      { return ( msg >> 12) & 0x0001; }
00093          unsigned hdrParity()     const        { return (_msg >> 12) & 0x0001; }
00095   static unsigned wrdCntParity(unsigned msg)   { return ( msg >> 13) & 0x0001; }
00097          unsigned wrdCntParity()  const        { return (_msg >> 13) & 0x0001; }
00099   static unsigned RCsummary(unsigned msg)      { return ( msg >> 14) & 0x0001; }
00101          unsigned RCsummary()     const        { return (_msg >> 14) & 0x0001; }
00103   static unsigned dataParity(unsigned msg)     { return ( msg >> 15) & 0x0001; }
00105          unsigned dataParity()    const        { return (_msg >> 15) & 0x0001; }
00107          unsigned raw()           const        { return _msg; }
00108 private:
00109   unsigned _msg;
00110 };
00111
00112
00116 class DLL_EXPORT_API GTRCerror
00117 {
00118 public:
00120   GTRCerror(unsigned tag) : _tag(tag) {}
00121   ~GTRCerror()                        {}
00122
00124   static unsigned currentTag(unsigned tag)     { return ( tag      ) & 0x0003; }
00126          unsigned currentTag()    const        { return (_tag      ) & 0x0003; }
00128   static unsigned layer0Tag(unsigned tag)      { return ( tag >>  2) & 0x0003; }
00130          unsigned layer0Tag()     const        { return (_tag >>  2) & 0x0003; }
00132   static unsigned expectedLayer(unsigned tag)  { return ( tag >>  8) & 0x000f; }
00134          unsigned expectedLayer() const        { return (_tag >>  8) & 0x000f; }
00136   static unsigned receivedLayer(unsigned tag)  { return ( tag >> 12) & 0x000f; }
00138          unsigned receivedLayer() const        { return (_tag >> 12) & 0x000f; }
00140          unsigned raw()           const        { return _tag; }
00141 private:
00142   unsigned _tag;
00143 };
00144
00145 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: LATcomponentIterator.h Source File

  • File List
  • File Members

LATcomponentIterator.h

00001
00041 #ifndef LATcomponentIterator_H
00042 #define LATcomponentIterator_H
00043
00044 #include "copyright_SLAC.h"
00045
00046 #include "libApiExport.h"
00047 #include "EBFcontribution.h"
00048 #include "TEMcontribution.h"
00049 #include "EBFcontributionIterator.h"
00050 #include "TEMcontributionIterator.h"
00051
00052 class DLL_EXPORT_API OSWcontribution;   // Avoid #include "OSWcontribution.h"
00053 class DLL_EXPORT_API GLTcontribution;   // Avoid #include "GLTcontribution.h"
00054 class DLL_EXPORT_API GEMcontribution;   // Avoid #include "GEMcontribution.h"
00055 class DLL_EXPORT_API AEMcontribution;   // Avoid #include "AEMcontribution.h"
00056 class DLL_EXPORT_API CALcontribution;   // Avoid #include "CALcontribution.h"
00057 class DLL_EXPORT_API TKRcontribution;   // Avoid #include "TKRcontribution.h"
00058
00059
00060 class DLL_EXPORT_API LATcomponentIterator : public EBFcontributionIterator,
00061                                             public TEMcontributionIterator
00062 {
00063 public:
00064   LATcomponentIterator(EBFevent*);
00065   LATcomponentIterator();
00066   virtual ~LATcomponentIterator() {}
00067
00068   unsigned iterate(EBFevent* event);
00069   virtual int handleError(EBFcontribution* contribution, unsigned code, unsigned p1=0, unsigned p2=0) const;
00070   virtual int handleError(EBFevent* event, unsigned code, unsigned p1=0, unsigned p2=0) const;
00071
00072   int OSW(EBFevent* event, EBFcontribution* contribution);
00073   int GLT(EBFevent* event, EBFcontribution* contribution);
00074   int GEM(EBFevent* event, EBFcontribution* contribution);
00075   int AEM(EBFevent* event, EBFcontribution* contribution);
00076   int TEM(EBFevent* event, EBFcontribution* contribution);
00077   int UDF(EBFevent* event, EBFcontribution* contribution);
00078   int CAL(EBFevent* event, TEMcontribution* contribution);
00079   int TKR(EBFevent* event, TEMcontribution* contribution);
00080
00081   virtual int UDFcomponent(EBFevent* event, EBFcontribution* contribution);
00082   virtual int OSWcomponent(EBFevent* event, OSWcontribution* contribution);
00083   virtual int GLTcomponent(EBFevent* event, GLTcontribution* contribution);
00084   virtual int GEMcomponent(EBFevent* event, GEMcontribution* contribution);
00085   virtual int ACDcomponent(EBFevent* event, AEMcontribution* contribution);
00086   virtual int CALcomponent(EBFevent* event, CALcontribution* contribution);
00087   virtual int TKRcomponent(EBFevent* event, TKRcontribution* contribution);
00088   virtual int diagnostic  (EBFevent* event, TEMcontribution* contribution);
00089   virtual int error       (EBFevent* event, TEMcontribution* contribution);
00090   virtual int cleanup     (EBFevent* event, TEMcontribution* contribution);
00091 };
00092
00093 inline unsigned LATcomponentIterator::iterate(EBFevent* event)
00094 {
00095   return EBFcontributionIterator::iterate(event);
00096 }
00097
00102 inline LATcomponentIterator::LATcomponentIterator(EBFevent* event) :
00103   EBFcontributionIterator(event)
00104 {
00105 }
00106
00110 inline LATcomponentIterator::LATcomponentIterator()
00111 {
00112 }
00113
00125 inline int LATcomponentIterator::OSW(EBFevent*        event,
00126                                      EBFcontribution* contribution)
00127 {
00128   return OSWcomponent(event, contribution->oswContribution());
00129 }
00130
00142 inline int LATcomponentIterator::GLT(EBFevent*        event,
00143                                      EBFcontribution* contribution)
00144 {
00145   return GLTcomponent(event, contribution->gltContribution());
00146 }
00147
00159 inline int LATcomponentIterator::GEM(EBFevent*        event,
00160                                      EBFcontribution* contribution)
00161 {
00162   return GEMcomponent(event, contribution->gemContribution());
00163 }
00164
00176 inline int LATcomponentIterator::AEM(EBFevent*        event,
00177                                      EBFcontribution* contribution)
00178 {
00179   return ACDcomponent(event, contribution->aemContribution());
00180 }
00181
00193 inline int LATcomponentIterator::TEM(EBFevent*        event,
00194                                      EBFcontribution* contribution)
00195 {
00196   TEMcontributionIterator::iterate(event, contribution->temContribution());
00197   return 0;
00198 }
00199
00211 inline int LATcomponentIterator::UDF(EBFevent*        event,
00212                                      EBFcontribution* contribution)
00213 {
00214   return UDFcomponent(event, contribution);
00215 }
00216
00228 inline int LATcomponentIterator::CAL(EBFevent*        event,
00229                                      TEMcontribution* contribution)
00230 {
00231   // Do this if CALend hasn't been set...
00232   if (0 == CALend())
00233       CALend( 3*sizeof(unsigned) );
00234   return CALcomponent(event, contribution->calContribution());
00235 }
00236
00248 inline int LATcomponentIterator::TKR(EBFevent*        event,
00249                                      TEMcontribution* contribution)
00250 {
00251   return TKRcomponent(event, contribution->tkrContribution());
00252 }
00253
00254
00262 inline
00263 int LATcomponentIterator::UDFcomponent(EBFevent*        /* event */,
00264                                        EBFcontribution* /* contribution */)
00265 {
00266   return 0;
00267 }
00268
00276 inline
00277 int LATcomponentIterator::OSWcomponent(EBFevent*        /* event */,
00278                                        OSWcontribution* /* contribution */)
00279 {
00280   return 0;
00281 }
00282
00290 inline
00291 int LATcomponentIterator::GLTcomponent(EBFevent*        /* event */,
00292                                        GLTcontribution* /* contribution */)
00293 {
00294   return 0;
00295 }
00296
00304 inline
00305 int LATcomponentIterator::GEMcomponent(EBFevent*        /* event */,
00306                                        GEMcontribution* /* contribution */)
00307 {
00308   return 0;
00309 }
00310
00318 inline
00319 int LATcomponentIterator::ACDcomponent(EBFevent*        /* event */,
00320                                        AEMcontribution* /* contribution */)
00321 {
00322   return 0;
00323 }
00324
00332 inline
00333 int LATcomponentIterator::CALcomponent(EBFevent*        /* event */,
00334                                        CALcontribution* /* contribution */)
00335 {
00336   return 0;
00337 }
00338
00346 inline
00347 int LATcomponentIterator::TKRcomponent(EBFevent*        /* event */,
00348                                        TKRcontribution* /* contribution */)
00349 {
00350   return 0;
00351 }
00352
00360 inline
00361 int LATcomponentIterator::diagnostic(EBFevent*        /* event */,
00362                                      TEMcontribution* /* contribution */)
00363 {
00364   return 0;
00365 }
00366
00374 inline
00375 int LATcomponentIterator::error(EBFevent*        /* event */,
00376                                 TEMcontribution* /* contribution */)
00377 {
00378   return 0;
00379 }
00380
00393 inline
00394 int LATcomponentIterator::cleanup(EBFevent*        /* event */,
00395                                   TEMcontribution* /* contribution */)
00396 {
00397   return 0;
00398 }
00399
00412 inline int
00413 LATcomponentIterator::handleError(EBFcontribution* contribution, unsigned code, unsigned p1, unsigned p2) const
00414 {
00415   return 0;
00416 }
00429 inline int
00430 LATcomponentIterator::handleError(EBFevent* event, unsigned code, unsigned p1, unsigned p2) const
00431 {
00432   return 0;
00433 }
00434 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: LATcontribution.h Source File

  • File List
  • File Members

LATcontribution.h

00001
00023 #ifndef LATcontribution_H
00024 #define LATcontribution_H
00025
00026 #include "copyright_SLAC.h"
00027 #include "stddef.h"
00028 #include "libApiExport.h"
00029
00030 #include "DFC_endianness.h"
00031 #include "EBF_swap.h"
00032
00033 #include "LATidentity.h"
00034 #include "LATtypeId.h"
00035
00036
00037 // Adding virtual methods add a hidden virtual function table pointer to the
00038 // class, preventing it from being memory mapable.  So, virtual methods have
00039 // been removed to keep this class concrete.
00040 // This means that we can't force derived classes from this one to provide
00041 // implementations for required methods, e.g., length() and next().  All
00042 // "leaf" classes derived from LATcontribution, e.g. EBFevent, must provide
00043 // a length() and next() method.
00044
00045 class DLL_EXPORT_API LATcontribution
00046 {
00047 public:
00048   LATcontribution();
00049   LATcontribution(LATtypeId identity, unsigned length);
00050   ~LATcontribution() {}
00051
00052   enum {ID = LATidentity_(LATprimaryId::Any, LATsecondaryId::Any)};
00053
00054   LATtypeId        identity()    const;
00055   LATcontribution* next()        const;
00056
00057   unsigned         length()      const;
00058   unsigned         rawDataSize() const;
00059   char*            rawData()     const;
00060
00061   void* operator   new(size_t);
00062   void* operator   new(size_t, LATtypeId identity, unsigned length);
00063   void* operator   new(size_t, const LATcontribution&);
00064   void* operator   new(size_t, void*, unsigned short supplemental, bool swap = !DFC_BIG_ENDIAN);
00065   void  operator   delete(void*, void*, unsigned short, bool);
00066   void  operator   delete(void*);
00067
00068   static LATcontribution* create(LATtypeId      identity,
00069                                  unsigned       size,
00070                                  unsigned char* buffer,
00071                                  bool           swap = !DFC_BIG_ENDIAN);
00072
00073   unsigned char*   string(bool swap = !DFC_BIG_ENDIAN);
00074
00075 private:
00076   LATtypeId      _identity;
00077   unsigned       _length;               // Units are bytes
00078 };
00079
00080
00084 inline LATcontribution::LATcontribution() :
00085   _identity(LATcontribution::ID),
00086   _length(sizeof(LATcontribution))
00087 {
00088 }
00089
00096 inline LATcontribution::LATcontribution(LATtypeId      identity,
00097                                         unsigned       length) :
00098   _identity(identity),
00099   _length(sizeof(LATcontribution) + length)
00100 {}
00101
00105 inline LATtypeId LATcontribution::identity() const
00106 {
00107   return _identity;
00108 }
00109
00113 inline unsigned LATcontribution::length() const
00114 {
00115   return _length;
00116 }
00117
00122 inline unsigned LATcontribution::rawDataSize() const
00123 {
00124   return length() - sizeof(*this);
00125 }
00126
00131 inline char* LATcontribution::rawData() const
00132 {
00133   return (char*)&this[1];
00134 }
00135
00139 inline LATcontribution* LATcontribution::next() const
00140 {
00141   return (LATcontribution*)((char*)this + length());
00142 }
00143
00152 inline void* LATcontribution::operator new(size_t size)
00153 {
00154   return ::new LATcontribution();
00155 }
00156
00157
00169 inline void* LATcontribution::operator new(size_t          size,
00170                                            LATtypeId       identity,
00171                                            unsigned        length)
00172 {
00173   return ::new LATcontribution(identity, length);
00174 }
00175
00176
00186 inline void* LATcontribution::operator new(size_t                 size,
00187                                            const LATcontribution& contribution)
00188 {
00189   return ::new LATcontribution(contribution);
00190 }
00191
00192
00211 inline void* LATcontribution::operator new(size_t         size,
00212                                            void*          location,
00213                                            unsigned short supplemental,
00214                                            bool           swap)
00215 {
00216   if (swap)
00217   {
00218     EBF_swap32_lclXbigN((unsigned*)location,
00219                         ((int)size + supplemental) / sizeof (unsigned));
00220   }
00221   return location;
00222 }
00223
00224
00231 inline void LATcontribution::operator delete(void*, void*, unsigned short, bool)
00232 {
00233 }
00234
00235
00242 inline void LATcontribution::operator delete(void* location)
00243 {
00244   ::delete((LATcontribution*)location);
00245 }
00246
00247
00264 inline LATcontribution* LATcontribution::create(LATtypeId      identity,
00265                                                 unsigned       size,
00266                                                 unsigned char* buffer,
00267                                                 bool           swap)
00268 {
00269   return new(buffer, size, swap) LATcontribution(identity, size);
00270 }
00271
00286 inline unsigned char* LATcontribution ::string(bool swap)
00287 {
00288   if (swap)
00289   {
00290     EBF_swap32_lclXbigN((unsigned*)this, _length / sizeof (unsigned));
00291   }
00292   return (unsigned char*)this;
00293 }
00294
00295 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: LATcontributionIterator.h Source File

  • File List
  • File Members

LATcontributionIterator.h

00001
00023 #ifndef LATcontributionIterator_H
00024 #define LATcontributionIterator_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030 #include "LATdatagram.h"
00031 #include "EBFevent.h"
00032 #include "ASCcontribution.h"
00033
00034 #include "LATcontribution.h"
00035
00036 class DLL_EXPORT_API LATcontributionIterator
00037 {
00038 public:
00039   LATcontributionIterator(LATdatagram*);
00040   LATcontributionIterator();
00041   virtual ~LATcontributionIterator() {}
00042
00043   enum
00044   {
00045     ERR_UDFcontribution = 1
00046   };
00047
00048   unsigned     iterate();
00049   unsigned     iterate(LATdatagram*);
00050
00051   virtual int  handleError(LATcontribution* contrib, unsigned code, unsigned p1=0, unsigned p2=0) const;
00052
00054   virtual int  EBF(EBFevent* start, EBFevent* end) = 0;
00055
00057   virtual int  ASC(ASCcontribution* start, LATcontribution* end);
00058
00060   virtual int  UDF(LATcontribution* start, LATcontribution* end);
00061
00062   const LATdatagram* datagram() const;
00063   int                status()   const;
00064
00065 private:
00066   LATdatagram* _datagram;
00067   int          _status;
00068 };
00069
00070
00078 inline LATcontributionIterator::LATcontributionIterator(LATdatagram* datagram) :
00079   _datagram(datagram),
00080   _status(0)
00081 {
00082 }
00083
00087 inline LATcontributionIterator::LATcontributionIterator() :
00088   _datagram(0),
00089   _status(0)
00090 {
00091 }
00092
00094 inline int LATcontributionIterator::status() const
00095 {
00096   return _status;
00097 }
00098
00100 inline const LATdatagram* LATcontributionIterator::datagram() const
00101 {
00102   return _datagram;
00103 }
00104
00112 inline unsigned LATcontributionIterator::iterate()
00113 {
00114   return iterate(_datagram);
00115 }
00116
00117 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: LATdataBufferIterator.h Source File

  • File List
  • File Members

LATdataBufferIterator.h

00001
00024 #ifndef LATdataBufferIterator_H
00025 #define LATdataBufferIterator_H
00026
00027 #include "copyright_SLAC.h"
00028
00029 #include "libApiExport.h"
00030
00031 #include "LATcomponentIterator.h"
00032 #include "EBFeventIterator.h"
00033 #include "LATcontributionIterator.h"
00034 #include "LATdatagramIterator.h"
00035
00036
00042 class DLL_EXPORT_API LDBI_EBFeventIterator : public EBFeventIterator
00043 {
00044 public:
00045   LDBI_EBFeventIterator(LATcomponentIterator*);
00046   LDBI_EBFeventIterator() {//printf ("LDBI_EBFeventIterator::ctor0\n");
00047                           }
00048   virtual ~LDBI_EBFeventIterator() {//printf ("LDBI_EBFeventIterator::dtor\n");
00049                                    }
00050
00051   enum
00052   {
00053     ERR_BadStatus = 1000
00054   };
00055
00056   virtual int handleError(EBFevent* event, unsigned code, unsigned p1=0, unsigned p2=0) const;
00057   virtual int process(EBFevent*);
00058
00059 private:
00060   LATcomponentIterator* _lci;
00061 };
00062
00063
00069 inline LDBI_EBFeventIterator::LDBI_EBFeventIterator(LATcomponentIterator* lci) :
00070   EBFeventIterator(), _lci(lci)
00071 {
00072   //printf ("LDBI_EBFeventIterator::ctor1\n");
00073 }
00074
00085 inline int LDBI_EBFeventIterator::process(EBFevent* event)
00086 {
00087   int s = 0;
00088
00089   if (event->status() != 0)
00090   {
00091     //printf ("LDBI_EBFeventIterator::process 1\n");
00092     s = handleError(event, LDBI_EBFeventIterator::ERR_BadStatus, event->status());
00093     //printf ("LDBI_EBFeventIterator::process 2\n");
00094   }
00095   else
00096   {
00097     // Iterate over the contributions to an EBF event
00098     //printf ("LDBI_EBFeventIterator::process 3\n");
00099     //_lci->EBFcontributionIterator::iterate(event);
00100     //_lci->iterate(event);
00101     _lci->EBFcontributionIterator::iterate(event);
00102     //printf ("LDBI_EBFeventIterator::process 4\n");
00103     //s = _lci->EBFcontributionIterator::status();
00104     //s = _lci->status();
00105     s = _lci->EBFcontributionIterator::status();
00106     //printf ("LDBI_EBFeventIterator::process 5\n");
00107   }
00108   return s;
00109 }
00110
00123 inline int LDBI_EBFeventIterator::handleError(EBFevent* event, unsigned code, unsigned p1, unsigned p2) const
00124 {
00125   //printf ("LDBI_EBFeventIterator::handleError 1\n");
00126   switch (code)
00127   {
00128     case LDBI_EBFeventIterator::ERR_BadStatus:
00129     {
00130       //printf ("LDBI_EBFeventIterator::handleError 2\n");
00131       //fprintf(stderr, "Bad status %d in event header\n", event->status());
00132       //fprintf(stderr, "Aborting processing of event\n");
00133       return -1;
00134       break;
00135     }
00136     default:
00137       //printf ("LDBI_EBFeventIterator::handleError 3\n");
00138       return EBFeventIterator::handleError(event, code, p1, p2);
00139       break;
00140   }
00141   //printf ("LDBI_EBFeventIterator::handleError 4\n");
00142   return 0;
00143 }
00144
00150 class DLL_EXPORT_API LDBI_LATcontributionIterator : public LATcontributionIterator
00151 {
00152 public:
00153   LDBI_LATcontributionIterator(LATcomponentIterator*);
00154   LDBI_LATcontributionIterator(LDBI_EBFeventIterator*);
00155   LDBI_LATcontributionIterator()          {  //printf ("LDBI_LATcontributionIterator::ctor0\n");
00156 }
00157   virtual ~LDBI_LATcontributionIterator() { if (_newEEI) {delete _eei;}   //printf ("LDBI_LATcontributionIterator::dtor\n");
00158 }
00159
00160   virtual int EBF(EBFevent* start, EBFevent* end);
00161   //virtual int UDF(LATcontribution* start, LATcontribution* end);    // Commented out to use the default
00162
00163 private:
00164   LDBI_EBFeventIterator* _eei;
00165   bool                   _newEEI;
00166 };
00167
00173 inline LDBI_LATcontributionIterator::LDBI_LATcontributionIterator(LATcomponentIterator* lci) :
00174   LATcontributionIterator(),
00175   _newEEI(true)
00176 {
00177   //printf ("LDBI_LATcontributionIterator::ctor1 1\n");
00178   _eei = new LDBI_EBFeventIterator(lci);
00179   //printf ("LDBI_LATcontributionIterator::ctor1 2\n");
00180 }
00181
00187 inline LDBI_LATcontributionIterator::LDBI_LATcontributionIterator(LDBI_EBFeventIterator* eei) :
00188   LATcontributionIterator(),
00189   _eei(eei),
00190   _newEEI(false)
00191 {
00192   //printf ("LDBI_LATcontributionIterator::ctor2\n");
00193 }
00194
00205 inline int LDBI_LATcontributionIterator::EBF(EBFevent* start,
00206                                              EBFevent* end)
00207 {
00208   // Iterate over a list of EBF events
00209   //printf ("LDBI_LATcontributionIterator::EBF 1\n");
00210   _eei->iterate(start, end);
00211   //printf ("LDBI_LATcontributionIterator::EBF 2\n");
00212   return _eei->status();
00213 }
00214
00215
00221 class DLL_EXPORT_API LDBI_LATdatagramIterator : public LATdatagramIterator
00222 {
00223 public:
00224   LDBI_LATdatagramIterator(LATcomponentIterator*);
00225   LDBI_LATdatagramIterator(LDBI_LATcontributionIterator*);
00226   LDBI_LATdatagramIterator(LDBI_EBFeventIterator*);
00227   LDBI_LATdatagramIterator() {//printf ("LDBI_LATdatagramIterator::ctor0\n");
00228                              }
00229   virtual ~LDBI_LATdatagramIterator()  { if (_newLCI) {delete _lci;}   //printf ("LDBI_LATdatagramIterator::dtor\n");
00230                                        }
00231
00232   virtual int process(LATdatagram*);
00233 private:
00234   LDBI_LATcontributionIterator* _lci;
00235   bool                          _newLCI;
00236 public:
00237
00238 };
00239
00245 inline LDBI_LATdatagramIterator::LDBI_LATdatagramIterator(LATcomponentIterator* lci) :
00246   LATdatagramIterator(),
00247   _newLCI(true)
00248 {
00249   //printf ("LDBI_LATdatagramIterator::ctor1 1\n");
00250   _lci = new LDBI_LATcontributionIterator(lci);
00251   //printf ("LDBI_LATdatagramIterator::ctor2 1\n");
00252 }
00253
00259 inline LDBI_LATdatagramIterator::LDBI_LATdatagramIterator(LDBI_LATcontributionIterator* lci) :
00260   LATdatagramIterator(),
00261   _lci(lci),
00262   _newLCI(false)
00263 {
00264   //printf ("LDBI_LATdatagramIterator::ctor2\n");
00265 }
00266
00272 inline LDBI_LATdatagramIterator::LDBI_LATdatagramIterator(LDBI_EBFeventIterator* eei) :
00273   LATdatagramIterator(),
00274   _newLCI(true)
00275 {
00276   //printf ("LDBI_LATdatagramIterator::ctor3 1\n");
00277   _lci = new LDBI_LATcontributionIterator(eei);
00278   //printf ("LDBI_LATdatagramIterator::ctor3 2\n");
00279 }
00280
00290 inline int LDBI_LATdatagramIterator::process(LATdatagram* datagram)
00291 {
00292   // Iterate over a list of datagram contributions
00293   //printf ("LDBI_LATdatagramIterator::process 1\n");
00294   int s = _lci->iterate(datagram);
00295   //printf ("LDBI_LATdatagramIterator::process 2\n");
00296   return s;
00297 }
00298
00299
00305 class DLL_EXPORT_API LATdataBufferIterator
00306 {
00307 public:
00308   LATdataBufferIterator(LATcomponentIterator*,         bool swap = !DFC_BIG_ENDIAN);
00309   LATdataBufferIterator(LDBI_LATcontributionIterator*, bool swap = !DFC_BIG_ENDIAN);
00310   LATdataBufferIterator(LDBI_LATdatagramIterator*,     bool swap = !DFC_BIG_ENDIAN);
00311   ~LATdataBufferIterator() { if (_newLDI) {delete _ldi;}   //printf ("LATdataBufferIterator::dtor\n");
00312 }
00313
00314   int iterate();
00315   int iterate(char* buffer, unsigned length);
00316   int iterate(char* buffer, unsigned length, bool swap);
00317
00318 private:
00319   LDBI_LATdatagramIterator* _ldi;
00320   LATdatagram*              _start;
00321   LATdatagram*              _end;
00322   bool                      _swap;
00323   bool                      _newLDI;
00324 };
00325
00326
00344 inline LATdataBufferIterator::LATdataBufferIterator(LATcomponentIterator* lci,
00345                                                     bool                  swap):
00346   _start(0),
00347   _end(0),
00348   _swap(swap),
00349   _newLDI(true)
00350 {
00351   //printf ("LATdataBufferIterator::ctor1: 1\n");
00352   _ldi = new LDBI_LATdatagramIterator(lci);
00353   //printf ("LATdataBufferIterator::ctor1: 2\n");
00354 }
00355
00374 inline LATdataBufferIterator::LATdataBufferIterator(LDBI_LATcontributionIterator* lci,
00375                                                     bool                          swap):
00376   _start(0),
00377   _end(0),
00378   _swap(swap),
00379   _newLDI(true)
00380 {
00381   //printf ("LATdataBufferIterator::ctor2: 1\n");
00382   _ldi = new LDBI_LATdatagramIterator(lci);
00383   //printf ("LATdataBufferIterator::ctor2: 2\n");
00384 }
00385
00403 inline LATdataBufferIterator::LATdataBufferIterator(LDBI_LATdatagramIterator* ldi,
00404                                                     bool                      swap):
00405   _ldi(ldi),
00406   _start(0),
00407   _end(0),
00408   _swap(swap),
00409   _newLDI(false)
00410 {
00411   //printf ("LATdataBufferIterator::ctor3\n");
00412 }
00413
00425 inline int LATdataBufferIterator::iterate(char*    buffer,
00426                                           unsigned length)
00427 {
00428   //printf ("LATdataBufferIterator::iterate1\n");
00429   return iterate(buffer, length, _swap);
00430 }
00431
00446 inline int LATdataBufferIterator::iterate(char*    buffer,
00447                                           unsigned length,
00448                                           bool     swap)
00449 {
00450   //printf ("LATdataBufferIterator::iterate2: 1\n");
00451   if (swap)
00452   {
00453     EBF_swap32_lclXbigN((unsigned*)buffer, length / sizeof (unsigned));
00454   }
00455
00456   //printf ("LATdataBufferIterator::iterate2: 2\n");
00457   _start = (LATdatagram*)buffer;
00458   _end   = (LATdatagram*)(&buffer[length]);
00459   //printf ("LATdataBufferIterator::iterate2: 3, start = %p, end = %p\n",
00460   //        _start, _end);
00461
00462   // Iterate over a list of datagrams from start to end
00463   int s = _ldi->iterate(_start, _end);
00464   //printf ("LATdataBufferIterator::iterate2: 4\n");
00465   return s;
00466 }
00467
00473 inline int LATdataBufferIterator::iterate()
00474 {
00475   //printf ("LATdataBufferIterator::iterate3\n");
00476   return _ldi->iterate(_start, _end);
00477 }
00478
00479 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: LATdatagram.h Source File

  • File List
  • File Members

LATdatagram.h

00001
00023 #ifndef LATdatagram_H
00024 #define LATdatagram_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include <new>
00029
00030 #include "libApiExport.h"
00031
00032 #include "DFC_endianness.h"
00033 #include "EBF_swap.h"
00034
00035 #include "LATidentity.h"
00036 #include "LATtypeId.h"
00037
00038
00039 class DLL_EXPORT_API LATcontribution;
00040 class DLL_EXPORT_API EBFevent;
00041
00042 class DLL_EXPORT_API LATdatagram
00043 {
00044 public:
00045   LATdatagram();
00046   LATdatagram(unsigned length);
00047   ~LATdatagram() {}
00048
00049   // If this class changes in any non-backwardly compatable way,
00050   // the secondary ID must change.
00051   enum {ID = LATidentity_(LATprimaryId::Id_Datagram,
00052                           LATsecondaryId::Id_Datagram)};
00053
00054   LATtypeId           identity()    const;
00055   unsigned            length()      const;
00056   LATdatagram*        next()        const;
00057   unsigned            payloadSize() const;
00058   LATcontribution*    payload()     const;
00059   EBFevent*           event()       const;
00060
00061   unsigned char*      alloc(unsigned size);
00062
00063   void* operator      new(size_t);
00064   void* operator      new(size_t, unsigned length);
00065   void* operator      new(size_t, const LATdatagram&);
00066   void* operator      new(size_t, void*, unsigned supplemental, bool swap = !DFC_BIG_ENDIAN);
00067   void  operator      delete(void*, void*, unsigned, bool);
00068   void  operator      delete(void*);
00069   static LATdatagram* create(unsigned char* buffer, unsigned size, bool swap = !DFC_BIG_ENDIAN);
00070
00071   unsigned char*      string(bool swap = !DFC_BIG_ENDIAN);
00072
00073 private:
00074   LATtypeId _identity;
00075   unsigned  _length;                    // Units are bytes
00076 };
00077
00078
00082 inline LATdatagram::LATdatagram() :
00083   _identity(LATdatagram::ID),
00084   _length(sizeof(LATdatagram))
00085 {
00086 }
00087
00092 inline LATdatagram::LATdatagram(unsigned length) :
00093   _identity(LATdatagram::ID),
00094   _length(sizeof(LATdatagram) + length)
00095 {
00096 }
00097
00101 inline LATtypeId LATdatagram::identity() const
00102 {
00103   return _identity;
00104 }
00105
00106
00110 inline unsigned LATdatagram::length() const
00111 {
00112   return _length;
00113 }
00114
00115
00119 inline LATdatagram* LATdatagram::next() const
00120 {
00121   return (LATdatagram*)((char*)this + length());
00122 }
00123
00124
00132 inline unsigned LATdatagram::payloadSize() const
00133 {
00134   return length() - sizeof(*this);
00135 }
00136
00144 inline LATcontribution* LATdatagram::payload() const
00145 {
00146   return (LATcontribution*)(&this[1]);
00147 }
00148
00156 inline EBFevent* LATdatagram::event() const
00157 {
00158   return (EBFevent*)payload();
00159 }
00160
00161
00171 inline unsigned char* LATdatagram::alloc(unsigned size)
00172 {
00173   LATdatagram* buffer = next();
00174
00175   // Round request up to an integer number of longwords to keep 4 byte alignment
00176   _length += (size + (sizeof(int) - 1)) & ~(sizeof(int) - 1);
00177
00178   return (unsigned char*)buffer;
00179 }
00180
00181
00190 inline void* LATdatagram::operator new(size_t size)
00191 {
00192   return ::new LATdatagram();
00193 }
00194
00195
00205 inline void* LATdatagram::operator new(size_t   size,
00206                                        unsigned length)
00207 {
00208   return ::new LATdatagram(length);
00209 }
00210
00211
00221 inline void* LATdatagram::operator new(size_t             size,
00222                                        const LATdatagram& datagram)
00223 {
00224   return ::new LATdatagram(datagram);
00225 }
00226
00227
00245 inline void* LATdatagram::operator new(size_t   size,
00246                                        void*    location,
00247                                        unsigned supplemental,
00248                                        bool     swap)
00249 {
00250   if (swap)
00251   {
00252     EBF_swap32_lclXbigN((unsigned*)location, ((int)size + supplemental) / sizeof (unsigned));
00253   }
00254   return location;
00255 }
00256
00257
00264 inline void LATdatagram::operator delete(void*, void*, unsigned, bool)
00265 {
00266 }
00267
00268
00275 inline void LATdatagram::operator delete(void* location)
00276 {
00277   ::delete((LATdatagram*)location);
00278 }
00279
00280
00295 inline LATdatagram* LATdatagram::create(unsigned char* buffer,
00296                                         unsigned       size,
00297                                         bool           swap)
00298 {
00299   return new(buffer, size, swap) LATdatagram(size);
00300 }
00301
00316 inline unsigned char* LATdatagram::string(bool swap)
00317 {
00318   if (swap)
00319   {
00320     EBF_swap32_lclXbigN((unsigned*)this, _length / sizeof (unsigned));
00321   }
00322   return (unsigned char*)this;
00323 }
00324
00325 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: LATdatagramIterator.h Source File

  • File List
  • File Members

LATdatagramIterator.h

00001
00023 #ifndef LATdatagramIterator_H
00024 #define LATdatagramIterator_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030 #include "LATdatagram.h"
00031
00032
00033 class DLL_EXPORT_API LATdatagramIterator
00034 {
00035 public:
00036   LATdatagramIterator(LATdatagram* start, LATdatagram* end);
00037   LATdatagramIterator();
00038   virtual ~LATdatagramIterator() {}
00039
00040   enum
00041   {
00042     ERR_IDmismatch = 1,
00043   };
00044
00045   unsigned     iterate();
00046   unsigned     iterate(LATdatagram* start, LATdatagram* end);
00047
00048   LATdatagram* start()  const;
00049   LATdatagram* end()    const;
00050   int          status() const;
00051
00052   virtual int  handleError(LATdatagram* datagram, unsigned code, unsigned p1=0, unsigned p2=0) const;
00053
00055   virtual int  process(LATdatagram*) = 0;
00056
00057 private:
00058   LATdatagram* _start;
00059   LATdatagram* _end;
00060   int          _status;
00061 };
00062
00063
00073 inline LATdatagramIterator::LATdatagramIterator(LATdatagram* start,
00074                                                 LATdatagram* end) :
00075   _start(start),
00076   _end(end),
00077   _status(0)
00078 {
00079 }
00080
00084 inline LATdatagramIterator::LATdatagramIterator() :
00085   _start(0),
00086   _end(0),
00087   _status(0)
00088 {
00089 }
00090
00092 inline LATdatagram* LATdatagramIterator::start() const
00093 {
00094   return _start;
00095 }
00096
00098 inline LATdatagram* LATdatagramIterator::end() const
00099 {
00100   return _end;
00101 }
00102
00104 inline int LATdatagramIterator::status() const
00105 {
00106   return _status;
00107 }
00108
00116 inline unsigned LATdatagramIterator::iterate()
00117 {
00118   return iterate(_start, _end);
00119 }
00120
00121 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: LATidentity.h Source File

  • File List
  • File Members

LATidentity.h

00001 /*
00002 *
00003 *  \brief Classes for storing type-identities
00004 *
00005 *   Classes containing the identity values for labeling the various classes
00006 *   involved in decoding event data from the LAT.
00007 *
00008 *   Ideas here are loosely copied from what was done in BaBar.  A number of
00009 *   the comments were copied verbatim.
00010 *
00011 *  \author
00012 *     R. Claus -- GLAST LAT I&T/Online - (claus@slac.stanford.edu)
00013 *
00014 *  $Revision: 1.16 $
00015 *  \date   March 3, 2003 -- Created
00016 *
00017 *     $Id: LATidentity.h,v 1.16 2006/07/22 00:03:50 claus Exp $
00018 *
00019 *  Copyright:
00020 *                                Copyright 2004
00021 *                                      by
00022 *                         The Board of Trustees of the
00023 *                       Leland Stanford Junior University.
00024 *                              All rights reserved.
00025 *
00026 */
00027
00028 #ifndef LATidentity_H
00029 #define LATidentity_H
00030
00031 #include "copyright_SLAC.h"
00032
00033 #include "libApiExport.h"
00034 #include "ev_latID.h"
00035
00047 class DLL_EXPORT_API LATprimaryId
00048 {
00049 public:
00050   // Default match-anything value.
00051   enum { Any = 0 };
00053   // First define bases and ranges for IDs allocated by sections
00054   enum { Base_FSW     = Pri_Base_FSW    ,
00055          Base_OEF     = Pri_Base_OEF    ,
00056          Base_ACD     = Pri_Base_ACD    ,
00057          Base_CAL     = Pri_Base_CAL    ,
00058          Base_TKR     = Pri_Base_TKR    ,
00059          Base_OSW     = Pri_Base_OSW    ,
00060          Base_Scratch = Pri_Base_Scratch };
00061
00062   enum { RangeSize    = 0x00FFF };
00063
00064   // This has to be maintained very carefully so that archival data can
00065   // always be interpreted correctly.
00066
00067   // ID definitions in FSW space:
00068   enum { Id_EBF      = Pri_Id_EBF        };
00069   enum { Id_EBF_MC   = Pri_Id_EBF_MC     };
00071   // ID definitions in Online Event Format (OEF) space:
00072   enum { Id_Datagram = Pri_Id_Datagram   };
00073   enum { Id_UnrecBuf = Pri_Id_UnrecBuf   };
00074   enum { Id_BtAncEvt = Pri_Id_BtAncEvt   };
00075   enum { Id_BtAncHdr = Pri_Id_BtAncHdr   };
00076   enum { Id_BtAncTlr = Pri_Id_BtAncTlr   };
00078   // ID definitions in ACD space:
00079   enum { Id_ASC      = Pri_Id_ASC        };
00081   // ID definitions in Calorimeter (CAL) space:
00082   enum { Id_CEDhdr   = Pri_Id_CEDhdr     };
00084   // ID definitions in Online Event Server (OSW) space:
00085   enum { Id_Time     = Pri_Id_Time       };
00086   enum { Id_Consumer = Pri_Id_Consumer   };
00087 };
00088
00089
00096 class DLL_EXPORT_API LATsecondaryId
00097 {
00098 public:
00099   // Default match-anything value.
00100   enum { Any = 0 };
00102   // First define bases and ranges for IDs allocated by sections
00103   enum { Base_FSW     = Sec_Base_FSW    ,
00104          Base_OEF     = Sec_Base_OEF    ,
00105          Base_ACD     = Sec_Base_ACD    ,
00106          Base_CAL     = Sec_Base_CAL    ,
00107          Base_TKR     = Sec_Base_TKR    ,
00108          Base_OSW     = Sec_Base_OSW    ,
00109          Base_Scratch = Sec_Base_Scratch };
00110
00111   enum { RangeSize    = 0x0FF };
00112
00113   // This has to be maintained very carefully so that archival data can
00114   // always be interpreted correctly.  If the meaning of "FSW_Foo", for
00115   // instance, were to change, the new meaning would have to be given a
00116   // new secondary Id number.
00117
00118   // ID definitions in FSW space:
00119   enum { Id_EBF_1    = Sec_Id_EBF_1    }; // GLT, no GEM
00120   enum { Id_EBF_2    = Sec_Id_EBF_2    }; // GEM, AEM @ 17, 18
00121   enum { Id_EBF_3    = Sec_Id_EBF_3    }; // 1st GASU ACD map
00122   enum { Id_EBF      = Sec_Id_EBF      }; // Current version
00123
00124   enum { Id_EBF_MC   = Sec_Id_EBF_MC   };
00125
00126   // ID definitions in Online Event Format (OEF) space:
00127   enum { Id_Datagram = Sec_Id_Datagram };
00128   enum { Id_UnrecBuf = Sec_Id_UnrecBuf };
00129   enum { Id_BtAncEvt = Sec_Id_BtAncEvt };
00130   enum { Id_BtAncEvt_1 = Sec_Id_BtAncEvt_1 };
00131   enum { Id_BtAncHdr = Sec_Id_BtAncHdr };
00132   enum { Id_BtAncTlr = Sec_Id_BtAncTlr };
00134   // ID definitions in ACD space:
00135   enum { Id_ASC      = Sec_Id_ASC      };
00137   // ID definitions in Calorimeter (CAL) space:
00138   enum { Id_CEDhdr   = Sec_Id_CEDhdr   };
00140   // ID definitions in Online Event Server (OSW) space:
00141   enum { Id_Time     = Sec_Id_Time     };
00142   enum { Id_Time_1   = Sec_Id_Time_1   };
00143   enum { Id_Consumer = Sec_Id_Consumer };
00144 };
00145
00146 // 2/9/04 - RiC: Kludge this for now to avoid bringing in LATtypeId and friends
00147 #define LATidentity_(prim, secy) (prim | (secy << 20))
00148
00149 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: LATp.h Source File

  • File List
  • File Members

LATp.h

00001
00023 #ifndef LATp_H
00024 #define LATp_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030
00031 class DLL_EXPORT_API LATPcellHeader
00032 {
00033 public:
00034   LATPcellHeader(unsigned header);
00035   LATPcellHeader()  {}
00036   ~LATPcellHeader() {}
00037
00038   static
00039   unsigned parity(unsigned header);
00040   unsigned parity();
00041
00042   static
00043   unsigned source(unsigned header);
00044   unsigned source();
00045
00046   static
00047   unsigned protocol(unsigned header);
00048   unsigned protocol();
00049
00050   static
00051   unsigned destination(unsigned header);
00052   unsigned destination();
00053
00054   static
00055   unsigned respond(unsigned header);
00056   unsigned respond();
00057
00058   static
00059   unsigned more(unsigned header);
00060   unsigned more();
00061
00062 private:
00063   unsigned _header;
00064 };
00065
00066
00070 inline LATPcellHeader::LATPcellHeader(unsigned header) :
00071   _header(header)
00072 {
00073 }
00074
00080 inline unsigned LATPcellHeader::parity(unsigned header)
00081 {
00082   return ( header      ) & 0x01;
00083 }
00084
00089 inline unsigned LATPcellHeader::parity()
00090 {
00091   return (_header      ) & 0x01;
00092 }
00093
00099 inline unsigned LATPcellHeader::source(unsigned header)
00100 {
00101   return ( header >>  1) & 0x3f;
00102 }
00103
00108 inline unsigned LATPcellHeader::source()
00109 {
00110   return (_header >>  1) & 0x3f;
00111 }
00112
00118 inline unsigned LATPcellHeader::protocol(unsigned header)
00119 {
00120   return ( header >>  7) & 0x03;
00121 }
00122
00127 inline unsigned LATPcellHeader::protocol()
00128 {
00129   return (_header >>  7) & 0x03;
00130 }
00131
00137 inline unsigned LATPcellHeader::destination(unsigned header)
00138 {
00139   return ( header >>  9) & 0x3f;
00140 }
00141
00146 inline unsigned LATPcellHeader::destination()
00147 {
00148   return (_header >>  9) & 0x3f;
00149 }
00150
00159 inline unsigned LATPcellHeader::respond(unsigned header)
00160 {
00161   return ( header >> 15) & 0x01;
00162 }
00163
00171 inline unsigned LATPcellHeader::respond()
00172 {
00173   return (_header >> 15) & 0x01;
00174 }
00175
00184 inline unsigned LATPcellHeader::more(unsigned header)
00185 {
00186   return respond(header);
00187 }
00188
00196 inline unsigned LATPcellHeader::more()
00197 {
00198   return respond();
00199 }
00200
00201 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: LATtypeId.h Source File

  • File List
  • File Members

LATtypeId.h

00001
00038 #ifndef LATtypeId_H
00039 #define LATtypeId_H
00040
00041 #include "copyright_SLAC.h"
00042
00043 #include "libApiExport.h"
00044
00045 // The following from BaBar's OdfContainer/odfTypeId.h by G. Dubois-Felsmann:
00046 //--------------------------------------------------------------------------
00047 // File and Version Information:
00048 //      Id: odfTypeId.hh,v 1.7 1999/12/09 08:02:26 gpdf Exp
00049 //
00050 // Description:
00051 //      odfTypeId
00052 //      Concrete base class that contains all the knowledge necessary to
00053 //      decode type ID codes for DataFlow's transmissible objects.
00054 //      This is a fully private class not intended for use outside the
00055 //      odfTypeIdPrimary and odfTypeIdQualified classes, its subclasses.
00056 //
00057 // Environment:
00058 //      Software developed for the BaBar Detector at the SLAC B-Factory.
00059 //
00060 // Author List:
00061 //      Gregory Dubois-Felsmann    gpdf    Originator
00062 //
00063 // Copyright Information:
00064 //      Copyright (C) 1997         California Institute of Technology
00065 //
00066 // Modification History:
00067 //      98.02.09  gpdf   Parent bit removed as per TC3 workshop decision.
00068 //
00069 //------------------------------------------------------------------------
00070
00071 typedef unsigned LATtypeIdPrimary_t;
00072 typedef unsigned LATtypeIdSecondary_t;
00073 typedef unsigned LATtypeIdValue_t;
00074
00075 class DLL_EXPORT_API LATtypeId
00076 {
00077 public:  //protected:
00078   // The full primary-type field.  Each value has a one-to-one correspondence
00079   // to a C++ type.  This field's values are arbitrary.
00080   enum { LATtypeIdPrimOff   = 0,
00081          LATtypeIdPrimMax   = 0x000FFFFF,
00082          LATtypeIdPrimMsk   = LATtypeIdPrimMax };
00083
00084   // The secondary type field (maps not onto C++ type, but onto a "usage"
00085   // of a class)
00086   enum { LATtypeIdSecyOff   = 20,
00087          LATtypeIdSecyMax   = 0x00000FFF,
00088          LATtypeIdSecyMsk   = LATtypeIdSecyMax << LATtypeIdSecyOff };
00089 public:
00090   enum { LATtypeIdSecyAny   = 0 };   // wild-card value
00091
00092   // A name for a null or wildcard ID (equivalent)
00093   enum { LATtypeIdAny  = 0 };
00094   enum { LATtypeIdNull = 0 };
00095
00096 public:  //protected:
00097
00098   // RiC added:    ... Cheat for now
00100   LATtypeIdValue_t value() const
00101     { return _val; }
00102
00103   // Selectors (const)
00105   LATtypeIdPrimary_t getPrimary()   const
00106     { return ( _val & (LATtypeIdValue_t) LATtypeIdPrimMsk ) >> LATtypeIdPrimOff; }
00108   LATtypeIdSecondary_t getSecondary()   const
00109     { return ( _val & (LATtypeIdValue_t) LATtypeIdSecyMsk ) >> LATtypeIdSecyOff; }
00110
00111   // Modifiers
00112   // Return success or failure (if value is out-of-range).
00117   int setPrimary( LATtypeIdPrimary_t prim ) {
00118     if ( prim <= (LATtypeIdValue_t) LATtypeIdPrimMax ) {
00119       _val &= ~((LATtypeIdValue_t) LATtypeIdPrimMsk);
00120       _val |= ( ( prim & LATtypeIdPrimMax ) << LATtypeIdPrimOff );
00121       return 1; }
00122     else {
00123       return 0; }
00124   }
00125
00130   int setSecondary( LATtypeIdSecondary_t secy ) {
00131     if ( secy <= LATtypeIdSecyMax ) {
00132       _val &= ~((LATtypeIdValue_t) LATtypeIdSecyMsk);
00133       _val |= ( ( secy & LATtypeIdSecyMax ) << LATtypeIdSecyOff );
00134       return 1; }
00135     else {
00136       return 0; }
00137   }
00138
00139   // Constructors
00141   LATtypeId( const LATtypeId& v2 ) : _val(v2._val) { }
00142
00144   LATtypeId( LATtypeIdPrimary_t prim, LATtypeIdSecondary_t secy ) :
00145     _val(((prim & LATtypeIdPrimMax) << LATtypeIdPrimOff) |
00146          ((secy & LATtypeIdSecyMax) << LATtypeIdSecyOff))  { }
00147
00149   LATtypeId( LATtypeIdValue_t value ) : _val(value) { }
00150
00152   LATtypeId( ) : _val( LATtypeIdNull ) { }
00153
00160   ~LATtypeId( ) { }
00161
00163   LATtypeId& operator=( const LATtypeId& id )
00164     { if ( this != &id ) { _val = id._val; };  return *this; }
00165
00167   int operator==( const LATtypeId& id ) const
00168     { return _val == id._val; }
00170   int operator!=( const LATtypeId& id ) const
00171     { return _val != id._val; }
00172
00173 private:
00174   LATtypeIdValue_t _val;
00175 };
00176
00177 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: LDFversion.h Source File

  • File List
  • File Members

LDFversion.h

00001
00023 #ifndef LDFversion_H
00024 #define LDFversion_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030 #define LDF_MAJOR        6
00031 #define LDF_MINOR        2
00032 #define LDF_REVISION     0
00033 #define LDF__version__  "6.2.0"   // Must match the above!  Can it be automated?
00034                                   // Must also match /LDF/configure.in...
00035
00036 #define LDF__facility__ "Online";
00037 #define LDF__abstract__ "GLAST LAT Data Format (LDF) parser";
00038 #define LDF__author__   "R. Claus <Claus@SLAC.Stanford.edu> SLAC - GLAST LAT I&T/Online";
00039 #define LDF__date__     "$Date: 2006/07/31 22:26:26 $";
00040 #define LDF__credits__  "SLAC";
00041 #ifdef major
00042 #undef major
00043 #undef minor
00044 #endif
00045
00046
00047 class DLL_EXPORT_API LDFversion
00048 {
00049 public:
00050   LDFversion()  {}
00051   ~LDFversion() {}
00052
00054   static unsigned major()    { return LDF_MAJOR;    }
00056   static unsigned minor()    { return LDF_MINOR;    }
00058   static unsigned revision() { return LDF_REVISION; }
00059 };
00060
00061
00062 /*
00063 **
00064 ** History:
00065 **   $Log: LDFversion.h,v $
00066 **   Revision 1.48  2006/07/31 22:26:26  claus
00067 **   Bumped minor version number.
00068 **
00069 **   Revision 1.47  2006/06/16 17:34:07  claus
00070 **   Changed version to 6.1.0.
00071 **
00072 **   Revision 1.46  2006/04/28 03:13:12  claus
00073 **   Bumped release number.
00074 **
00075 **   Revision 1.45  2006/04/28 01:45:11  claus
00076 **   Updated version.
00077 **
00078 **   Revision 1.44  2006/02/10 17:41:45  pfkeb
00079 **   Update version number
00080 **
00081 **   Revision 1.43  2006/01/10 23:43:09  claus
00082 **   Bumped revision number to reflect cleanup.
00083 **
00084 **   Revision 1.42  2005/12/07 03:32:30  claus
00085 **   Updates for DFI data.
00086 **
00087 **   Revision 1.41  2005/09/28 22:04:14  echarles
00088 **
00089 **   Added ACD scalar contribution (ASC) decoding in LDFdumper.py
00090 **   Updated configure.in
00091 **
00092 **   Updated LDFrelease.txt with changes for version 5.7.0.  All these changes
00093 **   have to do with adding ACD scalar contribution (ASC) decoding.
00094 **
00095 **   Added include/ASC*.h files for decoding ASC.
00096 **
00097 **   Updated ACDmap to include map from GEM index (0-128) to tile name
00098 **
00099 **   Updated LATcontributionIterator to call ASC decoding
00100 **
00101 **   Updated LDFversion.h
00102 **
00103 **   Revision 1.40  2005/04/15 20:24:00  claus
00104 **   Bumped revision number.
00105 **
00106 **   Revision 1.39  2005/04/02 00:10:50  claus
00107 **   no message
00108 **
00109 **   Revision 1.38  2005/03/31 00:34:39  claus
00110 **   Bumped minor version number.
00111 **
00112 **   Revision 1.37  2005/03/16 03:00:53  panetta
00113 **     - Added contribution/event to all handleError calls and prototypes
00114 **       This allows the user to do something with the problem...
00115 **     - Added implementation of handleError calls to LDFdump.py, LDFdumper.py
00116 **       and LDFdump.cpp
00117 **     - Added check for isatty to LDFdump.py to allow streaming to a file
00118 **     - Added test/data/reallyBad.ldf to test for really bad LDF problems.
00119 **     - Bumped the revision number in LDFversion.h and configure.in.
00120 **
00121 **   Revision 1.36  2005/02/24 00:06:50  panetta
00122 **     - Fixed bug in calculation of GEMonePPStime::timebase.
00123 **       Off-by-one error in bit shift.
00124 **     - Added call for GEMcontribution::missed() to return 8 LSB of missed
00125 **       events register (Feature in new GEM, not documented in LAT-TD-01545
00126 **       as of 05/02/23.)
00127 **     - Added missed() call to GEMcontribution.sip
00128 **     - Added example missed() usage to LDFdump.cpp and LDFdumper.py
00129 **     - Bumped the revision number in LDFversion.h and configure.in.
00130 **
00131 **   Revision 1.35  2005/02/15 01:54:07  panetta
00132 **   Add release notes and bump version numbers to 5.4.1
00133 **
00134 **   Revision 1.34  2005/02/01 21:40:39  claus
00135 **   no message
00136 **
00137 **   Revision 1.33  2005/02/01 02:08:31  claus
00138 **   Rolled back to 5.3.1 since it wasn't tagged or released yet.
00139 **
00140 **   Revision 1.32  2005/01/19 04:07:56  panetta
00141 **   Bump version number to 5.3.2
00142 **
00143 **   Revision 1.31  2004/12/21 20:02:05  claus
00144 **   Bumped revision number.
00145 **
00146 **   Revision 1.30  2004/11/18 18:22:18  panetta
00147 **   Bump minor release number
00148 **   Add section to release notes
00149 **
00150 **   Revision 1.29  2004/10/14 04:41:25  claus
00151 **   Bumped minor version number.
00152 **
00153 **   Revision 1.28  2004/09/01 02:17:59  claus
00154 **   no message
00155 **
00156 **   Revision 1.27  2004/08/03 03:24:26  claus
00157 **   Bumped revision number.
00158 **
00159 **   Revision 1.26  2004/07/08 22:01:29  claus
00160 **   Bumped to 5.1.0.
00161 **
00162 **   Revision 1.25  2004/06/02 02:36:40  claus
00163 **   Bumped package revision number.
00164 **
00165 **   Revision 1.24  2004/05/04 23:12:55  claus
00166 **   Bumped revision number for new ACDmap table
00167 **
00168 **   Revision 1.23  2004/04/23 23:15:27  claus
00169 **   Bumped revision number.
00170 **
00171 **   Revision 1.22  2004/04/21 15:56:57  claus
00172 **   Bumped major version number.
00173 **
00174 **   Revision 1.21  2004/04/20 00:06:57  claus
00175 **   Bump revision number.
00176 **
00177 **   Revision 1.20  2004/04/13 20:04:34  claus
00178 **   Bumped the minor version number for the new source ID table.
00179 **
00180 **   Revision 1.19  2004/04/08 03:16:14  claus
00181 **   Bumped revision number.
00182 **
00183 **   Revision 1.18  2004/04/02 02:59:31  claus
00184 **   Documentation.
00185 **   Bumped version number to 4.0.0.
00186 **   Added additional macros for Python access.
00187 **
00188 **   Revision 1.17  2004/03/17 22:22:00  panetta
00189 **   Tag for release v03-03-00
00190 **
00191 **   Revision 1.16  2003/12/15 22:08:02  panetta
00192 **   Increase Version to 3.2.0, announce Linux support
00193 **
00194 **   Revision 1.15  2003/12/11 02:05:17  panetta
00195 **   Weird problem with gcc:  major and minor are #defined symbols.
00196 **   This seems to cause problems with member functions named major
00197 **   and minor.  #undef them if defined
00198 **
00199 **   Revision 1.14  2003/12/02 00:58:39  panetta
00200 **   Add DIAGcontributionIterator with associated callbacks
00201 **   Add ERRcontributionIterator with associated callbacks
00202 **   Add TKRdiagnostic class
00203 **   Provide example code for all changes
00204 **
00205 **   Revision 1.13  2003/10/24 00:43:06  panetta
00206 **   Changed compiler flag _WIN32_STATIC to _WIN32_LDF_STATIC at
00207 **   request of offline.
00208 **
00209 **   Revision 1.12  2003/10/14 22:35:50  panetta
00210 **   LDF 3.1.5:  Fix for Win32 static libraries, fix for pointer offset problem,
00211 **   fix of setup files.
00212 **
00213 **   Revision 1.11  2003/09/02 21:31:51  panetta
00214 **   Fixed bug in dump() method of LDFdump.cpp:MyTKRiterator.
00215 **   Offset to end of TKR data was calculated incorrectly
00216 **
00217 **   Revision 1.10  2003/08/26 21:55:02  claus
00218 **   Bumped revision number by one for tkrContributionIterator::strip argument
00219 **   definition change and various fixes to avoid compiler warnings on some
00220 **   platforms.
00221 **
00222 **   Revision 1.9  2003/08/20 17:23:49  panetta
00223 **   Fix bug in LDFdump.cpp, used i where j should have been.
00224 **   Replace getch with getchar
00225 **
00226 **   Tag V03-01-02
00227 **
00228 **   Revision 1.8  2003/08/19 20:55:39  panetta
00229 **   Fix one error in TEMcontributionIterator.h.
00230 **
00231 **   Change style of C-like includes in .cpp and .h files.
00232 **   Using extern "C"{...} now.
00233 **
00234 **   Revision 1.7  2003/08/19 20:22:49  panetta
00235 **   Increase version number, tag for release.
00236 **
00237 **   Revision 1.6  2003/07/11 03:53:16  claus
00238 **   Bumped major version number for API changes
00239 **
00240 **   Revision 1.5  2003/05/09 03:13:40  claus
00241 **   Bumped revision number for TOT addressing bug fix
00242 **
00243 **   Revision 1.4  2003/05/08 19:17:28  claus
00244 **   Bump LDF package major version number since TKR iterator
00245 **   virual function signatures changed.
00246 **
00247 **   Revision 1.3  2003/03/13 04:09:47  claus
00248 **   This is the version number of the package, not the format, so put it back.
00249 **   Bumped Major version number for the new format.
00250 **
00251 **
00252 **
00253 */
00254
00255 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: libApiExport.h Source File

  • File List
  • File Members

libApiExport.h

00001 #ifndef _libAPIexports_H_
00002 #define _libAPIexports_H_
00003
00004 // Matthew D. Langston <langston@SLAC.Stanford.EDU>
00005 //
00006 // Every header file in our library that wants to export symbols
00007 // (e.g. class definitions) from a DLL on Windows must include this
00008 // header. It works on all platforms, both Windows and Linux/Unix.
00009 //
00010 // The following ifdef block is the standard way of exporting symbols
00011 // (e.g. class definitions) from a DLL on Windows. The macro
00012 // API_DLL_EXPORTS is defined when source code is compiled to
00013 // create the DLL, which causes DLL_EXPORT_API to expand to
00014 // __declspec(dllexport) so that symbols decorated with
00015 // DLL_EXPORT_API are exported from the DLL.
00016 //
00017 // Clients of our DLL don't have to do anything special to use it, since
00018 // they won't define API_DLL_EXPORTS, which means
00019 // DLL_EXPORT_API will expand to __declspec(dllimport) so that
00020 // symbols decorated with DLL_EXPORT_API are imported from the DLL.
00021 //
00022 // Clients on WIN32 systems that wish a static library need to
00023 // #define _WIN32_LDF_STATIC in order to not export these symbols
00024
00025 #if (defined(_WIN32) && defined(_MSC_VER)) && !defined(_WIN32_LDF_STATIC )
00026 # ifdef API_DLL_EXPORTS
00027 #  undef  DLL_EXPORT_API
00028 #  define DLL_EXPORT_API __declspec(dllexport)
00029 # else
00030 #  undef  DLL_EXPORT_API
00031 #  define DLL_EXPORT_API __declspec(dllimport)
00032 # endif
00033 #else
00034 // The gcc compiler (i.e. the Linux/Unix compiler) exports the Universe
00035 // of symbols from a shared library, meaning that we can't control the
00036 // API of our shared libraries. We therefore just define the Symbol
00037 // Export Macro to expand to nothing.
00038 # undef  DLL_EXPORT_API
00039 # define DLL_EXPORT_API
00040 #endif
00041
00042 #endif // _libAPIexports_H_
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: OSWcontribution.h Source File

  • File List
  • File Members

OSWcontribution.h

00001
00035 #ifndef OSWcontribution_H
00036 #define OSWcontribution_H
00037
00038 #include "copyright_SLAC.h"
00039
00040 #include "libApiExport.h"
00041
00042 #include "LATtypeId.h"
00043 #include "EBFcontribution.h"
00044
00045
00046 class DLL_EXPORT_API OSWtimeContribution;
00047
00048
00049 class DLL_EXPORT_API OSWcontribution : public EBFcontribution
00050 {
00051 public:
00053   OSWcontribution()  {}
00055   ~OSWcontribution() {}
00056
00057   LATtypeId identity() const;
00058   char*     data()     const;
00059
00060   OSWtimeContribution* timeContribution() const;
00061
00062 private:
00063   LATtypeId _identity;
00064 };
00065
00066
00071 inline LATtypeId OSWcontribution::identity() const
00072 {
00073   return _identity;
00074 }
00075
00076
00081 inline char* OSWcontribution::data() const
00082 {
00083   return (char*)&this[1];
00084 }
00085
00090 inline OSWtimeContribution* OSWcontribution::timeContribution() const
00091 {
00092   return (OSWtimeContribution*)this;
00093 }
00094
00095 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: OSWcontributionIterator.h Source File

  • File List
  • File Members

OSWcontributionIterator.h

00001
00024 #ifndef OSWcontributionIterator_H
00025 #define OSWcontributionIterator_H
00026
00027 #include "copyright_SLAC.h"
00028
00029 #include "libApiExport.h"
00030
00031 #include "EBFevent.h"
00032 #include "OSWcontribution.h"
00033 #include "OSWtimeContribution.h"
00034 #include "OSWtimeBase.h"
00035 #include "timespec.h"
00036
00037
00038 class DLL_EXPORT_API OSWcontributionIterator
00039 {
00040 public:
00049   OSWcontributionIterator(EBFevent* event, OSWcontribution* contribution);
00050
00054   OSWcontributionIterator();
00055   virtual ~OSWcontributionIterator() {}
00056
00057   virtual int handleError(OSWcontribution* contribution, unsigned code, unsigned p1=0, unsigned p2=0) const;
00058
00063   unsigned iterate();
00064
00071   unsigned iterate(EBFevent* event, OSWcontribution* contribution);
00072
00073   // Virtual methods
00080   virtual int OSWtime(const struct timespec* ts, const OSWtimeBase* tb) const;
00091   virtual int OSW_time(EBFevent* event, OSWtimeContribution* contribution) const;
00098   virtual int OSW_UDF(EBFevent* event, OSWcontribution* contribution)   const;
00099
00101   const EBFevent*        event()        const;
00103   const OSWcontribution* contribution() const;
00105   int                    status()       const;
00106
00107 private:
00108   EBFevent*        _event;
00109   OSWcontribution* _contribution;
00110   int              _status;
00111 };
00112
00113
00114 inline
00115 OSWcontributionIterator::OSWcontributionIterator(EBFevent*        event,
00116                                                  OSWcontribution* contribution):
00117   _event(event),
00118   _contribution(contribution),
00119   _status(0)
00120 {
00121 }
00122
00123 inline
00124 OSWcontributionIterator::OSWcontributionIterator():
00125   _event(0),
00126   _contribution(0),
00127   _status(0)
00128 {
00129 }
00130
00131 inline
00132 const EBFevent* OSWcontributionIterator::event() const
00133 {
00134   return _event;
00135 }
00136
00137 inline
00138 const OSWcontribution* OSWcontributionIterator::contribution() const
00139 {
00140   return _contribution;
00141 }
00142
00143 inline
00144 int OSWcontributionIterator::status() const
00145 {
00146   return _status;
00147 }
00148
00149 inline
00150 unsigned OSWcontributionIterator::iterate()
00151 {
00152   return iterate(_event, _contribution);
00153 }
00154
00155 inline
00156 int OSWcontributionIterator::OSWtime(const struct timespec* /*ts*/,
00157                                      const OSWtimeBase*     /*tb*/) const
00158 {
00159   return 0;
00160 }
00161
00162 inline
00163 int OSWcontributionIterator::OSW_time(EBFevent*            /* event */,
00164                                       OSWtimeContribution* contribution) const
00165 {
00166   return OSWtime(contribution->timeStamp(), contribution->timebase());
00167 }
00168
00169 inline
00170 int OSWcontributionIterator::OSW_UDF(EBFevent*        /* event */,
00171                                      OSWcontribution* /* contribution */) const
00172 {
00173   return 0;
00174 }
00175
00188 inline int
00189 OSWcontributionIterator::handleError(OSWcontribution* contribution, unsigned code, unsigned p1, unsigned p2) const
00190 {
00191   return 0;
00192 }
00193
00194 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: OSWtimeBase.h Source File

  • File List
  • File Members

OSWtimeBase.h

00001
00025 #ifndef OSWtimeBase_H
00026 #define OSWtimeBase_H
00027
00028 #include "copyright_SLAC.h"
00029
00030 #include "libApiExport.h"
00031
00032
00033 class DLL_EXPORT_API OSWtimeBase
00034 {
00035 public:
00036   OSWtimeBase();
00037   OSWtimeBase(unsigned* tb);
00038   OSWtimeBase(unsigned upper, unsigned lower);
00039   ~OSWtimeBase() {}
00040
00041   const unsigned* timebase() const;
00042
00043   unsigned upper() const;
00044   unsigned lower() const;
00045
00046 private:
00047   unsigned _timebase[2];
00048 };
00049
00050
00054 inline OSWtimeBase::OSWtimeBase()
00055 {
00056 }
00057
00061 inline OSWtimeBase::OSWtimeBase(unsigned* tb)
00062 {
00063 #if DFC_BIG_ENDIAN
00064   _timebase[0] = tb[1];
00065   _timebase[1] = tb[0];
00066 #else
00067   _timebase[0] = tb[0];
00068   _timebase[1] = tb[1];
00069 #endif
00070 }
00071
00077 inline OSWtimeBase::OSWtimeBase(unsigned upper, unsigned lower)
00078 {
00079 #if DFC_BIG_ENDIAN
00080   _timebase[0] = lower;
00081   _timebase[1] = upper;
00082 #else
00083   _timebase[0] = upper;
00084   _timebase[1] = lower;
00085 #endif
00086 }
00087
00092 inline const unsigned* OSWtimeBase::timebase() const
00093 {
00094   return _timebase;
00095 }
00096
00101 inline unsigned OSWtimeBase::upper() const
00102 {
00103 #if DFC_BIG_ENDIAN
00104   return _timebase[1];
00105 #else
00106   return _timebase[0];
00107 #endif
00108 }
00109
00114 inline unsigned OSWtimeBase::lower() const
00115 {
00116 #if DFC_BIG_ENDIAN
00117   return _timebase[0];
00118 #else
00119   return _timebase[1];
00120 #endif
00121 }
00122
00123 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: OSWtimeContribution.h Source File

  • File List
  • File Members

OSWtimeContribution.h

00001
00033 #ifndef OSWtimeContribution_H
00034 #define OSWtimeContribution_H
00035
00036 #include "copyright_SLAC.h"
00037
00038 #include "libApiExport.h"
00039
00040 #include "timespec.h"
00041 #include "OSWtimeBase.h"
00042 #include "OSWcontribution.h"
00043 #include "LATidentity.h"
00044 #include "eventSummary.h"
00045 #include <string.h>
00046
00047
00048 class DLL_EXPORT_API OSWtimeContribution : public OSWcontribution
00049 {
00050 public:
00052   OSWtimeContribution()  {}
00053   OSWtimeContribution(const OSWcontribution& contribution);
00055   ~OSWtimeContribution() {}
00056
00057   enum {ID = LATidentity_(LATprimaryId::Id_Time, LATsecondaryId::Id_Time)};
00058
00059   const struct timespec* timeStamp()   const;
00060   const OSWtimeBase*     timebase()    const;
00061   const unsigned         evtSeqMSW()   const;
00062   const unsigned         evtSequence() const;
00063
00064 private:
00065   struct timespec _timeStamp;
00066   OSWtimeBase     _timebase;
00067   unsigned        _evtSeqMSW;
00068 };
00069
00070
00078 inline OSWtimeContribution::OSWtimeContribution(const OSWcontribution& contribution)
00079 {
00080   memcpy((char*)this, (const char*)&contribution, sizeof(*this));
00081 }
00082
00092 inline const struct timespec* OSWtimeContribution::timeStamp() const
00093 {
00094   return &_timeStamp;
00095 }
00096
00107 inline const OSWtimeBase* OSWtimeContribution::timebase() const
00108 {
00109   return &_timebase;
00110 }
00111
00120 inline const unsigned OSWtimeContribution::evtSeqMSW() const
00121 {
00122   return (identity().getSecondary() >= LATsecondaryId::Id_Time_1) ? _evtSeqMSW
00123                                                                   : 0;
00124 }
00125
00137 inline const unsigned OSWtimeContribution::evtSequence() const
00138 {
00139   EventSummary es(summary());
00140   return (evtSeqMSW() << 17) | (es.eventNumber() << 2) | es.tag();
00141 }
00142
00143 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: OSWtimeSpec.h Source File

  • File List
  • File Members

OSWtimeSpec.h

00001
00023 #ifndef OSWtimeSpec_H
00024 #define OSWtimeSpec_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030 #include "timespec.h"
00031
00032
00033 class DLL_EXPORT_API OSWtimeSpec
00034 {
00035 public:
00036   OSWtimeSpec();
00037   OSWtimeSpec(struct timespec* ts);
00038   OSWtimeSpec(time_t sec, long nSec);
00039   ~OSWtimeSpec()   {}
00040
00041   const struct timespec* timespec() const;
00042
00043   time_t sec()  const;
00044   long   nsec() const;
00045
00046 private:
00047   struct timespec _timeSpec;
00048 };
00049
00050
00054 inline OSWtimeSpec::OSWtimeSpec()
00055 {
00056 }
00057
00061 inline OSWtimeSpec::OSWtimeSpec(struct timespec* ts)
00062 {
00063   _timeSpec.tv_sec  = ts->tv_sec;
00064   _timeSpec.tv_nsec = ts->tv_nsec;
00065 }
00066
00073 inline OSWtimeSpec::OSWtimeSpec(time_t sec, long nsec)
00074 {
00075   _timeSpec.tv_sec  = sec;
00076   _timeSpec.tv_nsec = nsec;
00077 }
00078
00083 inline const struct timespec* OSWtimeSpec::timespec() const
00084 {
00085   return &_timeSpec;
00086 }
00087
00092 inline time_t OSWtimeSpec::sec() const
00093 {
00094   return _timeSpec.tv_sec;
00095 }
00096
00101 inline long OSWtimeSpec::nsec() const
00102 {
00103   return _timeSpec.tv_nsec;
00104 }
00105
00106 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: stdafx.h Source File

  • File List
  • File Members

stdafx.h

00001 // stdafx.h : include file for standard system include files,
00002 // or project specific include files that are used frequently, but
00003 // are changed infrequently
00004 //
00005
00006 #ifdef WIN32
00007 #pragma once
00008
00009 #define WIN32_LEAN_AND_MEAN             // Exclude rarely-used stuff from Windows headers
00010 // Windows Header Files:
00011 extern "C" {
00012 #include <windows.h>
00013 }
00014 #endif
00015 // TODO: reference additional headers your program requires here
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: TEMcontribution.h Source File

  • File List
  • File Members

TEMcontribution.h

00001
00023 #ifndef TEMcontribution_H
00024 #define TEMcontribution_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030 #include "LATtypeId.h"
00031 #include "EBFevent.h"
00032 #include "EBFcontribution.h"
00033
00034 class DLL_EXPORT_API CALcontribution;
00035 class DLL_EXPORT_API TKRcontribution;
00036
00037
00038 class DLL_EXPORT_API TEMcontribution : public EBFcontribution
00039 {
00040 public:
00041   TEMcontribution()    {}
00042   ~TEMcontribution()   {}
00043
00044   unsigned         logAccepts()      const;
00045   unsigned         numLogAccepts()   const;
00046
00047   CALcontribution* calContribution() const;
00048   TKRcontribution* tkrContribution() const;
00049 };
00050
00051
00055 inline unsigned TEMcontribution::logAccepts() const
00056 {
00057   return ((unsigned*)payload())[0];
00058 }
00059
00063 inline unsigned TEMcontribution::numLogAccepts() const
00064 {
00065   unsigned mask = logAccepts();
00066   unsigned sum  = 0;
00067   while (mask)
00068   {
00069     sum   += mask & 0xf;
00070     mask >>= 4;
00071   }
00072   return sum;
00073 }
00074
00078 inline CALcontribution* TEMcontribution::calContribution() const
00079 {
00080   return (CALcontribution*)this;
00081 }
00082
00086 inline TKRcontribution* TEMcontribution::tkrContribution() const
00087 {
00088   return (TKRcontribution*)this;
00089 }
00090
00091 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: TEMcontributionIterator.h Source File

  • File List
  • File Members

TEMcontributionIterator.h

00001
00023 #ifndef TEMcontributionIterator_H
00024 #define TEMcontributionIterator_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030 #include "EBFevent.h"
00031
00032 class DLL_EXPORT_API TEMcontribution;   // Avoid #include "TEMcontribution.h"
00033
00034
00035 class DLL_EXPORT_API TEMcontributionIterator
00036 {
00037 public:
00038   TEMcontributionIterator(EBFevent*, TEMcontribution*);
00039   TEMcontributionIterator();
00040   virtual ~TEMcontributionIterator() {}
00041
00042   unsigned iterate();
00043   unsigned iterate(EBFevent*, TEMcontribution*);
00044
00045   virtual int handleError(TEMcontribution* contribution, unsigned code, unsigned p1=0, unsigned p2=0) const;
00046
00048   virtual int CAL       (EBFevent* event, TEMcontribution* contribution) = 0;
00050   virtual int TKR       (EBFevent* event, TEMcontribution* contribution) = 0;
00052   virtual int diagnostic(EBFevent* event, TEMcontribution* contribution) = 0;
00054   virtual int error     (EBFevent* event, TEMcontribution* contribution) = 0;
00056   virtual int cleanup   (EBFevent* event, TEMcontribution* contribution) = 0;
00057
00058
00059   const EBFevent*        event()         const;
00060   const TEMcontribution* contribution()  const;
00061   unsigned               CALend()        const;
00062   unsigned               TKRend()        const;
00063   unsigned               diagnosticEnd() const;
00064   unsigned               errorEnd()      const;
00065   int                    status()        const;
00066   void CALend         (unsigned offset);
00067   void TKRend         (unsigned offset);
00068   void diagnosticEnd  (unsigned offset);
00069   void errorEnd       (unsigned offset);
00070
00071 private:
00072   EBFevent*        _event;
00073   TEMcontribution* _contribution;
00074   unsigned         _calEnd;                // offset to end of CAL data
00075   unsigned         _tkrEnd;                //    "    "  "  "  TKR  "
00076   unsigned         _diagEnd;               //    "    "  "  "  diagnostic data
00077   unsigned         _errorEnd;              //    "    "  "  "  error data
00078   int              _status;
00079 };
00080
00081
00087 inline TEMcontributionIterator::TEMcontributionIterator(EBFevent*        event,
00088                                                         TEMcontribution* contribution) :
00089   _event(event),
00090   _contribution(contribution),
00091   _calEnd(0),
00092   _tkrEnd(0),
00093   _diagEnd(0),
00094   _errorEnd(0),
00095   _status(0)
00096 {
00097   // minimum spacing from beginning of contribution to CALend is 3 unsigned
00098   CALend( 3*sizeof(unsigned) );
00099   TKRend( CALend() + 3*sizeof(unsigned) );
00100   diagnosticEnd(TKRend());
00101   errorEnd(diagnosticEnd());
00102 }
00103
00105 inline TEMcontributionIterator::TEMcontributionIterator():
00106   _event(0),
00107   _contribution(0),
00108   _calEnd(0),
00109   _tkrEnd(0),
00110   _diagEnd(0),
00111   _errorEnd(0),
00112   _status(0)
00113 {
00114   // minimum spacing from beginning of contribution to CALend is 3 unsigned
00115 }
00116
00117
00122 inline unsigned TEMcontributionIterator::iterate()
00123 {
00124   return iterate(_event, _contribution);
00125 }
00126
00128 inline const EBFevent* TEMcontributionIterator::event() const
00129 {
00130   return _event;
00131 }
00132
00134 inline const TEMcontribution* TEMcontributionIterator::contribution() const
00135 {
00136   return _contribution;
00137 }
00138
00140 inline unsigned TEMcontributionIterator::CALend()        const
00141 {
00142   return _calEnd;
00143 }
00144
00146 inline unsigned TEMcontributionIterator::TKRend()        const
00147 {
00148   return _tkrEnd;
00149 }
00150
00152 inline unsigned TEMcontributionIterator::diagnosticEnd() const
00153 {
00154   return _diagEnd;
00155 }
00156
00158 inline unsigned TEMcontributionIterator::errorEnd()      const
00159 {
00160   return _errorEnd;
00161 }
00162
00164 inline int TEMcontributionIterator::status() const
00165 {
00166   return _status;
00167 }
00168
00173 inline void TEMcontributionIterator::CALend(unsigned offset)
00174 {
00175   _calEnd = offset;
00176   // minimum tracker size is 3 unsigned
00177   TKRend( _calEnd + 3*sizeof(unsigned) );
00178
00179 }
00180
00185 inline void TEMcontributionIterator::TKRend(unsigned offset)
00186 {
00187   _tkrEnd = offset;
00188   // no minimum spacing
00189   diagnosticEnd( _tkrEnd );
00190 }
00191
00196 inline void TEMcontributionIterator::diagnosticEnd(unsigned offset)
00197 {
00198   _diagEnd = offset;
00199   // no minimum spacing
00200   errorEnd( _diagEnd );
00201 }
00202
00207 inline void TEMcontributionIterator::errorEnd(unsigned offset)
00208 {
00209   _errorEnd = offset;
00210 }
00211
00224 inline int
00225 TEMcontributionIterator::handleError(TEMcontribution* contribution, unsigned code, unsigned p1, unsigned p2) const
00226 {
00227   return 0;
00228 }
00229 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: timespec.h Source File

  • File List
  • File Members

timespec.h

00001
00023 #ifndef timespec_h
00024 #define timespec_h
00025
00026 #if defined(WIN32)
00027 typedef long time_t;
00028
00029 typedef struct timespec {               /* definition per POSIX.4 */
00030         time_t          tv_sec;         /* seconds */
00031         long            tv_nsec;        /* and nanoseconds */
00032 } timespec_t;
00033 #else  /* not WIN32 */
00034 extern "C"
00035 {
00036 #  include <stdlib.h>
00037 #  include <time.h>
00038 }
00039 #endif /* WIN32 */
00040
00041 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: TKRcontribution.h Source File

  • File List
  • File Members

TKRcontribution.h

00001
00023 #ifndef TKRcontribution_H
00024 #define TKRcontribution_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030 #include "EBFevent.h"
00031 #include "TEMcontribution.h"
00032 #include "eventSummary.h"
00033
00034
00035 class DLL_EXPORT_API TKRcontribution : public TEMcontribution
00036 {
00037 public:
00038   TKRcontribution()    {}
00039   ~TKRcontribution()   {}
00040
00041   char*     accepts(const EBFevent* event)                      const;
00042   unsigned* acceptsMask(const EBFevent* event, unsigned* array) const;
00043   unsigned  numAccepts(const EBFevent* event)                   const;
00044   char*     data(const EBFevent* event)                         const;
00045 };
00046
00047
00051 inline char* TKRcontribution::accepts(const EBFevent* event) const
00052 {
00053   return &(payload()[(numLogAccepts() *
00054                       (1 + 3 * EventSummary::readout4(summary())) + 1) << 2]);
00055 }
00056
00060 inline unsigned* TKRcontribution::acceptsMask(const EBFevent* event,
00061                                               unsigned*       array) const
00062 {
00063   // Be careful of sign bits that are replicated by >>
00064   unsigned* pa   = (unsigned*)accepts(event);
00065   unsigned* mask = array;
00066   *mask++ =  (pa[0] >> 23)                            & 0x1ff;  // Xleft  CC6
00067   *mask++ =  (pa[0] >> 14)                            & 0x1ff;  // Xright CC3
00068   *mask++ =  (pa[0] >>  5)                            & 0x1ff;  // Xright CC7
00069   *mask++ = ((pa[0] <<  4) | ((pa[1] >> 28) & 0x00f)) & 0x1ff;  // Xleft  CC2
00070   *mask++ =  (pa[1] >> 19)                            & 0x1ff;  // Yright CC5
00071   *mask++ =  (pa[1] >> 10)                            & 0x1ff;  // Yleft  CC0
00072   *mask++ =  (pa[1] >>  1)                            & 0x1ff;  // Yleft  CC4
00073   *mask   = ((pa[1] <<  8) | ((pa[2] >> 24) & 0x0ff)) & 0x1ff;  // Yright CC1
00074   return array;
00075 }
00076
00080 inline unsigned TKRcontribution::numAccepts(const EBFevent* event) const
00081 {
00082   //                          0, 1, 2, 3, 4, 5, 6, 7, 8, 9, a, b, c, d, e, f
00083   const int nibbleBitCnt[] = {0, 1, 1, 2, 1, 2, 2, 3, 1, 2, 2, 3, 2, 3, 3, 4};
00084
00085   // Count the number of bits set in the 8 9-bit Accept words (72 bits)
00086   unsigned *words = (unsigned*)accepts(event);
00087   unsigned  word;
00088   unsigned  sum   = 0;
00089   unsigned  j     = 2;
00090   do
00091   {
00092     word = *words++;
00093     unsigned i    = 8;
00094     do
00095     {
00096       sum   += nibbleBitCnt[word & 0xf];
00097       word >>= 4;
00098     } while (--i);                      // 0 - 7, 8 - 15
00099   } while (--j);
00100   word   = *words >> 24;
00101   sum   += nibbleBitCnt[word & 0xf];    // 16
00102   word >>= 4;
00103   sum   += nibbleBitCnt[word & 0xf];    // 17
00104   return sum;
00105 }
00106
00115 inline char* TKRcontribution::data(const EBFevent* event) const
00116 {
00117   return &accepts(event)[8];
00118 }
00119
00120 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: TKRcontributionIterator.h Source File

  • File List
  • File Members

TKRcontributionIterator.h

00001
00023 #ifndef TKRcontributionIterator_H
00024 #define TKRcontributionIterator_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030 #include "eventSummary.h"
00031 #include "TKRmap.h"
00032
00033
00034 #include "EBFevent.h"
00035 #include "TKRcontribution.h"
00036
00037 class DLL_EXPORT_API TKRcontributionIterator
00038 {
00039 public:
00040   TKRcontributionIterator(EBFevent*, TKRcontribution*, TKRmap*);
00041   TKRcontributionIterator(EBFevent*, TKRcontribution*);
00042   TKRcontributionIterator(TKRmap*);
00043   TKRcontributionIterator();
00044   virtual ~TKRcontributionIterator() {}
00045
00046   enum
00047   {
00048     ERR_WrongOrder = 1,
00049     ERR_PastEnd    = 2,
00050   };
00051
00052   unsigned iterateStrips();
00053   unsigned iterateStrips(EBFevent*, TKRcontribution*);
00054   unsigned iterateStrips(EBFevent*, TKRcontribution*, TKRmap*);
00055   unsigned iterateTOTs();
00056   unsigned iterateTOTs(TKRcontribution*);
00057   unsigned iterateTOTs(TKRcontribution*, TKRmap*);
00058   virtual int handleError(TKRcontribution*, unsigned code, unsigned p1=0, unsigned p2=0) const;
00059
00061   const EBFevent*        event()        const  { return _event;        }
00063   const TKRcontribution* contribution() const  { return _contribution; }
00065   const TKRmap*          map()          const  { return _map;          }
00066   const unsigned         stripCount()   const;
00067   const unsigned         diagnostic()   const;
00068   const unsigned         error()        const;
00069
00070   //  The following methods should be protected, but SIP won't allow it.
00071   //protected:
00079   virtual void strip(unsigned tower, unsigned layerEnd, unsigned hit) = 0;
00087   virtual void TOT  (unsigned tower, unsigned layerEnd, unsigned tot) = 0;
00088
00089 private:
00090   EBFevent*        _event;
00091   TKRcontribution* _contribution;
00092   unsigned*        _accepts;
00093   unsigned         _stripCount;
00094   unsigned         _endTOTs;
00095   unsigned         _acceptMask[8];
00096   TKRmap*          _map;
00097   TKRmap           _TKRmap;             // Default map to use
00098
00099 public:
00101   const void       endTots(unsigned offset) {_endTOTs = offset;}
00102 };
00103
00104
00108 inline TKRcontributionIterator::TKRcontributionIterator() :
00109   _event(0),
00110   _contribution(0),
00111   _accepts(0),
00112   _stripCount(0),
00113   _endTOTs(0),
00114   _map(&_TKRmap)
00115 {
00116 }
00117
00121 inline TKRcontributionIterator::TKRcontributionIterator(TKRmap* map) :
00122   _event(0),
00123   _contribution(0),
00124   _accepts(0),
00125   _stripCount(0),
00126   _endTOTs(0),
00127   _map(map)
00128 {
00129 }
00130
00139 inline TKRcontributionIterator::TKRcontributionIterator(EBFevent*        event,
00140                                                         TKRcontribution* contribution) :
00141   _event(event),
00142   _contribution(contribution),
00143   _accepts(0),
00144   _stripCount(0),
00145   _endTOTs(0),
00146   _map(&_TKRmap)
00147 {
00148 }
00149
00160 inline TKRcontributionIterator::TKRcontributionIterator(EBFevent*        event,
00161                                                         TKRcontribution* contribution,
00162                                                         TKRmap*          map) :
00163   _event(event),
00164   _contribution(contribution),
00165   _accepts(0),
00166   _stripCount(0),
00167   _endTOTs(0),
00168   _map(map)
00169 {
00170 }
00171
00181 inline unsigned
00182 TKRcontributionIterator::iterateStrips()
00183 {
00184   return iterateStrips(_event, _contribution, _map);
00185 }
00186
00200 inline unsigned
00201 TKRcontributionIterator::iterateStrips(EBFevent*        event,
00202                                        TKRcontribution* contribution)
00203 {
00204   return iterateStrips(event, contribution, _map);
00205 }
00206
00217 inline unsigned
00218 TKRcontributionIterator::iterateTOTs()
00219 {
00220   return iterateTOTs(_contribution, _map);
00221 }
00222
00235 inline unsigned
00236 TKRcontributionIterator::iterateTOTs(TKRcontribution* contribution)
00237 {
00238   return iterateTOTs(contribution, _map);
00239 }
00240
00247 inline const unsigned TKRcontributionIterator::stripCount() const
00248 {
00249   return _stripCount;
00250 }
00251
00256 inline const unsigned TKRcontributionIterator::diagnostic() const
00257 {
00258   return _endTOTs;
00259 }
00260
00265 inline const unsigned TKRcontributionIterator::error() const
00266 {
00267   return _endTOTs + 12 * EventSummary::diagnostic(_contribution->summary());
00268 }
00269
00270 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: TKRdiagnostic.h Source File

  • File List
  • File Members

TKRdiagnostic.h

00001
00023 #ifndef TKRdiagnostic_H
00024 #define TKRdiagnostic_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030
00031 class DLL_EXPORT_API TKRdiagnostic
00032 {
00033 public:
00034   TKRdiagnostic(unsigned datum);
00035   TKRdiagnostic()  {}
00036   ~TKRdiagnostic() {}
00037
00038   static
00039   unsigned GTRC(unsigned datum, int gtrc);
00040   unsigned GTRC(int gtrc);
00041   static
00042   unsigned datum(unsigned d);
00043   unsigned datum();
00044
00045 private:
00046   unsigned _datum;
00047 };
00048
00049
00054 inline TKRdiagnostic::TKRdiagnostic(unsigned datum) :
00055   _datum(datum)
00056 {
00057 }
00058
00065 inline unsigned TKRdiagnostic::GTRC(unsigned datum, int gtrc)
00066 {
00067   return ( datum >> gtrc) & 0x1;
00068 }
00069
00075 inline unsigned TKRdiagnostic::GTRC(int gtrc)
00076 {
00077   return (_datum >> gtrc) & 0x1;
00078 }
00079
00085 inline unsigned TKRdiagnostic::datum(unsigned d)
00086 {
00087   return  d;
00088 }
00089
00094 inline unsigned TKRdiagnostic::datum()
00095 {
00096   return _datum;
00097 }
00098
00099 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: TKRmap.h Source File

  • File List
  • File Members

TKRmap.h

00001
00024 #ifndef TKRmap_H
00025 #define TKRmap_H
00026
00027 #include "copyright_SLAC.h"
00028
00029 #include "libApiExport.h"
00030
00031 #include "TWRmap.h"
00032 #include "LATtypeId.h"
00033
00034
00035 class DLL_EXPORT_API TKRmap : public TWRmap
00036 {
00037 public:
00038   TKRmap()          {}
00039   virtual ~TKRmap() {}
00040
00041   virtual unsigned layer(LATtypeId ebfId, unsigned cc, unsigned rc)    const;
00042   virtual unsigned layerEnd(LATtypeId ebfId, unsigned cc, unsigned rc) const;
00043 };
00044
00045
00059 inline unsigned TKRmap::layer(LATtypeId /* ebfId */,
00060                               unsigned  cc,
00061                               unsigned  rc) const
00062 {
00063 #if 1                                   // 1 if Normal case, 0 if Minitower 1
00064   // Normal tower case:
00065   //                          CC =  0, 1, 2, 3, 4, 5, 6, 7
00066   static const unsigned offset[] = {0, 0, 1, 1, 3, 3, 2, 2};
00067   return offset[cc] + (rc << 2);        // returns layer = 0 - 35
00068
00069 #else
00070   // First minitower (upside down TEM w/ 90 deg rotation) case:
00071   //                       Cable =  0, 1, 2, 3, 4, 5, 6, 7
00072   //                      TEM CC =  3, 2, 1, 0, 7, 6, 5, 4
00073   static const unsigned offset[] = {1, 1, 0, 0, 2, 2, 3, 3};
00074   return offset[cc] + (rc << 2);        // returns layer = 0 - 35
00075 #endif
00076 }
00077
00097 inline unsigned TKRmap::layerEnd(LATtypeId ebfId,
00098                                  unsigned  cc,
00099                                  unsigned  rc) const
00100 {
00101 #if 1                                   // 1 if Normal case, 0 if Minitower 1
00102   // Normal tower case:
00103   //                        CC =  0, 1, 2, 3, 4, 5, 6, 7
00104   static const unsigned lohi[] = {0, 1, 1, 0, 1, 0, 0, 1};
00105   return (layer(ebfId, cc, rc) << 1) | lohi[cc];
00106
00107 #else
00108   // First minitower (upside down TEM w/ 90 deg rotation) case:
00109   //                     Cable =  0, 1, 2, 3, 4, 5, 6, 7
00110   //                    TEM CC =  3, 2, 1, 0, 7, 6, 5, 4
00111   static const unsigned lohi[] = {0, 1, 1, 0, 1, 0, 0, 1};
00112   return (layer(ebfId, cc, rc) << 1) | lohi[cc];
00113 #endif
00114 }
00115
00116 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: TKRstrip.h Source File

  • File List
  • File Members

TKRstrip.h

00001
00023 #ifndef TKRstrip_H
00024 #define TKRstrip_H
00025
00026 #include "copyright_SLAC.h"
00027
00028 #include "libApiExport.h"
00029
00030
00031 class DLL_EXPORT_API TKRstrip
00032 {
00033 public:
00034   TKRstrip(unsigned datum);
00035   TKRstrip()  {}
00036   ~TKRstrip() {}
00037
00038   static
00039   unsigned done(unsigned datum);
00040   unsigned done();
00041
00042   static
00043   unsigned gtfe(unsigned datum);
00044   unsigned gtfe();
00045
00046   static
00047   unsigned strip(unsigned datum);
00048   unsigned strip();
00049
00050   static
00051   unsigned stripAdx(unsigned datum);
00052   unsigned stripAdx();
00053
00054 private:
00055   unsigned _datum;
00056 };
00057
00058
00063 inline TKRstrip::TKRstrip(unsigned datum) :
00064   _datum(datum)
00065 {
00066 }
00067
00072 inline unsigned TKRstrip::done(unsigned datum)
00073 {
00074   return ( datum >> 11) & 0x0001;
00075 }
00076
00080 inline unsigned TKRstrip::done()
00081 {
00082   return (_datum >> 11) & 0x0001;
00083 }
00084
00089 inline unsigned TKRstrip::gtfe(unsigned datum)
00090 {
00091   return ( datum >>  6) & 0x001f;
00092 }
00093
00097 inline unsigned TKRstrip::gtfe()
00098 {
00099   return (_datum >>  6) & 0x001f;
00100 }
00101
00106 inline unsigned TKRstrip::strip(unsigned datum)
00107 {
00108   return   datum        & 0x003f;
00109 }
00110
00114 inline unsigned TKRstrip::strip()
00115 {
00116   return  _datum        & 0x003f;
00117 }
00118
00123 inline unsigned TKRstrip::stripAdx(unsigned datum)
00124 {
00125   return   datum        & 0x07ff;
00126 }
00127
00131 inline unsigned TKRstrip::stripAdx()
00132 {
00133   return  _datum        & 0x07ff;
00134 }
00135
00136 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7


LDF: TWRmap.h Source File

  • File List
  • File Members

TWRmap.h

00001
00024 #ifndef TWRmap_H
00025 #define TWRmap_H
00026
00027 #include "copyright_SLAC.h"
00028
00029 #include "libApiExport.h"
00030
00031 #include "LATtypeId.h"
00032 #include "EBFevent.h"
00033
00034
00035 class DLL_EXPORT_API TWRmap
00036 {
00037 public:
00038   TWRmap()          {}
00039   virtual ~TWRmap() {}
00040
00051   virtual unsigned tower(LATtypeId evtId, unsigned id) const;
00052 };
00053
00054
00055 inline unsigned TWRmap::tower(LATtypeId /* evtId */, unsigned id) const
00056 {
00057 // There currently is no difference between source ID and tower ID.
00058 // At one point it was thought to make them different by one, so we leave
00059 // this here as an example or future reminder.
00060 //   switch (evtId.value())
00061 //   {
00062 //     case EBFevent::ID:
00063 //       return id - 1;                    // TEM adx runs from 1 - 16
00064 //     case EBFevent::ID_1:
00065 //       return id;                        // TEM adx runs from 0 - 15
00066 //     default:
00067 //       fprintf(stderr, "TWRmap::tower: "
00068 //               "No tower map exists for EBF version %0x\n", evtId.value());
00069 //   }
00070   return id;
00071 }
00072
00073 #endif
Generated on Mon Jul 31 17:48:10 2006 for LDF v06-02-00 by doxygen 1.4.7