This procedure defines the performance tests for the GASU.

5.1 Pre-Operation Verification

This section details the pre-operation verification checks before testing.

To perform the pre-operation verification checks:

1) Verify that this test has been completed successfully:
   - GASU Safe to Mate Test Procedure (LAT-TD-04260-03)

   Date: 3/22/2005  Time: 10:30 AM

   [Signature]

   Role: Test Director

5.2 Test Procedure Instructions/Information

This section provides the general instructions and information that are used and required to perform this procedure, including test sequence, test participants, and test equipment.

WARNING: This document is written so that there are no exposed connectors/circuitry of more than the safe working limits as stated in the SLAC Environment, Safety, and Health Manual (SLAC-1-720-0A29Z-001).

CAUTION: Follow ESD processes during this procedure.

Note: Prior to the connection of any hardware to other electronics, it shall be verified that all power supplies, signal generators, VME racks, and any other test and measurement equipment are connected to the same AC ground.

Note: This document shall be considered subordinate to any Assembly and Inspection Data Sheet (AIDS) that is used in conjunction with this testing process.

5.2.1 Test Sequence

The test procedure should be run in full and in the sequence given unless alternative instructions authorized by the Test Director are provided. These instructions can take the form of an AIDS, instructions hand-written into the procedure, or verbal instructions. Appendix C contains a datasheet listing all the tests contained in the procedure. An alternative test procedure can be defined by selecting a subset of the tests on this datasheet. The Test Setup Procedure must always be run first.

5.2.2 Participant List

1) Record all test participants in the table below.

2) If additional personnel participate, add them to the table.

<table>
<thead>
<tr>
<th>Role</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Test Director (TD)</td>
<td>Jana Thayer</td>
</tr>
</tbody>
</table>

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
5.2.3 Test Equipment

The test equipment listed below is necessary for the tests described in this procedure. If additional equipment is used, add it to the table below with the initials of the TC, and proceed with the test.

1) Record the model/LAT number, serial/revision number, and calibration due date or validation date (if applicable) for all equipment used in this procedure.

<table>
<thead>
<tr>
<th>Test Equipment Description, Manufacturer</th>
<th>Model/LAT Number</th>
<th>Serial/Revision Number</th>
<th>Calibration/Validation Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>VME Crate, Dawn VME Products</td>
<td>11-1011777-2119</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>VME SBC MVME 2034 card, Motorola</td>
<td>PN MVME2034-0123</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>VME LCB Mezzanine card, SLAC</td>
<td>LAT-TD-00860</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>Trigger Pattern Generator (TPG), SLAC</td>
<td>NA</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>Data - TEM front ends, SLAC</td>
<td>NA</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>FREE boards, SLAC</td>
<td>NA</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>Transition board, SLAC</td>
<td>NA</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>Software for the local PC</td>
<td>LATTE ONLINE-Head</td>
<td>GLAT0462</td>
<td>4-31-05</td>
</tr>
<tr>
<td>DC Power supply #1, BK Precision</td>
<td>BK 1697</td>
<td>GLAT0461</td>
<td>6-30-05</td>
</tr>
<tr>
<td>DC Power supply #2, BK Precision</td>
<td>BK 1697</td>
<td>GLAT0461</td>
<td>6-30-05</td>
</tr>
<tr>
<td>28 Volt GASU power cable, SLAC</td>
<td>LAT-DS-03611</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>LCB cable, SLAC</td>
<td>LAT-DS-02104</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>DAQ/TEM-GASU cable, SLAC</td>
<td>LAT-DS-02106</td>
<td>NA</td>
<td>NA</td>
</tr>
</tbody>
</table>

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
<table>
<thead>
<tr>
<th>Test Equipment Description, Manufacturer</th>
<th>Model/LAT Number</th>
<th>Serial/Revision Number</th>
<th>Calibration/Validation Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>GEM Testee FREE cable, SLAC</td>
<td>LAT-DS-05667</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>DAQ/DPU Spacecraft power cable, SLAC</td>
<td>LAT-DS-02095</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>CAT5 Ethernet cable</td>
<td>TRD855PL-30</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>RS-232 Cable</td>
<td>TDC003-7 (RECO98M connectors)</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>DAQ/FREE - GASU cable, SLAC</td>
<td>LAT-DS-02092</td>
<td>NA</td>
<td>NA</td>
</tr>
</tbody>
</table>

### 5.2.4 User Interfaces

This test uses the Run Control software provided for GLAST by SLAC. Each of the GUIs is described when it is first used in the body of the test procedure.

### 5.3 Test Setup

This section describes the hardware and software configuration for the GASU acceptance tests described in this document. Any break from configuration or deviation from a particular procedure must be authorized by the Test Director.

### 5.3.1 Unit Under Test (UUT)

The list below indicates the equipment that is tested in this procedure.

<table>
<thead>
<tr>
<th>Type</th>
<th>Manufacturer</th>
<th>GLAT Number</th>
<th>Firmware Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>GASU</td>
<td>SLAC</td>
<td>GLAT-0018</td>
<td>N/A</td>
</tr>
</tbody>
</table>

*Note: All references in the test to GLATXXXX will refer to the GLAT number written in this table.*

### 5.3.2 Hardware Setup

Three hardware configurations are used for GASU performance testing. These configurations are described when they are first used in the body of the test procedure.

### 5.4 GASU Acceptance Tests

Each of the GASU Acceptance Tests is run once with the primary side powered through connector JL-40 and with the redundant side powered through connector JL-41.

The following GASU Acceptance Tests are run in this procedure:

5.4.1: GASU DAQ Board and GEM TPG (Trigger Pattern Generator) Tests

5.4.1.3: GEM Register Tests (Primary Side)

*Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.*
5.4.1: GASU DAQ Board and GEM TPG (Trigger Pattern Generator) Tests

The GASU DAQ Board and GEM TPG (Trigger Pattern Generator) Functional Tests are run once with the primary side powered through connector JL-40 and once with the redundant side powered through connector JL-41.

5.4.1.1 GASU DAQ Board and GEM TPG Tests Configuration

Figure 1 depicts the generic hardware configuration for the GASU DAQ Board and GEM TPG Tests with the primary side powered through connector JL-40. Not all connectors are used for each test. Follow the specific instructions for each test procedure. For a four-port GASU, only the first four TEM connectors and the last eight ACD connectors are used.

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
5.4.1.2 GASU DAQ Board and GEM TPG Tests Setup Procedure (Primary Power Side)

To set up the hardware and software for GASU DAQ Board and GEM TPG tests:

1) Connect the GASU to the VME Crate per Figure 1 following this process:
   a) Connect one end of a LAT-DS-02104 cable to J5 on the LCB Mezzanine Card.
   b) Connect the other end of the LAT-DS-02104 cable to JL-44 on the GASU.

2) Connect the TPG TEM boards to the GASU per Figure 1 following this process:
   a) Connect one end of LAT-DS-2106 to JL-50 (TEM0) on the GASU.
   b) Connect the other end of the LAT-DS-02106 cable to slot 1, port 0 on the TPG.
   c) Connect one end of LAT-DS-2106 to JL-51 (TEM 1) on the GASU.
   d) Connect the other end of the LAT-DS-02106 cable to slot 1, port 1 on the TPG.
   e) Connect one end of LAT-DS-2106 to JL-52 (TEM 2) on the GASU.
   f) Connect the other end of the LAT-DS-02106 cable to slot 1, port 2 on the TPG.
   g) Connect one end of LAT-DS-2106 to JL-53 (TEM 3) on the GASU.
   h) Connect the other end of the LAT-DS-02106 cable to slot 5, port 0 on the TPG.
   i) Connect one end of the TPG external trigger cable (LAT-DS-06390) to JL-153 (external trigger) on the GASU.

*Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.*
3) Connect the TPG FREE boards to the GASU per Figure 1 following this process:
   a) Connect one end of LAT-DS-05667 to JL-172 (4LA-A) on the GASU.
   b) Connect the other end of the LAT-DS-05667 cable to slot 10, port 0 on the TPG.
   c) Connect one end of LAT-DS-05667 to JL-174 (4LB-A) on the GASU.
   d) Connect the other end of the LAT-DS-05667 cable to slot 10, port 1 on the TPG.
   e) Connect one end of LAT-DS-05667 to JL-176 (4RA-A) on the GASU.
   f) Connect the other end of the LAT-DS-05667 cable to slot 11, port 0 on the TPG.
   g) Connect one end of LAT-DS-05667 to JL-178 (4RB-A) on the GASU.
   h) Connect the other end of the LAT-DS-05667 cable to slot 11, port 1 on the TPG.
   i) Connect one end of LAT-DS-05667 to JL-173 (4LA-B) on the GASU.
   j) Connect the other end of the LAT-DS-05667 cable to slot 16, port 0 on the TPG.
   k) Connect one end of LAT-DS-05667 to JL-175 (4LB-B) on the GASU.
   l) Connect the other end of the LAT-DS-05667 cable to slot 16, port 1 on the TPG.
   m) Connect one end of LAT-DS-05667 to JL-177 (4RA-B) on the GASU.
   n) Connect the other end of the LAT-DS-05667 cable to slot 17, port 0 on the TPG.
   o) Connect one end of LAT-DS-05667 to JL-179 (4RB-B) on the GASU.
   p) Connect the other end of the LAT-DS-05667 cable to slot 17, port 1 on the TPG.

4) Connect the Power Supply to the GASU per Figure 1 following this process:
   a) Connect the red (28V) and black (GND) banana plugs of a LAT-DS-03611 cable to the + and
      - terminals of the Power Supply respectively.
   b) Connect the other end of the LAT-DS-03611 cable to JL-40 on the GASU.

5) Turn on the power supply following this process:
   a) Turn the external power supply power switch to ON.
   b) On the power supply, press Recall and then 1.

*Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.*
c) Verify that the voltage on the external power supply goes to +27.8 to +28.2.

6) Start OCS and OES running on the SBC in the VME crate following this process:
   a) On the VME crate, flip the power switch to On.
   b) Open a UNIX shell to lat-fargorn.
   c) Connect to lat-elf6:
      
      xplex lat-elf6
      
      d) Load the appropriate script by typing the following at the VxWorks prompt:
         
         < /afs/slac/g/glast/vxw000/GASTSU/ferazzo/ptgelf6_jana.x
      
      e) In the xplex window, verify that the boot is progressing.

7) Set up to use the ONLINE-Head release of LATTE following this process:
   a) Open a UNIX window to lat-hobbit1.
   b) Enter:
      
      setenv ONLINE_ROOT /afs/slac/g/glast/online/elx/releases/dev
      
      c) Change to this directory:
         
         /afs/slac/u/ey/jana
      
      d) Check out the latest version of the ELX test scripts from the repository:
         
         cvs co ELX

8) Start Run Control following this process:
   a) Change to this directory:
      
      /afs/slac/u/ey/jana/glast/TS/lat-elf6
      
      i) At the command prompt, type the following:
         
         `mate -server lat-elf6 --config runControl.cfg --schema schema/GasuPrimary.xml -ocs -fsw 0 -npdir /afs/slac/u/ey/jana/glast/Online/ELX`

---

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
b) Press Enter.

c) The Run Control Main window appears as shown in Figure 2.

![Run Control Main window](image)

Figure 2. Run Control Main window

9) To start the User Applications Browser, on the Run Control menu, click Tools and then User Applications Browser.

The User Applications Browser appears as shown in Figure 3.

---

Hard copies of this document are for REFERENCE ONLY and should not be considered the most revision.
5.4.1.3 GEM Register Tests (Primary Side)

To run the GEM Basic Registers test (primary side).

1) In the User Applications Browser, click the GEM tab.

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
2) Under Register Tests, select all eight tests, if they are not already selected:
   - Controller
   - Window
   - Engine
   - Statistics
   - Scheduler
   - Regions of Interest
   - Input Enables
   - Check out of range reg

3) Click the Load button.

4) At the Run Control Main window, click the run button (▶).

Note: These tests take about one minute to run.

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
5) Verify that the indicator light after each of the eight tests is green.

6) Copy log file from /tmp/janna/log/Gem_YYYMMDD_HHDDMM.log to V:GLAST/Electronics/Teststand Validation/GLATXXX.

5.4.1.3 Overall Outcome of the GEM Basic Register Test (Primary Power Side)
Based on the analysis of the test results, the overall outcome of the test is as follows:

Passed - All the tests passed without any errors or warnings

Failed - There were one or more errors or warnings in the tests

5.4.1.4 CRU Register Tests (Primary Side)
To run the CRU Basic Registers test (primary side):

1) In the Run Control Main window, click the Select Application button.

2) Select /afs/slac/u/ey/jana/glast/Onsite/ELX/CRU/CruTest.py

3) At the Run Control Main window, click the run button (▶).

4) Verify that the printout on the screen indicates 0 errors and 0 warnings.

5) Copy log file /tmp/janna/log/Cru_YYYMMDD_HHDDMM.log to V:GLAST/Electronics/Teststand Validation/GLATXXX.

5.4.1.4 Overall Outcome of the CRU Basic Register Test (Primary Side)
Based on the analysis of the test results, the overall outcome of the test is as follows:

Passed - All the tests passed without any errors or warnings

Failed - There were one or more errors or warnings in the tests

5.4.1.5 EBM Register Tests (Primary Side)
To run the EBM Basic Registers test (primary side):

1) In the Run Control Main window, select /afs/slac/u/ey/jana/ELX/EBM/EBmControlTest.py

2) At the Run Control Main window, click the run button (▶).

3) Wait for script to finish, running and for Run Control to return to the shutdown state.

4) At the Run Control Main window, select /afs/slac/u/ey/jana/ELX/EBM/EBmStatsTest.py

5) At the Run Control Main window, click the run button (▶).

6) Verify that the printout on the screen indicates 0 errors and 0 warnings.

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
7) Copy log file lat-hobbit1:/tmp/jana/log/Ebm_YYYMMDD_HHDDMMM.log to V:\GLAST\Electronics\Teststand Validation\GLATXXX.

8) At the Run Control Main window, select application:
   /afs/slac/cfell/jana/glasu/Online/ELX/Ebm/EbmStatsTest.py

9) At the Run Control Main window, click the run button (▶).

10) Verify that the printout to the screen indicates 0 errors and 0 warnings.

11) Copy log file lat-hobbit1:/tmp/jana/log/EbmStats_YYYYMMDD_HHDDMMM.log to V:\GLAST\Electronics\Teststand Validation\GLATXXX.

5.4.1.5.1 Overall Outcome of the EBM Basic Register Tests (Primary Side)
Based on the analysis of the test results, the overall outcome of the test is as follows:

☑ Passed – All the tests passed without any errors or warnings

☐ Failed – There were one or more errors or warnings in the tests

5.4.1.6 AEM Register Tests (Primary Side)
To run the AEM tests (primary side):

1) At the Run Control Main window, select application:
   /afs/slac/cfell/jana/glasu/Online/ELX/AEM/AemTest.py

2) At the Run Control Main window, click the run button (▶).

3) Verify that the printout to the screen indicates 0 errors and 0 warnings.

4) Copy log file lat-hobbit1:/tmp/jana/log/AemController_YYYYMMDD_HHDDMMM.log to V:\GLAST\Electronics\Teststand Validation\GLATXXX.

5.4.1.6.1 Overall Outcome of the AEM Basic Register Tests (Primary Side)
Based on the analysis of the test results, the overall outcome of the test is as follows:

☑ Passed – All the tests passed without any errors or warnings

☐ Failed – There were one or more errors or warnings in the tests

5.4.1.7 CEM Functional Tests (Primary Side)
To run the CEM functional tests (primary side):

1) In the User Applications Browser, click the CEM tab.

2) Under Functional Tests, select all three tests.

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
3) Click the Load button.

4) At the Run Control Main window, click the run button (►).

Note: These tests take about 90 seconds to run.

5) Verify that the indicator light after each of the three tests is green.

6) Copy log file lat:hobbit://tmp/jana/log/GemFunctional_YYYYMMDD_RHODMM.log to V:\GLAST\Electronics\Teststand Validation\GLATXXX.

5.4.1.7.1 Overall Outcome of the GEM Functional Tests (Primary Side)

Based on the analysis of the test results, the overall outcome of the test is as follows:

- **Passed** – All the tests passed without any errors or warnings
- **Failed** – There were one or more errors or warnings in the tests

5.4.1.8 GEM TPG Tests (Primary Side)

To run the GEM TPG tests (primary side):

1) Under TPG Tests, select all the boxes as follows:

   a) TEM TPG Lines. Click the Select box to select TEM0 – TEM3.

   b) FREE Boards TPG Lines. Click the Select box to select FREE8 – FREE11.

   c) External Lines. Click the Select box to select the external trigger.

   d) TPG Tests. Select all seven tests, if they are not already selected.

      - TEM Cable Tests
      - Free Cable Tests
      - Engines Tests
      - Window Tests
      - ROI Tests
      - Delta Tests
      - LVDS Tests

2) Click the Load button.

---

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
3) At the Run Control Main window, click the run button ( ).

Note: These tests take about 3 minutes to run.

4) Verify that the indicator light after each of the seven tests is green.

5) Copy log file to lat-hobbit1:/tmp/jana/log/GemTpg_YYMMDD_HHDDMM.log
   V:\GLAST\Electronics\Teststand Validation\GLATXXXX.

5.4.1.8.1 Overall Outcome of the GEM TPG Test (Primary Side)
Based on the analysis of the test results, the overall outcome of the test is as follows:

☑ Passed – All the tests passed without any errors or warnings

☒ Failed – There were one or more errors or warnings in the tests

5.4.1.9 GASU DAQ Board and GEM TPG Tests Setup Procedure (Redundant Side)
To set up the hardware and software for GASU DAQ Board and GEM TPG tests:

1) Close Run Control, by clicking the File menu and then Exit.

2) Turn off the external power supply following this process:
   a) On the external power supply, press Recall, 2, and then Enter.
   b) On the external power supply, verify that the voltage and current go to zero.

3) Demate LAT-DS-03611 P3 from JL-40 on the GASU.

4) Connect LAT-DS-03611 P3 to JL-41 on the GASU.

5) Turn on the power supply following this process:
   a) On the power supply, press Recall and then 1.
   b) Verify that the voltage on the external power supply goes to +27.8 to +28.2.
   c) Press Enter on the power supply to turn on the GASU.
   d) Verify that the current goes to 0.2 to 0.4 Amps.

6) Start Run Control following this process:
   a) At the command prompt, change to this directory:
      /afs/llnl/g/a/st/TS/lat-elf6

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
b) Type the following:

```
latr -server lat-elf6 -config runControl.cfg -schema schema/GasuRedundant.xml -ocs -fsw 0 -zapdir /afs/slac/ufey/jana/glast/Oslines/ELX
```

c) Press Enter.

The Run Control Main window appears.

7) To start the User Applications Browser, on the Run Control menu, click Tools and then User Applications Browser.

The User Applications Browser appears.

5.4.1.10  GEM Register Tests (Redundant Side)

To run the GEM Basic Registers test (redundant side):

1) In the User Applications Browser, click the GEM tab.

2) Under Register Tests, select all eight tests, if they are not already selected:

- Controller
- Window
- Engine
- Statistics
- Scheduler
- Regions of Interest
- Input Enables
- Check out of range reg

3) Click the Load button.

4) At the Run Control Main window, click the run button (►).

Note: These tests take about one minute to run.

5) Verify that the indicator light after each of the eight tests is green.

6) Copy log file from lat-hobbit:/tmp/jana/log/Gem_YYYYMMDD_HHDDMM.log to V:\GLAST\Electronics\Teststand\Validation\GLATXXXX.

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
5.4.1.10.1 Overall Outcome of the GEM Basic Register Test (Redundant Side)
Based on the analysis of the test results, the overall outcome of the test is as follows:

☑ Passed — All the tests passed without any errors or warnings

☐ Failed — There were one or more errors or warnings in the tests

5.4.1.11 CRU Register Tests (Redundant Side)
To run the CRU Basic Registers test (redundant side):

1) In the Run Control Main window, click the Select Application icon.

2) Select /afs/slac/ue/ey/jana/OnlineELX/CRU/CruTest.py

3) At the Run Control Main window, click the run button (▶).

4) Verify that the printout to the screen indicates 0 errors and 0 warnings.

5) Copy log file lat-hobbit1:/tmp/jana/log/Cru_YYYYMMDD_HHDDMM.log to V:\GLAST\Electronics\testsandValidation\GLATXXXX.

5.4.1.11.1 Overall Outcome of the CRU Basic Register Test (Redundant Side)
Based on the analysis of the test results, the overall outcome of the test is as follows:

☑ Passed — All the tests passed without any errors or warnings

☐ Failed — There were one or more errors or warnings in the tests

5.4.1.12 EBM Register Tests (Redundant Side)
To run the EBM Basic Registers test (redundant side):

1) In the Run Control Main window, select /afs/slac/ue/ey/jana/ELX/EBM/EBMControlTest.py

2) At the Run Control Main window, click the run button (▶).

3) Wait for script to finish running and for Run Control to return to the shutdown state.

4) In the Run Control Main window, select /afs/slac/ue/ey/jana/ELX/EBM/EBMStatsTest.py

5) At the Run Control Main window, click the run button (▶).

6) Verify that the printout to the screen indicates 0 errors and 0 warnings.

7) Copy log file lat-hobbit1:/tmp/jana/log/EBm_YYYYMMDD_HHDDMM.log to V:\GLAST\Electronics\testsandValidation\GLATXXXX.

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
8) At the Run Control Main window, select application: 
/afsl/slac/users/jana/glas/Online/ELX/EBM/EBnStatsTest.py

9) At the Run Control Main window, click the run button (>).

10) Verify that the printout to the screen indicates 0 errors and 0 warnings.

11) Copy log file lat-hobbit1:/tmp/jara/log/EBmStats_YYYYMMDD_HHDDMM.log to V:\GLAST\Electronics\Teststand Validation\GLATXXXX.

5.4.1.12.1 Overall Outcome of the EBM Basic Register Tests (Redundant Side)
Based on the analysis of the test results, the overall outcome of the test is as follows:

- **Passed** – All the tests passed without any errors or warnings
- **Failed** – There were one or more errors or warnings in the tests

5.4.1.13 AEM Register Tests (Redundant Side)
To run the AEM tests (redundant side):

1) At the Run Control Main window, select application: 
/afsl/slac/users/jana/glas/Online/ELX/AEM/AemTest.py

2) At the Run Control Main window, click the run button (>).

3) Verify that the printout to the screen indicates 0 errors and 0 warnings.

4) Copy log file lat-hobbit1:/tmp/jana/log/AemController_YYYYMMDD_HHDDMM.log to V:\GLAST\Electronics\Teststand Validation\GLATXXXX.

5.4.1.13.1 Overall Outcome of the AEM Basic Register Tests (Redundant Side)
Based on the analysis of the test results, the overall outcome of the test is as follows:

- **Passed** – All the tests passed without any errors or warnings
- **Failed** – There were one or more errors or warnings in the tests

5.4.1.14 GEM Functional Tests (Redundant Side)
To run the GEM Functional tests (redundant side):

1) In the User Applications Browser, click the GEM tab.

2) Under Functional Tests, select all three tests.

- Solicited Trigger
- Periodic Trigger

---

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
3) Click the Load button.

4) At the Ren Control Main window, click the run button (►).

Note: These tests take about 90 seconds to run.

5) Verify that the indicator light after each of the three tests is green.

6) Copy log file /tmp/janu/log/GenFunctional_YYYYMMDD_HHDDMM.log to

   $GLAST/electronics/Tests/Validation/GLATXXX

5.4.1.14.1 Overall Outcome of the GEM Functional Tests (Redundant Side)

Based on the analysis of the test results, the overall outcome of the test is as follows:

- Passed — All the tests passed without any errors or warnings
- Failed — There were one or more errors or warnings in the tests

5.4.1.15 GEM TPG Tests (Redundant Side)

To run the GEM TPG tests (redundant side):

1) Under TPG Tests, select all the boxes as follows:
   a) TEM TPG Lines. Click the Select box to select TEM0—TEM3.
   b) FREE Boards TPG Lines. Click the Select box to select FREE–FREE11.
   c) External Lines. Click the Select box to select the external trigger.
   d) TPG Tests. Select all seven tests, if they are not already selected.
      - TEM Cable Tests
      - Free Cable Tests
      - Engines Tests
      - Window Tests
      - ROI Tests
      - Delta Tests
      - LVDS Tests

2) Click the Load button.

3) At the Ren Control Main window, click the run button (►).

---

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
Note: These tests take about 3 minutes to run.

4) Verify that the indicator light after each of the seven tests is green.

5) Copy log file to /tmp/hanalog/GemTpg/YYYYMMDD_HDDMMH.log
    V:\GLAST\Electronics\Teasstand Validation\GLATXX.

5.4.1.16.1 Overall Outcome of the GEM TPG Tests (Redundant Side)
Based on the analysis of the test results, the overall outcome of the test is as follows:

☐ Passed – All the tests passed without any errors or warnings

☐ Failed – There were one or more errors or warnings in the tests

5.4.1.16 Test Shut Down Procedure
To shut down the hardware and software for GASU DAQ Board and GEM TPG tests:

1) Close Run Control, by clicking the File menu and then Exit.

2) Turn off the external power supply following this process:
   a) On the external power supply, press Recall, 2, and then Enter.
   b) On the external power supply, verify that the voltage and current go to zero.

3) Disconnect the LAT-DS-02106 cables from the GASU connectors JL-50 through JL-53.

4) Disconnect the TPG external trigger cable (LAT-DS-0690) from the GASU connector JL-153.

5) Disconnect the LAT-DS-05667 cables from the GASU connectors JL-172 through JL-179.

5.4.2 AEM Functional Tests
The AEM Functional Tests are run once with the primary side powered through connector JL-40 and once with the redundant side powered through connector JL-41.  

5.4.2.1 AEM Functional Test Configuration
Figure 5 shows the hardware configuration for the AEM Functional Tests with the primary side powered through connector JL-40.

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
5.4.2.2 AEM Functional Test Setup Procedure (Redundant Side)

To set up the hardware and software for the AEM Functional tests (redundant side):

1) Verify that the power supply is connected to JL-40.

2) Connect FREE boards to the 4 available FREE ports on the redundant side of the GASU following this process:

   a) Connect one end of LAT-DX-02092 to JL-172 (4LA-A) on the GASU.
   b) Connect the other end of the LAT-DX-02092 cable to FREE port JP1.
   c) Connect one end of LAT-DX-02092 to JL-174 (4LB-A) on the GASU.
   d) Connect the other end of the LAT-DX-02092 cable to FREE port JP2.
   e) Connect one end of LAT-DX-02092 to JL-176 (4RA-A) on the GASU.
   f) Connect the other end of the LAT-DX-02092 cable to FREE port JP1.
   g) Connect one end of LAT-DX-02092 to JL-178 (4RB-A) on the GASU.

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
h) Connect the other end of the LAT-DS-02092 cable to FREE port JP2.

i) Connect one end of LAT-DS-02092 to JL-173 (4LA-B) on the GASU.

j) Connect the other end of the LAT-DS-02092 cable to FREE port JS1.

k) Connect one end of LAT-DS-02092 to JL-175 (4LB-B) on the GASU.

l) Connect the other end of the LAT-DS-02092 cable to FREE port JS2.

m) Connect one end of LAT-DS-02092 to JL-177 (4RA-B) on the GASU.

n) Connect the other end of the LAT-DS-02092 cable to FREE port JS1.

o) Connect one end of LAT-DS-02092 to JL-179 (4RB-B) on the GASU.

p) Connect the other end of the LAT-DS-02092 cable to FREE port JS2.

3) Turn on the external power supply power connection to the GASU following this process:

a) On the power supply, press Recall and then 1.

b) Verify that the voltage on the external power supply goes to +27.8 to +28.2.

c) Press Enter on the power supply to turn on the GASU.

d) Verify that the current goes to 0.2 to 0.4 Amps.

4) Start Run Control following this process:

a) At the command prompt, change to this directory:

   /afs/slac/cal/gyf/jama/glast/TS/lat-el/f6

b) Type the following:

   latel -server 1at-el/f6 -config runControl.cfg -schema schema/GasuRedundant.xml -ocu -fsa
   0 -appdir /afs/slac/cal/gyf/jama/glast/Online/ElX

b) Press Enter.

   The Run Control Main window appears.

5) Turn on the power to the ACD following this process:

a) In the Run Control Main window, on the Tools menu, click Fabric/Power Control.

   The Fabric/Power Control window appears.

---

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
b) Under ACD, verify that Lock Lite Selections is selected.

c) Under ACD, select these boxes: 4LA, 4LB, 4RA, 4RB.

d) Click the Power Up button.

e) Wait for the ACD to power up.

The process takes about 12 seconds. When the process is complete, the boxes that are selected under ACD turn green.

5.4.2.3 AEM Functional Test Procedure (Redundant Side)

To run the AEM tests (redundant side):

1) Run the GARC test following this process.

   a) At the Run Control Main window, select application: /afs/slac/g/e/yama/glazu/OnlinE/AEM/AemGarcTest.py

   b) At the Run Control Main window, click the run button (►).

---

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
c) Verify that the printout to the screen indicates 0 errors and 0 warnings.

d) Copy log file \textcode{lat-bobbitt1:/tmp/jana/log/Gafes\_YYYYMMdd\_HHDDMM.log} to \textcode{\$GLAST\_Electronics\_Teststand\_Validation\_GLATXXX}.

2) Run the GAFE test following this process.

   a) At the Run Control Main window, select application: \textcode{/afs/slac/user/y/jana/glast/Online/ELX/AEM/AemGafeTest.py}

   b) At the Run Control Main window, click the run button (\textbullet{}).

   c) Verify that the printout to the screen indicates 0 errors and 0 warnings.

   d) Copy log file \textcode{lat-bobbitt1:/tmp/jana/log/Gafes\_YYYYMMdd\_HHDDMM.log} to \textcode{\$GLAST\_Electronics\_Teststand\_Validation\_GLATXXX}.

3) Run the CNO test following this process.

   a) At the Run Control Main window, select application: \textcode{/afs/slac/user/y/jana/glast/Online/ELX/AEM/GarcTriggerCso.py}

   b) At the Run Control Main window, click the run button (\textbullet{}).

   c) Verify that the printout to the screen indicates 0 errors and 0 warnings.

   d) Copy log file \textcode{lat-bobbitt1:/tmp/jana/log/Gafes\_YYYYMMdd\_HHDDMM.dot} to \textcode{\$GLAST\_Electronics\_Teststand\_Validation\_GLATXXX}.

4) Run the VETO test following this process.

   a) At the Run Control Main window, select application: \textcode{/afs/slac/user/y/jana/glast/Online/ELX/AEM/GarcTriggerVeto.py}

   b) At the Run Control Main window, click the run button (\textbullet{}).

   c) Verify that the printout to the screen indicates 0 errors and 0 warnings.

   d) Copy log file \textcode{lat-bobbitt1:/tmp/jana/log/Gafes\_YYYYMMdd\_HHDDMM.log} to \textcode{\$GLAST\_Electronics\_Teststand\_Validation\_GLATXXX}.

5.4.2.3.1 Overall Outcome of the AEM Functional Tests (Redundant Side)

Based on the analysis of the test results, the overall outcome of the test is as follows:

- **Passed** – All the tests passed without any errors or warnings
- **Failed** – There were one or more errors or warnings in the tests

---

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
5.4.2.4 AEM Functional Test Setup Procedure (Primary Side)
To set up the hardware and software for the AEM Functional tests (primary side):

1) Power down the ACD, following this process:
   a) In the Fabric/Power Control window, under ACD, verify that these boxes are selected: 4L A, 4L B, 4RA, 4RB.
   b) Click the Power Down button.
   c) Verify that all the boxes under ACD turn grey.
   d) Close the Fabric/Power Control window by clicking the X in the upper right corner.
   e) In the Run Control Main window, on the File menu, click Disconnect.
   f) On the external power supply, press Recall, 2, and then Enter.
   g) On the external power supply, verify that the voltage and current go to zero.

2) Close Run Control, by clicking the File menu and then Exit.

3) Turn off the external power supply following this process:
   a) On the external power supply, press Recall, 2, and then Enter.
   b) On the external power supply, verify that the voltage and current go to zero.

4) Disconnect LAT-DS-03611 P3 from JL-41 on the GASU.

5) Connect LAT-DS-03611 P3 to JL-40 on the GASU.

6) Turn on the external power supply power following this process:
   a) On the power supply, press Recall and then 1.
   b) Verify that the voltage on the external power supply goes to +27.8 to +28.2.
   c) Press Enter on the power supply to turn on the GASU.
   d) Verify that the current goes to 0.2 to 0.4 Aamps.

7) Start Run Control following this process:
   a) At the command prompt, change to this directory:
      /afs/dac/uy/jara/glast/TSi/at-elf6

---

Hard copy of this document are for REFERENCE ONLY and should not be considered the latest revision.
b) Type the following:

```
latte -server el16 -config runControl.cfg -schema schema/GasuPrimary.xml -ocs -fsw 0 -appdir /afs/slac/uc/ey/jana/glast/Online/ELX
```

c) Press Enter.

d) The Run Control Main window appears.

8) Turn on the power to the ACD following this process:

a) In the Run Control Main window, on the Tools menu, click Fabric/Power Control.

The Fabric/Power Control window appears.

b) Under ACD, verify that Lock Like Selections is selected.

c) Under ACD, select these boxes: 4LA, 4LB, 4RA, 4RB.

d) Click the Power Up button.

e) Wait for the ACD to power up.

The process takes about 12 seconds. When the process is complete, the boxes that are selected under ACD turn green.

5.4.2.5 AEM Functional Test Procedure (Primary Side)

To run the AEM tests (primary side):

1) Run the GARC test following this process.

a) At the Run Control Main window, select application:

```
/afs/slac/uc/ey/jana/glast/Online/ELX/AEM/AemGarcTest.py
```

b) At the Run Control Main window, click the run button (►).

c) Verify that the printout to the screen indicates 0 errors and 0 warnings.

d) Copy log file lat-hobbist1:/tmp/jana/log/Garcs_YYYYMMDD_HHMMDDMM.log to V:\GLAST\Electronics\Teststand Validation\GLATXXXX.

2) Run the GAFE test following this process.

a) At the Run Control Main window, select application:

```
/afs/slac/uc/ey/jana/glast/Online/ELX/AEM/AemGafeTest.py
```

b) At the Run Control Main window, click the run button (►).

c) Verify that the printout to the screen indicates 0 errors and 0 warnings.

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
d) Copy log file /tmp/jana/log/Gafes_YYYYMMDD_HHDDMM.log to 
/\GLAST\Electronics\Teststand\Validation\GLATXXX.

3) Run the CNO test following this process:

a) At the Run Control Main window, select application:
/afs/slac/user/jana/glastOnline/ELX/AEM/Gsc/TriggerCno.py
b) At the Run Control Main window, click the run button (►).
c) Verify that the printout to the screen indicates 0 errors and 0 warnings.
d) Copy log file /tmp/jana/log/Gafes_YYYYMMDD_HHDDMM.log to 
/\GLAST\Electronics\Teststand\Validation\GLATXXX.

4) Run the VETO test following this process.

a) At the Run Control Main window, select application:
/afs/slac/user/jana/glastOnline/ELX/AEM/Gsc/TriggerVeto.py
b) At the Run Control Main window, click the run button (►).
c) Verify that the printout to the screen indicates 0 errors and 0 warnings.
d) Copy log file /tmp/jana/log/Gafes_YYYYMMDD_HHDDMM.log to 
/\GLAST\Electronics\Teststand\Validation\GLATXXX.

5.4.2.5.1 Overall Outcome of the AEM Functional Tests (Primary Side)

Based on the analysis of the test results, the overall outcome of the test is as follows:

☑ Passed – All the tests passed without any errors or warnings
☐ Failed – There were one or more errors or warnings in the tests

5.4.2.6 Test Shut Down Procedure

To shut down the hardware and software for the AEM Functional tests:

1) Power down the ACD, following this process:

a) In the Fabric/Power Control window, under ACD, verify that these boxes are selected: 4LA, 4LB, 4RA, 4RB,
b) Click the Power Down button.
c) Verify that all the boxes under ACD turn grey.
d) Close the Fabric/Power Control window by clicking the X in the upper right corner.

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
e) In the Run Control Main window, on the File menu, click Disconnect.

f) On the external power supply, press Recall, 2, and then Enter.

g) On the external power supply, verify that the voltage and current go to zero.

2) Close Run Control, by clicking the File menu and then Exit.

3) Turn off the external power supply following its process:

a) On the external power supply, press Recall, 2, and then Enter.

b) On the external power supply, verify that the voltage and current gc to zero.

4) Disconnect LAT-DS-02104 from the LCB Mezzanine Card in the VME Crate.

5) Disconnect the eight LAT-DS-02092 cables from the FREE ports on the GASU.

5.4.3 TEM Functional Tests

5.4.3.1 Test Configuration

Figure 7 shows the configuration for the TEM Functional Tests with the primary side powered through connector JL-40.

Figure 7. Hardware Configuration for TEM Functional Tests

5.4.3.2 TEM Functional Test Setup Procedure (Primary Side)

To set up the hardware and software for the TEM Functional tests (primary side):

1) Verify that the power supply is connected to JL-40.

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
2) Connect the Dalek power supply to the Transition Board per Figure 7 following this process:
   a) Connect LAT-DS-03611 P2 (-) to the external power supply black (-) jack.
   b) Connect LAT-DS-03611 P1 (+) to the external power supply red (+) jack.
   c) Connect LAT-DS-03611 P3 to the PS CTRL port on the Transition Board.

3) Connect the Dalek to the Transition Board per Figure 7 following this process:
   a) Connect one end of a LAT-DS-02095 cable to the +28V connector on the Transition Board.
   b) Connect the other end of the LAT-DS-02095 cable to JPL on the Dalek.

4) Connect the GASU to the VME Crate per Figure 7 following this process:
   a) Connect one end of a LAT-DS-02104 cable to J5 on the LCB Mezzanine Card.
   b) Connect the other end of the LAT-DS-02104 cable to JL44 on the GASU.

5) Connect the LAT-DS-02106 cable from JL-50 (TEM0) to JT1 on the Dalek.

6) Turn on the external power supply connected to the GASU following this process:
   a) On the power supply, press Recall and then 1.
   b) Verify that the voltage on the external power supply goes to +27.8 to +28.2.
   c) Press Enter on the power supply to turn on the GASU.
   d) Verify that the current goes to 0.2 to 0.4 Amps.

7) Turn on the external power supply connected to the Transition Board following this process:
   a) Turn the external power supply power switch to ON.
   b) On the power supply, press Recall and then 1.
   c) Verify that the voltage on the external power supply goes to +27.8 to +28.2.
   d) Press Enter on the power supply.
   e) Verify that the current goes to 0.1 to 0.3 Amps.

8) Start OCS and OES running on the SBC in the VME crate following this process:
   a) On the VME crate, flip the power switch to On.
   b) Open a UNIX shell to 'at-fangorn.'
c) Connect to lat-elf6:
   `xyplex lat-elf6`

d) Load the appropriate script by typing the following at the VxWorks prompt:
   ```
   <ufs/slac/g/glax/vxw000/GASU/perrazzo/startup-mv2309.vx
   ```

9) Start Run Control following this process:

a) At the command prompt, change to this directory:
   ```
   /ufs/slac/u/ej/jena/glast/TS/lat-elf6
   ```
b) Type the following:
   ```
   latte --server lat-elf6 --config.runControl.cfg --schema schema/GasotPrimary.xml --ocs-fsw @
   --appdir /ufs/slac/u/ej/jena/glast/OnlineELX
   ```
c) Press Enter.

   The Run Control Main window appears.

5.4.3.3 TEM Functional Test Procedure (Primary Side)

To run the TEM functional tests (primary side):

1) Run TEM Register test on the first TEM port (JL-50) following this process:

a) At the Run Control Main window, select application:
   ```
   /ufs/slac/u/ej/jena/ELX/TEM/regRWTMTest.py
   ```
b) At the Run Control Main window, click the run button (►).

c) Verify that the Pass message appears.

d) At the Run Control Main window, select application:
   ```
   /ufs/slac/u/ej/jena/ELX/TEM/TEMEverTest.py
   ```
e) At the Run Control Main window, click the run button (►).

f) Verify that the Pass message appears.

2) Change the connection from JL-50 to JL-51 following this process:

a) At the Run Control Main window, on the File menu, click Disconnect.
b) On the external power supply connected to the Transition Board, press Recall, 2, and then Enter.

c) Verify that the voltage and current go to zero.

d) On the external power supply connected to the GASU, press Recall, 2, and then Enter.

e) Verify that the voltage and current go to zero.

f) Disconnect LAT-DS-02106 from JL-50 on the GASU.

g) Connect the LAT-DS-02106 cable to JL-51 (TEM 1) on the GASU.

3) Turn on the external power supplies following this process:

a) On the power supply connected to the GASU, press Recall and then 1.

b) Verify that the voltage on the external power supply goes to +27.8 to +28.2.

c) Press Enter on the power supply to turn on the GASU.

d) Verify that the current goes to 0.2 to 0.4 Amps.

e) On the power supply connected to the Transition Board, press Recall and then 1.

f) Verify that the voltage on the external power supply goes to +27.8 to +28.2.

g) Press Enter on the power supply to the Transition Board.

h) Verify that the current goes to 0.1 to 0.3 Amps.

4) In the Run Control Main window, on the File menu, click Connect.

5) Run TEM Register test on the second TEM port (JL-51) following this process:

a) At the Run Control Main window, select application:

   /afs/slac/atemy/jana/ELX/TEM/regRWTest.py

b) At the Run Control Main window, click the run button (▶).

c) Verify that the Pass message appears.

d) At the Run Control Main window, select application:

   /afs/slac/atemy/jana/ELX/TEM/TEMEventTest.py

e) At the Run Control Main window, click the run button (▶).

---

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
f) Verify that the Pass message appears.

6) Change the connection to from JL-51 to JL-52 following this process:
   a) At the Run Control Main window, on the File menu, click Disconnect.
   b) On the external power supply connected to the Transition Board, press Recall, 2, and then Enter.
   c) Verify that the voltage and current go to zero.
   d) On the external power supply connected to the GASU, press Recall, 2, and then Enter.
   e) Verify that the voltage and current go to zero.
   f) Disconnect LAT-DS-02106 from JL-51 on the GASU.
   g) Connect the LAT-DS-02106 cable to JL-52 (TEM 2) on the GASU.

7) Turn on the external power supplies following this process:
   a) On the power supply connected to the GASU, press Recall and then 1.
   b) Verify that the voltage on the external power supply goes to +27.8 to +28.2.
   c) Press Enter on the power supply to turn on the GASU.
   d) Verify that the current goes to 0.2 to 0.4 Amps.
   e) On the power supply connected to the Transition Board, press Recall and then 1.
   f) Verify that the voltage on the external power supply goes to +27.8 to +28.2.
   g) Press Enter on the power supply to the Transition Board.
   h) Verify that the current goes to 0.1 to 0.3 Amps.

8) In the Run Control Main window, on the File menu, click Connect.

9) Run TEM Regitstert test on the third TEM port (JL-52) following this process:
   a) At the Run Control Main window, select application:
      /afs/leac/a/eya/lanx/TEM/regRWTest.py
   b) At the Run Control Main window, click the run button (▶).
   c) Verify that the Pass message appears.

---

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
d) At the Run Control Main window, select application: 

/afs/sslac/u/eyl/jane/ELX/TEM/TEMEventTest.py

e) At the Run Control Main window, click the run button (▶).

f) Verify that the Pass message appears.

10) Change the connection to JL-52 to JL-53 following this process:

a) At the Run Control Main window, on the File menu, click Disconnect.

b) On the external power supply connected to the Transition Board, press Recall, 2, and then Enter.

c) Verify that the voltage and current go to zero.

d) On the external power supply connected to the GASU, press Recall, 2, and then Enter.

e) Verify that the voltage and current go to zero.

f) Disconnect LAT-DS-02106 from IL-52 on the GASU.

g) Connect the LAT-DS-02106 cable to IL-53 (TEM 3) on the GASU.

11) Turn on the external power supplies following this process:

a) On the power supply connected to the GASU, press Recall and then 1.

b) Verify that the voltage on the external power supply goes to +27.8 to +28.2.

c) Press Enter on the power supply to turn on the GASU.

d) Verify that the current goes to 0.2 to 0.4 Amps.

e) On the power supply connected to the Transition Board, press Recall and then 1.

f) Verify that the voltage on the external power supply goes to +27.8 to +28.2.

g) Press Enter on the power supply to the Transition Board.

h) Verify that the current goes to 0.1 to 0.3 Amps.

12) In the Run Control Main window, on the File menu, click Connect.

13) Run TEM Register test on the fourth TEM port (JL-53) following this process:

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
a) At the Run Control Main window, select application:

```
/afs/slac/c/user/jana/ELX/TEM/regRWTes.py
```

b) At the Run Control Main window, click the run button (▶).

c) Verify that the Pass message appears.

d) At the Run Control Main window, select application:

```
/afs/slac/c/user/jana/ELX/TEM/TEMEventTest.py
```

e) At the Run Control Main window, click the run button (▶).

f) Verify that the Pass message appears.

5.4.3.3.1 Overall Outcome of the TEM Functional Tests (Primary Side)

Based on the analysis of the test results, the overall outcome of the test is as follows:

☐ Passed – All the tests passed without any errors or warnings

☐ Failed – There were one or more errors or warnings in the tests

5.4.3.4 TEM Functional Test Setup Procedure (Redundant Side)

To set up the hardware and software for the TEM Functional tests (redundant side):

1) Close Run Control, by clicking the File menu and then Exit.

2) Power down the TEM following this process:

   a) On the external power supply connected to the Transition Board, press Recall, 2, and then Enter.

   b) Verify that the voltage and current go to zero.

3) Power down the GASU following this process:

   a) On the external power supply connected to the GASU, press Recall, 2, and then Enter.

   b) Verify that the voltage and current go to zero.

4) Disconnect LAT-DS-03611 P3 from JL-40 on the GASU.

5) Connect LAT-DS-03611 P3 to JL-41 on the GASU.

6) Turn on the external power supply power connection to the GASU following this process:

   a) On the power supply, press Recall and then 1.

Hart copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
b) Verify that the voltage on the external power supply goes to +27.8 to +28.2.

c) Press Enter on the power supply to turn on the GASU.

d) Verify that the current goes to 0.2 to 0.4 Amps.

7) Turn on the external power supply power connection to the Transition Board following this process:

a) On the power supply, press Recall and then 1.

b) Verify that the voltage on the external power supply goes to +27.8 to +28.2.

c) Press Enter on the power supply.

d) Verify that the current goes to 0.1 to 0.3 Amps.

8) Start Run Control following this process:

a) At the command prompt, change to this directory:

   /afs/slac/a/ey/jana/glast/TS/lat-elf6

b) Type the following:

   latte -server lat-elf6 -config runControl.cfg -schema schema/GasuRedundant.xml -ocs -fsw
do-appdir /afs/slac/a/ey/jana/glast/Online/ELX

c) Press Enter.

   The Run Control Main window appears.

5.4.3.5 TEM Functional Test Procedure (Redundant Side)
To run the TEM functional tests (redundant side):

1) Run TEM Register test on the fourth TEM port (JL-53) following this process:

a) Verify that JL-53 is connected to the Dakek.

b) At the Run Control Main window, select application:

   /afs/slac/a/ey/jana/ELX/TEM/RegRWTest.py

c) At the Run Control Main window, click the run button (►).

d) Verify that the Pass message appears.

---

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
e) At the Run Control Main window, select application.
   `/afs/slac/g/ey/jina/ELX/TEM/TEMEventTest.py`

f) At the Run Control Main window, click the run button (▸).

g) Verify that the Pass message appears.

2) Change the connection to JL-53 to JL-50 following this process:
   a) At the Run Control Main window, on the File menu, click Disconnect.
   b) On the external power supply connected to the Transition Board, press Recall, 2, and then Enter.
   c) Verify that the voltage and current go to zero.
   d) On the external power supply connected to the GASU, press Recall, 2, and then Enter.
   e) Verify that the voltage and current go to zero.
   f) Disconnect LAT-DS-02106 from JL-53 on the GASU.
   g) Connect the LAT-DS-02166 cable to JL-50 (TEM 0) on the GASU.

3) Turn on the external power supplies following this process:
   a) On the power supply connected to the GASU, press Recall and then 1.
   b) Verify that the voltage on the external power supply goes to +27.8 to +28.2.
   c) Press Enter on the power supply to turn on the GASU.
   d) Verify that the current goes to 0.2 to 0.4 Amps.
   e) On the power supply connected to the Transition Board, press Recall and then 1.
   f) Verify that the voltage on the external power supply goes to +27.8 to +28.2.
   g) Press Enter on the power supply to the Transition Board.
   h) Verify that the current goes to 0.1 to 0.2 Amps.

4) In the Run Control Main window, on the File menu, click Connect.

5) Run TEM Register test on the first TEM port (JL-50) following this process:

---

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
a) At the Run Control Main window, select application:

    /afs/slac/user/j/jana/ELX/TEM/regRWTest.py

b) At the Run Control Main window, click the run button (►).

c) Verify that the Pass message appears.

d) At the Run Control Main window, select application:

    /afs/slac/user/j/jana/ELX/TEM/TEMEventTest.py

e) At the Run Control Main window, click the run button (►).

f) Verify that the Pass message appears.

6) Change the connection from JL-50 to JL-51 following this process:

a) At the Run Control Main window, on the File menu, click Disconnect.

b) On the external power supply connected to the Transition Board, press Recall, 2, and then Enter.

c) Verify that the voltage and current go to zero.

d) On the external power supply connected to the GASU, press Recall, 2, and then Enter.

e) Verify that the voltage and current go to zero.

f) Disconnect LAT-DS-02106 from JL-50 on the GASU.

g) Connect the LAT-DS-02106 cable to JL-51 (TEM 1) on the GASU.

7) Turn on the external power supplies following this process:

a) On the power supply connected to the GASU, press Recall and then 1.

b) Verify that the voltage on the external power supply goes to +27.8 to +28.2.

c) Press Enter on the power supply to turn on the GASU.

d) Verify that the current goes to 0.2 to 0.4 Amps.

e) On the power supply connected to the Transition Board, press Recall and then 1.

f) Verify that the voltage on the external power supply goes to +27.8 to +28.2.

g) Press Enter on the power supply to the Transition Board.

---

Faxed copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
h) Verify that the current goes to 0.1 to 0.3 Amps.

8) In the Run Control Main window, on the File menu, click Connect.

9) Run TEM Register test on the second TEM port (JL-51) following this process:
   a) At the Run Control Main window, select application:
      
      /afs/slac/uey/jana/ELX/TEM/reg2WTest.py
   b) At the Run Control Main window, click the run button (►).
   c) Verify that the Pass message appears.
   d) At the Run Control Main window, select application:
      
      /afs/slac/uey/jana/ELX/TEM/TEMEventTest.py
   e) At the Run Control Main window, click the run button (►).
   f) Verify that the Pass message appears.

10) Change the connection to from JL-51 to JL-52 following this process:
    a) At the Run Control Main window, on the File menu, click Disconnect.
    b) On the external power supply connected to the Transition Board, press Recall, 2, and then Enter.
    c) Verify that the voltage and current go to zero.
    d) On the external power supply connected to the GASU, press Recall, 2, and then Enter.
    e) Verify that the voltage and current go to zero.
    f) Disconnect LAT-DS-02106 from JL-51 on the GASU.
    g) Connect the LAT-DS-02106 cable to JL-52 (TEM 2) on the GASU.

11) Turn on the external power supplies following this process:
    a) On the power supply connected to the GASU, press Recall and then 1.
    b) Verify that the voltage on the external power supply goes to +27.8 to +28.2.
    c) Press Enter on the power supply to turn on the GASU.
    d) Verify that the current goes to 0.2 to 0.4 Amps.

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
e) On the power supply connected to the Transition Board, press Recall and then 1.

f) Verify that the voltage on the external power supply goes to +27.8 to +28.2.

g) Press Enter on the power supply to the Transition Board.

h) Verify that the current goes to 0.1 to 0.3 Amps.

12) In the Run Control Main window, on the File menu, click Connect.

13) Run TEM Register test on the third TEM port (JL-52) following this process:

a) At the Run Control Main window, select application:
   
   /afs/slac/user/jana/ELX/TEM/regRWTTest.py

b) At the Run Control Main window, click the run button (►).

c) Verify that the Pass message appears.

d) At the Run Control Main window, select application:

   /afs/slac/user/jana/ELX/TEM/TEMEventTest.py

e) At the Run Control Main window, click the run button (►).

f) Verify that the Pass message appears.

5.4.3.5.1 Overall Outcome of the TEM Functional Test (Redundant Side)

Based on the analysis of the test results, the overall outcome of the test is as follows:

☑ Passed – All the tests passed without any errors or warnings

☒ Failed – There were one or more errors or warnings in the tests

5.4.3.6 Test Shut Down Procedure

To shut down the hardware and software for the TEM Functional test:

1) Close Run Control, by clicking the File menu and then Exit.

2) Power down the TEM following this process:

   a) On the external power supply connected to the Transition Board, press Recall, 2, and then Enter.

   b) Verify that the voltage and current go to zero.

   c) Turn the external power supply switch to Off.

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
3) Power down the GASU following this process:
   a) On the external power supply connected to the GASU, press Recall, 2, and then Enter.
   b) Verify that the voltage and current go to zero.
   c) Turn the external power supply switch to Off.

4) Disconnect the LAT-DS-02106 cable from JL-50 (TEM 0) on the GASU.

5) Disconnect LAT-DS-03611 P3 from JL-40 on the GASU.

6) Disconnect the GASU to the VME Crate following this process:
   a) Disconnect the LAT-DS-02104 cable from JL-44 on the GASU.
   b) Disconnect LAT-DS-02104 from the LCB Mezzanine Card.

7) Disconnect the Dalek power supply from the Transition Board following this process:
   a) Disconnect LAT-DS-03611 P3 from the Transition Board.
   b) Disconnect LAT-DS-03611 from the power supply.

8) Connect the Dalek from the Transition Board following this process:
   a) Disconnect the LAT-DS-02095 cable from the Transition Board.
   b) Disconnect the LAT-DS-02095 from the Dalek.

---

*Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.*
6. Certification

I certify that the information obtained under this test procedure is as represented and the information recorded in this document is complete and correct. Any deviations from test procedures described in Section 5 are identified in Appendix A.

4-25-04

[Signature]

Test Director (Print Name)

[Signature]

Test Director (Signature)

I certify that the information obtained under this test procedure is as represented and the information recorded in this document is complete and correct. Any deviations from test procedures described in Section 5 are identified in Appendix A.

4-25-04

[Signature]

Test Conductor (Print Name)

[Signature]

Test Conductor (Signature)

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
Appendix A: Deviations from Acceptance Test Procedure

This section details any deviations from the hardware configuration, software configuration, or test procedure followed during the execution of the test or tests described in this Acceptance Test Procedure document. All deviations from the approved procedure are agreed to by the Test Engineer and the Software Quality Engineer during the test execution session. All deviations must be reported during the Post Acceptance Test Review, where their impact on the test results will be evaluated.

A.1 Hardware Deviations

Describe any deviations from the hardware configuration defined in 5.2.3. Name the hardware that was modified and describe the modifications. If hardware is replaced during execution of the test, name the replaced hardware, the manufacturer, and list an identification number (e.g., GLAT ID number).

A.2 Software Deviations

Describe any changes made to the software configuration under test or the software configuration used to support test execution. Give version numbers of all PSW packages and test packages that were modified. Describe how the contents of the modified software load were verified. Describe these deviations for each test that was modified.

A.3 Procedural Deviations

Specify any deviations from the test procedure for the test being executed. List by number the steps modified or skipped. Provide a numbered sequence listing any added steps. Describe these deviations for each test that was modified.

The procedure was run on 3-9-95, prior to the release of this document. The data was transferred on 4-25-95. The data was transferred on 4-25-95.

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.
Appendix B: Check List

This checklist contains all the tests in the GASU test procedure.

<table>
<thead>
<tr>
<th>Complete (Check Off)</th>
<th>Outcome of Test (Circle)</th>
<th>Section</th>
<th>Test Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>NA</td>
<td>NA</td>
<td>5.4.1</td>
<td>GASU DAQ Board and GEM TPG (Trigger Pattern Generator) Tests</td>
</tr>
<tr>
<td>✔</td>
<td>NA</td>
<td>5.4.1.2</td>
<td>GASU DAQ Board and GEM TPG Tests Setup Procedure</td>
</tr>
<tr>
<td>✔</td>
<td>Test Fail</td>
<td>5.4.1.3</td>
<td>GEM Register Tests (Primary Side)</td>
</tr>
<tr>
<td>✔</td>
<td>Test Fail</td>
<td>5.4.1.4</td>
<td>CRU Register Tests (Primary Side)</td>
</tr>
<tr>
<td>✔</td>
<td>Test Fail</td>
<td>5.4.1.5</td>
<td>EFM Register Tests (Primary Side)</td>
</tr>
<tr>
<td>✔</td>
<td>Test Fail</td>
<td>5.4.1.6</td>
<td>AEM Register Tests (Primary Side)</td>
</tr>
<tr>
<td>✔</td>
<td>Test Fail</td>
<td>5.4.1.7</td>
<td>GEM Functional Tests (Primary Side)</td>
</tr>
<tr>
<td>✔</td>
<td>Test Fail</td>
<td>5.4.1.8</td>
<td>GEM TPG Tests (Primary Side)</td>
</tr>
<tr>
<td>✔</td>
<td>NA</td>
<td>5.4.1.9</td>
<td>GASU DAQ Board and GEM TPG Tests Setup Procedure (Redundant Side)</td>
</tr>
<tr>
<td>✔</td>
<td>Test Fail</td>
<td>5.4.1.10</td>
<td>GEM Register Tests (Redundant Side)</td>
</tr>
<tr>
<td>✔</td>
<td>Test Fail</td>
<td>5.4.1.11</td>
<td>CRU Register Tests (Redundant Side)</td>
</tr>
<tr>
<td>✔</td>
<td>Test Fail</td>
<td>5.4.1.12</td>
<td>EFM Register Tests (Redundant Side)</td>
</tr>
<tr>
<td>✔</td>
<td>Test Fail</td>
<td>5.4.1.13</td>
<td>AEM Register Tests (Redundant Side)</td>
</tr>
<tr>
<td>✔</td>
<td>Test Fail</td>
<td>5.4.1.14</td>
<td>GEM Functional Tests (Redundant Side)</td>
</tr>
<tr>
<td>✔</td>
<td>Test Fail</td>
<td>5.4.1.15</td>
<td>GEM TPG Tests (Redundant Side)</td>
</tr>
<tr>
<td>✔</td>
<td>NA</td>
<td>5.4.1.16</td>
<td>Test Shut Down Procedure</td>
</tr>
<tr>
<td>NA</td>
<td>NA</td>
<td>5.4.2</td>
<td>AEM Functional Tests</td>
</tr>
<tr>
<td>✔</td>
<td>NA</td>
<td>5.4.2.2</td>
<td>AEM Functional Test Setup Procedure (Redundant Side)</td>
</tr>
<tr>
<td>✔</td>
<td>Test Fail</td>
<td>5.4.2.3</td>
<td>AEM Functional Test Procedure (Redundant Side)</td>
</tr>
<tr>
<td>✔</td>
<td>NA</td>
<td>5.4.2.4</td>
<td>AEM Functional Test Setup Procedure (Primary Side)</td>
</tr>
<tr>
<td>✔</td>
<td>Test Fail</td>
<td>5.4.2.5</td>
<td>AEM Functional Test Procedure (Primary Side)</td>
</tr>
<tr>
<td>✔</td>
<td>NA</td>
<td>5.4.2.6</td>
<td>Test Shut Down Procedure</td>
</tr>
<tr>
<td>NA</td>
<td>NA</td>
<td>5.4.3</td>
<td>TEM Functional Tests</td>
</tr>
<tr>
<td>✔</td>
<td>NA</td>
<td>5.4.3.2</td>
<td>TEM Functional Test Setup Procedure (Primary Side)</td>
</tr>
<tr>
<td>✔</td>
<td>Test Fail</td>
<td>5.4.3.3</td>
<td>TEM Functional Test Procedure (Primary Side)</td>
</tr>
<tr>
<td>✔</td>
<td>NA</td>
<td>5.4.3.4</td>
<td>TEM Functional Test Setup Procedure (Redundant Side)</td>
</tr>
<tr>
<td>✔</td>
<td>Test Fail</td>
<td>5.4.3.5</td>
<td>TEM Functional Test Procedure (Redundant Side)</td>
</tr>
<tr>
<td>✔</td>
<td>NA</td>
<td>5.4.3.6</td>
<td>Test Shut Down Procedure</td>
</tr>
</tbody>
</table>

Hard copies of this document are for REFERENCE ONLY and should not be considered the latest revision.